14:00:28 <yboston> #startmeeting 2014-09-04 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:28 <pinesol_green> Meeting started Thu Sep  4 14:00:28 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:28 <pinesol_green> The meeting name has been set to '2014_09_04___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:00:38 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20140904-agenda
14:00:46 <yboston> #topic Introductions
14:00:47 <yboston> Please feel free to start introducing yourselves...
14:00:58 <yboston> #info yboston is Yamil Suarez @ Berklee college of Music - DIG meeting facilitator
14:01:14 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:01:15 <Guest59205> thanks kmlussier in fact I'm already done a separate application where I can upload the photo url to the system, but at the library asked me if there is a way that in the staff client can exist an option like this
14:01:15 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:26 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library
14:01:27 <rfrasur> #info rfrasur is Ruth Frasur @ Hagerstown - Jefferson Township Library - Evergreen Indiana
14:02:03 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative
14:03:16 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:03:32 <Christineb> #info Christineb is Christine Burns, BC Libraries Cooperative
14:04:16 <yboston> will start with old topics / old actions first
14:04:25 <yboston> #topic past action items
14:04:48 <yboston> action: "remingtron will create a DIG long term goals wiki page and will include ideas for improving PDFs"
14:04:53 <yboston> that was done
14:05:13 <yboston> don't think we need discussion on it?
14:05:24 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:todo
14:06:11 <yboston> next one
14:06:12 <yboston> action: yboston will help kbutler with her 2.6 task "Add granular settings for requiring staff initials for notes. "
14:06:30 <yboston> tI did not reach out to Kate, will postpone
14:06:30 <remingtron> for the record, the specific section is "Non-docs tasks": http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:todo&#non-docs_tasks
14:06:43 <kbutler> and I have not been around to be helped so. :)
14:06:53 <yboston> that worked out well
14:06:55 <yboston> :)
14:07:05 <yboston> #action yboston will help kbutler with her 2.6 task "Add granular settings for requiring staff initials for notes. "
14:07:16 <yboston> next one
14:07:26 <yboston> action: remingtron will ask for volunteers to help with documenting the new browser staff client on the general EG list
14:07:50 <yboston> I know he did, but don't htink he got feedback publicly
14:07:55 <remingtron> http://markmail.org/thread/ke5u3tbl62ghnajw
14:08:02 <remingtron> I haven't heard anything yet
14:08:11 <yboston> any direct feedback from anyone?
14:08:25 <remingtron> nope
14:08:56 <jihpringle> remingtron: is there a deadline when you'd like to see documentation done, ie. the circ module?
14:09:29 <jihpringle> I'd like to volunteer but turns out September is going to be a busy month for me
14:09:38 <remingtron> I'd love to see a preview version of the docs (aka. a draft) when the preview of the browser client is released with 2.7
14:09:55 <remingtron> so work would continue after that too
14:10:19 <kmlussier> I was wondering if it would be wortwhile to have a separate DIG hack-a-way day just to focus on web client documentation. Of course, it couldn't be done in time for the 2.7 release.
14:10:46 <yboston> I am open to a second event
14:10:59 <yboston> or if there is time during the upcoming one
14:11:18 <kmlussier> The nice thing about getting the documentation done early is that it also can serve as an opportunity to test functionality in the new web client.
14:11:32 <yboston> kmlussier: good point
14:11:33 <jihpringle> I'd be happy to work on it during the current hack-a-way or participate in a future specifc one
14:11:42 <kmlussier> yboston: I think doing both in one day would be ambitious.
14:12:10 <yboston> can't fault me for dreaming :)
14:12:33 <kmlussier> :)
14:13:04 <remingtron> I think sometime we should have a broader discussion about how our docs are used. I guess I'm having a mid-DIG crisis. "Does anybody even READ this stuff?" Getting Google Analytics on the docs would help, and any user feedback.
14:13:21 <remingtron> :)
14:13:34 <rfrasur> remingtron - are Google analytics already set up or is that something you'd like?
14:13:43 * rfrasur thinks that's a great idea, fwiw.
14:13:51 <kmlussier> remingtron: Oh, I think people read it. Analytics are good, but my sense is that the docs are used.
14:14:03 <kbutler> remingtron: you mean like those things they have on google and ms doc sites 'did this answer your question y/n' sort of stuff?  That might be helpful.
14:14:26 <remingtron> rsoulliere: we don't have Google analytics on the docs yet, right?
14:14:32 <dbs> Piwik is what we use for analytics on the core evergreen-ils.org web site
14:14:50 <yboston> dbs: thanks, good to know
14:15:02 <dbs> Please don't split the analytics streams :)
14:15:03 <rsoulliere> remingtron: I had set it up for tracking some pages...
14:15:24 <remingtron> kbutler: no, just page accesses and click tracking and such
14:15:38 <rfrasur> dbs - maybe rather than Google analytics...just analytics?
14:16:03 <remingtron> rfrasur: sure, any kind will do
14:16:14 <kbutler> remingtron: ahh ok. That's useful too.
14:16:22 <dbs> Ideally just one, though, so we can see patterns across the various evergreen properties
14:16:56 <Stompro> How possible would it be to add per page comments to the documentation like the Postgresql or php docs.  That moves the feedback extremly close to the source and removes a barrier to leaving feedback.
14:16:57 <dbs> e.g. "Are people going from the docs to one section of the wiki consistently? Maybe we should get that wiki page into the docs..."
14:17:10 <dbs> I hate the per page comments on the PHP docs.
14:17:10 <yboston> can we turn this into some action itmes? like putting a request through rsoulliere and maybe the EG web team for setting up analytics
14:17:22 <dbs> Speaking as someone who used to volunteer to moderate them.
14:17:25 <rfrasur> I do agree with kmlussier.  I know, anecdotally, that people are using them.  But some quantitative proof could only be helpful (right?).
14:18:06 <dbs> Our community would more likely be close to the PostgreSQL doc comment style (relatively quiet and low volume) though.
14:18:14 <Stompro> As someone just getting back into Evergreen, I've found the Official docs extremely useful.
14:18:35 <jihpringle> would it be useful to send out something to the general list reminding everyone the docs are out there and guiding people new to EG to the docs?
14:18:36 <dbs> docs++
14:19:28 * dbs withdraws from the DIG meeting, sorry for interrupting
14:19:40 <remingtron> dbs++ #thanks for your perspective
14:19:59 <yboston> I think the docs have a good presence on the EG site. a big icon in the middle and a main menu item
14:20:31 <yboston> though, this train of dicsuion reminds of sending out a survey to solicit feedback
14:20:36 <yboston> *discussion
14:20:49 <yboston> never thought to ask how often peopel used the offical docs
14:20:54 <remingtron> rsoulliere: would you be able to work with the EG web admins (bshum?) to get piwik setup for the docs? I'm guessing it's similarly easy to Google analytics
14:21:11 <yboston> I do think they get used. I definetly use them all the time
14:21:14 <remingtron> probably just add a javascript to the template
14:21:29 <rsoulliere> yes, I was going to enquiry about the requirements for stting it up in the shared environment.
14:22:08 <remingtron> yboston: sounds like we have an action item for rsoulliere
14:22:20 * phasefx tends to link to the documentation when helping people, fwiw
14:22:50 <yboston> like  "rsoulliere: look into setting up analytics in offical docs site"
14:23:01 <yboston> (with better spelling)
14:23:29 <yboston> #action rsoulliere: look into setting up analytics in official docs site like on the main EG site
14:23:49 <rsoulliere> OK, will do.
14:24:05 <remingtron> phasefx: thanks for feedback!
14:24:37 <yboston> back on the topic of new staff browser and volunteers, anything else ebfore I move on to the next old action item?
14:24:52 <yboston> or we can keep the current dicsusion running
14:25:05 <remingtron> (sorry to derail the topic)
14:25:18 <kmlussier> Do we want to schedule an event or should we wait to hear if remingtron gets more feedback?
14:26:10 <yboston> alternatively, do we want to see how the hack-a-way goes to see if we find new volunteers that might want to help witht he new client docs?
14:26:11 <remingtron> let's revisit the browser client docs at next meeting. 2.7 features are more important at this point, and I'll report mid month about any feedback.
14:26:34 <kmlussier> Sounds like a good approach to me.
14:26:42 <remingtron> or...I'll report pre-dig-hackaway
14:26:50 <yboston> me too, good idea
14:27:20 <yboston> #action remingtron revisit the browser client docs at next DIG meeting or earlier
14:27:28 <remingtron> great
14:27:38 <yboston> btw, I like the discussion that we drifted to
14:27:43 <yboston> next action item
14:27:52 <yboston> action: yboston start a thread on DIG mailing list on targeting small older docuemntation tasks for the month of August; like working on 1 to 3 features from the 2.5 list between now and the next meeting?
14:28:03 <yboston> no work done :( postponed
14:28:25 <yboston> #action yboston start a thread on DIG mailing list on targeting small older docuemntation tasks for the month of September; like working on 1 to 3 features from the 2.5 list between now and the next meeting?
14:28:42 <yboston> next one
14:28:46 <yboston> action: kmlussier(and others) identify 2.7 doc needs and add to the 2.7 wiki page
14:28:59 <yboston> thanks for doing this Kathy
14:29:10 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.7_needs
14:29:22 <yboston> any comments or updates?
14:29:58 <kmlussier> We need lots of help with the 2.7 docs, so feel free to sign up for something!
14:31:06 <yboston> I hope we put a big dent at the hack-a-way
14:31:14 <yboston> on this list
14:31:48 <yboston> BTW, the remaining old action items have been taken care of, thanks to jihpringle sending out the doodle poll for the hack-a-way
14:31:50 <remingtron> for the record, the goal is to have all new 2.7 features documented by Sept 18 (expected 2.7 launch day)
14:32:08 <kmlussier> Some of the tasks, like the switch to XLSX or the change in holds shelf expire date, probably only require small changes in existing docs.
14:32:47 <yboston> nice, should we label does as bitesize?
14:32:56 <remingtron> yes, good idea
14:32:59 <kmlussier> Sure, I can do that.
14:33:10 <remingtron> maybe even link to the github file from the todo list
14:33:22 <yboston> remingtron: cool
14:33:33 <remingtron> at least for bitesize ones
14:33:57 <yboston> kathy can I put you done for that or are you already doing it?
14:34:00 <yboston> :)
14:34:43 <kmlussier> I added the bitesize label already.
14:34:50 <yboston> also, at this point we can start with new action items; I would like to jump to talk about the DIG hack-a-way, but we can start with another new item like
14:34:53 <yboston> Potential DIG Outreach Program for Women projects (Kathy)
14:34:59 <yboston> kmlussier: thanks!
14:35:06 <kmlussier> I can revisit a little later for the github links.
14:35:20 <kmlussier> yboston: do you need to do a #topic for that?
14:36:01 <yboston> I was just mentioning a potential next topic, not starting it, but I can start with that one then switch to the hack-a-way
14:36:12 <kmlussier> Oh, sorry. Misunderstood. :)
14:36:58 <yboston> lets do the kathy item first,then switch to hack-a-way
14:37:12 <yboston> #action Potential DIG Outreach Program for Women projects (Kathy)
14:37:15 <yboston> sorry
14:37:20 <yboston> #topic Potential DIG Outreach Program for Women projects (Kathy)
14:37:47 <kmlussier> I sent out an e-mail to the list on this: http://markmail.org/message/ecnsuuets32glrve
14:38:00 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=opw
14:38:47 <kmlussier> I thought of two potential DIG-related projected for this program. I wanted to hear if others thought either of these projects would be worthwhile.
14:39:00 <kmlussier> Or if you think there are some other documentation projects that could be added to the list.
14:39:41 <kmlussier> And, also, if you think a project is worthwhile, if anyone has the time/interest in volunteering to mentor the intern who would work on the project.
14:39:42 <yboston> I like what you listed, can't think of aything else tight now but I am sure I will think of soemthing
14:40:20 <kbutler> kmlussier: I really liked the idea of updating the style/functionality of the docs with things like the extra links at the top.
14:40:22 <yboston> I will put myself down as a mentor for both docs related item
14:40:24 <yboston> items
14:40:30 <kmlussier> I have to say I wasn't as excited about the web client documentation because a part of me thinks it might be better to have it done by people more familiar with the software.
14:40:41 <kmlussier> But it is a big job that needs to be done.
14:40:49 <kmlussier> yboston++
14:41:06 <remingtron> kmlussier: I'd add docs usability improvements to the revamp idea
14:41:35 <remingtron> (analytics, getting user feedback, considering ways to integrate the docs or links to them in the software)
14:41:37 <kmlussier> remingtron: Thanks, I all that. I think that's part of what I was getting it, but didn't clearly state.
14:41:58 <kmlussier> /s/all/add
14:42:02 <kmlussier> Typos. :P
14:42:12 <remingtron> kmlussier: yeah, same idea as what you already had down
14:42:37 <yboston> BTW, we are at the 42 minute mark, nervous that we will run out of time to talk about hack-a-way, though we may be fine
14:43:16 <kmlussier> As long as everyone things these are good idea, then I'll go with it. If we don't get a 2nd mentor for the web client docs by tomorrow, I'll probably remove it from the list.
14:43:30 <kmlussier> But I think I'm okay with focusing on the other one too.
14:44:11 <remingtron> yeah, I think the revamp is the better project for an intern
14:44:57 <yboston> May I switch to talking about hack-a-way?
14:45:08 <kmlussier> yboston: Go for it!
14:45:19 <yboston> #topic DIG hack-a-way planing
14:45:55 <yboston> kmlussier asked around for votes on where to have the Massachusetts one, and people were TOO flexible
14:46:07 <yboston> kmlussier: what would you like to do?
14:46:20 <kmlussier> kbutler showed a slight preference for Worcester.
14:46:29 <yboston> I wonder if Worcester, MA will lead to more volunteers
14:46:35 <yboston> specially first time ones
14:46:40 <kmlussier> I don't know if bshum or mceraso have a preference.
14:46:48 <remingtron> I'm remote from Michigan
14:47:02 <kmlussier> remingtron: You don't want to drive down to Worcester? ;)
14:47:17 <bshum> kmlussier: Worcester is fine.  (spells it right, but can't pronounce it for his life...)
14:47:27 <yboston> BTW, chime in those that are planning to join in remotely
14:47:35 * mceraso agrees with bshum (even about the spelling)
14:47:42 <jihpringle> I'm planning to join remotely
14:47:44 <yboston> (wooster)
14:47:56 <remingtron> bshum: W....ster
14:48:12 <kmlussier> bshum: WŎŎS-tah
14:48:20 <kbutler> I'm fine with Worcester.
14:48:24 <kmlussier> yboston: You forgot to drop the "r"
14:48:44 <yboston> woostaah
14:49:05 <yboston> So lets do Worcester
14:49:27 <kmlussier> OK, I'll let tspindler know.
14:50:18 <tspindler> kmlussier, just happened to look and see this
14:50:22 <yboston> can I get a volunteer to collect the Google hangout compatible email address to set up a hang out?
14:50:32 <yboston> actually, I could do that since I am not hosting :)
14:51:07 <yboston> #action yboston collect the Google hangout compatible email address to set up a hang out
14:51:40 <yboston> #action (all DIG members) send yboston your Google hangout compatible email address for the DIG hack-a-way hangout
14:52:12 <yboston> in terms of goals, I think we are pretty clear on focusing on new 2.7 features.
14:52:21 <yboston> any other issues to bring up today?
14:52:23 <jihpringle> we settled on the day but did we ever talked about start and end times?
14:52:29 <yboston> (we have 8 minutes)
14:53:03 <remingtron> I can probably only join for the morning
14:53:06 <yboston> from expereince, I always needed until 9:30 AM EST to be set up with a hangout at the earliest
14:53:52 <kmlussier> 9:30 works for me, but may be a little early for jihpringle. :)
14:54:03 <yboston> so for ending time?
14:54:18 <kmlussier> But maybe people can join in as they start their workday.
14:54:21 <yboston> usually we end aorund 5 PM EST
14:55:05 <yboston> what are the food options in Worcester?
14:55:46 <kmlussier> I'll talk to to the C/W MARS folks about it. There are places we can go, but it might be easier to call something in.
14:55:55 <jihpringle> I won't be around at 9:30am EST but I'll try to be around by 10:30/11am
14:56:18 <kmlussier> There's nothing we can really walk to.
14:56:33 <yboston> kmlussier: can you send out ifnormation like the street adress, room number?
14:56:46 <kmlussier> Yes, I can do that.
14:57:42 <yboston> #action kmlussier will send out information on the Worcester, MA venue
14:58:05 <yboston> not sure if you want those that will attend to send you their email or sending on the DIG list?
14:59:12 <yboston> any final thoughts. comments, questions?
14:59:27 <yboston> (we are reaching the 1 hours mark, but I can keep going)
14:59:30 <kmlussier> It would be good if people could just contact me directly if they're planning to go to Worcester. So that we know how many people to plan for. But i'll include that info in the e-mail I send out.
15:00:08 <yboston> BTW, I am extremely excited to have a set set of goals for the hack-a-way
15:00:30 <yboston> anything else for now?
15:00:40 <remingtron> I'm excited that we're being more on-time for releases
15:00:49 <remingtron> hack-a-way++
15:01:02 <yboston> remingtron++ you helped a lot with that
15:01:10 <yboston> OK folks will shut down now
15:01:14 <kmlussier> remingtron++ indeed
15:01:17 <yboston> #endmeeting