14:00:24 <yboston> #startmeeting 2014-10-02 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:24 <pinesol_green> Meeting started Thu Oct  2 14:00:24 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:24 <pinesol_green> The meeting name has been set to '2014_10_02___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:38 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20141002-agenda
14:00:49 <yboston> #topic Introductions
14:00:59 <yboston> Please feel free to start introducing yourselves...
14:01:07 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:09 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:26 <Christineb> #info Christineb is Christine Burns @ BC Libraries Cooperative
14:01:34 <kbutler> #info kbutler is Kate Butler, Rodgers Library (Hudson NH)
14:01:43 <sandbergja> #info sandbergja is Jane Sandberg, Linn Benton Community College (Albany, OR)
14:01:45 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:01:50 <jihpringle> #info jihpringle is Jennifer Pringle @ BC Libraries Cooperative
14:02:12 <stompro> #info stompro is Josh Stompro @ Lake Agassiz Regional Library System (MN)
14:02:22 <snigdha26> #info snigdha26 is Snigdha Dagar, OPW candidate
14:02:55 <bshum> #info bshum is Ben Shum, Bibliomation
14:02:56 <yboston> heads up there is another meeting that start at 3:00 PM EST
14:02:58 <yboston> today
14:03:17 <yboston> #topic old business
14:03:30 <yboston> sorry, we shoudl do content coordinator reports
14:03:40 <yboston> #topic coordinator reports (if any)
14:03:43 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:03:57 <ericar> #info ericar is Erica Rohlfs @ Equinox
14:04:00 <kmlussier> #topic Release Coordinator report
14:04:20 <kmlussier> #info The Release Notes for 2.7.0 are done
14:04:37 <remingtron> kmlussier++
14:04:46 <kmlussier> #info I do plan to add links from the release notes to the documentation for the new feature, but we're still waiting on some 2.7 documentation.
14:04:48 <kmlussier> End of report.
14:05:10 <yboston> kmlussier++
14:05:33 <yboston> kmlussier: do you know what is missing?
14:05:54 <kmlussier> Also, I just wanted to mention that there were very few features missing from the release notes on my first pass, so the developers did a good job of adding the release notes as they submitted code.
14:05:56 <kmlussier> developers++
14:06:21 <yboston> developers++
14:06:38 <kmlussier> yboston: Just a few things missing, I think. http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.7_needs
14:07:47 <yboston> should we check in on each other between now and the next meeting to make sure we are done with 2.7?
14:08:20 <remingtron> yes, good idea
14:09:13 <kmlussier> I have updates for a couple of the items. I asked krvmga to send me his Content Cafe docs so that I could review them and put them in a working branch.
14:09:52 <remingtron> kmlussier: do you have them now? or still waiting?
14:09:54 <yboston> kmlussier: do you mind sending out another emial to check in in a couple of weeks? if not we can wait for the next meeting, by putting an item in the agenda again for 27
14:10:01 <kmlussier> And I have on outstanding item for MARC Stream Importer. I have a colleague who did some rough documentation a while back that I was going to use. But I won'g get to it for at least another week.
14:10:18 <kmlussier> remingtron: Still waiting. I'll see him Monday and can remind him again.
14:10:29 <kmlussier> yboston: Sure
14:10:48 <remingtron> kmlussier: sounds fine. if you need a hand reviewing or pushing things in, let me know
14:11:02 <kmlussier> remingtron: Thanks! I'll probably take you up on that offer.
14:11:19 <yboston> #action kmlussier will check in on list to help move along pending 2.7 docs
14:11:52 <yboston> #action yboston will add agenda entry to November DIG meeting to check in on pending 2.7 docs
14:12:45 <yboston> if neccessary, in a couple of weeks we can just find another volunteer to finsish was was started on stream importer (I could volunteer then)
14:13:20 <yboston> should we move on to see if Robert wants to report soemthing?
14:13:26 <remingtron> yes
14:13:29 <rsoulliere> #topic Conversion Coordinator Report
14:13:37 <rsoulliere> #info 2.7 docs should be built in the next couple of days from the new rel_2_7 branch. One faulty image is causing a delay but should be an easy fix.
14:14:00 <remingtron> rsoulliere: I'll try to backport that fix right now
14:14:15 <rsoulliere> remingtron++
14:14:25 <rsoulliere> That is all I had.
14:14:33 <yboston> rsoulliere++
14:15:12 <yboston> in the interest of time, I would like to start with new business
14:15:18 <kmlussier> rsoulliere++
14:15:25 <remingtron> rsoulliere++
14:15:29 <yboston> #topic new business
14:15:36 <yboston> #topic Review of EG Upgrading Instructions (Robert)
14:16:17 <remingtron> I was discussing this with rsoulliere earlier today
14:16:26 <rsoulliere> Remingtron addressed the issue nicely by adding a note in the docs.
14:17:19 <yboston> do you have a link or commit has for what he added?
14:17:53 <remingtron> it was July 10 or so
14:18:04 <remingtron> I'll look for a link
14:18:15 <yboston> the date is fine for now
14:18:34 <remingtron> #link http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=28a5085fd645c9470b852c9700661dbe4cbddf18
14:18:34 <pinesol_green> [evergreen|Remington Steed] Documentation: Upgrade instructions examples - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=28a5085>
14:19:22 <yboston> I have never done an upgrade so I have not been able to help with testing those instructions so far. thanks rsoulliere and remingtron for working on this
14:19:28 <rsoulliere> And here it is in the docs: http://docs.evergreen-ils.org/2.6/_upgrade_the_evergreen_database_schema.html
14:19:32 <yboston> anything else to add or any questions from others?
14:21:08 <yboston> OK, I will move on
14:21:33 <yboston> #topic 2014 DIG hack-a-way post-mortem (Yamil)
14:21:49 <yboston> (I am skipping the topic on 2.7 since we spoke about it already)
14:22:15 <yboston> I am personally drwaing a blank on anything that I had pending from the hack-a-way
14:22:36 <kmlussier> yboston: It was a great day. Fun was had by all!
14:22:43 <yboston> is anyone waiting for me to push any code to the repo for them?
14:22:54 <kbutler> yboston: it felt like it was really productive
14:22:56 <yboston> is this the first time we speak of the DIG hack-a-way since it happened?
14:23:11 <remingtron> yboston: I think this is the first time
14:23:18 <kmlussier> Yes
14:23:27 <yboston> I thought it was the best one so far
14:23:55 <yboston> I am glad that since the last one we we severla small adjustments to our practices to improve our success
14:24:02 <yboston> like just focusing on 2.7
14:24:35 <yboston> it was helpful how many more peopel are usign git or Github one way or another
14:25:02 <remingtron> it's exciting to see people participating so much!
14:25:22 <yboston> the next time we plan to be together physically again will be at the next conference in May
14:25:56 <remingtron> should we try for at least a digital hackaway before the next release, whenever that is?
14:25:58 <yboston> unless we want to try another one earlynext year
14:26:00 <remingtron> might be before the conf
14:26:40 <yboston> I am open to another event, even if it is remotely or just half a day befoer the next release
14:27:21 <yboston> we can just wait to see what the developers decide in the next couple of months
14:27:46 <yboston> they might want to stick to a February/March release date liek they have been doing lately
14:27:52 <remingtron> agreed. we'll address it when 2.8 release is scheduled
14:28:05 <kmlussier> Unless we wanted to spend a day focusing on web client docs
14:28:15 <yboston> kmlussier: very true
14:28:18 <remingtron> oooooo, good point
14:28:43 <remingtron> well, let's discuss that on the list
14:29:13 <kmlussier> I know I'll be doing some documentation while testing, but I don't know how far I'll get.
14:29:43 <remingtron> jihpringle volunteered to help with preview web client docs
14:29:44 <yboston> who would like to follow up on the list to get ideas for how to tackle web client docs
14:29:46 <yboston> ?
14:29:54 <remingtron> kmlussier: let's coordinate
14:30:02 <kmlussier> remingtron: Sure, sounds good.
14:30:12 <remingtron> yboston: I'll take the lead
14:30:15 <yboston> OK
14:30:25 <jihpringle> are we going to have a separate set of docs for the web client or a section in 2.7or 2.8?
14:30:48 <yboston> #action remingtron will start a thread on DIG list on documenting the web client
14:31:02 <remingtron> jihpringle: I think in 2.7 and 2.8, etc.
14:31:09 <remingtron> but that could change
14:31:30 <jihpringle> I just wonder at how long that will get as more module are done
14:31:33 <bshum> I think a section makes the most sense.
14:31:39 <yboston> good question, though I doubt we can answer it today
14:32:06 <jihpringle> do we want to discuss it on the list and then decide in November?
14:32:16 <jihpringle> we can contribute docs to it until we know where to put them
14:32:19 <yboston> BTW, we are just past the 30 minute mark
14:32:20 <jihpringle> can = can't
14:32:43 <remingtron> jihpringle: yeah, let's discuss on the list and revisit at next mtg
14:32:50 * kmlussier agrees that a section makes the most sense.
14:33:06 <remingtron> sounds like we'll start with a section in 2.7
14:33:28 <kmlussier> It will get long, but we'll eventually be getting rid of the old docs once the old client is deprecated.
14:33:31 <yboston> or a section in master?
14:33:40 <remingtron> thanks all for the input!
14:33:47 <kmlussier> If the preview is available in 2.7, then it probably should be in 2.7
14:33:48 <remingtron> yboston: yeah, 2.7 and master both
14:33:59 <yboston> should we move on? or we can continue too
14:34:00 <remingtron> master will change as the new version changes
14:34:06 <remingtron> I'm happy to move on
14:34:11 <kmlussier> +1
14:34:46 <yboston> #idea hack a DIG hack-a-way just for the new web client
14:35:06 <yboston> #idea consider having another DIG hack-a-way nefore the next major EG release in 2015
14:35:13 <yboston> #topic Feedback to OPW candidate's doc site ideas (Kathy, Snigdha)
14:35:54 <kmlussier> #link http://markmail.org/thread/kjddts4zod2uwbe6
14:36:06 <yboston> first of all I would like to welcome our OPW intern candidate snigdha26
14:36:17 <remingtron> snigdha26: welcome!
14:36:26 <yboston> and perhaps other OPW candidates that might be lurking
14:36:52 <kbutler> I really liked snigdha26's ideas, especially the collapsible TOC over on the left.
14:36:53 <snigdha26> yboston: remingtron: thanks :)
14:37:17 <remingtron> kbutler: +1 to that idea
14:37:27 <yboston> kbutler: +1
14:37:33 <stompro> I also like the collapsible TOC idea.
14:37:35 <kmlussier> I know snigdha26 received some feedback on her ideas in the e-mail thread, but I thought it might be good to see if others have feedback. It will help her has she pulls together her OPW application.
14:37:45 <yboston> it is ice to get a fresh perspective from someone from the outside
14:37:49 <yboston> *nice
14:38:17 <kmlussier> Also, if people have other suggestions, now is a perfect time to bring them up. :)
14:38:51 <stompro> I've posted to the list about changing how the search scoping works.. no responses though.
14:38:54 <remingtron> I love the idea for adding a "Get Help" box at the top
14:39:20 <kbutler> stompro: I liked that idea as well. It would make so much more sense than searching everything by default.
14:39:24 <remingtron> stompro: I like the idea, but will depend on how easy it is to accomplish via Google custom search
14:39:43 <kmlussier> stompro: I like the idea of choosing whether to search this release or all docs.
14:39:45 <snigdha26> stompro: I did respond on the thread, but I think google marked that as spam
14:39:46 <stompro> I think Google custom search can do it, with the pro version.
14:39:52 <remingtron> stompro: and how much time rsoulliere can put into it. If you figure out the details, send it to the DIG list
14:40:06 <kmlussier> I wasn't sure about the "search the entire site" option since it would replicate what's on the Evergreen home page.
14:40:12 <yboston> stompro: I liked the ides too, but I also have remingtron's reservation. though we just need a little research to find out what can be done
14:40:57 <stompro> I'll look into it some more and post to the list.
14:41:10 <remingtron> stompro++
14:41:59 <remingtron> Not sure about adding user comments to the docs
14:42:02 <kbutler> I'm also in favor of taking a look at the documentation organization.  As it's grown, we may find there are some topics better grouped together that are not together now.
14:42:11 <stompro> I also like the FAQ idea, but populating it might be hard, we need to know which questions are frequently asked.  And there are other FAQ's on the evergreen site that maybe already cover some things.
14:42:39 <kmlussier> In the realm of other suggestions, one thing I like about PostgreSQL's doc site is that it clearly identifies which release the docs apply to (in case you arrived through a Google search) and has links along the top to quickly jump to the same section for other releases.
14:43:06 <remingtron> kmlussier: +1 to that!
14:43:23 <kmlussier> stompro: One thing I was thinking is we could maybe tie it closely together with the Evergreen site. I think there is a FAQ plug-in for WordPress (can't recall if we're using it).
14:43:26 <yboston> I agree with kbutler , we might want to rethink the overall organization, but it might require having another docs server set up to test out new re-orgs of the content for us to see, wihtout impacting the main docs server
14:43:39 <stompro> kbutler, I've wondered why there are 3 sections on tpac and several sections on Acquisitions.  A reorg would be good.
14:44:13 <jihpringle> +1 to a reorg
14:44:25 <kmlussier> stompro: That's partially due to the Evergreen in Action docs being added without replacing the existing docs. I think if those were more explicitly called out as being "Evergreen in Action" docs, it would make more sense to the user.
14:44:57 <remingtron> would someone like to give a try at reorganizing the docs? Even baby steps are good. Let's start a wiki page with Table of Contents
14:45:09 <kmlussier> In terms of a docs server, I e-mailed with rsoulliere a few weeks ago about trying to replicate his set up on one of the MassLNC VM's
14:45:11 <kbutler> +1 to that idea
14:45:23 <kbutler> (wiki with table of contents)
14:45:43 <yboston> +1 to wiki table of contents page to list ideas
14:45:49 <kmlussier> I don't know if it could serve that purpose permanantly, but I think it will be needed if the doc project is one that's selected for OPW
14:46:22 <vrani> hi I'm 2n year Student of MCA in NIT Durgapur. I'm interseted in ccontributing in Docccumentation part of Evergreen. Could anybody help in this regard?
14:46:50 <remingtron> vrani: welcome!
14:46:52 <yboston> kmlussier: csharp told me to contact gmcharlt about formally requesting a permanent VM for EG community purpoes to be used by DIG
14:47:00 <yboston> to be hosted by PINES
14:47:02 <kmlussier> Welcome vrani! You arrived at a good time. We're holding a documentation meeting right now. :)
14:47:14 <vrani> awesome :)
14:47:19 * gmcharlt perks up
14:47:33 <yboston> vrani: I will send you a private message right now to ask for more info
14:47:44 <yboston> vrani: I am one of the mentors for OPW
14:47:44 <vrani> sounds good :)
14:47:55 <snigdha26> In case the wiki page with TOC is implemented, I could help out with it too and based on the ideas, see how the documentation could be re-organized
14:47:57 <vrani> hi yboston
14:48:11 <gmcharlt> yboston: I'm listening re VM - or feel free to email me
14:48:28 <remingtron> snigdha26: sounds good. I will start the wiki page for reorganization ideas
14:48:29 <yboston> I'll send you the email I started at the hack-a-way that I never sent :)
14:48:48 <yboston> BTW, we have 12 minutes left in this meeting
14:49:13 <snigdha26> remingtron: I'll work with you on that then
14:49:23 <remingtron> snigdha26++
14:49:23 <kmlussier> vrani: You may want to read up in the discussion we've just had about doc site ideas. http://irc.evergreen-ils.org/evergreen/2014-10-02
14:50:25 <remingtron> vrani: on that chat log, you can start at about 14:00
14:50:40 <vrani> ok thanks alot :)
14:51:42 <yboston> how do we want to proceed at this point?
14:51:56 <yboston> we talked about brinstorming on a re-orf
14:52:00 <yboston> *re-org
14:52:11 <yboston> with a wiki
14:52:15 <snigdha26> Thanks for the feedback everyone :)
14:52:26 <yboston> remingtron: can I put you down for that action of creating the wiki?
14:52:32 <remingtron> yboston: yes
14:52:52 <yboston> #action remingtron will create a wiki page to collect ideas for a docs re-org
14:52:58 <remingtron> I think we should keep discussing snigdha26's ideas on that email thread
14:53:12 <yboston> we talked about setting up a test server to be used for OPW purposes, and a few other experiments
14:53:14 <kmlussier> snigdha26++ Thanks for the ideas!
14:53:32 <yboston> I can assign that task to me and kmlussier ? is that OK?
14:54:04 <kmlussier> Does it need to be assigned? snigdha26 already started the thread. People should feel free to continue offering feedback and ideas, I think.
14:54:12 <yboston> did we want to focus on a couple of the ideas first liek the search changes or testing the addition of a (collapsible) TOC tot he pages?
14:54:59 <yboston> kmlussier: I meant about following up with a docs test server
14:55:04 <kmlussier> Oh, sorry.
14:55:08 * kmlussier was confused.
14:55:32 <yboston> BTW, the next meeting, Academics for Evergeen, will start in 5 minutes
14:55:58 <kmlussier> Yes, you should assign it to the two of us. And wrap up this meeting to make way for the academics. :)
14:56:15 <yboston> #action yboston kmlussier will work to allocate a VM for use by DIG memebres and OPW intern for DIG work
14:56:28 <snigdha26> yboston: regarding the collapsible TOC - Im not sure if it can be done in asciidoc, but I can definitely do that in HTML
14:56:30 <remingtron> kmlussier++ #VM
14:56:40 <yboston> we need to stop, but if anyone has other questions or comments, bring them up on the DIG list for now
14:56:50 <yboston> #stopmeeting
14:56:57 <kmlussier> remingtron: No karma until I actually figure out how to do it. : \
14:57:00 <kmlussier> end
14:57:01 <yboston> #endmeeting