15:00:56 <jeff> #startmeeting 2014-10-06 - Developer Meeting
15:00:56 <pinesol_green> Meeting started Mon Oct  6 15:00:56 2014 US/Eastern.  The chair is jeff. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:56 <pinesol_green> The meeting name has been set to '2014_10_06___developer_meeting'
15:01:00 <jeff> #link http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-10-06 meeting agenda here
15:01:05 <jeff> #topic Introductions
15:01:05 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
15:01:22 <bshum> #info bshum is Ben Shum, Bibliomation
15:01:25 <phasefx> #info phasefx is Jason Etheridge, Equinox Software
15:01:28 <tsbere> #info tsbere is Thomas Berezansky, MVLC
15:01:31 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:01:36 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:01:40 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:02:07 <berick> #info berick Bill Erickson KCLS
15:02:46 <kmlussier> OPW candidates should feel free to introduce themselves here too. :)
15:02:48 <kmlussier> And welcome!
15:03:08 <jeff> Yes, welcome!
15:03:14 <Dyrcona> #info Jason Stephenson, MVLC
15:03:45 <jeff> #topic Action items from last meeting
15:03:46 <jeff> #info kmlussier and others to make time to test the latest branch (negative balances).
15:03:57 <jeff> kmlussier: anything to report?
15:04:29 <kmlussier> Yes, I've done more testing and reported my most recent feedback to the bug.
15:04:46 <kmlussier> I thought I saw a new branch floating around during the hack-a-way. Is that something that's ready for testing?
15:04:47 <jeff> excellent. related:
15:04:58 <jeff> #info dbwells to work on display ideas for negative balance branch
15:05:28 <dbwells> It's blossomed into a few different branches.
15:05:32 <jeff> (this may answer kmlussier's question, if not -- feel free to chime in regardless of the current bullet item)
15:06:04 <jeff> dbwells: testing and eyeballs being needed, as always?
15:06:08 <dbwells> The extra fine bug was actually related to a separate code branch for "new overdues for returned lost" stuff
15:06:22 <DPearl> #info DPearl = Dan Pearl, C/W MARS
15:06:25 <dbwells> That is it's own branch, courtesy of berick and eeevil
15:06:43 <dbwells> Then we have the current negative balances bug branch.
15:07:02 <kmlussier> Ah! It may explain an issue we came across when working on another billing project. Has that 'new overdues' branch been posted to LP?
15:07:09 <jeff> #link https://bugs.launchpad.net/evergreen/+bug/1198465 Support for Conditional Negative Balances
15:07:10 <pinesol_green> Launchpad bug 1198465 in Evergreen "Support for Conditional Negative Balances" (affected: 14, heat: 62) [Wishlist,Confirmed]
15:07:18 <dbwells> Then we have a separate branch written mostly at the Hack-a-Way for display, which is (at this point) independant of the neg balances branch.
15:07:59 <dbwells> My plan is to create new bugs for the two new branches, and then update the original bug with all this info.
15:08:13 <dbwells> Put me down as an action item to do just that.
15:08:15 <jeff> dbwells++ thanks
15:08:19 <berick> dbwells++
15:08:27 <kmlussier> I'll test anything dbwells puts out there. :)
15:08:28 <bshum> dbwells++
15:08:30 <kmlussier> dbwells++
15:08:45 <bshum> kmlussier++ # testing too :)
15:08:49 <jeff> #action dbwells to update Conditional Negative Balances bug 1198465 with links to new branches, etc.
15:08:50 <pinesol_green> Launchpad bug 1198465 in Evergreen "Support for Conditional Negative Balances" (affected: 14, heat: 62) [Wishlist,Confirmed] https://launchpad.net/bugs/1198465
15:09:13 <jeff> kmlussier++ dbwells++ berick++ Dyrcona++ and probably more :-)
15:09:22 <jeff> #info jeff and csharp to test websockets work by the end of this week.
15:09:42 <jeff> That happened and/or didn't happen, but what did happen was (iirc):
15:09:43 <jeff> #info gmcharlt to cut alpha of OpenSRF the middle of next week (week of Aug. 4th)
15:10:32 <bshum> That did occur I think
15:10:45 <bshum> Or at least, there's an OpenSRF 2.4 alpha around :)
15:10:48 * jeff nods
15:10:56 <jeff> #info kmlussier to move Sandbox discussion to dev list
15:10:59 <bshum> And the websockets stuff I think I poked at a bit.
15:11:06 <jeff> i believe that also happened in advance of the bug squashing day
15:11:07 <kmlussier> Done.
15:11:16 <jeff> #info berick to add an LP bug for web based circ client with notes on pre-reqs and a list of existing client interfaces that need special attention.
15:11:19 <jeff> And that happened!
15:11:21 <bshum> yes
15:12:35 <jeff> #topic Development Updates
15:12:45 <jeff> #topic Release info - OpenSRF
15:13:09 <dbs> #info dbs is Dan Scott, Laurentian University (3 hours of meetings and counting)
15:13:28 <jeff> I'm not sure if gmcharlt is present, but we do have a new OpenSRF alpha out since last meeting.
15:14:55 <bshum> Last I talked with gmcharlt in channel, he mentioned getting OpenSRF 2.4 out soon.
15:15:03 <bshum> There's a few things we have to put in there I think
15:15:21 <bshum> And I need to revisit the updates I made to the main README for websocket steps.
15:15:33 <jeff> bshum: currently, due to websockets and other things, Evergreen 2.7 does require OpenSRF 2.4 alpha, correct? Downloads page seems to confirm...
15:15:44 <bshum> Generally speaking, yes.
15:15:50 <bshum> I never tested it with anything less.
15:15:54 <bshum> I think that's correct though.
15:16:01 <bshum> It doesn't require websockets
15:16:04 <jeff> bshum: anything specific that you/gmcharlt could use help/signoff with toward the goal of OpenSRF 2.4 making it to release?
15:16:06 <bshum> But I think there were other changes.
15:16:58 <bshum> Bug with branch is https://bugs.launchpad.net/opensrf/+bug/1369169
15:16:59 <pinesol_green> Launchpad bug 1369169 in OpenSRF "Add install instructions for websockets to README (and other cleanup)" (affected: 1, heat: 6) [Undecided,New]
15:17:00 <bshum> For the README stuff
15:17:23 <jeff> since bshum says gmcharlt already has intention of this being an action item, i don't feel too bad giving him an action item in his absence.
15:17:26 <jeff> #action gmcharlt to release OpenSRF 2.4 when ready
15:17:35 <Dyrcona> bshum is the expert but I don't recall anything critical to 2.7 in 2.4.
15:17:59 <jeff> #link https://bugs.launchpad.net/opensrf/+bug/1369169 OpenSRF README updates to be considered for 2.4 release
15:18:00 <pinesol_green> Launchpad bug 1369169 in OpenSRF "Add install instructions for websockets to README (and other cleanup)" (affected: 1, heat: 6) [Undecided,New]
15:18:09 <bshum> Now that Dyrcona mentions it, the only reason to use OpenSRF 2.4 with Evergreen 2.7 is if you wanted websockets to play with the web based staff client.  I think.
15:18:09 <ldw> #info ldw is Liam Whalen Sitka
15:18:27 <jeff> #topic Release info - Evergreen
15:18:29 <bshum> I didn't personally test OpenSRF 2.3 stable with Evergreen 2.7 though to make sure that XUL stuff and catalog is still happy.
15:18:36 <jeff> Evergreen 2.7 is released! Everyone's upgraded by now, right?
15:18:39 * jeff ducks
15:18:43 <bshum> If anyone wants to volunteer to try that, maybe that's worth it.
15:18:55 <bshum> But really, getting 2.4 out the door is better anyways :D
15:19:01 <bshum> jeff: Actually......!
15:19:10 <jeff> #info Testing of Evergreen 2.7 with OpenSRF 2.3 would be appreciated -- pass feedback to bshum
15:19:18 <Dyrcona> jeff: We're on 2.7alpha give or take a few later fixes.
15:19:30 <bshum> We were going to upgrade to 2.7 a few days after I cut 2.7.0, but we were delayed a bit.  We plan our upgrade to 2.7 this upcoming Saturday.
15:19:47 <jeff> excellent.
15:19:52 <bshum> The maintenance release schedule calls for new cuts next week 10/15 I think?
15:19:57 * bshum checks the calendar
15:20:05 <bshum> Yes, Wednesday 10/15
15:20:19 <bshum> I expect to push things into master and rel_2_7, etc. to prepare for that
15:20:52 <bshum> The big thing i want to see there is the updated i18n script so that we can pull more recent translations for tpac and other areas into the next 2.7 release.
15:20:56 <bshum> 2.7.1 should be better.
15:21:16 <jeff> #info bshum to push things to rel_2_7 in preparation for scheduled 2.7.1 maintenance release
15:21:50 <bshum> If anyone else has any bug fixes with code that they want to see in 2.7.1, please feel free to target or put a pullrequest up.
15:21:57 <jeff> #info bshum pulling updated translations for tpac (and other areas) into 2.7.1
15:22:00 <bshum> And if anyone has time to test and sign-off on them, that'd be great too :)
15:22:20 <jeff> bshum: anything else for Evergreen release info/updates?
15:22:38 <bshum> Nothing for me.  I hope to keep 2.7 series happy and stable.
15:22:43 <jeff> #info targeting, testing/signoff of bugs against 2.7.1 appreciated as always
15:22:55 <jeff> bshum++
15:23:10 <kmlussier> bshum++
15:23:11 <Dyrcona> bshum++
15:23:26 <jeff> #topic New Business
15:23:27 <jeff> #topic Bug Squashing Day Wrap-Up
15:23:34 <jeff> kmlussier: want to take this one?
15:23:37 <kmlussier> Sure
15:23:57 <jeff> #link http://evergreen-ils.org/bug-squashing-day-wrap-up/ bug squashing day wrapup
15:24:21 <kmlussier> The August bug squashing day was somewhat of a trial balloon to see if it helped move bugs along and get new people involved in the bug squashing effort.
15:24:48 <kmlussier> I was just looking for some informal feedback to see if you all think it's worth pursuing on a regular basis. Quarterly is what I originally recommended.
15:25:17 <bshum> More like a pinata we busted open with lots of tasty candy in the form of bug signoffs and fixes pushed, in my opinion.
15:25:23 <kmlussier> Also, if you think anything could be done to improve bug squashing days or to make it easier for more people to participate, let me know.
15:25:35 <kmlussier> :D
15:25:44 <jeff> For those who set up or used the sandboxes, how did that go?
15:25:46 <bshum> I loved seeing all the contributions everybody made on the first bug squashing day.
15:26:21 <Bmagic> I had no problem with it. I think it was a good thing! (setting up sandboxes and applying patches)
15:26:23 <kmlussier> tsbere created a script that makes it very easy to set up the MassLNC bug squashing sandboxes.
15:26:25 <dbs> pinatas++
15:26:33 <ldw> I found working with the sandbox very easy and enjoyable.
15:26:39 <dbs> pinatas-filled-with-bugs--
15:26:40 <jeff> Bmagic++ tsbere++
15:27:17 <berick> I was unable to attend the first one.  hope we can do it again.
15:27:26 <kmlussier> Also, the MassLNC sandboxes continue to be available between bug squashing days. I need to highlight them better on the community web site.
15:27:29 <bshum> We talked about quarterly right?
15:27:42 <bshum> If they were a good thing, that is.
15:27:46 <jeff> MassLNC++
15:27:54 <kmlussier> bshum: Yes, I think quarterly would work well.
15:28:02 <Bmagic> quarterly is ok with me
15:28:05 <kmlussier> Meaning our next day would need to be November? Is that right?
15:28:23 <jeff> i wasn't able to participate either, but it sounds like the first one was successful. who wants to take the action item of scheduling a second one?
15:28:34 <kmlussier> I can do that.
15:28:51 <jeff> kmlussier++ out of one scheduling task and into another
15:29:11 <jeff> #action kmlussier to schedule another Bug Squashing Day
15:29:23 <kmlussier> Heh
15:29:59 <kmlussier> I'll try to do it soon so that people have plenty of lead time to set the day aside in their calendars.
15:30:11 <bshum> kmlussier++
15:30:56 <jeff> anything else on the topic of bug squashing?
15:31:26 <jeff> #topic Feedback for New Features Under Development
15:32:08 <kmlussier> I don't think we have any new features up for discussion this time around.
15:32:13 <jeff> Is anyone currently working on new features that they'd like to bring up for discussion or for general "hey, go look at this and provide feedback" purposes?
15:33:23 * bshum listens for the crickets...
15:33:23 <ldw> I just made a feature for Import MARC records, that allows items from on-order records to be matched with items from the records being imported.
15:34:05 <bshum> ldw: is that different from vandelay matching on copy id?
15:34:08 <kmlussier> What do they match on?
15:34:15 <ldw> It also does org-unit matching, so it overlays the incoming record on top of the record with the most copies from the org unit.
15:34:20 <bshum> I mean yes, what fields.
15:34:48 <jeff> ldw: sounds nice! local code only at this point, or do you have a working branch with intent to submit for inclusion in Evergreen?
15:34:51 <ldw> It uses the current match logic, but matches on copy-status as well looking for 'on-order'
15:34:55 <jeff> ldw++ sitka++
15:35:05 <kmlussier> Ooh! That could be handy.
15:35:09 <ldw> jeff: It is local code only.
15:35:09 <kmlussier> ldw++
15:35:20 <ldw> I can move it over though.
15:35:32 <dbwells> ldw: That sounds a lot like the "opportunistic" overlay added in 2.6 (2.5?)
15:35:43 <dbwells> 2.5
15:36:01 <ldw> dbwells: yes, it was heavily bassed on that. But, it works outside of Acq.
15:36:01 <jeff> ldw: even if it's not yet ready for pullrequest, please do share. you may find that someone else with sufficient motivation/tuits can do integration and you don't have to. :-)
15:36:13 * csharp suddenly remembers this meeting
15:36:20 <dbwells> ldw: Ah, thanks
15:36:21 * kmlussier waves to csharp
15:36:23 <ldw> jeff: Ok, I will post to the list with the branch on Sitka's git.
15:37:43 <bshum> ldw++
15:38:00 <jeff> There's also some interesting possible development of features going on related to OPW, which gives me a chance to bring up:
15:38:26 <jeff> #topic Evergreen participation in OPW - Outreach Program for Women
15:38:56 <jeff> kmlussier++ for running with this one -- i can't remember if i should be incrementing someone else equally, i know there have been many hands involved.
15:39:13 <kmlussier> opw-mentors++
15:39:36 <kmlussier> We've had a fair number of candidates asking questions here and on the list. And also posting some ideas for feedback.
15:39:53 <kmlussier> Are any here right now and watching the meeting?
15:40:10 <jeff> #link http://wiki.evergreen-ils.org/doku.php?id=opw Project Ideas for Outreach Program for Women
15:41:12 <kmlussier> The application deadline is coming up in a couple of weeks. As people come in and ask questions, I encourage everyone to help out when and if they can.
15:41:25 <jeff> #link https://wiki.gnome.org/OutreachProgramForWomen
15:41:26 <kmlussier> From what I've seen so far, everyone has been very helpful.
15:41:45 <csharp> a few are popping in on the weekend, I noticed
15:42:04 <csharp> might be worth a weekend check-in from time to time
15:42:18 <dbs> Yep, kmlussier's idea of advertising IRC office hours for mentors makes sense
15:42:29 <jeff> kmlussier: are there other project ideas like http://wiki.evergreen-ils.org/doku.php?id=opw:ui_suggest#julia_lima that have been created in the wiki that you know of? Are ideas like that linked from somewhere else in the wiki that I didn't see?
15:42:43 * dbs splits
15:42:47 <bshum> i think that's the first one in the wiki that I've seen so far.
15:42:57 <kmlussier> That's the only one I know of so far. It's the recommended contribution for the UI project.
15:43:05 <jeff> dbs++ say hi to your next meeting!
15:43:28 <kmlussier> I know I've received a request from one other candidate for the project to set up a wiki account. berick may know more since he is a mentor for that project.
15:43:35 <csharp> looks like the biggest hurdles they're facing are installation and what to restart to see code changes - dunno if there's any docs on that anywhere
15:43:35 <jeff> kmlussier: anything else to add or any action items you have in mind?
15:43:57 <kmlussier> We've had several bitesize doc contributions from one candidate too.
15:44:07 <kmlussier> dbs mentioned the office hours, so I'll elaborate on that a bit.
15:44:16 <csharp> ~hours
15:44:21 <jeff> csharp: might be a good place to start dev-focused chapters in the docs :-)
15:44:24 <jeff> csharp++
15:44:26 <csharp> yeap
15:44:37 <kmlussier> When we have selected interns for the projects, we agreed that the mentors should set up weekly office hours in IRC to discuss the projects.
15:45:22 <kmlussier> That way, the projects are being discussed in the open and we can keep up to date on how the project is going. We'll be adding those office hours to the calendar when the time comes.
15:45:31 <csharp> ~hours is <reply> Most #evergreen participants are active during the hours of 9:00 AM and 5:00 PM Eastern Time, Monday through Friday.
15:45:31 <pinesol_green> I'll remember that, csharp
15:45:48 <kmlussier> But maybe we should do some ahead of time for the candidates. Especially if they're dropping in on the weekends?
15:47:07 <jeff> If people are able to commit to that, great -- otherwise I'd suggest just being aware that new faces coming in looking for assistance with install/setup/etc are likely OPW participants, and to... well, pretty much do what you normally would do, right? Assist in any way that you can, as time permits, etc. :-)
15:47:08 <kmlussier> jeff: I don't have any action items at this time.
15:47:27 <jeff> kmlussier: got it. thanks!
15:47:40 <jeff> #topic Evergreen 2.8 Release Manager
15:48:06 <jeff> added to the agenda at the request of bshum, it's time to start thinking about the Evergreen 2.8 Release Manager
15:48:15 <bshum> Thanks jeff
15:48:24 <bshum> So I briefly mentioned this in a quick post on the dev list the other day
15:48:45 <jeff> I don't recall if traditionally we've burdened the current RM with some of the tasks of kicking off the selection process for the next RM.
15:48:47 <bshum> We discussed at the Hack-A-Way that we're going to ask the immediately preceding RM to ask for volunteers for next.
15:49:27 <bshum> So yeah, traditionally, but it's semi-official.
15:49:28 <bshum> :)
15:49:30 <csharp> #info see https://docs.google.com/document/d/1lL9S07c8X_zfXSexXfnwzRllnvVvJsW0qf65QxGtH7A/edit - "2.next" discussion
15:49:40 <jeff> clear responsibility there. :-)
15:49:53 <jeff> csharp++
15:49:56 <kmlussier> Is there anyone who has shown interest yet?
15:50:05 <bshum> #link http://markmail.org/message/5cba3zdvshegq2fx
15:50:09 <jeff> also, mosh++ -- without which i would not be able to be here today. oof.
15:50:16 <csharp> heh
15:51:06 <bshum> So, yeah, don't step up all at once :)
15:51:11 <bshum> You can think about it a bit.
15:51:50 <jeff> bshum: anything else you want to cover today regarding 2.8 RM?
15:51:52 <kmlussier> I'm assuming RM needs to be a core committer, right?
15:52:36 <bshum> kmlussier: That's something we haven't codified per say.  But I think that whoever is elected to RM would need to be trusted by the community to shepard Evergreen's next steps.
15:53:37 <bshum> Speaking as a former release manager (I say former, because I have actually released something), I find that the job entails more about keeping to timelines.
15:54:02 <bshum> The technical portion of reviewing code and making decisions still rests with the whole core committers and other contributors to the developer team.
15:54:26 <bshum> And I would have been lost without much of the input I received from many of you all.
15:54:27 <bshum> :D
15:54:38 <jeff> bshum++
15:55:23 <jeff> #topic 2014 Hack-a-way Summary
15:55:30 <berick> a non-core-commiter RM would just need a trusty committer on retainer
15:55:36 <jeff> #link https://docs.google.com/a/tadl.org/document/d/1lL9S07c8X_zfXSexXfnwzRllnvVvJsW0qf65QxGtH7A/edit 2014 Hackaway Collaboration document
15:55:39 <berick> for pushing release branches.  certainly doabl, though
15:55:55 <jeff> berick: yeah, logistically-speaking, tricky but possible.
15:56:16 * bshum starts staring at kmlussier intently.
15:56:27 <kmlussier> Why is bshum staring at me?
15:56:31 <bshum> Oops, that wasn't supposed to be in the main channel :)
15:56:32 <jeff> Anyone from the hackaway want to summarize/wrap up, or just point at a blog post or other document instead?
15:56:50 <berick> bshum: kmlussier: hahaaa
15:57:27 <bshum> jeff: I think Rogan wrote up a nice write-up on his blog
15:57:29 * bshum digs around
15:57:47 <bshum> http://www.roganhamby.com/evergreen/2014/9/27/hack-a-way-2014-wrapup-and-photos
15:57:47 <dbwells> I think being an RM who couldn't commit to master would be a pretty major hassle.  My two cents.
15:58:22 <jeff> #link http://www.roganhamby.com/evergreen/2014/9/27/hack-a-way-2014-wrapup-and-photos 2014 Hack-a-way wrap-up from Rogan
15:58:33 <bshum> But yeah, the google doc is a loose thing of all the stuff we were working on
15:59:07 <csharp> I understand that we don't have a slew of core committers, but that seems to me like a necessary hurdle for an RM
15:59:50 <csharp> (as one who was put forward informally as a future RM at the Hackaway ;-))
16:00:15 <kmlussier> That was my assumption too, but it probably should be written down somewhere. :)
16:00:19 <Dyrcona> Well, someone could alway be granted the necessary access.
16:00:24 <bshum> Dyrcona++
16:00:26 <bshum> :)
16:01:02 <jeff> this is probably a good discussion to continue outside of the meeting, either immediately following or at another time. :-)
16:01:07 <csharp> yeah
16:01:15 <jeff> Anyone else have agenda items before I endmeeting?
16:02:00 <jeff> #endmeeting