14:00:44 <yboston> #startmeeting 2014-11-06 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:44 <pinesol_green> Meeting started Thu Nov  6 14:00:44 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:44 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:44 <pinesol_green> The meeting name has been set to '2014_11_06___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:46 <RoganH> kmlussier: I didn't think so but I wanted to be sure and nope.
14:00:54 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20141106-agenda
14:00:55 * kmlussier shuts up and pays attention to yboston
14:01:04 <yboston> #topic Introductions
14:01:10 <yboston> Please feel free to start introducing yourselves...
14:01:20 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:28 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:34 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:44 <snigdha26> #info snigdha26 is Snigdha Dagar, OPW candidate
14:01:49 <phasefx> #info phasefx is Jason Etheridge, ESI (lurking)
14:02:00 <kbutler> #info kbutler is Kate Butler, Rodgers Library (Hudson, NH)
14:02:22 <yboston> I will wait about a minute before we start
14:02:31 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College (Albany, OR)
14:02:31 <RoganH> #info RoganH, Rogan Hamby (SCLENDS) (lurking) (mainly because I was here anyway)
14:03:39 <yboston> moving on...
14:03:53 <yboston> #topic Updates from Content Coordinators
14:04:01 <yboston> do we have any updates this time around?
14:04:07 <kmlussier> I don't have any updates
14:04:29 <yboston> OK, and it looks liek Robert is not here today
14:04:40 <yboston> so we can move to past action items
14:05:06 <yboston> 1) kmlussier will check in on list to help move along pending 2.7 docs
14:06:01 <yboston> any comments kmlussier ?
14:06:18 <yboston> I beleive we might be all set with 2.7, oor is there anything missing?
14:06:33 <kmlussier> Sorry. We are still missing a couple of things. One is something I volunteered to do.
14:06:56 <kmlussier> And the other is something that krvmga worked on. He was going to send them along to me, but I haven't received them yet.
14:07:00 <yboston> would you like to have someone help you or collborate with you?
14:07:23 <kmlussier> For my piece, no. Sorry, I've been busy, but my time has actually freed up a bit. I'll do it tomorrow.
14:07:39 <kmlussier> But if somebody would like to poke krvmga about the added content docs, that might help.
14:07:53 <kmlussier> Also, I don't think we have anything on RDA yet.
14:08:29 <yboston> I can contact krvmga if you want?
14:08:41 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.7_needs
14:09:08 <kmlussier> yboston: That would be helpful. Somebody else was working on added content too. I don't know if it overlaps with what krvmga did.
14:09:18 <Stompro> #Info Stompro is Josh Stompro, Lake Agassiz Regional Library, MN
14:09:41 <yboston> kmlussier: do you mean the docs for listing local images?
14:09:57 <yboston> that would be (the wonderful) Josh
14:10:08 <kmlussier> yboston: There were 2 parts of it. Listing by local images was one, but there was also something specific to Content Cafe.
14:10:18 <yboston> I see
14:10:43 <kmlussier> yboston: Did the Display "Imported As" in Vandelay make it in? That's the only other new feature I'm seeing that isn't marked as completed on the wiki.
14:10:52 * kmlussier thinks it was just an updated screenshot, right?
14:10:59 <yboston> BTW, I just checked the "master" docs PDF and did not see the RDA section docuemnted yet
14:11:31 <yboston> I thought I had done the RDA stuff, but I defiently did the "imported as"
14:11:38 <kmlussier> I thought jpringle was doing something with RDA.
14:12:01 <kmlussier> OK, I'll update the wiki page on the Vandelay thing.
14:12:44 <yboston> I remember now, yes Jennifer was going to add it to the
14:12:51 <yboston> cataloging docs
14:13:08 <yboston> BTW< I just verified the "imported as" is in "master" docs
14:13:26 <kmlussier> If I have time after putting the marc stream importer docs into asciidoc, I can do RDA. It should be simple, just a note saying what we support.
14:13:42 <yboston> kmlussier: sure but let Jennifer knwo if you do
14:14:03 <kmlussier> yboston: Yes, I'll do that.
14:14:14 <yboston> #action yboston will contact krvmga to check in on his 2.7 docs work
14:14:24 <yboston> kmlussier: what should I put you down for, if anything?
14:14:49 <kmlussier> I'll complete the marc stream importer work and check on the status of the RDA docs.
14:15:11 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs.
14:15:26 <yboston> may I move on?
14:15:31 <kmlussier> yes
14:16:09 <yboston> (the next old action item was for me to bring up reviewing 2.7 pending issues. so I am skipping it)
14:16:22 <yboston> 2) remingtron will start a thread on DIG list on documenting the web client
14:16:32 <yboston> remingtron: any comments?
14:16:36 <remingtron> sure
14:16:53 <remingtron> I posted a wiki page and sent it to the DIG list, and I'll find that link...
14:17:09 <yboston> I have it
14:17:13 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:webclient
14:17:15 <remingtron> thanks
14:17:39 <remingtron> And here's an email thread that followed:
14:17:43 <remingtron> #link http://markmail.org/thread/q6umnsqu7xg4af6j
14:17:49 <yboston> did you get any takers at the time? should we try again on the general list?
14:18:03 <remingtron> I had one interested party and can't remember who it was
14:18:47 <remingtron> I know Sally Fortin was mentioned as being involved through Equinox
14:18:56 <yboston> since we are between relese versions, should we make a small team to work on it?
14:19:35 <remingtron> sure, that's a good idea, with the hope that we shift back to 2.8 docs when appropriate
14:19:35 <yboston> alternatively, set a deadline for all of us to get some docs done by next meeting?
14:19:47 <kmlussier> I still think it would be a good idea to schedule a day for people to focus on it.
14:20:18 <kmlussier> Similar to Bug Squashing Day. Web Client Documentation Day
14:20:24 <remingtron> I'm game for a "Web Staff Client Docs Squashing Day"
14:20:25 <yboston> kmlussier: love it
14:20:37 <kmlussier> Or maybe not an entire day if that's too difficult for people.
14:20:55 <kmlussier> remingtron: Yes, let's get "squashing" in there. :)
14:21:00 <yboston> we might need a few hours to think through how we shoudl approach things
14:21:22 <yboston> though we may be able to do that by email befoer the sqaushing day
14:21:25 <kmlussier> We could do that ahead of time through e-mail.
14:22:06 <remingtron> I would appreciate feedback on the wiki page, which proposes an outline for web client docs
14:22:15 <remingtron> at least during the preview
14:23:05 <remingtron> (doesn't have to be now, just before we hold a day of working on it)
14:23:31 <yboston> shoudl we make a Doodle poll to find a day or half day to work on this?
14:23:50 <kmlussier> remingtron: This page here?
14:23:51 <kmlussier> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:web_staff_client_workflow_and_label_changes
14:24:07 <remingtron> kmlussier: I just meant the page yboston posted for me earlier:
14:24:11 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:webclient
14:24:14 <remingtron> (sorry to be unclear)
14:24:47 <kmlussier> remingtron: No, you weren't. I was just confused.
14:24:50 <yboston> remingtron: would you set up a Doodle poll to see if we can find a time?
14:25:09 <remingtron> yboston: sure, sign me up for that action item
14:25:28 <yboston> do we want to narrow down the time frame before hand?
14:25:31 <yboston> like ...
14:25:38 <yboston> between now and December?
14:25:49 <yboston> we can debate it by email too, sicne more people coudl chime in
14:26:01 <remingtron> yeah, let's do it by email
14:26:02 <yboston> (sorry for the bad spelling)
14:26:07 <kmlussier> It's a good goal, just remember that the end of November will be difficult.
14:26:16 <yboston> not for our Canadian friends
14:26:21 <remingtron> I'll aim the poll at early December
14:27:03 <yboston> #action remingtron will set up a Doodle poll to find a dai to exclusively work on web client docs (remotely)
14:27:43 <yboston> should I go to the next old action item? it deal with remingtron's re-org proposals
14:28:11 <remingtron> sure
14:28:39 <yboston> 3) remingtron will create a wiki page to collect ideas for a docs re-org
14:28:50 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:reorg_2014
14:29:06 <yboston> remingtron: thanks for making this page
14:29:13 <yboston> any comments?
14:29:14 <remingtron> you are welcome :)
14:29:20 <remingtron> no comments or edits yet
14:29:32 <Stompro> I started to look at this but become overwhelmed with looking at the whole structure.
14:29:45 <kbutler> ditto
14:29:57 <remingtron> Stompro: kbutler: thanks for your interest
14:30:15 <yboston> I hope that woriking on the web client docs will naturally gives us a chance to try out new organizations
14:30:16 <remingtron> what if we start with basic, very broad structure?
14:30:16 <Stompro> I would like to start with some small things, like combining all the tpac/catalog docs into one section.
14:30:52 <remingtron> Stompro: good idea, +1
14:31:29 <remingtron> kbutler: do you have a specific area of interest? or more the broad structure of the docs?
14:31:29 <yboston> remingtron: can you give me a beter idea of what you mean?
14:31:35 <kmlussier> I think one area of confusion is the Evergreen in Action stuff was added a separately, because we wanted that content in our official docs, but it also replicates information already in there.
14:32:05 <kmlussier> I wonder if it would be better to set them under an "Evergreen in Action" heading to make it easier to understand why it's there.
14:32:15 <remingtron> kmlussier: right, I think the current organization is a bit messy
14:32:53 <remingtron> it seems we could approach the problem from different angles:
14:33:03 <kbutler> remingtron: I think I am more interested in the overall structure. The way it is right now is overwhelming with way too many topics on the same level
14:33:11 <remingtron> 1. make small improvements like Stompro suggested (very much appreciated!)
14:33:23 <yboston> Stompro++
14:33:56 <remingtron> 2. medium level improvements by combining Evergreen In Action more nicely
14:34:49 <remingtron> 3. rethink the structure from scratch (similar to some of snigdha26's ideas)
14:35:10 <remingtron> maybe #1 and #2 can happen now, and #3 is a long term goal
14:35:31 <yboston> I agree with #1 and #2 being able to happen now
14:35:33 <kbutler> +1 - I think accomplishing #1 and #2 will make #3 easier in the long run
14:37:07 * kmlussier can work on #2
14:37:36 <kmlussier> Or just the Evergreen in Action piece of it. Maybe there are other medium level improvements.
14:37:38 <remingtron> kmlussier++
14:37:47 <yboston> should we find volunteers to work on re-org tasks?
14:37:59 <yboston> or an assignment for the whole crew?
14:38:58 <Stompro> I'll work on #1, specifically getting the catalog releated docs in one spot.
14:39:28 <remingtron> Stompro++
14:40:04 <yboston> I can try to work on #3
14:40:47 <yboston> BTW kmlussier, Simmons has just anounced a NOvember 21st deadline to apply for an MLS intern
14:41:07 <yboston> I may want to apply for an intern to help with work like the re-org
14:41:41 <yboston> so should we start another thread in the mailing list? should we set a deadline?
14:41:55 <yboston> what about having a seperate IRC meeting to compare re-org ideas?
14:42:03 <kmlussier> yboston: Great! Keep us posted.
14:42:17 <remingtron> yboston: yes, separate meeting sounds good
14:42:34 <remingtron> then we can come prepared with ideas to share, and hopefully reach a concensus
14:43:08 <remingtron> yboston: I propose that it be a meeting focused on idea #3 though
14:43:25 <yboston> I can create a doodle poll for chatting about re-org, how long from now should I shoot for?
14:43:29 <remingtron> since #1 and #2 seem doable by a single person without group decisions
14:43:31 <yboston> yes, focusing on #3 is fine
14:44:24 <remingtron> maybe postpone that meeting until January? don't want to distract from web client docs day
14:44:33 <remingtron> thoughts everyone?
14:44:34 <yboston> no problem
14:44:37 <kmlussier> Yes, let's spread out the work. :)
14:44:41 <Stompro> January sounds good.
14:44:58 <yboston> I also tink that while working ont he web lcients docs we can start experimenting with re-orgs
14:45:04 <remingtron> so December is web client docs, January is docs re-organization planning
14:45:21 <yboston> remingtron: yes, O with me
14:45:25 <yboston> *OK
14:45:56 <yboston> BTW, we are at the 45 minute mark
14:46:22 <remingtron> I'll send a doodle for the January meeting too
14:46:41 <yboston> thanks!
14:47:09 <yboston> #action remingtron will set up doodle to set up a meeting on IRC in Janaury 2015 to discuss re-organizing the EG docs
14:47:52 <yboston> if we decide to move on, the next old action is about setting up a DIG VM
14:48:15 <yboston> though, I have nothing much to add abotu that topic at this point
14:48:44 <yboston> should I move on?
14:48:46 <remingtron> still something we want to pursue?
14:49:07 <yboston> I think we should have a secodn server that build the docs every day
14:49:24 <yboston> or maybe multiple times a day
14:49:35 <remingtron> Robert already made his server build twice a day, right?
14:49:40 <yboston> remingtron: is that what you meant?
14:49:54 <yboston> I was not aware of that
14:50:01 <remingtron> hm, let me check his email...
14:50:21 <yboston> also, we could have the second server be used to test re-organizations
14:50:41 <kmlussier> It's not just the multiple builds. If we want to make changes to the docs site, it's good to have a place to test them out ahead of time before putting them into production.
14:50:44 <yboston> though in theory we can set up Robert's server to do that, though I beleive his servers are pretty taxed already
14:50:46 <remingtron> on 10/3/2014 Robert emailed me and yboston, saying he added a 1pm build time to his docs server
14:50:55 * kmlussier is thinking of some of the ideas snigdha26 raised at the last DIG meeting.
14:51:06 <yboston> I need to learn how to read better
14:51:29 <remingtron> yboston: no prob, you're a busy guy
14:52:14 <remingtron> yboston: did we have a potential host for our new test docs VM?
14:52:33 <yboston> PINES provides VMs for the EG community
14:52:49 <yboston> and Galen started the discussion on provisioning a server for us
14:53:12 <remingtron> anything we need to do to keep that moving forward?
14:53:13 <yboston> someitme in the last four weeks we talked abotu RAM needs for exmale
14:53:22 <yboston> *example
14:53:39 <yboston> I think I just need to follow up with Galen and Robert
14:54:02 <remingtron> sounds good, I think it's worth pushing forward, for all the reasons mentioned
14:54:15 <yboston> #action yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:54:48 <yboston> BTW, we are down to the last 5 minutes, if we want to stop at the hour mark
14:54:56 <yboston> no more old actions to discuss
14:55:21 <remingtron> what about snigdha26's ideas?
14:55:35 <yboston> before I forget, sandbergja++
14:55:50 <kmlussier> Indeed sandbergja++
14:56:12 <sandbergja> yboston: kmlussier: Awww, thanks
14:56:13 <kmlussier> Work on the hard due date docs was long overdue - no pun intended.
14:56:20 <yboston> ha ha ha
14:56:25 <kmlussier> Well, maybe it was intended.
14:56:46 <yboston> kmlussier: any comments on snigdha26's ideas, we are sitll on a holding pattern?
14:56:53 <remingtron> sandbergja++
14:57:55 <remingtron> I love snigdha26's ideas for better TOC navigation in a sidebar, and easy to find "Get help" box at top right of the page
14:58:05 <yboston> me too
14:58:10 <kmlussier> remingtron is right. There is an agenda item on snigdha26's doc site ideas.
14:58:32 <kbutler> I thought the ideas were very good.
14:58:48 <yboston> my apologies that we have hit the hour mark already, I can stay on longer
14:58:51 <kmlussier> But is this a leftover agenda item from last month?
14:59:08 <yboston> I thought ti was leftover, but I could be wrong
14:59:27 <remingtron> I don't recall discussing it much, or at least not deciding to try anything
14:59:35 <remingtron> maybe we got sidetracked with needing a test server
14:59:49 <remingtron> but I think we can decide to try things before the server is ready
15:00:02 <kmlussier> remingtron: I think we're in an awkward period at the moment because snigdha26 has incorporated a lot of these ideas in her proposal, but the application review period isn't over yet.
15:00:27 <remingtron> kmlussier: right, you mean that if accepted, she would do these things herself?
15:00:37 <kmlussier> remingtron: Yes, exactly.
15:00:53 <remingtron> kmlussier: cool, we can wait on discussing it further then
15:00:57 <kmlussier> I do remember there was a bit of feedback last month, though, and she did incorporate a lot of that feedback in her proposal.
15:01:40 <remingtron> snigdha26++
15:01:41 <kmlussier> snigdha26++ #Bring forward lots of great ideas to improve our docs!
15:01:54 <kmlussier> Ugh, excuse my poor grammar.
15:01:54 <yboston> snigdha26++
15:02:55 <yboston> do we want to discuss anything else fromt he old topcia section, or something compeltely different? Should we end the meeting now?
15:03:03 * kmlussier votes for ending the meeting.
15:03:09 <remingtron> I'm satisfied too
15:04:02 <yboston> I am OK with ending too, but if any one has any particualr DIG related question you can ask after I end the meeting or use the DIG list or contact me directly
15:04:30 <yboston> #endmeeting