14:02:53 <bshum> #startmeeting 2014-11-12 - Developer Meeting
14:02:53 <pinesol_green> Meeting started Wed Nov 12 14:02:53 2014 US/Eastern.  The chair is bshum. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:53 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:53 <pinesol_green> The meeting name has been set to '2014_11_12___developer_meeting'
14:02:59 <bshum> #topic Introductions
14:03:04 <bshum> #info bshum = Ben Shum, Bibliomation
14:03:17 <phasefx_> #info phasefx_ = Jason Etheridge, ESI
14:03:21 <DPearl> #info DPearl = Dan Pearl, C/W MARS
14:03:21 <kmlussier> bshum++
14:03:22 <bshum> Please feel free to introduce yourselves, I'll dig up the agenda
14:03:28 <bshum> #link http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-11-12
14:03:31 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:03:48 <berick> #info berick Bill Erickson, KCLS
14:03:54 <dbs> #info dbs = Dan Scott, Laurentian University
14:04:05 <bshum> Bit slim looking at the moment, but I'm happy to take on any final discussion topics as we go
14:04:09 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:04:45 <eeevil> #info eeevil is Mike Rylander, Equinox
14:05:25 <Stompro> #info stompro is Josh Stompro, LARL
14:07:07 <bshum> Alrighty, as folks show up, please feel free to announce your presence.  We'll move on through the agenda...
14:07:22 <remingtron> bshum: I don't see past action items on the agenda
14:07:25 <bshum> Though of course
14:07:28 <bshum> Yeah I just noticed that :)
14:07:51 <bshum> Okay, based on the past meeting
14:07:55 <bshum> #topic Past action items
14:08:08 <bshum> #info dbwells to update Conditional Negative Balances bug 1198465 with links to new branches, etc.
14:08:08 <pinesol_green> Launchpad bug 1198465 in Evergreen "Support for Conditional Negative Balances" (affected: 14, heat: 62) [Wishlist,Confirmed] https://launchpad.net/bugs/1198465
14:08:17 <bshum> I saw that dbwells put some new comments on that bug
14:08:40 <remingtron> dbwells is out today, but I might be able to clarify any questions about his latest bug comment
14:09:20 <gmcharlt> #info gmcharlt is Galen Charlton, ESI
14:09:21 <bshum> I know I need more time to digest things on that
14:09:45 * dbs disappears to do some hardware stuff, grr
14:10:08 <bshum> Let's defer on that subject till we get some more time to read through and respond to the latest?
14:10:08 <kmlussier> I plan to test it soon, but I haven't had a chance look closely enough to come up with any questions yet.
14:10:39 <bshum> Though I think for the action item, it's settled since it looks like dbwells did update the bug with new details.
14:10:46 <bshum> Next past item
14:10:54 <bshum> #info gmcharlt to release OpenSRF 2.4 when ready
14:11:04 <bshum> Which actually links us to the OpenSRF release topic
14:11:12 <gmcharlt> #action gmcharlt will release OpenSRF 2.4.0 on 13 November
14:11:19 <bshum> gmcharlt++
14:11:51 <bshum> Okay, last item was
14:11:57 <bshum> #info kmlussier to schedule another Bug Squashing Day
14:12:01 <bshum> Which is done and was done
14:12:12 <bshum> Since we held that day earlier this week
14:12:23 <kmlussier> Yes indeed. I should have a wrap-up blog post written by the end of the week.
14:12:32 <bshum> kmlussier++
14:12:37 <berick> kmlussier++
14:12:46 <DPearl> kmlussier++
14:12:48 <gmcharlt> kmlussier++
14:12:52 <bshum> #action kmlussier to have results of second Bug Squashing Day posted to blog by end of week.
14:13:06 <bshum> okay
14:13:08 <bshum> Next topic
14:13:18 <bshum> #topic Release info
14:13:34 <bshum> We already covered OpenSRF latest.  Is there anything else we need to say about OpenSRF?
14:14:36 <bshum> ... and nope, everyone is just too excited about the next subject
14:14:57 <bshum> Quick info insert
14:15:31 <bshum> #info Security releases for Evergreen have been released, see http://evergreen-ils.org/security-releases-evergreen-2-7-1-2-6-4-and-2-5-8/
14:15:59 <bshum> #topic Next Evergreen Release Manager
14:16:56 <bshum> So on the agenda, we see "berick throws his hat in the ring."
14:17:02 <bshum> Comments, thoughts?
14:17:11 <bshum> Other hats?
14:17:28 * berick confirms he in fact wrote that
14:17:33 <gmcharlt> berick: inquiring minds want to know... bowler, top hat, or fez?
14:18:06 <berick> gmcharlt: http://www.clownantics.com/images/products/a2020r.jpg
14:18:18 <gmcharlt> berick++
14:18:32 <phasefx_> 20 gallon?
14:18:55 <berick> phasefx_: heh, sounds about right
14:19:42 <berick> quick note, if I'm elected RM, my time for contributing to the OPW project will be diminished.
14:20:13 <berick> seems like we have that generally covered, though
14:20:22 <gmcharlt> I think we have enough devs who have previously expressed willingness to mentor to compensate
14:20:23 <kmlussier> berick: There are two other mentors for that project, so I think OPW will be fine.
14:20:38 * berick nods
14:21:35 <bshum> Okay, so next steps, do we want to go through a formal list vote (with some more info on what might be the vision of 2.next)?
14:21:42 <bshum> Or should we just vote berick in now ;)
14:22:11 <kmlussier> I'm okay with voting berick now, but I would still like to see a post to the list on objectives, vision, etc.
14:22:30 * gmcharlt agrees
14:23:48 <bshum> Alrighty
14:24:55 <bshum> #startvote Vote to show support of berick as our 2.next Release Manager
14:24:55 <pinesol_green> Unable to parse vote topic and options.
14:25:04 <bshum> Oh, gap
14:25:24 <gmcharlt> #startvote Foo? Option1, Option2
14:25:31 <bshum> #startvote Vote to show support of berick as our 2.next Release Manager? Yes, No
14:25:31 <pinesol_green> Begin voting on: Vote to show support of berick as our 2.next Release Manager? Valid vote options are Yes, No.
14:25:31 <pinesol_green> Vote using '#vote OPTION'. Only your last vote counts.
14:25:38 <gmcharlt> #vote Yes
14:25:39 <bshum> #vote Yes
14:25:39 <Stompro> #vote yes
14:25:40 <phasefx_> #vote Yes
14:25:43 <Dyrcona> #vote Yes
14:25:45 <jeff> #vote Yes
14:25:48 <jeff> (hi)
14:25:50 <kmlussier> #vote Yes
14:25:54 <eeevil> #vote yes
14:26:02 <DPearl> #vote Yes
14:27:17 <bshum> Okay
14:27:18 <bshum> #endvote
14:27:18 <pinesol_green> Voted on "Vote to show support of berick as our 2.next Release Manager?" Results are
14:27:18 <pinesol_green> Yes (9): kmlussier, DPearl, jeff, Dyrcona, gmcharlt, Stompro, phasefx_, bshum, eeevil
14:27:40 <bshum> That's good enough for me.  Thanks berick for volunteering to steer the ship!
14:27:50 <gmcharlt> berick++
14:27:54 <bshum> #info berick is the next release manager for Evergreen 2.next
14:28:04 <kmlussier> Hooray!
14:28:06 <DPearl> berick++
14:28:08 <bshum> Your first action item is to write something up for the lists
14:28:13 <Dyrcona> berick++
14:28:18 <berick> thanks for the votes.  i'll send a note to the lists..
14:28:29 <bshum> #action berick to write about his ideas for 2.next to the lists
14:28:57 <bshum> And also, I affirm that I'll be helping out as always during the next cycle to help review and help with the release process.
14:29:20 <berick> bshum++
14:29:22 <gmcharlt> bshum++
14:29:29 <bshum> Also, 2.8 or 3.0?  (the eternal struggle)
14:29:42 <bshum> These are questions I'll be curious to see addressed as we move forward.
14:29:53 * gmcharlt settles on the absolutist position that I will be happy if it is called either 2.8 or 3.0
14:30:02 <gmcharlt> SO THERE!
14:30:09 <bshum> Heh
14:30:14 <berick> version 37 it is, then
14:30:20 <gmcharlt> :)
14:30:25 <bshum> Okay, if we're fine with this topic, let's move on then :)
14:31:03 <bshum> #topic New Business: Outreach Program for Women
14:31:11 * bshum passes the mic to kmlussier
14:31:28 <kmlussier> OPW just made the announcement about 30 minutes ago, and I just made an announcement to the community blog.
14:31:33 <kmlussier> #link http://evergreen-ils.org/welcome-julia-to-the-evergreen-opw-internship-program/
14:31:57 <kmlussier> Julia Lima will be working as the intern for Evergreen. She'll be working on the UI style guide project.
14:32:50 <kmlussier> berick, dbwells, and graced will be the mentors. But, as berick mentioned above, a lot of that might fall to graced and dbwells and to others in the community.
14:33:12 <kmlussier> Julia shared some great suggestions for UI improvement at http://wiki.evergreen-ils.org/doku.php?id=opw:ui_suggest:julialima
14:33:51 <kmlussier> I'm really excited about the project.
14:34:29 <bshum> Cool, cool
14:35:01 <kmlussier> Also, many thanks to everyone who helped out with the project during the application period, especially everyone who volunteered to be mentors.
14:35:04 <bshum> Any questions or comments for kmlussier?
14:35:18 <bshum> berick++ dbwells++ graced++ kmlussier++
14:35:22 <bshum> And everyone++
14:35:23 <bshum> :)
14:35:50 <kmlussier> I also added something to the agenda that came up in conversation during the application review when we talked about ways to improve the application period if we decide to do a similar project again.
14:36:22 <phasefx_> Julia++
14:36:47 <kmlussier> It really was better as a developer community discussion than an OPW discussion. Basically, it would be easier to encourage new people to contribute to Evergreen if the installation process were easier.
14:37:57 <bshum> "easier" in the sense of fewer steps, less manual from source building?
14:38:28 <bshum> Or what else do we mean
14:38:34 <kmlussier> Well, seeing as how I've never installed Evergreen, I throw that question out for others.
14:38:57 * gmcharlt tosses out a couple thoughts
14:39:01 <kmlussier> I do think that installing Evergreen presents a big hurdle for somebody trying to get their first code contribution in. I don't know what we can do to make it easier.
14:39:08 <Stompro> The install docs could include various methods, such as the install script that I've heard about, and the Pines repo method.  How would you all feel to having multiple install methods.
14:39:32 * kmlussier also notes that none of the coding applicants for OPW successfully made a code contribution to the project.
14:39:49 <gmcharlt> 1. being able to run through the installer is kinda necessary for doing dev -- maybe we could throw people at the problem -- i.e., an informal system for partnering with folks tackling it
14:40:12 <kmlussier> Stompro: I added the install script to the OPW wiki page at one point, but I know dbs had suggested adding it to the readme.
14:40:21 <gmcharlt> 2. as a more techie route, the Koha ecosystem has tools for converting a package install to a variant that can grab code from a Git checkout
14:40:30 <gmcharlt> kinda a best of both worlds setup
14:40:37 <gmcharlt> that might be worth spending cycles on replicating
14:41:34 <remingtron> #link http://wiki.evergreen-ils.org/doku.php?id=server_installation:semi_automated
14:41:49 <remingtron> that's a wiki page of all the installer scripts I'd heard of in the community
14:42:23 <kmlussier> I don't think berick's script is there.
14:42:30 <Dyrcona> When we're talking packages, what distro(s)?
14:43:22 <Dyrcona> We could always share the scripts that tsbere developed for the MassLNC sandboxes. Those might prove helpful.
14:43:41 * tsbere thought those were already out there
14:43:59 <kmlussier> tsbere: I added those to the OPW wiki too.
14:44:22 <Dyrcona> OK. I didn't know.
14:44:24 <kmlussier> I had forgotten about the page that remingtron just linked to. Is that fairly up to date?
14:44:58 <Dyrcona> It points at something of mine that no longer exists.
14:44:58 <kmlussier> The OPW wiki isn't an ideal place to share these scripts. If we think they might be useful to people, then maybe adding them to the install docs or the readme, as dbs previously suggested, is a good idea.
14:45:25 * Dyrcona puts curmudgeon hat on.
14:45:43 <Dyrcona> I think the current installation procedure is a good test for potential developers.
14:46:14 <Dyrcona> If you can't follow a README, do a manuals installation, and troubleshoot issues, you're going to have a very hard time later figuring out why your code broke something.
14:46:46 <kmlussier> Dyrcona: The curmudgeon hat suits you. :)
14:47:31 <Stompro> Dyrcona: I understand your view, but if people give up during the install phase, then there is never the possibility of them contributing at all.
14:47:53 <kmlussier> Like I've said, I've never done an installation, so I feel out of my depth in this discussion. But when you look at a project like the responsive design one, it seems like you shouldn't have to be able to do a manual install to make a valuable contribution.
14:48:22 <remingtron> kmlussier: you haven't had to do a manual install to make a valuable contribution!
14:48:28 <gmcharlt> one nuance is that "developer" does not refer to just single, unitary skillset that could make useful code-level contributions to Evergreen
14:48:42 <berick> remingtron++
14:49:21 <Dyrcona> All good points, and I've maybe limited my view to the backend too much.
14:49:38 <gmcharlt> so it should be possible for (say) a JavaScript person or a web develoepr to be able to jump in without having to care about the backend
14:50:06 <gmcharlt> that said, I don't entirely disagree with Dyrcona either; being able to follow install instructions is a useful skill
14:50:23 <kmlussier> Going beyond contributions, another question is does the install process impeded adoption of Evergreen?
14:50:25 * Stompro just added phasefx's wheezy_installer to the "semi_automated" page.  And removed Dyrcona's 404 link.
14:50:42 <kmlussier> s/impeded/impede
14:51:06 <kmlussier> It was a light agenda, so I figured it was a good time to raise weighty questions. :)
14:51:21 <phasefx_> Stompro: more berick's than mine, but cool deal
14:51:23 <Dyrcona> Going beyond Evergreen, installation impedes the adoption of anything.
14:51:34 <gmcharlt> I think separating the question of installation for code-level contributors vs. production use would be a good idea, though
14:51:49 * Dyrcona agrees with gmcharlt.
14:51:50 <kmlussier> OK, I withdraw the question then.
14:52:06 <krvmga> just a note back to the list on the "Frozen" search issue from early today: fiddling with the 246 did nothing to change the display order; the older DVD still appears first in returns.
14:52:11 <Dyrcona> Developers of any project typically have to follow different installation methods from regular users.
14:52:29 <bshum> krvmga: We're in the midst of a dev meeting, give us say another 8 minutes.
14:52:41 * krvmga says sorry and slinks off.
14:53:46 <bshum> Okay
14:54:04 <bshum> So since we're coming up on good time chatting on this, I'd like to ask for some actionable items to help move us in new directions.
14:54:24 <bshum> From the discussion, I think we can summarize that installation could be "easier" (for lack of a more precise term)
14:54:44 <bshum> Does anyone want to take some action items to investigate or help poke on this topic further?
14:55:44 * gmcharlt is interest, but cannot promise any cycles before 2015
14:55:50 <gmcharlt> *interested
14:56:12 <bshum> I can define it more generically if we're not ready to commit to anything.
14:56:15 <bshum> Just adding something in the notes for now
14:56:31 <Dyrcona> I know! Let's form a committee!
14:56:35 <bshum> #help Looking for input and ideas to make the installation process easier on future developers and contributors.
14:56:39 <kmlussier> I can see it being a long-term action item. :)
14:56:49 <Dyrcona> Oh wait.... librarian hat slipped on there for a moment.
14:57:03 <gmcharlt> kmlussier: that wouldn't be any different ... and to be fair to the project, it actually has gotten TONS better by many accounts
14:57:16 <kmlussier> Dyrcona: Put the curmudgeon hat back on!
14:57:23 <bshum> I'm curious to see if there's more we can learn from our Koha neighbors, i.e. tools that gmcharlt alluded to.
14:57:33 <kmlussier> gmcharlt: That's good to hear.
14:57:56 <kmlussier> FWIW, I've been planning for a while to try a manual install over the weekend. Just for "fun." :)
14:58:16 <bshum> How about this, then, so that we don't forget about it
14:58:20 <gmcharlt> kmlussier++ # please take good notes!
14:58:36 <bshum> If berick is fine with it, I think maybe we can consider this to be a potential goal for our next release.
14:58:43 <bshum> To look at finding ways of making the process "easier"
14:58:49 * berick likes it
14:58:56 <gmcharlt> especially since once somebody has done their first install, they start to stop perceiving the rough points
14:59:05 <bshum> Gives us a soft target (through next year) and we can keep working on it then.
14:59:09 <gmcharlt> +1
14:59:13 <kmlussier> gmcharlt: I think Stompro has been helpful in that respect.
15:00:01 <bshum> Okay
15:00:24 <bshum> We're at the one hour mark (more or less) so I'd like to leave this topic for now and finish with one little detail before we close.
15:01:08 <bshum> #info Look at ways of improving installation process during the next release cycle as a potential 2.next goal.
15:01:14 <bshum> #topic Release Maintainers
15:01:31 <bshum> gmcharlt asked about this and so I just wanted to make a note on the release maintaining.
15:01:55 <bshum> For 2.7, I'm happy to continue to help coordinate and cut new maintenance releases for that series.
15:02:20 <gmcharlt> bshum++
15:02:34 <bshum> For 2.6, dbwells can speak on that later, but presumably he's still on board there.
15:03:03 <bshum> And 2.5 has ended maintenance releases unless there are further security backports needed.
15:03:56 <bshum> #info 2.7 series release maintainer will be bshum
15:04:00 <bshum> Okay
15:04:08 <bshum> Any other topics for discussion before we adjourn today?
15:04:13 <gmcharlt> #info 2.5 series will receive security updates only
15:04:20 <bshum> gmcharlt: Thanks :)
15:04:26 <gmcharlt> :)
15:05:06 <bshum> Okay, thanks to berick for keeping us on track with organizing the meetings.  We okay with setting up the next meeting before the holidays?
15:05:20 <bshum> (and also for being our next intrepid leader)
15:05:39 <kmlussier> Okay with me
15:05:57 <gmcharlt> +1
15:06:13 <remingtron> +1
15:06:47 <bshum> Alrighty then.  Thanks for your attention and participation.  Enjoy the rest of the week.  And thus this meeting ends, but the discussion goes on!
15:06:56 <bshum> #endmeeting