14:00:20 <kmlussier> #startmeeting 2014-11-13 - Evergreen for Academics meeting
14:00:20 <pinesol_green> Meeting started Thu Nov 13 14:00:20 2014 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:20 <pinesol_green> The meeting name has been set to '2014_11_13___evergreen_for_academics_meeting'
14:00:35 <kmlussier> #info Meeting agenda is available at http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_for_academics:2014-11-13
14:00:45 <kmlussier> #topic Introductions
14:01:03 <kmlussier> Please introduce yourselves with the #info command.
14:01:13 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:19 <mdriscoll> #info mdriscoll is Martha Driscoll, NOBLE
14:01:29 <kakes> #info kakes is Kelly Drake, FLO
14:01:56 <tspindler> #info tspindler is Tim Spindler, C/W MARS
14:02:03 <yboston> #info yboston - Yamil suarez, Berklee College of Music
14:02:19 <Christineb> #info Christineb is Christine Burns BC Libraries Cooperative
14:03:51 <kmlussier> Rather than going through the past action items, which are very similar to the new business items, I think we can dive into each subgroup area to see where we're at.
14:04:12 <kmlussier> #topic Academic PAC flavor
14:04:21 <kmlussier> yboston: Can I hand over the updating to you on this one?
14:04:31 <yboston> sure
14:04:49 <yboston> I don't hvae  an update for the PAC flovor group, except...
14:05:08 <yboston> that I put together a wiki page from the main Evergreen for academics page
14:05:41 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_for_academics:pac_academic_flavor
14:05:49 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_for_academics:pac_academic_flavor
14:06:19 <yboston> going forward I can send out an email to solicit comments on how this group wants to proceed
14:06:37 <yboston> any comments so far?
14:06:55 <yboston> kmlussier: feel free to make an action item for me
14:07:02 <kakes> looks good, I'm surprised DanB hasn't commented
14:07:19 <kmlussier> I think one thing we need to do is look at the suggestions that have already been made and figure out which ones are truly academic issues and which ones should be LP bugs/feature requests for the overall catalog.
14:07:54 <yboston> makes sense
14:08:20 <pinesol_green> [evergreen|Jason Stephenson] LP#1246371: Allow BibCommon::title_is_empty to accept a bre id or bre object. - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=984b402>
14:08:40 <yboston> would you like me to pull that data together? maybe you can send the follow up email for the group?
14:08:45 <yboston> or viceversa?
14:08:55 <kmlussier> In my mind, the one that might play into academic flavor is perhaps a view with more fields displaying. Everything else seems to be general catalog issues.
14:09:30 <kmlussier> yboston: No, we can start with your email soliciting general comments.
14:09:48 <yboston> OK,
14:10:05 <kmlussier> #action yboston to send email to list on how to proceed with academic flavor ideas.
14:10:50 <kmlussier> Does anybody else want to add anything on the academic flavor topic? Or throw out some ideas now on what we should be doing here?
14:11:23 <kmlussier> #topic Batch Patron Functions
14:11:33 <kmlussier> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_for_academics:batch_patron_functions
14:11:41 <kmlussier> I know mdriscoll has done a bit of work on this.
14:11:59 <mdriscoll> Yes, those are my notes based on lots of patron loads
14:12:30 <mdriscoll> I tried to include all the issues I run into when loading files
14:13:05 <mdriscoll> I would also like to see batch patron update and delete functionality.
14:13:10 <yboston> mdriscoll++
14:13:18 <mdriscoll> I know the database has patron buckets but no front-end to use them
14:13:25 <tspindler> batch update and delete would be great
14:13:28 <kmlussier> So those look like they could potentially be two different projects.
14:13:54 <mdriscoll> They would probably be two different interfaces, so two different projects makes sense
14:14:43 <kmlussier> mdriscoll: I'm thinking batch loading of patron records may run into similar issues as batch loading records. Maybe I'll look at some of the issues we've run across there to see if any may be things we should be thinking about for these requirements.
14:15:01 <mdriscoll> Sounds good.
14:16:02 <kmlussier> Does anyone have any specific comments or suggestions for these projects right now?
14:16:20 <kmlussier> If not, I think this would also be a good one to share via the list for feedback. But they look really good to me.
14:16:22 <pinesol_green> [evergreen|Josh Stompro] LP#1384932: document the zips.txt ZIP code database feature - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=66544eb>
14:16:25 <kmlussier> mdriscoll++
14:16:28 <tspindler> on the patron load, i think having good reporting on matches etc. would be good
14:17:01 <mdriscoll> tspindler: agreed.  I'm thinking of the vandelay interface where you can view every match.
14:17:01 <tspindler> mdriscoll has a lot down though
14:18:04 <mdriscoll> kmlussier: should I send a message to the general list looking for feedback?
14:18:24 <kmlussier> It might also be good to identify a minimum number of records you expect the loading interface to handle.
14:18:43 <tspindler> kmlussier++
14:19:00 * kmlussier doesn't know what this number should be, but she knows this is a big issue with bib record loading.
14:19:09 <mdriscoll> Good idea.
14:19:17 <kmlussier> mdriscoll: Yes, I'll put you down for an action item.
14:19:21 <mdriscoll> I load 1000 records at a time but do see a hit on the db
14:19:22 <tspindler> in our network it is probably 5000
14:19:42 <tspindler> we have community colleges that have that many
14:19:52 <mdriscoll> That's why I put "don't impact running system" in the specs
14:20:19 <mdriscoll> Nobody cares if the load slows down, but users care if the db slows down.  It should not timeout either.
14:20:22 <kmlussier> #action mdriscoll to send message to Evergreen list to get feedback on requirements for batch patron load and for batch batch patron updates/deletes through patron buckets
14:20:43 <tspindler> mdriscoll++
14:20:54 <kmlussier> Thanks Martha! They look good. :)
14:21:09 <kmlussier> Anything else on patron batches?
14:21:41 <kmlussier> #topic Authorities
14:22:10 <kmlussier> We have a link at http://evergreen-ils.org/dokuwiki/doku.php?id=authorities, but I think that's the pre-existing authorities page, right?
14:22:10 <tspindler> First, I'm going to have to step down since I will have change in responsibilities starting January 1
14:22:25 <kmlussier> tspindler: Congrats, by the way! :)
14:22:30 <mdriscoll> tspindler: congrats!
14:22:34 <yboston> what is the new position?
14:22:45 <tspindler> I start as executive director
14:22:53 <yboston> Cool
14:23:10 <tspindler> I looked at yboston page closely and he has a lot of detail on there
14:23:14 <kmlussier> tspindler++
14:23:16 <tspindler> i think it is a good start
14:23:34 <tspindler> btw, jkranich will continue to participate here with the academics for us
14:23:49 <kmlussier> I just want to note that there is some work being done on overlaying authorities via Vandelay.
14:24:10 <kmlussier> Or, I should say, it looks like there is work being done.
14:24:16 <kakes> yboston: it's a great start, very good list
14:24:24 <yboston> BTW, I have been working with EG authorities for a while and could lead the group, but oly if someoe else takes over the LC group
14:24:31 <yboston> *only
14:24:41 <kmlussier> bug 1171984
14:24:41 <pinesol_green> Launchpad bug 1171984 in Evergreen "add support in Vandelay for overlaying authorities during import using match sets" (affected: 4, heat: 18) [Wishlist,Triaged] https://launchpad.net/bugs/1171984 - Assigned to Liam Whalen (whalen-ld)
14:24:50 <kakes> kmlussier: who do you think is working on the overlay?
14:25:06 <kmlussier> Are there still issues for the LC Call number group once dbwells's code is tested and merged?
14:25:21 <Stompro> gmcharlt: Thanks for reviewing and committing the KPAC setup docs. gmcharlt++
14:25:23 <kmlussier> Sorry, that's the next agenda item. I withdraw the question.
14:25:30 <dbs> #info dbs = Dan Scott, Laurentian University (with coffee in hand, finally)
14:25:38 <kmlussier> kakes: It looks like berick has been working on it.
14:25:51 <kmlussier> dbs: Welcome! I'm glad you have coffee. :)
14:26:11 <kmlussier> MassLNC has also been talking to ESI to get some tweaking done for the browse authority work.
14:27:21 <kmlussier> Other than yboston, is there anyone else who is willing to take over the authorities group? If not, is there somebody who can take over the LC Call Number group (if needed) so that yboston can focus on authorities?
14:29:00 <kmlussier> yboston: Which area do you prefer to work on?
14:29:26 <yboston> I think my co-workers would prefer I focus on authoritites
14:29:49 <yboston> so we can move me to authorities for now, and look for a new volunteer for LC callnumbers later on
14:30:01 <kmlussier> OK, then, I'm inclined to say you should lead that group and we'll deal with the other group in a minute.
14:30:13 <DonB> #info DonB = Don Butterworth, Asbury Seminary. Was on the phone with YBP (Yankee Book Peddler). Evergreen EDI does *not* work with YBP. Another Academic issue for us.
14:30:20 <yboston> I sitll have a smalll report for call numbers today
14:30:25 <kmlussier> #action yboston to take charge of the authorities group.
14:30:45 <kmlussier> I think authorities is a big area to tackle.
14:30:57 <DonB> What would be involved in leading LC callnumber. I might be able to take that on.
14:31:08 <tspindler> i think yboston has some of the biggest issues on the wiki page
14:31:11 <kmlussier> Hold on a second. Anything else on authorities?
14:31:53 <kmlussier> #topic Call Number Sorting
14:32:02 <kmlussier> yboston: Can you start us with an update?
14:32:08 <yboston> yes
14:32:18 <yboston> I finally put in a bug for issues searching LC calnumbers in OPAC numeric searches; bug 1389403
14:32:18 <pinesol_green> Launchpad bug 1389403 in Evergreen "OPAC numeric search's call number search bug with LC call numbers " (affected: 1, heat: 6) [Undecided,Confirmed] https://launchpad.net/bugs/1389403
14:32:41 <yboston> I then added a link inside the bug to some test code that Dan Wells wrote to address the issue. I saw that Kathy tried testing that code during the EG bug squashing day.
14:32:48 <yboston> I still need to query the community to see what other LC call number issues need to be addressed
14:33:04 <kmlussier> I still owe a response to dbwells regarding what we're seeing in the logs.
14:33:05 <yboston> and I made a basic wiki page for this group too
14:33:24 <kmlussier> I think I sent out a query to the Evergreen community.
14:33:26 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen_for_academics:improved_lc_call_number
14:33:52 <yboston> kmlussier: yes, you sent out an email, and I might have beent he only one that replied at the time?
14:33:55 <kmlussier> #link http://georgialibraries.markmail.org/thread/wwdb2nrn4g4sunbb
14:34:32 <kmlussier> I didn't get any other responses. Are there other issues you all have seen with LC Call number other than what was identified in the bug yboston just posted?
14:35:30 <kmlussier> Because if that code fixes all of the LC issues that are out there, I don't think this sub-group is needed.
14:36:45 <kmlussier> Sorry. There is also the issue with spine label printing that DonB identified in bug 1352542.
14:36:45 <pinesol_green> Launchpad bug 1352542 in Evergreen "Printing: LC Call number formatting (2.5.2)" (affected: 1, heat: 6) [Undecided,New] https://launchpad.net/bugs/1352542
14:37:57 <dbs> dbwells: are we normalizing the incoming call number label? /me isn't seeing that immediately in supercat
14:38:15 <remingtron> dbwells is in a meeting at the moment
14:38:42 <yboston> since we have one definite open bug, and one bug that has a fix awaiting more testing, we can keep the group open for now
14:38:58 <kmlussier> DonB: Since you semi-volunteered up above, is this something you want to work through. At this time, I'm thinking it's primarily about identifying specific issues that are still out there.
14:39:16 <yboston> I am sure there are other bugs I could report if I talk to the cataloger here, though she is on maternity leave right now
14:39:19 * dbs sees that that's what the patch from dbwells is trying to do; seems reasonable
14:40:22 <DonB> I'm willing to try to identify LC Call number issues and report back to the group, if that would be helpful
14:40:36 <kmlussier> DonB: Yes, that would be very helpful. Thanks!
14:40:38 <kmlussier> :)
14:40:43 <yboston> DonB: that would help, also if you can add info tot he wiki page too
14:40:57 <kmlussier> #action DonB to identify remaining LC Call Number issues and report back to the group.
14:41:01 <yboston> I can help train you on using the wiki
14:41:27 <kmlussier> Anything else on LC call numbers?
14:41:37 <DonB> Willing to try. Thanks for being willing to teach the new guy
14:42:19 <yboston> shoudl we set an action for you to give feedbacl to Dan? Don't think it is neccesary, just wondering
14:42:26 <kmlussier> DonB: We like new people, so we're always willing to help the new guy. :)
14:42:28 <pinesol_green> [evergreen|alzr] LP#1207529: Make sure $PATH includes /openils/bin when configuring - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=85f3866>
14:42:29 <pinesol_green> [evergreen|alzr] LP#1207529: Add /openils assumption note - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=e38ec30>
14:42:29 <yboston> you being Kathy
14:42:45 <yboston> we were all new like you once
14:43:11 <kmlussier> #action kmlussier to post testing feedback for dbwells on bug 1389403
14:43:11 <pinesol_green> Launchpad bug 1389403 in Evergreen "OPAC numeric search's call number search bug with LC call numbers " (affected: 1, heat: 6) [Undecided,Confirmed] https://launchpad.net/bugs/1389403
14:43:21 <kmlussier> Got it.
14:43:28 <kmlussier> Those are all the sub-groups then.
14:43:37 <kmlussier> Is there anything else anybody wants to bring up?
14:44:07 <DonB> Does anybody else care about EDI working with YBP
14:44:08 <DonB> ?
14:44:33 <DonB> It is a major player with academic vendors
14:45:03 <tspindler> DonB: we have academics that use them but do not use EG acquisitions
14:45:20 <DonB> And it frustrates me that the parent company Baker and Taylor has a working EDI with Evergreen
14:45:25 <DonB> but not YBP
14:45:25 <tspindler> YBP does noting with EDI?
14:45:43 <DonB> It worked well with our legacy system
14:45:48 <kmlussier> Is it just the invoicing/enriched EDI, or is it the ordering too?
14:45:55 <DonB> Ordering
14:46:27 <dbs> Is YBP specifically academic? /me really doesn't know
14:46:37 <DonB> They are starting to lose my business because of all the hoops they make me jump through
14:46:52 <DonB> Sorry. Maybe I'm just venting
14:46:53 <tspindler> dbs: not sure but in my experience, i have only known academics to use them
14:47:10 <gmcharlt> ditto
14:47:50 <kmlussier> I think there are probably a number of vendors that EDI still doesn't support, but, with each of them, some development needs to be done to get Evergreen talking to them.
14:48:29 <kmlussier> But it doesn't sound like there are many people in the channel right now who use them heavily and use EDI. Maybe it's a good question for the lsit.
14:48:38 <kmlussier> s/lsit/list
14:48:53 <tspindler> i was just talking to one of our staff, he worked for YPB and he said they were working to get set up with evergreen at the time about 3 years ago
14:48:55 <kmlussier> If there are a few sites interested in it, it might be a good opportunity to pool funds to get the development done.
14:49:25 <DonB> We need more academic libraries so we can get a mass critical enough to interest vendors like YBP and Harrassowitz
14:50:00 <kmlussier> DonB: But is the problem that YBP is unwilling to work with Evergreen or that nobody on the Evergreen side of things has tried to get it to work with YBP?
14:50:34 <DonB> kmlussier: We have tried to get it to work without success
14:50:52 <jihpringle> we don't use YBP but I know we had to do some tweaking of the PO JEDI action trigger and the EDI fetcher/pusher to get Evergreen to work with the major Canadian public library vendors
14:51:00 <tspindler> DonB: have you got it working with others?
14:51:16 <DonB> kmlussier: It works with Baker & Taylor
14:52:39 <kmlussier> I think a good start might be to query the list to see which other sites out there need EDI working with YBP. And then maybe you can, as a mass, try to get YBP to work with Evergreen.
14:53:00 * mdriscoll runs off to another meeting
14:53:14 <kmlussier> DonB: Does that sound like a good approach?
14:53:18 <DonB> Might make for a good survey question.
14:53:25 <kmlussier> Thanks for joining us mdriscoll!
14:53:55 <DonB> What vendors do you use? and Who uses EDI?
14:54:35 <jihpringle> we'd be interested in the results of that survey
14:54:39 <kmlussier> I know a lot of our libraries use B&T, Ingram, Midwest Tape. tspindler may know of more.
14:55:24 <kmlussier> What exactly would be the goal of the survey then? To see what vendors we want to see working with EDI?
14:56:09 <kmlussier> If so, is anyone willing to create this survey?
14:56:21 <DonB> Just to see how many libraries use EDI
14:56:23 <DonB> and
14:56:35 <DonB> How many would like to use EDI
14:56:38 <DonB> and
14:56:50 <DonB> Who would they like to use if they could
14:57:20 <jihpringle> the end result would also be a list of known vendors that work with Evergreen's EDI
14:57:26 <kmlussier> I think the survey is fine. But I think we're not stepping outside of the purely academic realm. Because all types of libraries use EDI.
14:57:39 <DonB> Then perhaps we could use the results to get some vendors working on making the connections work with Evergreen
14:58:12 <DonB> You're right Kathy
14:58:17 <kmlussier> We're closely approaching the one-hour mark. Does anyone want to take this as an action item?
14:58:36 <DonB> Maybe we could put this on the back burner as another academic library topic to address at a later date?
14:58:50 <tspindler> kmlussier:  we have librairies currently using only B&T, Ingram and Midwest Tape.  We have not tried others.
14:59:08 <kmlussier> Sure, that works for me.
14:59:12 <tspindler> at lest with EDI.  We have some tracking manual orders
14:59:15 <kmlussier> Anything else before I wind things up?
14:59:54 <kmlussier> Our next meeting is scheduled for 2 p.m. EST on December 11.
15:00:04 <kmlussier> #info Our next meeting is scheduled for 2 p.m. EST on December 11.
15:00:24 <kmlussier> #info Add an EDI survey as a future to-do item.
15:00:27 <kmlussier> #endmeeting