14:00:37 <yboston> #startmeeting 2014-12-04 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:37 <pinesol_green> Meeting started Thu Dec  4 14:00:37 2014 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:37 <pinesol_green> The meeting name has been set to '2014_12_04___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:00:46 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20141204-agenda
14:01:10 <yboston> #topic Introductions
14:01:16 <yboston> Please feel free to start introducing yourselves...
14:01:31 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:37 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:01:45 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:03:12 <remingtron> quiet day in #evergreen
14:03:41 <yboston> I always set a timer to decide when I start the meeting. Almost done
14:04:35 <remingtron> well, everyone with Action Items is here, I guess that's something
14:04:51 <kmlussier> It's a busy time of year. Sometimes hard to get people to a meeting.
14:04:52 <yboston> good point. I am ready to start
14:05:07 <remingtron> kmlussier: true, holidays and all
14:05:24 <yboston> it is about quality not quantity
14:05:28 <yboston> :)
14:05:30 <purcellm> #info purcellm is michelle purcell drexel
14:05:35 <remingtron> I should have brought cookies
14:05:37 <kmlussier> Ha ha. But quantity does help. :)
14:05:44 <yboston> I know :(
14:05:44 <kmlussier> Welcome purcellm!
14:05:45 <remingtron> welcome purcellm!
14:05:50 <purcellm> Hi!
14:05:51 <yboston> purcellm++
14:05:59 <yboston> I think we can start now
14:06:07 <remingtron> yboston: go for it
14:06:19 <yboston> #topic past meeting action items
14:06:34 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:06:49 <kmlussier> Hi sandbergja!
14:06:54 <yboston> #topic yboston will contact krvmga to check in on his 2.7 docs work
14:06:56 <remingtron> welcome sandbergja!
14:07:36 <yboston> I reached out to him last week (or earlier)
14:07:56 <yboston> he said he still needed more work to be done on these docs
14:08:05 <yboston> he said he would try to get it donw and contact us
14:08:22 <yboston> I can reach out to him again?
14:08:24 <remingtron> sound like he was wanting/willing for help?
14:08:38 <yboston> yes, he wanted to finish the work
14:08:56 <remingtron> you mean, finish it himself? or give it to someone else?
14:09:24 <yboston> yes, himself
14:09:30 <remingtron> ah, okay
14:09:34 <yboston> just looked up our conversation. he still needs to test
14:09:45 <yboston> that EG behaves as his docs describes
14:09:52 <yboston> tis was back on November 26
14:09:57 <remingtron> I'd say yes, just follow up with him again, whenever seems best
14:10:01 <yboston> OK
14:10:15 <yboston> #action yboston will contact krvmga to check in on his 2.7 docs work
14:10:42 <yboston> #topic kmlussier will complete the marc stream importer work and check on the status of the RDA docs.
14:10:52 * kmlussier needs to defer her action items.
14:11:05 <yboston> no worries
14:11:06 <kmlussier> Sorry! The month goes by more quickly than I expect.
14:11:17 <remingtron> kmlussier: any way we can help?
14:11:35 <kmlussier> RDA should be easy. I just need to do it.
14:11:50 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs.
14:11:52 <kmlussier> I'm basing the marc stream importer documentation on notes I received from somebody else.
14:12:15 <yboston> I don't mind restarting the action item
14:12:18 <kmlussier> I can dig those up and post them on a google doc somewhere if somebody wants to help with it.
14:12:34 <sandbergja> I can help with that, if you want to go the google doc route
14:12:48 <kmlussier> It's not just documentation for the new feature. I don't think there's every been marc stream importer documentation, so it's really starting from scratch.
14:13:11 <yboston> kmlussier: should I add an action item for sharing what you have?
14:13:30 <kmlussier> sandbergja: OK. Can you send me a private message with the e-mail address you have linked to your Google account?
14:13:31 <remingtron> sandbergja++ #for sharing the load
14:13:48 <yboston> sandbergja++
14:13:49 <kmlussier> I probably won't pull it together until next week since I really want to focus on the web client tomorrow.
14:13:59 <sandbergja> sounds good!
14:14:00 <kmlussier> sandbergja++ indeed!
14:14:31 <yboston> if we want to move on, this is the perfect segway to the web client work
14:14:45 <remingtron> yboston: go right ahead
14:14:58 <yboston> #topic Web Client documentation work
14:15:10 <yboston> thanks to remingtron for putting together the poll and other logistics
14:15:14 <yboston> remingtron++
14:15:26 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:webclient
14:15:27 <kmlussier> remingtron++
14:15:29 <sandbergja> remingtron++
14:15:37 <remingtron> you're welcome. I'm not sure what comes next, though.
14:16:25 <kmlussier> I think we need more people to sign up for tasks. I tried to flesh out the outline for what can be documented tomorrow. Maybe we need to send out one last reminder asking people to assign themselves?
14:16:31 <yboston> of the top of my head, when was the test server built? I wonder what commits it contains, in case new features are in master that are not in the test server?
14:16:48 <kmlussier> Actually, the opposite is true
14:16:57 <yboston> I still need to assign myself a tasks
14:17:03 <kmlussier> webby has bug fixes that have not been merged into master yet.
14:17:14 <yboston> good to know
14:17:25 <remingtron> #link https://webby.evergreencatalog.com/eg/staff/
14:17:38 <kmlussier> graced also told us she would try to make sure webby stays as stable as possible tomorrow.
14:17:38 <yboston> by the way, applying 2020 hindsight
14:17:42 <kmlussier> graced++
14:17:54 <remingtron> graced++
14:17:54 <yboston> I would have mentioned in our emails that no software instalation was needed to help out
14:18:30 <yboston> I wonder if folks assumed they needed to install software for documenting, but then again it is a web client
14:19:05 <remingtron> yboston: good question. I'll send another reminder today, with the added note about no software needed
14:19:37 <kmlussier> And we want a Google Hangout tomorrow, right?
14:19:40 <yboston> BTW, should one of us host a google hangout? I can do that
14:19:48 <yboston> you read my mind
14:20:09 <remingtron> yes, I'd be glad for one of you to host it
14:20:10 <kmlussier> remingtron and I were talking about it earlier. I'm happy to set it up too.
14:20:46 <kmlussier> heads says yboston sets it up; tails is me.
14:20:47 <kmlussier> @coin
14:20:47 <pinesol_green> kmlussier: tails
14:21:07 <remingtron> kmlussier: good decision making tool
14:21:15 <kmlussier> remingtron: I need to use it more often. :)
14:21:25 <yboston> if you have any issues let me know, and I can step in
14:21:36 <remingtron> starting about 8am EST?
14:21:51 <yboston> should we mention that you ned to share your Google accoutn email address to Kathy in an email tomorrow?
14:22:36 <remingtron> kmlussier: yeah, do you want to send the info to the DIG list about joining?
14:22:42 <kmlussier> Yes, I can do that.
14:22:49 <remingtron> kmlussier++
14:22:50 <kmlussier> I'll also post a link in here tomorrow.
14:23:41 <kmlussier> And I'll have it ready by 8 a.m. I don't have to commute tomorrow, so I should be able to start early.
14:23:48 <yboston> cool
14:24:29 <yboston> BTW, off the top of my head I don't know what feature of the web cleints to docuemnt. I am open to suggestions or if someone want to team up with me to geta feel of how to make docs
14:24:43 <yboston> remeber that AsciiDoc is not required
14:25:31 <yboston> Also, remind me where we are placing the new docs we create? an appendix section?
14:25:56 <remingtron> yboston: good question!
14:26:10 <kmlussier> I think we talked about having a separate section.
14:26:12 <purcellm> I need to head to another meeting.  I'll take a look at the web client and try and find a task to assign myself to.
14:26:23 <yboston> thanks purcellm
14:26:23 <purcellm> Bye.
14:26:25 <kmlussier> purcellm++
14:26:44 * kmlussier looks for old meeting minutes
14:27:24 <remingtron> I don't think we ever discussed where in the docs to put this stuff
14:27:41 <remingtron> I think appendix sounds fine for now
14:28:00 <remingtron> maybe with links from the current staff client docs in some places
14:28:56 <kmlussier> We discussed it in October. The consensus was a separate section at the time. http://evergreen-ils.org/meetings/evergreen/2014/evergreen.2014-10-02-14.00.log.html
14:29:08 <kmlussier> Around the 14:31 point of the meeting.
14:29:09 <remingtron> thanks kmlussier
14:29:59 <kmlussier> And then it looks like we need to backport it to 2.7
14:30:04 <yboston> I should have made an action item to bring this topic up to the list
14:30:24 <kmlussier> I don't think you did because we had general consensus at the meeting.
14:30:25 <yboston> but the early consensus was a new section
14:30:39 <kmlussier> I can create the section when this meeting is done to get ready for tomorrow if it helps.
14:30:45 <yboston> OK
14:31:00 <remingtron> great
14:31:32 <yboston> anything else to talk about tomorrow?
14:31:56 <remingtron> yes briefly
14:32:02 <yboston> go ahead
14:32:12 <yboston> I did not mean to rush you
14:32:14 <remingtron> all are welcome to improve the wiki page with helpful instructions for participants
14:32:18 <remingtron> (no worries)
14:33:39 <remingtron> I added some brief "How to Help" steps
14:33:49 <remingtron> and basic info about the demo server
14:34:11 <yboston> very nice
14:34:35 <remingtron> thanks
14:35:31 <yboston> after the meeting I will put my name down in a couple of sections.
14:35:44 <yboston> does it matter if they are based on XUL code, like the patron record itnerface?
14:36:08 <yboston> I guess I can docuemnt the new look with new screenshots
14:36:57 <kmlussier> yboston: Yeah, that documentation probably doesn't need much updating. But you might want to do the new screenshots if it looks a little different.
14:36:59 <remingtron> yboston: yes, I think the goal is to work from the new interface. In most case it is very similar to the XUL, but not always
14:37:10 <kmlussier> I think we may have new scrollbars that we didn't see in the patron editor before.
14:37:26 <kmlussier> remingtron: In the case of patron registration, they just ported over the Dojo interface.
14:37:33 <remingtron> ah, got it
14:37:56 <kmlussier> yboston: That's the one you were asking about, right?
14:38:38 <yboston> I am not 100% sure of what the section called "III. Circulation - Patron Record" covers
14:38:56 <yboston> I suspect it might mean editign a patron record at the very least
14:38:58 <kmlussier> yboston: Those section titles were just copied over from the existing docs.
14:39:03 <yboston> I just signed myself for it
14:39:09 <yboston> OK
14:39:47 <kmlussier> yboston: So it would be anything listed here - http://docs.evergreen-ils.org/dev/_circulation_patron_record.html
14:40:00 <kmlussier> Which is a lot. You might want to divvy it up further.
14:40:03 <remingtron> I think our goal for tomorrow should be to do what the web client has done: basically copy the existing documentation and make the minimum changes to work with the web client
14:40:35 <remingtron> (meaning, the web client is mostly a copy of the XUL client)
14:40:38 <kmlussier> Yes, I was planning to copy files from the existing docs and edit them accordingly.
14:40:53 <remingtron> so if we find big problems or holes in the docs, let's make notes about it but not get side tracked
14:41:31 <yboston> OK
14:41:32 <remingtron> since I tend to get side tracked by things :)
14:41:55 <kmlussier> remingtron: Yes, me too! A small doc change often turns into a day-long revamp of a section. :)
14:42:16 <yboston> yep
14:42:18 <remingtron> kmlussier: so, so familiar
14:42:29 <remingtron> alright, anything else about tomorrow?
14:43:04 <kmlussier> Nothing from me.
14:43:08 <yboston> I think I am all set
14:43:20 <remingtron> great, back to you, maestro yboston
14:43:28 <yboston> I had to small points to bring up before the meeting ends
14:43:37 <yboston> (gracias)
14:43:50 <yboston> #topic yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:44:24 <yboston> I forgot abotu this action item until like an hour ago, so I send out an email to the involved parties and will await a reponse
14:44:34 <yboston> #action yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:44:45 <remingtron> yboston++ #meetings encourage us to do things :)
14:44:59 <yboston> #topic Date for DIG monthly meeting in January
14:45:27 <yboston> If we follow that usual schedule, the next meeting would be on Janaury 1st
14:45:39 <yboston> I suspect, that we don't want to do that
14:45:43 <remingtron> hm, following week then?
14:46:20 <yboston> yes, and until now I thought I was unavailable but I will be at work
14:46:51 <yboston> oh wait, there is an Evergreen for academics meeting that day
14:46:53 <yboston> at 2 PM
14:47:16 <yboston> I can send out a an email tot he DIG list to see if we can meet before or after that meeting
14:47:26 <remingtron> sure, or how about the 15th?
14:47:33 <remingtron> you can ask the list or do a doodle
14:47:41 <yboston> EG board meeting at 2 PM :)
14:47:49 <remingtron> thursdays are packed!
14:48:01 <yboston> I can put out a doodle poll
14:48:10 <kmlussier> +1 to doodle
14:48:21 <yboston> I suspect I might want to wait until early Janaury to send it out
14:48:46 <remingtron> sounds fine
14:49:17 <yboston> OK
14:49:42 <yboston> I think we can wrap things up, unless someone has any comments or question, specially from newer members or lurkers
14:49:52 <remingtron> you can repeat my other action item for next meeting
14:50:27 <yboston> #action remingtron will set up doodle to set up a meeting on IRC in Janaury 2015 to discuss re-organizing the EG docs
14:50:36 <remingtron> thanks
14:50:38 <yboston> I totally misread that action item as being about the web client
14:51:10 <yboston> anything else?
14:51:26 <remingtron> nope
14:51:43 <yboston> OK will end the meeting, thanks
14:51:46 <remingtron> thanks for leading, as always!
14:51:47 <yboston> #endmeeting