14:03:58 <bbqben> #startmeeting Evergreen Oversight Board Meeting, 20.12.14
14:03:58 <pinesol_green> Meeting started Thu Dec 18 14:03:58 2014 US/Eastern.  The chair is bbqben. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:58 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:58 <pinesol_green> The meeting name has been set to 'evergreen_oversight_board_meeting__20_12_14'
14:04:17 <bbqben> #topic introductions
14:04:25 <bbqben> EOB members, please introduce yourself with #info
14:04:27 <bshum> #info bshum = Ben Shum, Bibliomation
14:04:36 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
14:04:41 <yboston> #info ysboston - Yamil Suarez - Berklee College of Music (EOB)
14:04:42 <bbqben> #info bbqben = Ben Hyman, BC Libraries Co-op
14:04:43 <montgoc1> #info montgoc1 = Chauncey Montgomery, Consortium of Ohio Libraries
14:04:57 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:05:06 <abneiman> #info abneiman Andrea Buntz Neiman, Kent County Public Library
14:05:35 <bbqben> Hi everyone! csharp sends his regrets
14:05:52 <bbqben> #topic Minutes / Actions from last meeting
14:06:00 <bbqben> #info http://evergreen-ils.org/meetings/evergreen/2014/evergreen.2014-11-20-14.01.html
14:06:25 <bbqben> and it looks like we'll cover the actions in our agenda
14:06:34 <bbqben> so moving on...
14:06:49 <bbqben> #topic  Financial Report
14:06:58 <bbqben> bshum ++
14:07:04 <bbqben> #info http://list.evergreen-ils.org/pipermail/eg-oversight-board/2014-December/000931.html
14:07:30 <bshum> Indeed, the kind folks over at Conservancy got me all squared away and I've learned the basics of getting info out of the books.
14:07:37 <bbqben> thanks to bshum for gaining access to the ledger and mind melding with gmcharlt
14:07:51 <kmlussier> bshum++
14:08:07 <gmcharlt> (graced is returning from an errand and should be joining shortly, BTW)
14:08:30 <bbqben> great - any questions about the finances today?
14:08:58 <bbqben> ok moving on then
14:09:10 <bbqben> #topic Evergreen Conference Report
14:09:54 <bbqben> looks like Buzzy's not here.
14:10:24 <kmlussier> I can report that keynote2k received an agreement from the hotel just this week.
14:10:43 <kmlussier> We'll need the agreement sign before we can start the registration process.
14:11:13 <kmlussier> I think buzzy was planning to send an update out to the community shortly.
14:11:34 <keynote2k> Hi, all.  I plan to the review the agreement this afternoon. Kmlussier:  I'll let you and buzzy know if I see any red flags
14:11:42 * keynote2k goes back to lurk mode
14:11:49 <kmlussier> Sorry, I don't have any other updates other than the issues that came up in the e-mail keynote2k sent out to the Board earlier.
14:11:56 <bbqben> kmlussier++
14:11:58 <kmlussier> Thanks keynote2k!
14:12:10 <bbqben> good to see some momentum building here...
14:12:33 <bbqben> anxious to see sponsorship package and registration up and out asap in 2015
14:12:41 <kmlussier> bbqben: Should we take some time to discuss the issues with the wordpress plugin now or defer it to later?
14:13:00 <bbqben> now works for me...
14:14:22 <bbqben> #topic conference registration platform
14:14:36 <kmlussier> OK, I personally would like to move forward with the WordPress plug-in to handle registrations. I know it's know there are some gray areas with licensing with WordPress plugins, but I think it's a better solution than the Eventbrite ones.
14:15:26 <kmlussier> The question is if you all feel comfortable using it or if you think the concerns keynote2k are too much of a red flag.
14:16:53 <kmlussier> Ideally, I would have found a fully-GPL'ed WordPress plugin that handled our needs, but each of the ones I investigated were missing certain features that I thought were important to our registration process.
14:17:22 <RoganH> I don't have an objection to using a commercial plugin if the license is clearly legal.
14:17:29 <RoganH> I'm not sure what you mean by grey area here.
14:17:33 <bshum> I like working solutions.
14:17:42 <bbqben> I understand the desire to integrate around WordPress - as a community we've focused energy here
14:18:17 <kmlussier> RoganH: I was specifically referring to the issues keynote2k raised in his e-mail to the Board.
14:18:27 <bbqben> I did raise an alternative FLOSS solution (but not WordPress in https://pkp.sfu.ca/ocs/ ...but cycles are very tight this year
14:19:13 <kmlussier> For those who don't know, keynote2k is Tony Sebro, the attorney for the Software Freedom Conservancy. He came today in case anyone has any questions about the licensing.
14:20:16 <kmlussier> bbqben: My only concern with that is the time factor. I have 2 more days before I'm on vacation for the rest of the year. But it doesn't mean others couldn't give it a thorough look-through if they have the tuits.
14:20:22 <yboston> kmlussier: thanks
14:21:06 <yboston> I would rther go back to Eventbrite, because I hate to rush into a brand new system that will handle credit card information
14:21:19 <kmlussier> The plug-in integrates with PayPal.
14:21:35 * keynote2k reads the backlog.
14:21:44 <kmlussier> yboston: Unless you're referring to the software bbqben was linking to?
14:21:57 <yboston> I meant both of them, but mostly Ben's
14:22:21 <montgoc1> I agree with yboston. Due to time constraints, etc., would it be easier just to use what we have an investigate other options for the future?
14:22:26 <yboston> though I appreciate the fact that the first one relies on PayPal
14:22:30 <bbqben> The jist: EventBrite=proprietary, but a known entity, and possibly gratis vs Events Manager Pro, integrating with WordPress, but possibly representing a GPLv2 violation
14:22:30 <kmlussier> In the past, Eventbrite has waived its fees, but my understanding is that's not a sure thing anymore.
14:22:52 <abneiman> Agreed with yboston; also time is starting to become a factor here so I'd be inclined to go with what we can get up & running faster.
14:22:53 <kmlussier> They charge 2.5% plus .99 per transaction, which is about $1,000?
14:23:15 <keynote2k> Like kmlussier said, I'm here to answer any questions you may have.  I should note, though, that I don't view the Events Mgr Pro's licensing issues as a gray area, per se.  Either it's GPLv2-compliant, or it isn't -- and if it's compliant, it's on the edge.  We'd need more time to vet it thoroughly
14:23:16 <RoganH> Eventbrite has always been willing to waive charges for me, even for small events.
14:23:30 <montgoc1> If they are willing to waive, I'd go with Eventbrite.
14:23:31 <kmlussier> I've been working with the plug-in for a few weeks to evaluate it. Time is not a factor with that particular solution.
14:23:42 <montgoc1> But license is?
14:23:52 <kmlussier> montgoc1: Yes
14:23:53 <RoganH> I'm in favor of using Eventbite if there's a question about GPL compatibility.  I am curious what part of the GPL it might be violating though.
14:23:54 <keynote2k> As for Eventbrite:  we're working on whether they'll waive the fees for 2015; I haven't heard back yet
14:24:29 <graced> #info graced is Grace Dunbar  (better late than never)
14:24:31 <yboston> good to know that on the techinical side kmlussier has been testing the first solution
14:24:33 <kmlussier> keynote2k: But in the past, you have indicated it's less likely than it has been previously, right?
14:24:40 <yboston> but I think we need tme for the license vetting
14:24:43 * gmcharlt would like to point out that the investigation of the event plugin is not something that was being undertaken lightly; my understanding is that there has been significant uncertainty about whether EventBrite would waive this year
14:24:56 <abneiman> kmlussier: sorry, I meant more time on the analysis, not deployment.
14:25:40 <keynote2k> RoganH:  the GPL compliance analysis will depend in part on how the pro add-on connects to the base plug-in.  The license status of the base plug-in is confusing as well
14:26:07 <montgoc1> How long until we can licensing stuff figured out and how does that impact the timeline?
14:26:12 <kmlussier> abneiman: gotcha
14:26:16 <yboston> montgoc1: +1
14:26:23 <RoganH> keynote2k: gotcha so the shared calls and data structures part of the traditional gpl interpretation
14:26:37 <keynote2k> re: Eventbrite:  Yes, I had previously placed the odds at being lower than in years past. But my contact didn't mention any low odds when I reached out to her this time around.
14:27:10 <keynote2k> (This was not the tune she was singing a year ago) So, I can't really handicap it at this point until I hear back.
14:28:20 <keynote2k> montgoc1:  in terms of timeline:  ideally, 1-2 weeks.  But compliance investigations are messy, unfortunately:  sometimes, pulling on one thread unravels something else.
14:28:25 <kmlussier> I think I'm hearing people prefer to stick with Eventbrite. Although I would be interested in hearing the results of the analysis, if it takes longer than a week, I'm really concerned about timeline.
14:28:34 <bbqben> keynote2k in practical terms, what is the risk to the EG project if at the end of your analysis the gpl isn't being respected?
14:28:48 <kmlussier> We have people who want to register for the conference before the end of their fiscal year, which is soon.
14:28:52 <bbqben> (and we choose to go with wordpress integration over EventBrite)
14:30:11 <kmlussier> I think that's been my question. What is the risk? My understanding is these types of add-ons aren't unusual in the WordPress community.
14:30:23 <RoganH> They're down right common.
14:32:12 <yboston> also; what if the analysis come back as being on the "bleeding edge" as it is currently suspected. I can see that to some in our board that would be good enough, but perhaps not to the conservancy
14:32:32 <keynote2k> bbqben, kmlussier:  I'm reluctant to discuss risk associated with using this particular solution in a public channel.  But, as a general matter, a GPL'ed project would risk damage to its reputation
14:32:39 <kmlussier> yboston: I think that decision should rest in the hands of the community, not the conservancy.
14:33:00 <yboston> kmlussier: that makes sense
14:33:01 <graced> kmlussier: I agree
14:33:23 <bbqben> keynote2k: appreciate this perspective....
14:33:52 <bbqben> For this group, I suppose we weigh the reputation associated with using an imperfect proprietary solution against an imperfect GPL'ed version
14:35:12 <bbqben> hearing kmlussier and concern re: time getting away, I see a couple of approaches here
14:36:16 <bbqben> Approach 1: give it to the end of the week to hear back from EventBrite (& possibly keynote2k re: analysis of Event Manager Pro) re: gratis or not & GPL compliance or not, then call a vote
14:36:32 <bbqben> Approach 2: call a vote now.
14:36:39 <bbqben> Thoughts?
14:36:53 <montgoc1> Approach 1 for me.
14:36:54 <kmlussier> End of week is end of tomorrow?
14:37:04 <RoganH> If end of the week means tomorrow I'm for #1.
14:37:05 <montgoc1> Ah yes.
14:37:07 <bbqben> kmlussier: yep - day end tomorrow
14:37:10 <montgoc1> Time flies.
14:37:25 <graced> I can wait until tomorrow for a vote
14:37:31 <abneiman> Same as Rogan, if this means tomorrow +1
14:37:32 <kmlussier> OK, that's fine with me. That gives me all of Monday to implement whatever solution we go with.
14:37:37 <keynote2k> I might have an answer from Eventbrite by tomorrow (not sure), but I won't have much to add on the compliance anlaysis by then
14:37:38 <bshum> How long would it take to setup EventBrite (regardless of whether fees are waved or not)?
14:38:01 <bshum> *waived, whatever.
14:38:01 <keynote2k> 1 more day is a lot shorter than 1-2 additional weeks
14:38:07 <bbqben> keynote2k: fair enough, thanks
14:38:09 <kmlussier> bshum: I could do either one in the same amount of time. It will be Monday one way or another because I don't really have another choice.
14:38:42 <graced> I am concerned, like kmlussier, that we will lose substantial conference goers if they can register under this FY - (by the end of the month).
14:38:51 <kmlussier> And if the agreement with the venue isn't signed, I'll place it in the hands of somebody else to pull the trigger when we are allowed.
14:38:59 <graced> So I don't think we can wait 2 weeks for an answer
14:39:20 <bbqben> thanks everyone
14:39:44 <bbqben> #action bbqben call a vote at 1600 Pacific on 19.12.14 re: registration platform for EG2015
14:39:54 <abneiman> I also agree with this concern about people needing to register before 12/31 for their own budgetary reasons.
14:39:55 <kmlussier> Thanks keynote2k for answering questions!
14:40:15 <bbqben> keynote2k++
14:40:16 <keynote2k> Glad to help.  If you have any other questions, let me know
14:40:17 <montgoc1> keynote2k++
14:40:27 <bbqben> ok, moving on
14:40:33 * keynote2k is signing of
14:40:34 <keynote2k> f
14:40:38 <bbqben> #topic Evergreen 2.8 Release Manager's Report
14:40:50 <bbqben> #info Latest from the dev list: http://libmail.georgialibraries.org/pipermail/open-ils-dev/2014-December/009764.html
14:41:06 <bbqben> berick: you around and available?
14:41:31 <bbqben> er, the latest from the dev list isn't actually the latest - sorry
14:42:28 <berick> bbqben: i am
14:42:38 <berick> but have not prepared anything in particular
14:42:50 <berick> we're just hashing out the details of schedule now
14:42:56 <bbqben> berick: sorry to put you on the spot.
14:43:07 <berick> no problem
14:43:46 <bbqben> berick: was just thinking that the countdown to this release is a bit like the enjoyment you get from an advent beer pack ;)
14:44:22 <bbqben> any q's for berick or shall we see where things get for the January meeting?
14:44:25 <kmlussier> bbqben: advent beer pack? Is that a real thing?
14:44:31 <berick> bbqben: hah, i'll do my best to help us live up to that ;)
14:45:06 <bbqben> kmlussier: this is the one I've been enjoying: http://www.snowcasecalendar.com/
14:45:28 <bbqben> but enough if that :)
14:45:41 <bbqben> #topic SFC update (Emergency Fund)
14:46:36 <bbqben> Heard back 2 days ago from Karen Sandler at SFC re: additional questions that Kathy and I had re: what role the SFC could play/at what cost WRT pooling of funds...
14:47:06 <bbqben> Next steps - I'll summarize some of the notes and likely survey this group on a couple of topics, after double checking out Terms of Reference
14:47:44 <bbqben> Expect to hear from me in January on this. Any questions/concerns?
14:48:11 <bshum> bbqben++ # sounds like a plan
14:48:27 <bbqben> #action bbqben summarize SFC feedback & survey board on relevant topics
14:48:43 <bbqben> #topic Evergreen web FAQ development
14:50:24 <bbqben> yboston - you able to provide an update?
14:50:39 <yboston> I do not have anything to add at this point
14:50:51 <yboston> no new updates have been made to the FAQ
14:51:05 <yboston> I was thinking of removeing the "draft" label at this point
14:51:27 <bbqben> yboston - ambitious ;)
14:51:33 <kmlussier> +1
14:51:42 <bbqben> +1
14:51:52 <bshum> +1
14:51:55 <montgoc1> +1
14:52:23 <RoganH> +1
14:52:41 <kmlussier> It's so nice when we can all come to agreement this easily. :)
14:52:53 <yboston> DONE
14:52:57 <bbqben> #action yboston will press into production the revised vendor FAQ's
14:53:03 <bbqben> yboston++
14:53:09 <bbqben> and a belated berick++
14:53:15 <yboston> berick++
14:53:33 <bbqben> #topic Code of Conduct - Procedures
14:53:50 <kmlussier> I'll need to defer my update until the next meeting.
14:53:54 <kmlussier> Since I haven't done anything on it.
14:54:11 <kmlussier> At this point, I think the call for volunteers should go out after the New Year.
14:54:40 <bbqben> kmlussier: sounds good and timing should work as we build to EG2015
14:54:41 <kmlussier> Because we've reached the point of the year when people stop paying attention to e-mail.
14:55:07 <bbqben> true, that. Moving on...
14:55:16 <bbqben> #topic new business
14:55:35 <bbqben> anyone? going once...
14:56:03 <bbqben> ...going twice (& final)
14:56:35 <bbqben> #topic happy holidays everyone!
14:57:12 <bbqben> Do watch for an email from me tomorrow re: voting on registration platform. 1600 Pacific should be considered a time estimate only for this
14:57:43 <graced> Happy holidays, everyone!
14:57:54 <bbqben> #endmeeting