#evergreen: Evergreen development meeting, 13 January 2014^W2015

Meeting started by gmcharlt at 14:09:04 US/Eastern (full logs).

Meeting summary

    1. Agenda is http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-01-13 (gmcharlt, 14:09:11)

  1. Introductions (gmcharlt, 14:09:22)
    1. gmcharlt = Galen Charlton, ESI (gmcharlt, 14:09:30)
    2. bshum = Ben Shum, Bibliomation (bshum, 14:09:34)
    3. dbs = Dan Scott, Laurentian University (dbs, 14:09:44)
    4. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 14:09:53)
    5. berick = Bill Erickson, KCLS (berick, 14:09:55)
    6. RoganH = Rogan Hamby, SCLENDS (RoganH, 14:10:00)
    7. phasefx = Jason Etheridge, ESI (phasefx, 14:10:09)
    8. jeffdavis = Jeff Davis, Sitka (jeffdavis, 14:10:14)
    9. eeevil = Mike Rylander, ESI (eeevil, 14:10:21)
    10. kmlussier = Kathy Lussier, MassLNC (kmlussier, 14:10:40)
    11. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 14:10:43)
    12. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 14:10:48)

  2. Updates - OpenSRF (gmcharlt, 14:12:11)
    1. OpenSRF 2.4.0 released (gmcharlt, 14:12:18)
    2. current main target for OpenSRF 2.4.1 is adding a configuration option for using ports 80/443 for WS/WSS (gmcharlt, 14:12:59)

  3. Evergreen 2.8 updates (gmcharlt, 14:15:29)
    1. 14 January 2015 is the deadline for targeting new features slated for 2.8; use the 2.8-beta milestone (gmcharlt, 14:18:38)

  4. New business - quality assurance (gmcharlt, 14:19:44)
    1. One accessibility checking API: http://wave.webaim.org/api/ (costs $$$ but it's an option) (dbs, 14:47:06)
    2. another accessibility checking API: https://github.com/inclusive-design/AChecker (GPL v2) (dbs, 14:50:20)
    3. There is general agreement that for the 2.8 cycle, we'll be stricter about requiring relevant pgTAP & perl unit tests (gmcharlt, 14:59:43)
    4. berick will write some guidelines on writing Perl and pgTAP tests (gmcharlt, 14:59:55)
    5. dbs and gmcharlt will work on automating accessibility and RDFa tests of TPAC (gmcharlt, 15:00:13)
    6. kmlussier will do an environement scan of QA practices and experts in other project, with help from gmcharlt and others (gmcharlt, 15:00:43)

  5. Overdrive circulation API code (gmcharlt, 15:01:26)
    1. http://markmail.org/message/cgcrmqdz4nrm5erv (gmcharlt, 15:01:34)

  6. Negative blances / billing improvements (gmcharlt, 15:21:06)
    1. https://bugs.launchpad.net/evergreen/+bug/1198465 (gmcharlt, 15:21:17)
    2. ACTION: dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing (gmcharlt, 15:24:58)


Meeting ended at 15:26:25 US/Eastern (full logs).

Action items

  1. dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing


Action items, by person

  1. berick
    1. dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing
  2. dbwells
    1. dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing
  3. jeff
    1. dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing


People present (lines said)

  1. gmcharlt (70)
  2. jeff (38)
  3. kmlussier (29)
  4. berick (28)
  5. dbs (27)
  6. jeffdavis (18)
  7. eeevil (14)
  8. dbwells (9)
  9. bshum (5)
  10. pinesol_green (4)
  11. phasefx (4)
  12. RoganH (3)
  13. csharp (1)
  14. remingtron (1)


Generated by MeetBot 0.1.4.