14:00:37 <yboston> #startmeeting 2015-02-05 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:37 <pinesol_green> Meeting started Thu Feb  5 14:00:37 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:37 <pinesol_green> The meeting name has been set to '2015_02_05___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:54 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20150205-agenda
14:01:03 <yboston> #topic Introductions
14:01:14 <yboston> Please feel free to start introducing yourselves...
14:01:29 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:38 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:52 <kbutler> #info kbutler is Kate Butler at Rodgers Memorial Library (Hudson, NH)
14:02:05 <bshum> #info bshum is Ben Shum, Bibliomation
14:02:08 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:03:33 <phasefx> #info phasefx is Jason Etheridge, ESI
14:04:10 <yboston> My timer is done, ready to start
14:04:32 <yboston> any reports from content coordinators?
14:05:27 <rsoulliere> Nothing from me this time.
14:05:32 <yboston> OK
14:05:53 <yboston> Previous Action items...
14:06:11 <yboston> #topic yboston will contact krvmga to check in on his 2.7 docs work
14:06:35 <yboston> I forgot to reach out to krvmga; will push forward for next meeting
14:06:48 <yboston> #action yboston will contact krvmga to check in on his 2.7 docs work
14:07:00 <yboston> #topic kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:07:18 <kmlussier> Sorry. I wasn't paying attention.
14:07:28 <kmlussier> #info kmlussier is Kathy Lussier MassLNC
14:08:06 <yboston> did you want to postpone for next meeting?
14:08:18 <kmlussier> I was supposed to get the notes I have to Jane Sandberg so that she could work on the docs.
14:08:34 <kmlussier> Unfortunately, I forgot about my action item. I'll try to pull them together for Jane this afternoon.
14:09:54 <kmlussier> yboston: So, yes, in answer to your question, postpone to the next meeting.
14:10:00 <yboston> same wording?
14:10:03 <kmlussier> Sure
14:10:22 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:10:43 <yboston> #topic yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:11:29 <yboston> right before the start of our last meeting on December 4, 2014  I sent out an email to Galen and others to psuh this forward, but I did not hear back.
14:11:52 <yboston> right before this meeting I sent another email to try to push this forward
14:12:04 <yboston> I will postpone again this action item
14:12:14 <yboston> #action yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:12:26 <yboston> #topic remingtron will set up doodle to set up a meeting on IRC in Janaury 2015 to discuss re-organizing the EG docs
14:12:59 <remingtron> I have stalled on the docs re-org, mostly because of focusing on web client docs, but I'd like your feedback
14:13:24 <remingtron> should we pause web client work and work on re-org for a while, since webclient will take a while to progress?
14:13:36 <remingtron> (web client *may* take a while)
14:13:49 <remingtron> or press on with web client work?
14:14:11 <yboston> good question
14:14:43 <remingtron> And keep in mind that we want to shift focus to 2.8 when beta is released
14:14:54 <remingtron> (though I think that's a fairly small list of new features this time)
14:14:54 <kmlussier> remingtron: Do you recall if there was still work to be done on the circulation web client docs?
14:15:55 <remingtron> my perspective is just the wiki, which seems to have a lot more to do
14:16:00 <yboston> I did not finsih everything in "Circulation - Patron Record"
14:16:01 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:webclient
14:16:42 <yboston> I also suspect, some features that were missing when I wrote the docs might have been ported over, so it would be useful for me to review again
14:16:54 <remingtron> ah, but now I see some comments that some items aren't in the web client yet, etc.
14:17:55 <kmlussier> Does it need to be either/or? To be honest, docs organization is not my strong suit. But I see there are still some areas I could work on for the web client.
14:18:31 <kmlussier> Whereas others may prefer to work on the reorganization.
14:19:04 <remingtron> sure, people can certainly do what they are most interested in
14:19:20 <remingtron> and if anyone doesn't know where to start, they can work on web client stuff
14:19:41 <remingtron> but I'll plan to shift focus to the reorganization project
14:20:54 <yboston> I am not sure on what to focus if we should only choose one. BTW, do we want to also put down a time in the near future to work on one or both do of these topics. Like an hour long IRC meeting or re-org were we can talk about different approaches?
14:22:15 <remingtron> where's that wiki page with suggestions from the OPW candidate?
14:23:34 <remingtron> maybe it was just an email
14:23:56 <yboston> I am trying to find it
14:24:16 <remingtron> #link http://markmail.org/thread/kjddts4zod2uwbe6
14:25:27 <remingtron> anyway, yes, I guess it is still worth a meeting to discuss reorganization approaches
14:25:45 <remingtron> I'll send a doodle
14:26:56 <yboston> How is this… "remingtron will set up doodle to set up a meeting on IRC in February 2015 to discuss re-organizing the EG docs"?
14:27:08 <remingtron> perfect
14:27:41 <yboston> #action remingtron will set up doodle to set up a meeting on IRC in February 2015 to discuss re-organizing the EG docs
14:28:17 <yboston> no more previous action items
14:28:49 <yboston> should we talk about the web client docs?
14:28:57 <remingtron> sure, I have a question
14:29:25 <remingtron> does anyone know where development progress is at? mainly, are they ready for using launchpad yet for filing bugs?
14:29:28 <yboston> go ahead
14:29:39 <remingtron> maybe that's a question for graced ?
14:30:38 <phasefx> I think we're pretty close; I can have a better answer tomorrow
14:30:58 <kmlussier> I know there is a lot of bug fixing going on in https://bugs.launchpad.net/evergreen/+bug/1402797
14:30:58 <pinesol_green> Launchpad bug 1402797 in Evergreen "Browser client sprint1 miscellaneous repairs" (affected: 1, heat: 8) [Undecided,New]
14:31:14 <phasefx> and here, http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/miker/web-client-sprint1-bug-fixing-rebased-collab
14:32:52 <remingtron> phasefx: thanks, we'd love to hear when you have an update
14:33:15 <yboston> I think there are still some web cleint docs hat have to be added to master
14:33:52 <phasefx> remingtron: no problem.  we need to be more proactive with updates
14:33:55 <yboston> I need to review some DIG related emails I have pilled up since the ned of last year
14:34:36 <yboston> I beleive there are a couple of web clients submissions through the DIG list there that need to be added
14:34:53 <remingtron> yboston: I think you're right. let's work together to get those into master
14:35:12 <yboston> specially to avoid the both of us working on the same content
14:35:27 <remingtron> but let's still not push into 2.7 branch until we're ready to use launchpad for web client bugs
14:35:42 <yboston> I can set up a time to reach out to you early next week or even tomorrow to coordinate
14:35:55 <remingtron> great
14:36:36 <yboston> anything else web client related? or we can shift to another topic?
14:37:01 <yboston> (we are barely past the 30 minute mark)
14:37:14 <remingtron> sure, press on
14:38:04 <yboston> #topic Decide best presentation of web client install instructions
14:38:13 <yboston> See draft by bshum:
14:38:22 <yboston> #link http://evergreen-ils.org/~bshum/Evergreen-README.html#_optional_extra_steps_for_browser_based_staff_client
14:39:47 <yboston> remingtron: did you add this or was it bshum?
14:41:14 <yboston> I can move on to something else. I was just going downt he list
14:41:15 <remingtron> I think I did, but probably asked bshum first
14:41:42 <remingtron> basically, he wrote the instructions draft, and he wants some feedback
14:42:19 <remingtron> maybe he/we should ask the general and dev lists for help on that
14:42:52 <yboston> ats ome point I need to build a new test server to try out the web client, I can give him some feedback at that point
14:43:34 <yboston> I can put an action item to reach out to him to see if this has been included in master, and if others have been able to run his intructions
14:43:43 <yboston> they look fine to me, bu I have nos tested them yet
14:43:44 <bshum> It has not been added up to master yet.
14:43:54 <bshum> Sorry, stepped away a sec there.
14:44:16 <bshum> I'll work on it with more devs in the coming weeks.
14:44:49 <yboston> I can reach out to you when I am ready to build a new VM to test the web client, to make sure I use the latest version
14:45:07 <yboston> is there a git branch that has these instructions?
14:45:35 <bshum> yboston: I haven't put all the changes into a git branch yet.  That's also on my to-do list I think.
14:45:44 <yboston> no worries
14:46:31 <yboston> I can move on, but want suggestions on what action item if any we should leave for next meeting for this?
14:46:44 <yboston> (or we can continue on this topic too)
14:47:48 <remingtron> maybe action item to revisit state of those install docs.
14:47:50 <yboston> another topic to cover is the next release
14:48:30 <yboston> #action all check in on state of latest web cleint docs from bshum or others
14:50:19 <yboston> let me take a moment to look up the milestone dates for EG 2.8
14:50:57 <yboston> Friday, February 20th is the 2.8 beta cut off date
14:51:40 <yboston> the EG 2.8 beta release is scheduled for Wednesday, February 25th
14:52:14 <yboston> when woud we want to focus on the docs for the new features?
14:52:21 <yboston> I ca't rmemebr what we have done in the past?
14:52:36 <kmlussier> I would say we should start as soon after the beta release as possible.
14:52:38 <remingtron> after the 25th beta should be "feature stable"
14:52:50 <remingtron> kmlussier: yes, I agree
14:53:23 <kmlussier> Also, I don't know if I'm going to be able to use the MassLNC server as a community server for doc work this time around.
14:53:24 <yboston> Also, the projected release for EG 2.8 is Monday, March 9th. Though these dates coudl slip a bit, understandably so
14:54:21 <yboston> remingtron: the 25th make sense
14:54:23 <remingtron> should we try to have a day (or half day) hack-fest to focus on 2.8 features, or only use a wiki page to track progress?
14:54:54 <kmlussier> hack-fests are very effective for me. Otherwise, I tend to let tasks slip. But maybe I'm the only one with that problem.
14:55:37 <yboston> Ihack-fest for me too, I have that problem
14:55:54 <remingtron> okay, I'm in too
14:56:25 <remingtron> maybe on a Friday?
14:56:28 <yboston> sure
14:56:37 <remingtron> March 27, April 6, April 13?
14:56:47 <yboston> any volunteers to run a doodle poll targetting after February 25th?
14:57:04 <remingtron> whoa, sorry, I'm a month off!
14:57:13 <remingtron> Feb 27, March 6, March 13
14:57:30 <kmlussier> Feb 27 is bad for me. The other dates look fine.
14:57:31 <yboston> we may be able to try just on the mailing list, I wonder if some potential volunteers are scared off by doodle?
14:58:07 <remingtron> hmm, let's try a combo of the list and doodle
14:58:21 <remingtron> I'll do it
14:58:42 <remingtron> and I suggest I wait on the reorganization meeting until after 2.8 docs are finished. thoughts?
14:59:02 <kmlussier> They're scared off by Doodle, but please write in AsciiDoc? :)
14:59:29 <remingtron> or I guess it makes sense to sqeeze in the reorg meeting now, before beta
14:59:39 <remingtron> nevermind, I'll do both doodles
14:59:39 <yboston> #action remingtron will set up a doodle poll and ask on the DIG list to set up a time for a DIG 2.8 hackfest
15:00:02 <remingtron> kmlussier: double standard, eh?
15:00:09 <yboston> kmlussier: point taken
15:01:29 <yboston> we are slightly past the one hour mark
15:01:38 <yboston> shoudl we stop now, or
15:01:47 <remingtron> I think we've covered everything
15:01:50 <yboston> is there one more topic or quick question we woudl like to cover?
15:02:07 <remingtron> kmlussier: are you able to make the wiki page for 2.8 features again?
15:03:20 <kmlussier> Yes, I can.
15:03:30 <kmlussier> Sorry, I was pulled into another discussion.
15:03:40 * gmcharlt jumps in to mention that I intend to provision the doc testing server next week
15:03:45 <gmcharlt> sorry for hte delay
15:03:50 <kmlussier> gmcharlt++
15:04:06 <yboston> no problem, you have a lot on your olate
15:04:11 <yboston> *plate
15:04:14 <remingtron> gmcharlt++
15:04:49 <yboston> I laughed when I realized this nice reply on code4lib list was from you, as another example of your omnipresence
15:04:59 <yboston> OK, I will end the meeting
15:05:12 <yboston> #endmeeting