15:00:22 <bshum> #startmeeting 2015-02-17 - Developer Meeting
15:00:22 <pinesol_green> Meeting started Tue Feb 17 15:00:22 2015 US/Eastern.  The chair is bshum. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:22 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:22 <pinesol_green> The meeting name has been set to '2015_02_17___developer_meeting'
15:00:23 <jeff> bshum++
15:00:36 <bshum> #topic Welcome and introductions
15:00:41 <bshum> #info bshum = Ben Shum, Bibliomation
15:00:53 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:01:01 <berick> #info berick Bill Erickson, KCLS
15:01:01 <DPearl> #info DPearl = Dan Pearl, C/W MARS
15:01:05 <julialima_> #info julialima_ = Julia Lima. UI Style Guide (OPW), Argentina.
15:01:09 <bshum> #link Agenda: http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-02-17
15:01:09 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:01:26 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:01:31 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:01:40 <phasefx> #info phasefx = Jason Etheridge, ESI
15:02:59 <bshum> Alrighty, well, as others come along, feel free to add yourselves.  We'll move on for now.
15:03:11 <bshum> #topic Action items from last meeting
15:03:17 <bshum> #info dbwells will separate the cstore billing code into a separate bug; jeff and berick will help with testing
15:03:19 <kmlussier> #info kmlussier is Kathy Lussier - MassLNC
15:03:34 <bshum> Any report on that?
15:03:49 <berick> #info dbwells posted collab/dbwells/1198465_cstore_fines_gen -- I have not done any testing yet
15:04:06 <jeff> i can confirm that dbwells has a working branch with said separation and that i'm still planning to test -- sooner than later.
15:04:13 <eeevil> #info eeevil = Mike Rylander, ESI
15:04:17 <Bmagic> #info bmagic is Blake GH - MOBIUS
15:04:29 <dbwells> I did split it, but I also did a bad job at bothering people about it.
15:04:38 <eeevil> (I added a couple things to the agenda at the last moment ... sorry)
15:04:48 <bshum> Alrighty, I think we can leave it off the meeting action items.  Hopefully you guys can test it out before the beta cutoff?  :)
15:04:49 <kmlussier> We have it loaded on a test server at MassLNC, but I've only looked at it quickly. I'm planning to take a closer look this week.
15:05:05 <bshum> #info Testing to continue.
15:05:09 <berick> one sec...
15:05:38 <dbwells> kmlussier: I did push an update earlier today to fix penalty generation.  Just FYI.
15:05:48 <kmlussier> dbwells: OK, thanks. I'
15:05:52 <berick> this branch basically blocks the pending billing code?
15:05:54 <kmlussier> I'll let Dyrcona know.
15:06:31 <eeevil> berick: you mean the negative balance branches?
15:06:31 <berick> the conditional negative balances code?
15:06:33 <bshum> eeevil: Noted, I will refresh my agenda and go from what I see then.
15:06:41 <berick> eeevil: yeah
15:06:46 <eeevil> I don't think so, on either, actually
15:06:55 <dbwells> berick: Yes, this is a precursor to that.
15:07:16 <jeff> berick: my understanding is that it is some cleanup found during conditional negative balance work, which was seen as being useful to break out on its own.
15:07:22 <eeevil> well, it shouldn't block mine
15:07:33 <jeff> before merge, it should probably gain a LP of its own.
15:07:34 <berick> which means it needs to get merged before bug #1198465, which needs to be merged by friday.
15:07:34 <pinesol_green> Launchpad bug 1198465 in Evergreen "Support for Conditional Negative Balances" (affected: 15, heat: 70) [Wishlist,Confirmed] https://launchpad.net/bugs/1198465
15:07:55 <berick> (just making sure I'm understanding right)
15:08:41 <dbwells> berick: any branches on 1198465 would need to be heavily rebased after this gets in.  These change were all mixed into that code, so this was an attempt to make it more bite sized.
15:08:50 <dbs> #info dbs = Dan Scott, Laurentian University
15:09:37 <berick> dbwells: that's fine.  i'm just trying to make sure we're on the same page as far as order of events and when they need to get done
15:10:21 <bshum> Alrighty.
15:10:36 <dbwells> berick: Right.  I can try to make that more clear on the bug page.
15:11:43 <bshum> Okay then.
15:12:01 <bshum> #topic OpenSRF release
15:12:16 <gmcharlt> so, a couple things about that
15:12:37 <gmcharlt> I've got some WIP for improving osrf_control --diagnostic
15:12:46 <gmcharlt> and the incipient pound proxy example config
15:13:00 <gmcharlt> stuff that warrants a 2.4.next in March
15:13:30 <gmcharlt> but I want to ask others: any other pending stuff that folks would want to target for a March release?
15:13:35 * bshum assumes the pound proxy example config is in reference to getting websockets happier with standard ports?
15:13:40 <gmcharlt> yep
15:14:59 <bshum> Sweet, gmcharlt++ # looking forward to testing those things out.
15:15:31 <bshum> #info gmcharlt with new WIP for improving osrf_control --diagnostic and pound proxy example config for websockets in upcoming OpenSRF release.
15:16:34 <bshum> ... anything else on OpenSRF?
15:16:44 <bshum> Do we want to assign an action for 2.4.1 cutting?
15:17:29 <gmcharlt> bshum: go for it
15:17:34 <gmcharlt> you have... THE POWER
15:17:59 <bshum> @who will have the last say about cutting OpenSRF 2.4.1
15:17:59 <pinesol_green> artunit will have the last say about cutting OpenSRF 2.4.1.
15:18:03 <bshum> Well anyways
15:18:22 <gmcharlt> seriously, I'll accept an action item :)
15:18:33 <bshum> #action gmcharlt will cut OpenSRF 2.4.1 in March once new features are pushed.
15:18:38 <bshum> Thanks gmcharlt
15:18:42 <bshum> ;)
15:18:50 <bshum> Alrighty, moving along
15:19:04 <bshum> #topic Evergreen release (web client help)
15:19:19 <bshum> eeevil: I think this is one of your topics?
15:19:40 <eeevil> yes.
15:19:56 <eeevil> in particular, we are embedding many interfaces so we can get to a web client faster
15:20:16 <eeevil> and there's an opportunity for folks to jump in by reimplementing them in angularjs
15:20:39 <jeff> currently no work is in progress for the patron editor, for example (unless i'm wrong).
15:20:44 <eeevil> for instance, the user editor/registration screen, and the user permission editor
15:20:55 <eeevil> jeff: zackly
15:22:02 <eeevil> these are things that can be worked on essentially in isolation, without concern for breaking work already done or planned
15:22:55 <eeevil> they'd be good learning projects
15:23:04 <eeevil> so ... that's pretty much it :)
15:23:07 * bshum tries crafting an entry for the notes.
15:23:16 <Bmagic> The user permission editor has bugs for sure, hopefully the reimplementation would do something about that. I am interested in helping but I don't know what sort of time we are looking at
15:23:49 * gmcharlt woudl be more than happy to give some pointers and review code for anybody who wants to take a crack at any of this
15:23:49 <dbs> So, "Hi community, please plan amongst yourselves to implement the things that some subset of us are not planning on implementing"?
15:23:58 <bshum> #help Looking for intrepid folks interested to help in rewriting certain embedded interfaces to angularjs.  (like the user editor/registration screen, user permission editor)
15:24:27 <dbs> If there's a published plan for what those who are working on the current web client are planning on implmeenting so that we don't tread on those toes, that would be helpful
15:24:30 <jeff> i'm interested and i know there's interest here in having more of the "embedded legacy" web interfaces... modernized.
15:24:55 * dbs wants to create a simple hours-of-operation UI
15:24:55 <eeevil> dbs: "hi community, please feel free to jump in and start working in parallel on things that you all agreed could be pulled over in the interest of expedience"
15:25:20 <kmlussier> Yes, there is strong interest here in having those interfaces modernized too. The patron editor being the most critical among them.
15:26:00 <Bmagic> I don't want to commit to something that I can't finish inside of a timetable
15:26:40 <jeff> http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_sprints is the current best resource for "these are the things that are planned to be worked on", but I don't know if that's the place for coordination.
15:26:52 <eeevil> dbs: there are exactly such published plans
15:27:32 <eeevil> NTS: start crossing stuff off sprint2 :)
15:28:18 <jeffdavis> Can we add jeff's link to the minutes if it's the de facto roadmap for web client dev?
15:28:49 <bshum> jeffdavis: Seems like a good idea to me.  If that's what we're going to check towards.
15:28:50 <kmlussier> I don't know if that particular link is helpful. It doesn't note the interfaces that were carried over, as is.
15:29:07 <bshum> kmlussier: Good point :)
15:29:10 <eeevil> jeffdavis: it is the roadmap
15:29:16 <dbs> eeevil: so jeff's link (to a page with no title, and which has exactly one line--from the DIG doc planning page) are the published plans?
15:29:19 <kmlussier> Would it be helpful to have somebody identify the interfaces that need to be angularized on a wiki page?
15:29:23 <dbs> s/line/link/
15:29:28 <berick> kmlussier: they are marked on there
15:29:32 <eeevil> kmlussier: it does ... if it's got a * by it, we pulled the existing version
15:29:47 <bshum> *, gotcha
15:29:55 <kmlussier> Ah, ok. I didn't scroll down to the bottom of the page.
15:30:11 <eeevil> dbs: ? ... his link brings you to a page of links
15:30:35 <dbs> eeevil: one backlink from the entire wiki: http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_sprints&do=backlink
15:30:52 <jeff> "where can I start to learn and contribute without colliding with existing planned work" has been on my mind, so I'm interested in working on those suggested interfaces above, but can't commit off the cuff to specifics. sounds like that's me, bshum, Bmagic and gmcharlt offering to do some mentoring/guidance
15:31:10 <dbs> I'm just confirming that's the page. Sounds like it is, and now we can give it more visibility.
15:31:42 <eeevil> dbs: sorry, I'm not following. if you go to http://wiki.evergreen-ils.org/doku.php?id=dev:browser_staff:dev_sprints you will see sprints 1-4 documented
15:32:19 <eeevil> I'm happy to provide guidance as well. and berick has been responsive (thanks!)
15:32:41 <kmlussier> eeevil: Yeah, I think he's saying that the docs page is the only page that links to that page and that we need to increase the visibility of the dev sprints page.
15:32:44 <jeff> yes, berick++ -- already helpful just in getting things running for training here
15:33:04 <kmlussier> Sorry, I don't think that last statement from me made any sense.
15:33:05 <eeevil> kmlussier: ah, gotcha.
15:33:07 <berick> jeff++ # taking the plunge!
15:33:24 <bshum> Okay folks, so, let's use that page as a starting point for coordinating some of this.  Or at least noting areas that can use help.
15:33:39 * dbs has added a title and brief description to the page
15:33:59 <bshum> Anything else about web client work before we move along?
15:34:02 <eeevil> dbs: thanks. IIRC, that's be posted to the lists a few times ... maybe
15:34:15 <jeff> the existing dev sprints page reflects / is influenced by the fact that most/all of the work so far has been the community funding ESI performing the work. now that that's likely to change (with more contributions), i expect the page will change also.
15:34:16 <eeevil> bshum: not from me, thanks
15:34:35 <jeff> dbs++ edits
15:34:59 <bshum> Alrighty, berick you're up next with...
15:35:02 <bshum> #topic Evergreen 2.8
15:35:22 <berick> ok, i posted a list of reminders in the agenda
15:35:43 <berick> most notable of course is the pending feature merge cut-off this friday
15:36:11 <bshum> #info 2.8 Beta *features* merge cut-off is Friday, February 20, 2015.
15:36:31 <gmcharlt> speaking of which - just so there are no surprises, the one feature we'd like some leeway re merging is message center (bug 1410369)
15:36:31 <pinesol_green> Launchpad bug 1410369 in Evergreen "Message Center for the Public Catalog" (affected: 1, heat: 6) [Wishlist,New] https://launchpad.net/bugs/1410369 - Assigned to Jason Etheridge (phasefx)
15:36:43 <gmcharlt> it will be complete with a pull request tomorrow afternoon
15:37:08 <jeffdavis> I don't see bug 1410537 on either of those feature-related LP search results - presumably because it doesn't have a pullrequest tag
15:37:08 <pinesol_green> Launchpad bug 1410537 in Evergreen "Overdrive API integration" (affected: 2, heat: 12) [Wishlist,Triaged] https://launchpad.net/bugs/1410537
15:37:39 <berick> jeffdavis: yeah, the lists I posted filtered on pullrequests
15:37:40 <jeffdavis> Has anyone had a chance to look at it (besides hbrennan)? I'm assuming it hasn't had enough eyeballs to get in to 2.8
15:37:47 <berick> gmcharlt: re merging?
15:37:53 <berick> ohh
15:37:56 <berick> re:.. merging
15:38:05 <berick> <-- slow
15:38:05 <gmcharlt> berick: well, a quick review to be clear
15:38:09 <Bmagic> Im sure no one looked at this one https://bugs.launchpad.net/evergreen/+bug/1174498
15:38:09 <pinesol_green> Launchpad bug 1174498 in Evergreen "Payment by billing type breakdown" (affected: 7, heat: 38) [Wishlist,In progress] - Assigned to Jeff Godin (jgodin)
15:38:22 <bshum> jeffdavis: I actually got my Overdrive API test key last week.  So I might look more closely soon, but not sure if it'll be in time for Friday :\
15:38:51 <gmcharlt> jeffdavis: I'd look at it when you mentioend it (last month? how time flies); have you made any tweaks since then?
15:39:18 <jeff> Bmagic: i have concerns about payment by billing type interaction with some other billing changes -- it currently can be wrong about things with regard to future-dated overdues.
15:39:42 <jeffdavis> gmcharlt: no, no changes since then
15:39:42 <Bmagic> jeff: this is a materialized table
15:39:58 <jeff> Bmagic: right. i'm familiar with it. :-)
15:40:01 <gmcharlt> jeffdavis: I'm not sure about 2.8, but I'd be willing to give it some time to toughen it up against DOM changes and set it up as a contrib
15:40:13 <gmcharlt> I think the main blocker for that, though, would be clarifying the license?
15:41:36 <berick> gmcharlt: i'd be up for some horsetrading.  1171984 for 1410369
15:41:41 <jeffdavis> It's MIT licensed and my employer owns the copyright.
15:42:20 <gmcharlt> jeffdavis: I think some concerns about work-for-hire were expessed -- but I think that's OK for it living as a contrib
15:42:46 <kmlussier> We also have some people lined up here to look at 1410369.
15:42:54 <bshum> In the interests of finishing up this meeting, I'm going to ask us to delay discussions on specific features / requests for 2.8 post-meeting.  I'll give it a moment to wrap up last typing.
15:42:56 <gmcharlt> berick: you've got a deal; I'll start testing that tomorrow
15:43:18 <berick> gmcharlt++ # point me at the branch when it's published
15:43:24 <bshum> berick: Anything else about 2.8 beta before we move on?
15:43:27 <gmcharlt> berick: will do
15:43:31 <berick> and kmlussier's testing is welcome :)
15:43:40 <berick> bshum: one last thing.
15:43:46 <kmlussier> berick: The more the merrier. :)
15:44:11 <berick> i want to reiterate that any testing we can do with master between Friday and next Wednesday (beta release) is greatly apprecaited
15:44:21 <berick> to reduce the amount of beta bugs
15:44:30 <berick> or bug fix merges, for that matter
15:45:14 <berick> i'll try to finalize the DB upgrade script well before wednesday, too, for eyes
15:45:26 <jeff> berick++
15:45:32 <bshum> #info Beta release cut on Wednesday, February 25
15:45:57 <bshum> #help Please help test between beta deadline and cut to minimize bugs in beta.  And also help with bug fixes in general.
15:46:08 <bshum> berick++
15:46:16 <bshum> Alrighty.
15:46:26 <bshum> #topic OPW Progress Report
15:46:44 <dbwells> The OPW group would like to update the community on the progress of the Evergreen Style Guide project.  Our intern julialima_ has joined us today to give the update.
15:47:11 <julialima_> We have been working very hard and we have made a lot of progress.
15:47:45 <julialima_> We are focused mainly in ensuring consistency and providing the best  user experience we can. Of course it is a working progress, we are still testing some ideas and thinking new solutions for different situations. We still have 3 weeks until my internship is finished so we have a lot of time to try new things.
15:48:13 <julialima_> You can find the UI style guide in https://github.com/JuliaLima/Evergreen/tree/patch-1/docs/style_guide, remember that we are working on it, and also you can check in my blog for updates about our progress: http://lima-julia.tumblr.com/EG-style-guide.
15:48:33 <julialima_> Feel free to contact us and give your opinion, we need your feedback in order to improve our work, it is very important for us.
15:49:23 <kmlussier> julialima_ / dbwells: I can't remember. Have the links to the blog and github repo been posted to the mailing list yet?
15:49:29 <bshum> #link Style guide: https://github.com/JuliaLima/Evergreen/tree/patch-1/docs/style_guide
15:49:42 <bshum> #link Blog: http://lima-julia.tumblr.com/EG-style-guide
15:50:12 <dbwells> kmlussier: I can't recall either, but I'd say the blog more likely than the github repo.  We could certainly post them again.
15:50:55 <kmlussier> Sure. I know there have been a lot of discussions in here, but the mailing list post might reach some people who don't venture into IRC.
15:51:03 <dbwells> #action julialima_ will send a similar update with links to the mailing list
15:51:09 <dbwells> :)
15:51:17 <kmlussier> dbwells: Thanks! :)
15:51:24 <bshum> julialima_++ # thanks for the update!
15:51:37 <julialima_> :)
15:51:46 <kmlussier> julialima++ dbwells++
15:51:58 <bshum> Any other questions or comments on OPW before we move on?
15:52:06 <bshum> dbwells++ too :)
15:52:23 <dbs> julialima_: is there anything you need or want from us other than feedback?
15:52:24 <jeff> julialima_++ dbwells++
15:53:16 <julialima_> dbs: I think that your feedback is the most important thing we need now.
15:54:18 <bshum> Okie dokey then.
15:54:25 <bshum> #topic Google Summer of Code 2015
15:54:54 * bshum takes a deep breath.
15:55:39 <kmlussier> I added that item to the agenda to see if there was interested in applying for GSoC this year.
15:56:10 <kmlussier> We came up with a few solid ideas for coding projects for OPW, and I could see us building off of that list if there are devs who have time to mentor.
15:57:20 <kmlussier> We've also heard from a couple of potential OPW candidates over the past month who have been interested in some of those projects.
15:58:04 <bshum> So I see three coding ideas on that page http://wiki.evergreen-ils.org/doku.php?id=opw#coding
15:58:59 <bshum> Do the potential dev mentors for any of those projects want to reaffirm their interest in helping if we do decide to try using them as a baseline.  Or any other good ideas?
15:59:30 * bshum is generally okay with the idea, but isn't sure we have enough ideas / interest from the developers to mentor coding projects.
16:00:02 * bshum isn't ready to stand alone on that front either (since he notices now that his name is on two of those ideas)
16:00:17 <jeff> i wondered if you were going to notice that. :-)
16:00:22 <gmcharlt> heh
16:00:24 <kmlussier> Ha ha. It's all on you bshum
16:00:51 * gmcharlt is going to make a firm stand: I've got too much on my plate this summer, and do not put my name forward as a mentor
16:01:43 * bshum wonders if anyone else has the chops/time to mentor on angularjs rewriting (which is basically the first idea)
16:01:56 <kmlussier> It sounds like it's a resounding 'no' for this round?
16:02:09 <bshum> Seems quiet.
16:03:20 <bshum> Alrighty then...
16:03:22 <berick> a little too quiet
16:03:24 <dbs> We don't use the self-check currently, so..
16:03:25 <berick> dang, too late
16:03:48 <dbs> I could still help with responsive design, round 34
16:04:27 <dbs> But I fear all of the overhead associated with GSoC applications, etc is not appealing
16:05:33 <kmlussier> I would be willing to co-admin and help with applications, even though it's a very busy week, but it doesn't look like we have enough potential mentors throwing their hat in the ring.
16:06:08 * dbwells probably should sit out mentoring for the summer as well :(
16:06:41 <bshum> kmlussier: It didn't take many mentors last time we did it (there were only three who registered I think), but I'd be nervous that we don't have a lot of interest / project ideas for students to poke with.
16:07:56 <bshum> Anyways, we can talk more about it post-meeting, since we're not grabbing enough solid interest.  Other than dbs on responsive, whee!  :)
16:08:07 <kmlussier> bshum: True, but if it's just dbs and you, it looks like we would only be offering responsive design as an option.
16:08:19 <bshum> Anything else for this meeting before we close?  Thanks for your attention and participation.
16:09:04 <bshum> Alrighty, thanks folks.
16:09:10 <bshum> #endmeeting