13:01:50 <yboston> #startmeeting DIG docs re-org discussion
13:01:50 <pinesol_green> Meeting started Thu Feb 19 13:01:50 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:50 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:50 <pinesol_green> The meeting name has been set to 'dig_docs_re_org_discussion'
13:02:04 <yboston> #topic Introductions
13:02:11 <yboston> Please feel free to start introducing yourselves...
13:02:12 <krvmga> #info krvmga = Jim Keenan, CWMARS
13:02:29 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music
13:02:50 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
13:03:02 <yboston> for the record, I am always prepared to lead monthly DIG meetings, I prepare my cheat sheet and have several web pagesopenw ith agend and stuff
13:03:07 <sandbergja> #info sandbergja is Jane Sandberg @ Linn-Benton Community College
13:03:12 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
13:03:18 <yboston> I just meant the other day someone ask me to run a meeting at the last moment, and I survived
13:03:47 <remingtron> yboston: thanks for being brave
13:03:58 <afterl> #info afterl = Amy Terlaga, Bibliomation
13:03:58 <yboston> here is the agenda / wiki page
13:04:00 <akilsdonk> #info akilsdonk is Angela Kilsdonk, ESI
13:04:02 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:reorg_2014
13:04:53 <yboston> #topic Ideas for Organization
13:05:10 <yboston> my bad
13:05:15 <yboston> #topic Use the structure of "Evergreen in Action" as the main organizing structure for the docs
13:05:24 <yboston> I though I would start with this idea
13:05:33 <remingtron> good place to start
13:05:51 <remingtron> is everyone familiar with this book?
13:05:58 <krvmga> EIA was an interesting project to participate in.
13:05:59 <remingtron> #link http://en.flossmanuals.net/evergreen-in-action/
13:06:00 <yboston> #link http://en.flossmanuals.net/evergreen-in-action/
13:06:03 <yboston> ha ha
13:06:27 <yboston> I'll start of by saying that I liked readign Evergreen in Action; and that the organization made sense
13:06:32 <yboston> at least for a beguiner
13:06:45 <remingtron> it was a special manual written for approx. Evergreen 2.2
13:07:03 <krvmga> but because it was off-the-cuff, the organization wasn't actually planned out at the start. it grew with discussion.
13:07:21 <krvmga> lots of post-it notes and then discarding topics
13:07:38 <krvmga> we only had a few days to write the whole book
13:08:15 <remingtron> krvmga: how happy were you all with the resulting book? any gaping holes or problems you see looking back?
13:08:22 <krvmga> as to work organization: we all split topics up, wrote them up, then passed our write-ups to other team members for review.
13:08:46 <krvmga> as an experiment in rapid document production, i thought it was great
13:08:49 <krvmga> and successful
13:09:06 <sandbergja> I think one of the things that makes the Evergreen in Action manual so successful and helpful is that it has a really defined audience
13:09:23 <krvmga> yes, i think that's true.
13:09:29 <remingtron> great point
13:09:37 <sandbergja> Folks from my consortium think that the current official docs try to be too many things to too many people
13:09:50 <krvmga> i was thinking the same about the current docs -- that this was a weakness
13:09:57 <remingtron> krvmga: sandbergja: do you think we should reorganize based on audience?
13:10:04 <krvmga> we have a grand mass of documentation but it's not targeted
13:10:06 <yboston> sandbergja: thanks, I will make a note of this opinion
13:10:34 <jihpringle> +1 reorganize based on audience
13:10:36 <krvmga> i have the impression libraries wish they had essentially "For Dummies" books about each topical area
13:11:01 <krvmga> so they could give tech services the "Evergreen Cataloging" book, the circ desk "Evergreen Circulation", etc.
13:11:38 <yboston> these are all great feedback
13:11:39 <krvmga> and each "book" tailored to the end user at the desk rather than to an admin user.
13:11:54 <krvmga> these are things i've heard from people.
13:12:10 <remingtron> krvmga: right, with all the admin stuff in a separate book
13:12:12 <jihpringle> but we also want a "book" tailored to the admin user in the staff client
13:12:20 <krvmga> remingtron: yes
13:12:31 <krvmga> jihpringle: yes
13:13:20 <remingtron> It seems like this kind of change would be more about new presentation
13:13:23 <krvmga> we might start at the point of defining the audiences we want to address and then begin to consider books from there.
13:13:25 <sandbergja> Folks I talked to thought 3 "books": one for a really in-depth consortium-level admin with access to the shell on the server; one for a local admin type working with the staff client; one for circ/cat/acq staff who are just using eg on a daily basis
13:14:22 <krvmga> i was amazed at the number of people who wanted dead tree versions of EIA.
13:14:34 <krvmga> i could imagine people wanting "desk copies" of manuals
13:15:33 <sandbergja> krvmga: I agree about desk copies option, especially for staff new to evergreen
13:16:11 <afterl> sandbergja:  I like the three book division
13:16:29 <remingtron> sandbergja: I like the 3 book idea also
13:16:58 <krvmga> i have a concern that the staff user book might end up being too thick of a brick.
13:17:14 <yboston> I think the 3 book devision sounds fine, but in practice I suspect a 2 book division would be easier to maintain in the short term (front line vesrsu admin staff)
13:17:18 <afterl> kvmga: with reports in there too, eh?
13:17:19 <krvmga> maybe split out circ, cat, serials/acq
13:17:21 <remingtron> krvmga: you could separate by "module" or workflow or such
13:17:27 <remingtron> krvmga: right, that
13:17:33 <jihpringle> if staff really want to print it they can print the relevant sections
13:18:32 <remingtron> jihpringle: we would need to improve the PDF to make it nice to print
13:18:46 <remingtron> but that is probably doable
13:19:38 <krvmga> remingtron: i'm sure it would be doable.
13:19:38 <yboston> one technical concern is that I like usiing "jump links/see also" link between sections in the HTML version, would those links go away if we have multiple manuals?
13:19:57 <krvmga> yboston: that's an interesting question.
13:20:32 <remingtron> yboston: I'm sure we could preserve that functionality
13:20:41 <yboston> my previous ILS had manuals brken down by module and also you had circ staff versus circ admin/set up
13:20:49 <krvmga> there could be a couple of different ways to handle it so that we didn't lose that.
13:21:10 <yboston> I had to grab multiple manuals at a time to figure out stuff becuase content only appeard in one of those two (for circ)
13:21:52 <krvmga> with dead tree versions, you're always going to have that but electronic versions can do this much better.
13:21:56 <yboston> I just want to be the devil's advocate that there will be a burden (and benefits) to having multiple manuals
13:22:33 <remingtron> yboston: good concern
13:22:41 <krvmga> yboston: were we not thinking that all these would be combined into an aggregate online?
13:22:42 <yboston> krvmga: I want to have an automated solution to the crosslinking of manuals that does not depend on a human to create the cross links for the HTML version
13:23:09 <yboston> krvmga: I don't know what you mean by aggregate?
13:23:20 <krvmga> yboston: one giant mass of document
13:23:21 <remingtron> the current docs have a nice custom Google search engine
13:23:45 <remingtron> krvmga: I think we should separate them in how we present them
13:23:51 <remingtron> but provide cross-search ability
13:24:03 <krvmga> yboston: i'm sure we're not the first people to face this problem in the business world. i don't know if there's an open source solution for it. (requires some looking)
13:24:09 <remingtron> so you don't have to use the admin search box, then the circ search box, etc.
13:24:23 <yboston> krvmga: I was assuming that we would have differnt documents online too, though we might be able to do some AsciiDoc /Docbook magic to combine or seperate the output after being written
13:24:39 <krvmga> yboston: i was kind of thinking in that direction.
13:26:17 <yboston> I think this is a good  start to have all these comments in one place
13:26:32 <yboston> aas we approach the 30 minute mark
13:26:37 <krvmga> yboston: i agree
13:26:41 <yboston> we might want to focus on some areas
13:27:04 <yboston> like should we start picking our most important flaws of the current docs or
13:27:10 <yboston> what we think the audience should be
13:27:41 <yboston> what should be the overall goals and "values/requirements" of the new re-organized docs
13:28:00 <krvmga> i'm guessing everyone knows the story of the little red hen who wanted to bake a cake?
13:28:08 <yboston> I don't
13:28:49 <krvmga> the hen asks various animals for help getting ingredients for the cake. they all have excuses for not helping. the hen does all the work. the various animals all show up to eat the cake at the end.
13:29:05 <krvmga> i'd like to assume everyone here is going to be a helper. :)
13:30:25 <krvmga> in the hen story, the animals who come later don't get to eat the cake; only the hen and her chicks :)
13:30:39 <yboston> BTW, at some point we shuold ask opinions fromt he whole community
13:31:04 <yboston> but for example  that can be done after we have had a secodn meeting to talk about re-orgs
13:31:17 <krvmga> yboston: in that same line, i think, at some point, we should "play test" the docs with our expected end users.
13:31:36 <remingtron> yboston: might be good to have a proposed outline to get feedback on
13:31:45 <sandbergja> yboston: I like the sound of that -- I think we would get more feedback if we send out something concrete
13:32:53 <yboston> I prefer to first have a clear list of things that we want to adress in the re-org and the minimun requirements for the re-org. Though both can be revised with time
13:33:20 <yboston> since I think we probalvy do not agree 100% on how we want the re-org to be , I would liek to start finding what we do agree on
13:33:58 <krvmga> yboston: it seems we agree on dividing the docs into some functional areas.
13:34:03 <jihpringle> I'm assuming we're planning on reorganizing going forward so would it start with 2.8?
13:34:21 <remingtron> jihpringle: not that soon
13:34:44 <yboston> yboston: I am concerned that we might not be ready to support seperated docs yet
13:34:49 <remingtron> this is just a brainstorming meeting, so it may take a while to slowly change
13:35:09 <yboston> I would like to run some tests to make sure we have the correct automated worlflow first
13:35:48 <krvmga> yboston: that sounds good
13:35:55 <remingtron> yboston: right, it would require changes to the docs building process on the server
13:36:26 <yboston> I do agree that we should explore seperating the docs, both drafting some content and also starting to experiment with the processign side of it
13:36:34 <remingtron> Just a note, we need to conclude before 2pm, since there's another meeting on this channel at 2pm
13:36:51 <krvmga> part of the aim with EIA was to publish the docs through flossmanuals; are we thinking this at all?
13:37:30 <remingtron> krvmga: we would need an automated way to publish small changes
13:37:47 <yboston> I don't know enough about  flossmanuals to answer that
13:37:54 <krvmga> remingtron: yes, this was an ongoing issue with the process.
13:38:04 <krvmga> we also made the books available through lulu
13:38:45 <yboston> lets delay the issue of flossmanuals since we are runing out of time
13:39:13 <yboston> krvmga: can I assign an action item that has you ask us this question again at the next meeting?
13:39:34 <krvmga> yboston: i accept that action item.
13:40:10 <yboston> #action krvmga will follow up with DIG to see if the community wants to publish the docs through flossmanuals
13:40:44 <yboston> what action items can we agree on to start researching and experimenting with seperating part of the docs ?
13:41:01 <yboston> and who would like to work on that?
13:41:18 <jihpringle> brainstorm on wiki intended audiences?
13:41:22 <remingtron> I will try arranging the existing chapters into separate books as discussed
13:41:45 <remingtron> jihpringle: good idea
13:41:50 <yboston> also, we need to pick abother time to meet on this topic; either on IRC or by email
13:41:51 <sandbergja> remingtron: I can help with that, if you'd like
13:42:21 <yboston> #action remingtron & sandbergja will try arranging the existing chapters into separate books as discussed
13:42:25 <remingtron> sandbergja: great! I'll make it a wiki page
13:42:50 <remingtron> yboston: let's do another Doodle poll / reply-by-email-if-desired
13:43:16 <yboston> remingtron: do mind doing another poll?
13:43:31 <yboston> jihpringle: can assign to you that work on the audience?
13:43:44 <jihpringle> yboston: sure
13:43:59 <remingtron> yboston: sure, I'll send out the doodle again
13:44:14 <jihpringle> I'll create a wiki page and link it back to the reorg page
13:44:16 <gmcharlt> berick: around?
13:44:45 <yboston> #action jihpringle will brainstorm on wiki intended audiences?
13:44:59 <gmcharlt> (whoops, sorry)
13:45:10 <remingtron> gmcharlt: no worries
13:45:41 <yboston> jihpringle: would you mind sumaririzing the docs comments and complians in this chat too?
13:46:08 <jihpringle> yboston: no problem, I can do that
13:46:13 <yboston> I was thinking of emailing kmlussier and Robert Souliere to warn them about our desire to split the docs, so we can start brainstorimin gthe techincal side
13:46:30 * kmlussier is hear, but hasn't been paying close attention.
13:46:36 <kmlussier> s/hear/here
13:46:37 <krvmga> yboston: i think that's a good idea. dan scott, too, maybe.
13:46:54 <yboston> #action jihpringle will sumaririze the docs comments and compliants in this chat log on the wiki
13:47:34 <yboston> should I do it on the mail DIG list too? though it might start a big thread of comments and complaints, but I am OK with that too :)
13:47:49 <krvmga> yboston: i'm okay with that.
13:48:59 <yboston> #action yboston will send an email to the DIG list with to anounce that we want to research the techical side of processign a multi manual approach to the docs
13:48:59 <berick> gmcharlt: for just a few minutes
13:49:29 <yboston> we have ten minutes, but there is another meeting starting at 2 PM EST
13:49:54 <yboston> when should we meet to discuss this topic again? btw, I think having a single topic discsion was helpfuk
13:49:59 <yboston> *helpful
13:50:10 <remingtron> I agree, very helpful
13:50:19 <yboston> sorry, forfot that remingtron would find that out
13:50:24 <remingtron> yes
13:50:32 <yboston> any last comments, specially fromt hose that have not said anything yet, if they want to
13:51:09 <afterl> Just that I'm willing to help where it would make sense for a newbie to
13:51:44 <yboston> do you want to help jihpringle summarize the complaints and comments?
13:52:08 <afterl> Sure, will go to jhpringle for instruction
13:52:16 <yboston> you can then add your own and your libraries's too
13:52:27 <remingtron> afterl: do you have a wiki account? you can help on any of the wiki pages we're starting
13:52:37 <jihpringle> we should probably add to that page as well as people comment/complain via the list
13:52:39 <yboston> (sorry for my bad grammar when I type fast)
13:52:50 <afterl> remingtron:  I do have a wiki account
13:53:22 <remingtron> afterl: great, jump in wherever you like!
13:53:36 <afterl> Okay!
13:53:57 <yboston> seven minues left until the Evergreen Board meeting starts
13:54:04 <yboston> * minutes
13:54:21 <yboston> any final thoughts?
13:54:28 <krvmga> i'm very happy everyone showed up. this is wonderful.
13:54:37 <remingtron> yes, thanks all for your thoughts!
13:54:49 <yboston> krvmga: BTW, I will send you a private message ina few moments
13:55:02 <krvmga> yboston: okey doke
13:55:07 <yboston> OK then, I think I will end the meeting now
13:55:11 <yboston> thank you all very much
13:55:16 <krvmga> yboston++
13:55:19 <yboston> #endmeeting