14:00:59 <yboston> #startmeeting 2015-03-05 - DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:59 <pinesol_green> Meeting started Thu Mar  5 14:00:59 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:59 <pinesol_green> The meeting name has been set to '2015_03_05___dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:01:13 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20150305-agenda
14:01:25 <yboston> #topic Introductions
14:01:26 <yboston> Please feel free to start introducing yourselves...
14:02:19 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:02:33 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library
14:02:51 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:02:52 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:03:19 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:03:57 <yboston> ok lets move on
14:04:14 <yboston> any reports from coordinators (no woorries if there are none)?
14:04:59 <rsoulliere> none from me.
14:05:17 <yboston> OK
14:05:32 <yboston> #topic old action items
14:05:42 <yboston> #info 1) yboston will contact krvmga to check in on his 2.7 docs work
14:05:56 <yboston> I spoke to krvmga, and apparently this has been taken care of
14:06:12 <yboston> #info 2) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:06:23 <remingtron> yboston: question about #1
14:06:31 <yboston> go ahead
14:06:32 <remingtron> does that mean it's been pushed to master?
14:06:50 <yboston> that is an excelent question
14:07:10 <remingtron> otherwise, we just need to know where his finished work is so we can review and push it in
14:07:11 <yboston> the notes I had at the last time I contacted him did not specify
14:07:25 <yboston> what was missing, only that I had to check in on him
14:07:37 <yboston> I can ask him again to verify exactly what it was
14:07:46 <yboston> kmlussier: do you remember what it was?
14:08:17 <yboston> I thought it either had to do with added content or with the MARC stream importer?
14:08:56 <remingtron> looks like added content
14:09:06 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.7_needs
14:09:21 <remingtron> (look for Jim Keenan, under OPAC section)
14:09:30 <yboston> I see
14:09:58 <kmlussier> Sorry, I stepped away.
14:10:45 <yboston> I am grepping the docs to see what I find under "cafe"
14:10:50 <kmlussier> I haven't seen Jim's documentation merged anywhere. However, there was some other work done on Added Content since then. I don't know if it overlaps or not.
14:11:24 <kmlussier> I think Josh Stompro may have done that work?
14:11:33 * kmlussier still needs to defer her action item.
14:11:44 <kmlussier> Sorry sandbergja! I know I owe you some notes.
14:12:16 <sandbergja> kmlussier: no worries!
14:13:33 <yboston> It looks like there is nno recent updates to content related to "content cafe" in master right now
14:13:54 <yboston> here is a link ot the history of the file that covers contnet cafe http://git.evergreen-ils.org/?p=Evergreen.git;a=history;f=docs/admin_initial_setup/designing_your_catalog.txt;h=4699ae2fe912acc71fbc7729bd8a8330d2c9b780;hb=master
14:15:20 <yboston> I can follow up with krvmga to verify where the content is; or if he can provide with another copy of it
14:15:32 <remingtron> I was expecting Jim to send us a link to his docs, then we would review and push it in
14:15:54 <remingtron> so I figured since we didn't hear anything, we just needed to follow up with him
14:16:10 <yboston> I will reach out to him again
14:16:10 <remingtron> yboston++
14:16:18 <yboston> #action yboston will reach out to krvmga for another copy of his docs to push to master
14:16:38 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:16:55 <yboston> anything else before I move on to older action items?
14:17:23 <yboston> will move on
14:17:31 <yboston> #info 3) yboston will follow up with gmcharlt and Robert about provisioning a VM for DIG
14:18:10 <yboston> I have spoken to gmcharlt , we hope to have a partially set up VM next week
14:18:25 <remingtron> hurray!
14:18:36 <yboston> though we would need to then start configuring it for docs processing
14:19:10 <yboston> gmcharlt++
14:19:15 <yboston> csharp++
14:19:23 <yboston> any additional comments on this topic?
14:19:46 <yboston> moving on
14:19:52 <yboston> #info 4) remingtron will set up doodle to set up a meeting on IRC in February 2015 to discuss re-organizing the EG docs
14:20:00 <yboston> done and done
14:20:03 <remingtron> yup
14:20:04 <yboston> remingtron++
14:20:19 <yboston> I thought it was great t have a whle meeting on one subject
14:20:28 <yboston> though it might been a nightmare for others
14:20:36 <remingtron> me too, very focused
14:20:59 <kbutler> I thought it was great, even though I ended up missing most of it in person.
14:21:06 <yboston> there were some next action from that meeting, none of which I currently recall
14:21:13 <yboston> should I add them to this meeting too?
14:21:23 <remingtron> yboston: we can discuss it under "New Business"
14:21:31 <remingtron> I can remind you about some of them
14:21:35 <yboston> OK, lets move on (thanks)
14:21:53 <yboston> #info 5) all check in on state of latest web client docs from bshum or others
14:22:47 <remingtron> we can get to that in a minute too, under Old Business, and I'll explain the state of things
14:23:07 <yboston> I got a chance to install OSRF 2.4 and saw soem of the web clietn install docs, but I have not verified that the process worked
14:23:16 <yboston> OK, moving on
14:23:29 <yboston> #info 6) remingtron will set up a doodle poll and ask on the DIG list to set up a time for a DIG 2.8 hackfest
14:23:37 <yboston> done & and to be done tomorrow
14:23:48 <yboston> remingtron++
14:23:49 <remingtron> yes, excited for the hackfest
14:24:05 <yboston> that is the last of the old business
14:24:57 <yboston> sorry, the last of the previous meeting action items
14:25:26 <yboston> any preference between tacklign old busniess versus new business? I rather tackle the hackfest first
14:25:45 <yboston> (sorry for my bad spelling)
14:25:53 <remingtron> sure, hackfest first
14:26:11 <yboston> #topic DIG hackfest
14:26:27 <yboston> thanks to kmlussier & remingtron for helping to move things forward
14:26:51 <yboston> I can host the goolge hangout
14:26:57 <remingtron> great!
14:27:40 <yboston> any other questions or comments ont he hackfest?
14:27:40 <remingtron> I can't join until about 9am EST
14:28:13 <yboston> on a related note, I will be out for a meeting bewteen 9:50 and 11 AM EST
14:28:33 <remingtron> can you leave the hangout open during that time?
14:28:43 <yboston> yes
14:28:51 <yboston> out of curiosity, can I get a show of hands of how can make it?
14:29:07 <yboston> also, if possible I guess we can start markign what we want to work on
14:29:24 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:30:30 <yboston> now that I thik about it, since we are not meeting in groups in a physical location there might not be much to talk about right now
14:30:40 <yboston> any final questosn or comments on the topic of the hackfest?
14:30:59 <remingtron> just that all who are willing should sign up for something
14:31:04 * kmlussier raises here hand
14:31:19 <remingtron> the goal is to have all 2.8 features documented and pushed to master before 2.8 is released
14:31:37 <remingtron> I think the target release date is still March 18
14:32:15 <yboston> kmlussier: did you have a question?
14:32:23 <yboston> or just sowing support
14:32:27 <yboston> *showing
14:32:34 <kmlussier> yboston: You asked for a show of hands
14:32:39 <kmlussier> So I showed my hand. :)
14:32:40 <yboston> oops
14:32:43 <yboston> thanks
14:32:47 <yboston> kmlussier++\
14:32:57 <yboston> kmlussier++
14:33:21 <yboston> I can move on to other business now
14:34:10 <yboston> let me stick to new busniess
14:34:24 <yboston> #topic We should use .asciidoc file extension.
14:34:50 <remingtron> this and the next topic were suggestions from.....someone I can't remember
14:35:11 <remingtron> and I lost that IRC session. Josh someone?
14:35:23 <remingtron> sorry whoever you are!
14:35:27 <yboston> I can't remember either, but I really like having Github parse the docs automatically
14:35:44 <yboston> Justin Hopkins?
14:35:58 <remingtron> yes, I think that's it!
14:36:05 <kmlussier> rsoulliere: Does that cause any problems with the doc build?
14:36:09 <remingtron> hopkinsju++
14:37:09 <rsoulliere> kmlussier: shouldn't cause any problems.
14:37:13 <dbs> kmlussier: all of the references to the doc source filenames would need to be adjusted, a one time pain
14:37:40 <remingtron> dbs: right, we'd have to choose a time and make the switch
14:38:16 <remingtron> so if everyone agrees, I can help coordinate the time, probably after 2.8 is released
14:38:21 * kmlussier has no opinion on the matter
14:38:29 <kmlussier> Just tell me what to do, and I'll do it. :)
14:38:59 <remingtron> anyone have concerns?
14:39:05 <yboston> I could argue that the use of the txt suffix looks friendlier to newcomers than what we are proposing
14:39:30 <yboston> the files can open by default ona windows or Mac machine
14:39:49 <remingtron> yboston: yes, but GitHub will be much friendlier by auto-generating the HTML to preview
14:40:18 <yboston> remingtron: I agree, that part is very enticing
14:40:27 <remingtron> true, we would lose the niceness for working on their local computer
14:41:03 <yboston> we can create a guide to teach folks to use Notepad or Notepadd++ to open these files
14:41:03 * dbs doesn't have a sense for how many people contribute to the docs via github
14:41:43 <yboston> it could help promote the uses of gists even more
14:42:56 <remingtron> I think we've had more github activity recently
14:42:57 <yboston> should we have a vote on the mailing list?
14:43:11 <yboston> (for the change)
14:43:16 <remingtron> sure, I'll send a note to the list
14:43:22 <remingtron> that will get more voices, hopefully
14:43:55 <yboston> #action remingtron will send out emial to list about cahnging the file suffix in the docs repo to .asciidoc
14:44:18 <yboston> #topic We should use the alternate style of headings
14:44:37 <yboston> #link http://paste.evergreen-ils.org/36
14:44:46 * dbs thinks .adoc might work too, which has the advantage of being shorter
14:45:08 * dbs confirms .adoc works : https://github.com/opendevise/asciidoc-samples
14:45:11 <kmlussier> I've seen both styles of headings used in our docs. I'm not sure I see the benefit of choosing one over the other. Couldn't people just use whichever they prefer?
14:45:22 <remingtron> dbs++
14:45:43 <yboston> dbs++
14:45:48 <kbutler> I think the alternate style is more readable unrendered.
14:46:03 <yboston> kbutler: I agree
14:46:07 <remingtron> kmlussier: the underline style is easy to get wrong, must be the exact right length
14:46:27 <remingtron> kmlussier: and underlines are hard to remember which character to use for which level
14:46:33 <remingtron> unintuitive
14:46:49 <kbutler> remingtron: I agree on all points
14:47:00 <remingtron> I would call them minor differences, but worth changing
14:47:00 * dbs agrees that it comes down to preferences
14:47:12 <yboston> kbutler: I misread, I disagree with you :(
14:47:43 <dbs> and potentially more churn in two more years if a different group decides they prefer a different style
14:47:53 <remingtron> dbs: hm, good point
14:48:04 <yboston> I guess it would probably get confusing if we were using both styles all over the place
14:48:25 <kmlussier> dbs: A different group? Where are we going? ;)
14:49:21 <remingtron> well, it's certainly not an urgent issue, so let's move the discussion to the list
14:49:23 <yboston> either way, we should turn to the list for more opinions / votes
14:49:33 <remingtron> yboston: my thoughts exactly!
14:49:38 <yboston> :)
14:49:40 <kmlussier> My preference is to leave it so that people use whichever style they prefer. But, if others want to go with the alternate style, I'll learn the other way.
14:49:47 <yboston> and we would need to pick a time to do the switch, if we want to
14:50:27 <yboston> I am a bit concerend that it will ger really confusing if we mix two styles in the same file
14:50:58 <remingtron> yboston: agreed, we should always use the same style within one file
14:51:13 <remingtron> any edits or additions should use the existing style
14:51:27 <yboston> does any one to volunteer to send an email to the list to talk abotu this further?
14:51:29 <remingtron> I'll send that email to the list in a few weeks
14:51:30 <kmlussier> That's fine with me.
14:52:05 <yboston> #action remingtron will send an emial to the list to consider changing the AsciiDoc section header style
14:52:31 <yboston> we have less than ten minutes
14:52:40 <yboston> shoudl we cover web clients or the re-org?
14:52:50 <yboston> I mean cover first
14:52:53 <remingtron> one question about the re-org
14:53:00 <yboston> go agead
14:53:07 <remingtron> does everyone think we should have another special meeting about it?
14:53:17 <remingtron> if so, I'll send another doodle to pick the time
14:53:47 <yboston> I definetly want another meeting at some point
14:54:02 <remingtron> otherwise, let's discuss it next meeting
14:54:07 <yboston> though, I prefer that someone has summarized the notes from the first meeting first
14:54:18 <remingtron> there's a few links here:
14:54:23 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:reorg_2014
14:54:52 <remingtron> I guess a few of the links are empty pages
14:55:01 <remingtron> but I posted my ideas here:
14:55:02 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:reorg_2014:audience_focused_layout
14:55:30 <remingtron> about presenting the docs as separate books related to user type
14:55:38 <yboston> remingtron++
14:56:30 <kbutler> remingtron++
14:57:10 <yboston> we can wait untilt he next meeting to talk abotu this again and decide whn to have another meeitng
14:57:30 <yboston> or I can create a doodle poll for another meeting
14:57:42 <remingtron> sure, let's wait until next meeting
14:57:48 <yboston> ok
14:58:09 <remingtron> and all ideas are welcome! you can edit those wiki pages!
14:58:15 <remingtron> (you = anyone)
14:58:21 <yboston> #action all decide how to proceed with docs reorganization next meeting
14:58:46 <yboston> we have two mintues left
14:58:57 <yboston> any questions or comemnts about web cleitn docs?
14:59:03 <yboston> *client
14:59:24 <remingtron> just web client
14:59:27 <remingtron> oh, right
14:59:30 <remingtron> one comment
14:59:47 <remingtron> there are 3 docs ready to review on this page:
14:59:52 <remingtron> http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:webclient
15:00:12 <remingtron> we should try to review and push them to master. no rush, just didn't want to forget them
15:00:30 <yboston> remingtron++
15:00:34 <remingtron> that's all
15:00:39 <yboston> anything else?
15:00:43 <yboston> from enyone else?
15:01:07 <yboston> OK then, thanks everyone and hope to see soem of you tomorrow
15:01:22 <yboston> #endmeeting