15:04:23 <gmcharlt> #startmeeting Development meeting, 16 March 2015
15:04:23 <pinesol_green> Meeting started Mon Mar 16 15:04:23 2015 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:23 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:23 <pinesol_green> The meeting name has been set to 'development_meeting__16_march_2015'
15:04:37 <gmcharlt> #info Agenda is http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-03-16
15:04:53 <gmcharlt> #topic Introductions
15:04:59 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:05:09 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:05:09 <DPearl> #info DPearl = Dan Pearl, C/W MARS
15:05:14 <julialima> #info julialima = Julia Lima. UI Style Guide (OPW), Argentina.
15:05:16 <Dyrcona> #info Dyrcona = Jason Stephenson, MVLC
15:05:18 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:05:33 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:05:37 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:06:03 <bshum> #info bshum = Ben Shum, Bibliomation
15:06:09 <dbs> #info dbs = Dan Scott, Laurentian University
15:06:17 <dbs> (land o' the flaky wireless)
15:06:28 <gmcharlt> dbs: Thanks, Harper!
15:06:55 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:08:00 <gmcharlt> ok, moving on
15:08:05 <gmcharlt> #topic OpenSRF release
15:08:48 <gmcharlt> not much specifically to say at the moment, beyond http://git.evergreen-ils.org/?p=working/OpenSRF.git;a=shortlog;h=refs/heads/collab/gmcharlt/better_osrf_control_diagnostic and websocket port standardization being on the radar
15:09:24 * gmcharlt notes that csharp has an update to the Fedora instructions in the working repo as well
15:09:36 <eeevil> #info eeevil = Mike Rylander, ESI
15:09:54 <phasefx> #info phasefx = Jason Etheridge, ESI
15:10:06 <bshum> Does that sort of change warrant 2.5? I'm not sure the particulars of how we decide versioning for OpenSRF.
15:11:02 <gmcharlt> bshum: it could, though I lean more towards those changes warranint just a 2.4.1
15:11:20 <gmcharlt> I don't have particularly strong feelings either way
15:11:27 <gmcharlt> what *would* warrant a 2.5 is http2 support, IMO
15:12:07 <gmcharlt> any other comments
15:12:07 <gmcharlt> ?
15:13:05 <Dyrcona> Doesn't look it warrants a 2.5 just for the diagnostic changes.
15:13:55 <gmcharlt> agreed
15:13:58 <gmcharlt> moving on
15:14:05 <gmcharlt> #topic Evergreen release
15:14:08 <gmcharlt> berick: about?
15:15:18 <berick> omg, yes
15:15:26 <gmcharlt> :)
15:15:27 <berick> odd morning
15:15:30 <gmcharlt> welcome, berick
15:15:33 <berick> thanks ;)
15:15:39 <berick> so, we ready for an RC1?
15:15:44 <gmcharlt> (you've been volunteered to do all the things, by the way ;) )
15:15:49 <berick> heh
15:15:57 <bshum> berick++
15:16:30 <berick> i think we're ready for an RC1.  so i will cut one very soon
15:16:34 <berick> probaby tomorrow
15:16:46 <gmcharlt> berick: +1 to an RC1
15:17:08 <gmcharlt> #info berick to cut an RC1 for Evergreen 2.8.0 in the next day or so
15:17:17 <berick> i have not heard any problems w/ the beta, fwiw, apart from standard bug reports
15:17:38 <bshum> Fwiw, we're still testing up our upgraded DB to master, but the upgrade scripts didn't blow up anywhere so far for us.
15:17:48 <bshum> So far.
15:18:33 <berick> thanks, bshum
15:19:20 <gmcharlt> berick: anything else to say about 2.8 rc1?
15:19:59 <berick> nothing at the moment to add
15:20:30 <gmcharlt> ok, moving on
15:20:37 <gmcharlt> #topic Questions about Security Bugs/Process
15:21:16 <gmcharlt> #info Kathy Lussier's questions + responses - http://markmail.org/thread/fqrhegamnyej2s57
15:21:42 <gmcharlt> #info Proposal for defined process for security team membership - http://wiki.evergreen-ils.org/doku.php?id=dev:security#security_team
15:21:57 <gmcharlt> #info Current security team - http://wiki.evergreen-ils.org/doku.php?id=dev:security#current_security_team_members
15:22:25 <gmcharlt> as you can see, kmlussier has joined the team (as of today)
15:22:26 <gmcharlt> kmlussier++
15:22:30 <berick> kmlussier++
15:22:47 <bshum> kmlussier++
15:22:53 <Bmagic> kmlussier++
15:23:03 <jeff> kmlussier++
15:23:11 * kmlussier hasn't done much yet beyond making a lot of noise. ;)
15:23:52 <dbwells> kmlussier++
15:24:48 <gmcharlt> so, at this point, the floor is open to any follow-up discussion
15:25:58 * kmlussier has nothing to add.
15:28:09 <gmcharlt> I propose that we carry on any further discussion on the ML, then
15:28:26 <gmcharlt> moving on in 15 seconds
15:28:26 <bshum> It seems like it'll be good to see how the new policy and members work out for awhile and then see what else needs adjustment.
15:29:05 <dbwells> I agree
15:29:42 <gmcharlt> ok
15:29:46 <gmcharlt> #topic Style Guide Project
15:29:56 <gmcharlt> #info OPW project finsihed on 3/9
15:30:08 <gmcharlt> #info Project blog is at http://lima-julia.tumblr.com/
15:30:19 <gmcharlt> #info Project branch is at https://github.com/JuliaLima/Evergreen/tree/patch-1/docs/style_guide
15:30:27 <gmcharlt> julialima: you have the floor
15:31:00 <dbwells> julialima has agreed to join us today for at least one more time (hopefully more again, someday :)
15:32:02 <dbwells> I took the opportunity to post some public gists to the agenda to perhaps encourage more review of what has been accomplished so far.
15:32:27 <dbwells> The guide is much more interesting and entertaining with all the pictures in place.
15:33:18 <dbwells> Finally, the "Next Steps" is my interpretation of some of julialima's recommendations in her last blog post.
15:33:43 <dbwells> Basically, how do we get this to a point where it is in full use?
15:33:57 <gmcharlt> julialima: I'd be interested in hearing your thoughts
15:35:58 <julialima> Well, I know it is not easy the implementation of the UI style guide, so I try to think in the starting points about how to implement it (that is what I wrote in my blog post)
15:36:59 <julialima> And I think dbwells understand what I mean in his proposal. I really hope it can be achieve
15:37:07 <gmcharlt> julialima: thanks, that helps :)
15:39:11 <gmcharlt> so, I think there are some details to digest
15:39:17 <gmcharlt> do folks have any immediate feedback?
15:39:20 <kmlussier> I would like to see the full style guide posted somewhere on the Evergreen web site. Maybe as an appendix to the docs?
15:39:28 <Bmagic> julialima++
15:39:57 <hopkinsju> julialima++
15:41:22 <gmcharlt> julialima++
15:41:45 <dbwells> It seems like engagement here is pretty light today, so it probably makes sense to extend the "next steps" proposal discussion to the list as well?  I want to be clear that this proposal as written is my own, just so there is no confusion about it.
15:42:11 <gmcharlt> yeah, I think moving the discussion onto open-ils-dev is the next step
15:42:34 <gmcharlt> any other comments before we move on to the next agenda item?
15:42:46 <dbwells> will do.  Does anyone have any immediate feedback on the idea of a new team?
15:43:21 <dbwells> I'd like to address any concerns if possible when I email the list.
15:43:28 <remingtron> I like the idea of a new team to help facilitate adoption of the guide
15:43:44 * kmlussier agrees
15:43:45 <gmcharlt> -1 unless a reason can be articulated why a discussion cannot be held on open-ils-general and open-ils-dev
15:44:46 <kmlussier> I don't see why discussion can't happen in our normal communication channels.
15:45:39 <dbwells> I am thinking meetings would happen in #evergreen, certainly.  It is really more about commitment than anything else.
15:45:40 <dbs> Let's start with the regular mailing lists and see what develops
15:46:38 <kmlussier> I'm mostly interested in the commitment factor too. I actually wouldn't want to see too much more expansion happen with the style guide at this point. I would rather focus on starting to incorporate what's already there.
15:47:14 <dbs> A big part of this is just building out the basic pieces that have been laid out
15:47:43 <dbs> and we'll rename the .txt files to .adoc to get fancy highlighting in github :)
15:47:54 <dbwells> +1 to that :)
15:50:41 <gmcharlt> ok
15:50:43 <julialima> Once more, I want to thank you all. It was an awesome experience for me. I am willing to help in whatever (opinions in general or questions about my work). I will try to be aware of the project and say hi once in a while. It was a real pleasure :)
15:50:52 <gmcharlt> thanks, julialima!
15:50:54 <gmcharlt> julialima++
15:50:57 <dbs> julialima++
15:50:58 <jboyer-isl> julialima++
15:50:59 <dbwells> julialima++
15:51:04 <remingtron> julialima++
15:51:11 <jeff> julialima++ thank you!
15:52:13 <gmcharlt> #topic Potential upcoming localhost WebSockets restrictions
15:52:38 <gmcharlt> #info Link to discussion of Chromium potentially blocking localhost websockets access https://code.google.com/p/chromium/issues/detail?id=378566
15:54:08 <jeff> I added this -- there's not much in stone yet, but I wanted to ensure that as wide an audience was aware of the issue (and how it could potentially affect Evergreen).
15:55:50 <gmcharlt> jeff++ # thanks for the heads-up
15:56:07 <kmlussier> Monday must be a bad day for meetings.
15:56:09 <jeff> We do not seem to be alone in having a use case for localhost WebSockets connections from Chrome, which is good.
15:56:25 <gmcharlt> yeah, but we should add our voice to the chorus
15:56:34 <gmcharlt> berick: are you up for that/
15:56:35 <gmcharlt> ?
15:56:53 <jeff> kmlussier: I'm just glad I didn't #startmeeting -- i'm presently out on the floor tag-teaming a recalcitrant microfilm scanner. :-)
15:57:16 <kmlussier> heh
15:57:27 * dbs needs to split for kids
15:57:56 * Bmagic is glad dbs is not splitting kids
15:58:22 <gmcharlt> ok, I"m going to assign an action anyway
15:58:38 <gmcharlt> #action berick, gmcharlt, and eeevil will add a response to the chromium localhost ws bug
15:58:56 <gmcharlt> and finally, very briefly
15:59:09 <gmcharlt> #topic Feedback for new features under development
15:59:18 <gmcharlt> does anybody have new stuff in the works they want to mention?
16:00:23 <jeff> equally briefly: we're looking at adding some things to Missing Pieces with regard to default circ duration after marking missing, etc. If others are interested, let me know or look for a launchpad wishlist bug in the near future.
16:00:53 <gmcharlt> sounds intriguing
16:00:57 <gmcharlt> thanks, jeff!
16:01:14 <gmcharlt> and as it is 16:01 here...
16:01:16 <gmcharlt> #endmeeting