14:00:31 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:31 <pinesol_green> Meeting started Thu Apr  2 14:00:31 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:31 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:40 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20150402-agenda
14:00:59 <yboston> #topic Introductions
14:00:59 <yboston> Please feel free to start introducing yourselves...
14:01:12 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:35 <rsoulliere> #info rsoulliere is Robert Soulliere, Mohawk College
14:02:11 <jihpringle> info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:21 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:21 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:03:47 <yboston> welcome everyone
14:04:01 <yboston> Robert or Kathy, do either of you have anything to report?
14:04:08 <yboston> it is OK if you don't
14:04:15 <kmlussier> I do
14:04:20 <yboston> go ahea
14:04:26 <yboston> *ahead
14:04:26 <kmlussier> #topic Release Coordinator Report
14:04:50 <kmlussier> #info I am adding acknowledgements plus one missing feature to the Release Notes as we meet
14:05:02 <kmlussier> #info The 2.8 Release Notes should be complete by the end of today.
14:05:05 <kmlussier> End of report
14:05:29 <kmlussier> Oh, I do have something else.
14:05:48 <yboston> BTW, Kathy do you have any doceumntation ont he process of making the release ntoes?
14:06:10 <kmlussier> There has been some talk among the devs of possibly doing release notes for point releases. That's something I might like to consider doing if I have time for the 2.8 point releases.
14:06:24 <pinesol_green> [evergreen|Bill Erickson] 2.8 release notes creation and cleanup - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=eee6a71>
14:06:26 <kmlussier> yboston: No, I don't have documentation. Is this documentation for devs who are writing release note entries?
14:06:35 <kmlussier> Ha, nice timing berick
14:06:39 <yboston> no, for the documentation side
14:06:45 <yboston> in case you ever need a sub
14:07:07 <yboston> or help
14:07:14 <kmlussier> No, I don't have documentation because, as long as the devs do their release notes, I don't do much other than read them for clarity and add acknowledgements.
14:07:22 <kmlussier> I do go through the ChangeLog to make sure everything is there.
14:07:27 <yboston> OK
14:07:29 <kmlussier> I can add something to the wiki, though.
14:07:33 <yboston> I thought it was more involved
14:08:07 <yboston> if you have the time, even a high level overview could be helpful
14:08:08 <kmlussier> No, I think what the RM does is a little more involved.
14:08:18 <yboston> yes, I agree
14:08:33 <kmlussier> In terms of generating the Release Notes, that is.
14:08:49 <yboston> Robert did you want to mention anything?
14:08:57 <rsoulliere> I have a couple of items.
14:09:01 <yboston> go ahead
14:09:03 <rsoulliere> #topic Conversion Coordinator Report
14:09:09 <rsoulliere> #info Evergree Documentation for 2.8 is up and pulling for the rel_2_8 branch.
14:09:18 <rsoulliere> #link http://docs.evergreen-ils.org/2.8/
14:09:27 <kmlussier> rsoulliere++
14:09:30 <rsoulliere> #info I have updated the 2_8 repository to include the 2.8 release notes.
14:09:58 <yboston> rsoulliere++
14:09:59 <rsoulliere> #info I have also added the 2.8 database schema documentation.
14:10:08 <rsoulliere> #info Links have been added to the documentaiton menu page:
14:10:13 <rsoulliere> #link http://docs.evergreen-ils.org/
14:10:52 <rsoulliere> #questions any updates on the new doc servers?
14:11:31 <yboston> I think the web group met yesterday
14:11:49 <yboston> and they mentioned that they have an IP address and that thet need to still create the VM
14:12:03 <yboston> kmlussier: where you at the meeting yesterday?
14:12:19 <kmlussier> yes
14:12:35 <yboston> am I remembering correctly that you know of?
14:12:43 <kmlussier> Yes, that's what gmcharlt reported
14:13:01 <yboston> kmlussier: thanks
14:13:12 <yboston> I can follow up for next time to see what the progress is
14:13:26 <yboston> #action yboston will check in on DIG VM
14:13:54 <rsoulliere> OK, sounds good. That is all I had for today.
14:14:05 <yboston> thanks
14:14:16 <yboston> I will move on to past meetign action items
14:14:40 <yboston> #topic past meeting action items
14:14:47 <yboston> #info 1 ) yboston will reach out to krvmga for another copy of his docs to push to master
14:15:00 <yboston> I did not get a chance to do this, will defer for next time
14:15:22 <yboston> #info 2 ) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:15:43 <yboston> kmlussier: any updates ont his?
14:15:52 <kmlussier> I need to defer for next time. My plan is to create my own DIG day to work on my to-do list
14:16:02 <yboston> OK
14:16:28 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:17:05 <yboston> the next two items were assigned to remingtron; but I am not sure if he is here?
14:17:19 <yboston> will defer them for now
14:17:39 <yboston> #action remingtron will send out email to list about cahnging the file suffix in the docs repo to .asciidoc
14:17:46 <yboston> #action remingtron will send an email to the list to consider changing the AsciiDoc section header style
14:18:07 <yboston> the next item was for the whole group
14:18:12 <yboston> #info 5 ) all decide how to proceed with docs reorganization next meeting
14:18:30 <yboston> this might be a good topic of discussion at the conference
14:18:55 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:18:59 <remingtron> (sorry so late)
14:19:02 <yboston> hola
14:19:40 <remingtron> may I give a quick update on my two action items?
14:19:41 <yboston> not sure  if you have read what we have gone over so far
14:19:47 <yboston> go right ahead
14:21:05 <remingtron> I have not initiated either of those conversations yet. I still plan to do the first, but not the second (header style syntax) since consensus was to allow individual choice, and I have come to agree
14:21:18 <yboston> makes sense
14:21:59 <remingtron> that's all I wanted to say :)
14:22:20 <yboston> not sure how to cancel one for the defered actions with meetbot, but I on't think it is a big deal
14:22:25 <yboston> thank remingtron
14:23:15 <yboston> so right before remingtron joined us I had just brought up the topic of "5 ) all decide how to proceed with docs reorganization next meeting"
14:23:39 <yboston> I had also mentioned this might be a good topic for the upcoming conference
14:23:51 <yboston> any comments or questiosn about the re-org goal?
14:24:13 <kmlussier> #info remingtron will NOT send email to the list to consider changing AsciiDoc section header because the consensus was to allow individual choice.
14:24:17 <kmlussier> For the minutes. :)
14:24:35 <remingtron> kmlussier++
14:25:42 <yboston> we can also defer the topic of the re-org for next meeting, if that is what we want to do as group today
14:25:43 <remingtron> I created a wiki page with some re-org ideas here:
14:25:46 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:reorg_2014:audience_focused_layout
14:26:24 <kmlussier> It seems like the in-person meeting is a great opportunity to discuss something like a doc reorg.
14:26:31 <remingtron> I'd be glad for any input or reactions
14:26:52 <remingtron> and FYI, I'm not able to attend the conference this year
14:26:57 <yboston> we need to plan to have a laptop to stream the meeting for those that cannot make it
14:27:02 <remingtron> so I'll do my best to participate remotely
14:27:10 <remingtron> yboston: thanks!
14:27:18 <yboston> or a phone on speaker phone
14:27:21 <yboston> (de nada)
14:27:57 <yboston> remingtron: that links looks pretty good
14:28:05 <yboston> *link
14:28:22 <remingtron> all are welcome to edit and expand that wiki page
14:29:08 <yboston> should we stay ont his topic or move on?
14:29:45 <yboston> the other two major topics arae web clients and EG 2.8 new feature docs
14:30:04 <remingtron> I'm happy to move on
14:30:47 <yboston> good enough for me
14:31:12 <yboston> #topic Progress on documenting new features in Evergreen 2.8
14:31:23 <yboston> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:32:09 <kmlussier> I got about half-way through my assigned topics.
14:32:11 <yboston> we still have a few features that need documenting.
14:32:24 <yboston> I just realized I signed up for a second feature I need to document
14:32:50 <kmlussier> I decided to do a new section regarding all billing OU settings, so it became a bigger project than I originally intended.
14:32:59 <yboston> I see
14:33:13 <yboston> that is what happens when adding new features :)
14:33:30 <kmlussier> I also could document most of the items in the OPAC section, but I didn't want to sign up until I had finished my first two items. :)
14:33:52 <yboston> some of those OPAC ones could be really simple, and great for a beguiner
14:33:55 <kmlussier> Two of them are mine, so I feel a responsibility to document them.
14:34:09 <kmlussier> yboston: Yes, I agree. I was thinking they would be good for a beginner too.
14:34:27 <kmlussier> In some cases, it may just require checking to see if a screenshot needs to be replaced.
14:35:10 <yboston> worse case scenario, we can use this low hanging fruit to give to newcomers at the conference. Though I am sure we would rather be done with 2.8 beofre the conference
14:36:38 <yboston> also, thanks to I think remingtron for sending out reminders aout 2.8 new features ont he list
14:37:44 <yboston> #action all finish outstanding EG 2.8 features listed here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:38:06 <yboston> should we switch to talking about web client docs?
14:39:00 <remingtron> I have one comment
14:39:09 <remingtron> (sorry, not paying close enough attention today!)
14:39:25 <yboston> go ahead
14:40:25 <remingtron> I realized that any time we don't document a feature on a given version, it's hard to remember to go back and work on those.
14:40:34 <rjackson_isl> :q
14:41:16 <yboston> remingtron: I agree
14:41:18 <remingtron> I'd like to add a section at the bottom of the 2.8 docs needs wiki page called "From older versions" or such, which lists all outstanding docs features needing new docs
14:41:22 <remingtron> thoughts?
14:42:25 <yboston> I think it would be helpful
14:43:01 <kmlussier> sure, why not?
14:43:02 <yboston> though some of it would have to be moved over when we do the 2.9 page, though I don't think that is a problem
14:43:42 <remingtron> okay, I'll work on that for 2.8 at least
14:44:03 <yboston> should I make it an action item?
14:44:11 <remingtron> then DIG can use that list at the conference for any outstanding items
14:44:13 <remingtron> yboston: sure!
14:44:24 <yboston> good idea
14:45:37 <yboston> #action remingtron will add information of older outstanding doc needs to the 2.8 new feature doceumentation wiki page
14:46:27 <yboston> any more questions/comments on EG 2.8 docs?
14:47:08 <yboston> should we talk about the web client docs?
14:47:16 <remingtron> sure, onward
14:47:44 <yboston> thanks again to remingtron for sending out an email to remind folks to help reivew some web cleint ocs that were submitted
14:47:52 <yboston> we should make that an "all" action item
14:47:59 <yboston> for next meeting
14:48:30 <kmlussier> Yes, I was just thinking of those. You can give that action item to me if you want.
14:48:37 <kmlussier> And I promise I will follow through on that one. :)
14:48:45 <remingtron> yboston: I'd put a higher priority on 2.8 docs, and suggest we wait on web client docs
14:49:09 <yboston> remingtron: that makes sense;
14:49:36 <yboston> we will have plenty of web client docs to work on at the conference
14:49:46 <remingtron> but if kmlussier wants an action item, I will not stand in her way!
14:50:06 <kmlussier> I just want to review the ones we have.
14:50:19 <yboston> #action kmlussier will review submitted web client docs to be included in repository
14:51:18 <yboston> any other comments or questions on the topic of web client docs or anything else?
14:52:14 <remingtron> just the comment I added to the agenda
14:52:34 <remingtron> that we no longer need to wait before backporting web client docs to live docs versions
14:52:49 <remingtron> since ESI folks have published their remaining bugs on launchpad
14:52:55 <kmlussier> We're backporting to 2.8 then?
14:53:25 <remingtron> yes, for as much is included in 2.8, and then 2.9 as more comes outs, etc.
14:54:23 <remingtron> though some have already been backported to 2.8
14:55:43 <yboston> we are talking about doc commits?
14:56:00 <remingtron> yes
14:56:14 <yboston> but are we keeping the seperate web client docs sections?
14:56:38 <remingtron> yes, still a "preview" version of the docs until the web client is more official
14:56:49 <yboston> just makign sure
14:56:58 <remingtron> yboston: good clarification
14:57:06 <yboston> thank you
14:57:16 <yboston> we are almost at the hour mark
14:57:31 <yboston> any other commetns or questions before we wrap up?
14:57:37 <remingtron> not from me
14:58:25 <yboston> OK then, then I will wrap up
14:58:36 <yboston> thank you everyone for attending
14:58:57 <yboston> #endmeeting