#evergreen: Development Meeting, 23 April 2015

Meeting started by dbwells at 15:13:07 US/Eastern (full logs).

Meeting summary

    1. Agenda is http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-04-23 (dbwells, 15:13:39)

  1. Introductions (dbwells, 15:13:46)
    1. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:14:06)
    2. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:14:14)
    3. jeffdavis = Jeff Davis, Sitka (jeffdavis, 15:14:19)
    4. berick Bill Erickson (berick, 15:14:23)
    5. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:14:28)
    6. csharp = Chris Sharp, GPLS (csharp, 15:14:36)
    7. berick is with KCLS, y'all (csharp, 15:14:54)
    8. dbs = Dan Scott, Laurentian University (dbs, 15:15:08)
    9. jeff = Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:15:12)
    10. phasefx = Jason Etheridge, Equinox (phasefx, 15:15:16)
    11. bshum = Ben Shum, Bibliomation (bshum, 15:15:27)

  2. Action Items from Last Meeting (dbwells, 15:16:36)
    1. berick, gmcharlt, and eeevil will add a response to the chromium localhost ws bug (dbwells, 15:16:51)
    2. eeevil Mike Rylander, ESI (eeevil, 15:17:22)
    3. gmcharlt Galen Charlton, ESI (gmcharlt, 15:17:25)
    4. https://code.google.com/p/chromium/issues/detail?id=378566#c77 is the best summary. (jeff, 15:18:13)
    5. For the most part, we're in a "wait and see, remain aware, star the issue and keep our ears/eyes open" mode. (dbwells, 15:24:10)

  3. OpenSRF Release Update (dbwells, 15:25:25)
    1. gmcharlt will cut an OpenSRF release by the EG conference - or AT the conference, if it comes to it (gmcharlt, 15:26:29)

  4. Evergreen Release Updates (dbwells, 15:27:16)
    1. 2.8.0 was set loose upon the world (dbwells, 15:34:28)
    2. AGREED: 2.8.1 and other maintenance releases will be cut on Wednesday, April 29 (dbwells, 15:35:02)

  5. QA Discussion (dbwells, 15:35:49)
    1. gmcharlt's Cats of Doom: http://cat.evergreen-ils.org.meowbify.com/ (csharp, 15:52:48)
    2. ACTION: AllTheDevs will read and think about berick's QA page, and come to the conference ready to discuss and take action (dbwells, 15:53:41)

  6. berick proposes we vote on a set day / time for monthly meetings (dbwells, 15:54:57)
    1. ACTION: berick will set up a poll for a set meeting day/time for dev meetings (dbwells, 15:59:12)

  7. Release notes for point releases (kmlussier) (dbwells, 15:59:32)
  8. Web client: Keyboard shortcut issues (dbwells, 16:06:59)
    1. keyboard shortcuts are failing when an input form element is selected. Suspected cause is the angular wrapper to mousetrap. eeevil is asking for more eyes on the problem. (dbwells, 16:12:32)

  9. ACQ blanket orders proposal (dbwells, 16:17:00)
  10. Overdrive API (dbwells, 16:23:20)
    1. https://launchpad.net/overdrive-eg-opac (dbwells, 16:26:35)
    2. jeffdavis suggests that any potential testers file bugs at the link given above (dbwells, 16:29:44)
    3. ACTION: jeffdavis will pursue contacting OverDrive to ask about test credentials / a test environment (dbwells, 16:30:38)


Meeting ended at 16:33:36 US/Eastern (full logs).

Action items

  1. AllTheDevs will read and think about berick's QA page, and come to the conference ready to discuss and take action
  2. berick will set up a poll for a set meeting day/time for dev meetings
  3. jeffdavis will pursue contacting OverDrive to ask about test credentials / a test environment


Action items, by person

  1. berick
    1. AllTheDevs will read and think about berick's QA page, and come to the conference ready to discuss and take action
    2. berick will set up a poll for a set meeting day/time for dev meetings
  2. jeffdavis
    1. jeffdavis will pursue contacting OverDrive to ask about test credentials / a test environment


People present (lines said)

  1. dbwells (61)
  2. berick (51)
  3. jeff (42)
  4. kmlussier (29)
  5. eeevil (22)
  6. bshum (20)
  7. gmcharlt (19)
  8. jeffdavis (19)
  9. csharp (16)
  10. dbs (6)
  11. pinesol_green (5)
  12. phasefx (1)
  13. remingtron (1)
  14. jboyer-isl (1)


Generated by MeetBot 0.1.4.