15:07:37 <gmcharlt> #startmeeting Evergreen Development meeting, 3 June 2015
15:07:37 <pinesol_green> Meeting started Wed Jun  3 15:07:37 2015 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:37 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:07:37 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__3_june_2015'
15:07:41 <gmcharlt> #info Agenda is http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-06-03
15:07:46 <gmcharlt> #topic Introductions
15:07:51 <gmcharlt> #info Galen Charlton, ESI
15:08:09 <tsbere> #info Thomas Berezansky, MVLC
15:08:17 <StomproJ> #info Josh Stompro, LARL
15:08:19 <Dyrcona> #info Jason Stephenson, MVLC
15:08:30 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:08:42 <jeffdavis> #info jeffdavis = Jeff Davis, Sitka
15:08:45 <dbs> #info dbs = Dan Scott, Laurentian University
15:08:45 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:08:54 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:08:59 <ldw> #info ldw = Liam Whalen, Sitka
15:09:25 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:09:26 <kmlussier> Relying on Panera wireless is probably not the best way to stay connected to a meeting.
15:09:38 <Dyrcona> :)
15:09:43 <gmcharlt> tasty, though
15:09:58 <Dyrcona> Can't be worse than our wifi today. I plugged in.
15:11:07 <gmcharlt> ok, so moving on
15:11:14 <gmcharlt> #topic OpenSRF udpate
15:11:49 <gmcharlt> #info 2.4.1 will be released tomorrow, 4 June 2015; minor release containing a significant websockets fix, some doc improvements, and minor srfsh enhancements
15:11:57 <gmcharlt> questions?
15:12:19 <Dyrcona> What's the lp bug # for the websockets fix. I'd like to read about it.
15:12:28 <gmcharlt> Dyrcona: 1418613
15:12:36 <Dyrcona> Thanks.
15:13:04 <gmcharlt> anything else?
15:13:48 <jeff> gmcharlt: any desire for recent srfsh pullrequests to be merged before tomorrow, or would you prefer not?
15:14:22 <gmcharlt> jeff: I have such a desire, indeed, if you have time to look at them
15:14:46 <gmcharlt> but no big deal either way
15:14:54 <jeff> sounds good.
15:16:00 <gmcharlt> thanks!
15:16:01 <gmcharlt> moving on
15:16:09 <gmcharlt> #topic Evergreen update
15:16:12 <gmcharlt> Dyrcona: you have the follor
15:16:15 <gmcharlt> floor, even
15:16:37 <Dyrcona> Well, I am looking to gather up items for the 2.9 Road Map.
15:17:10 <Dyrcona> It looks like we might not have enough people here to really talk about it.
15:17:48 <gmcharlt> well, I can toss out a few items that ESI is hoping to get in
15:17:50 <kmlussier> Is it something we can add to a wiki page?
15:18:50 <Dyrcona> kmlussier: Yes, actually there are wiki pages for the previous releases.
15:19:07 <gmcharlt> specifically, the results of the cataloging sprint of the webstaff client, to wit - MARC editor, record buckets interface, Angular Z39.50 client, the MARC tag tables service, and an Angular holdings maintenance editor
15:19:10 * dbs has no solid plans
15:19:56 <gmcharlt> and depending on timing, at least some of Angular admin/config interfaces
15:19:58 <dbs> would like to address some of the authority linked data possibilities as outlined on the list a month or two ago but tuits
15:20:51 <Dyrcona> I mentioned some things in my plans/goals email: http://markmail.org/message/zm6hy45zqbhxqvoa
15:20:52 <kmlussier> MassLNC has an activity metric project on its way, but, since ESI is doing it, can't speak to whether it would be ready for 2.9.
15:21:32 * kmlussier would love to see the negative balances branch on that roadmap. :)
15:21:43 <Dyrcona> So, I'll start the new road map and link it from here: http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:21:48 <jeffdavis> At Sitka we've been working on pushing local changes upstream, so we have a bunch of pullrequests in LP targeted at 2.next. Not sure which of them are "big" enough to specify on a roadmap.
15:21:48 <jeff> Dyrcona++
15:22:39 <jeffdavis> bug 1353643 for example
15:22:39 <pinesol_green> Launchpad bug 1353643 in Evergreen "URI $9 displayes too many links in TPAC" (affected: 1, heat: 8) [Undecided,New] https://launchpad.net/bugs/1353643
15:23:31 <Dyrcona> Well, since it is a wiki, I don't have a problem with people adding whatever, as long as they don't have a problem with me or someone else removing it later. :)
15:23:37 <kmlussier> I think it's good to get any new features on that roadmap, even if they are small. Just to give people an idea of what they might see.
15:24:27 <jeffdavis> Ok, I'll add "put the bug on the roadmap" to our workflow for this stuff. Thanks!
15:24:38 * kmlussier would like to get bug 1422802 straightened out by release time.
15:24:38 <pinesol_green> Launchpad bug 1422802 in Evergreen "Parts need to be more visible on the place holds screen" (affected: 2, heat: 10) [Wishlist,New] https://launchpad.net/bugs/1422802 - Assigned to Kathy Lussier (klussier)
15:26:14 <Dyrcona> On a related note, is it too soon to create milestones in LP?
15:28:16 <gmcharlt> Dyrcona: for a 2.9-alpha or the like?
15:28:25 <Dyrcona> gmcharlt: Yes.
15:28:32 <Dyrcona> And a 2.9 series.
15:28:46 <gmcharlt> seems reasonable to do so to me
15:30:00 <Dyrcona> Ok. I can do that after the meeting.
15:31:43 <Dyrcona> #action Dyrcona to add series and milestone(s) for 2.9 in Launchpad.
15:31:52 <dbwells> I think it's better to not have a 2.9 series until it splits from master, but I can't recall why I think that.
15:32:17 <Dyrcona> hmm.
15:32:37 <berick> dbwells: because there's a default series (master, basically) which acts as the most recent series
15:32:55 <berick> if we create a 2.9, it creates extra, unnecessary work
15:33:03 <Dyrcona> Ok, then we'll wait.
15:33:16 <Dyrcona> At what point do we usually split? alpha?
15:33:30 <berick> +1 for 2.9-alpha, etc targets, though
15:34:15 <dbwells> Dyrcona: we've been not splitting until release.  i.e. 2.9 and master are one and the same until we actually branch in git.
15:34:20 <berick> Dyrcona: i'd say beta.  that's when we usually create the rel_x_y branch
15:34:44 <Dyrcona> OK. I should have remembered that. :)
15:34:58 <gmcharlt> hmm, looks like it's easy enough to move a milestone from one series to another
15:35:35 <gmcharlt> if we create a 2.9-alpha milestone now, that would mean that 2.next would be used for stuff meant for the post-2.9 future?
15:35:42 <berick> but, yeah, master and 2.9 will effectively be the same target until after 2.9.0 is cut (since we discourage feature dev during beta period)
15:36:25 <berick> gmcharlt: that's my understanding, yes.  (time to rename 2.next yet?)
15:37:30 <gmcharlt> 2.next => gallifrey
15:37:32 <Dyrcona> Ok, so I'll add the 2.9-alpha milestone and we can move it.
15:38:00 <dbwells> sounds good
15:40:20 <Dyrcona> I should probably get an action item for the road map, too, just to make it official.
15:40:55 <gmcharlt> indeed
15:41:39 <Dyrcona> Does it work if anyone does it, or does the person who started the meeting have to do it? (I tried adding one earlier.)
15:41:50 <gmcharlt> anybody can do it
15:43:58 <Dyrcona> #action Dyrcona to create 2.9 road map and add it to DokuWiki at http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap
15:44:37 <gmcharlt> any other questions for Dyrcona or discussions on the ramp-up to 2.9?
15:44:38 <kmlussier> Dyrcona++
15:46:36 <gmcharlt> ok, moving on
15:46:44 <gmcharlt> #topic Updates and new business
15:47:28 <gmcharlt> #info QA proposal - http://libmail.georgialibraries.org/pipermail/open-ils-dev/2015-May/009840.html
15:47:51 <gmcharlt> this came out of the EG conference and got a bit of attention, but just a bit
15:48:12 <gmcharlt> so just bringing it up now in case folks have any questions
15:48:32 <dbs> I'm in favour of cats.
15:49:21 <Dyrcona> I'm +1 on the proposal.
15:49:31 <ldw> +1
15:49:50 <kmlussier> +1 on the proposal, but I'm more of a dog person
15:50:04 <StomproJ> +1
15:52:16 <Dyrcona> If it turns out to not work as is, we can always change it in the future.
15:52:42 <gmcharlt> FWIW, I've started putting in test plans in my OpenSRF patches
15:53:53 <Dyrcona> gmcharlt++ # I noticed and would have tried it out, but the meeting came up.
15:54:10 <gmcharlt> in other news
15:54:39 <gmcharlt> #action gmcharlt and eeevil to organize a webstaff client hacking day in July
15:55:00 <gmcharlt> anything else that folks want to bring up?
15:55:33 <Dyrcona> kmlussier: Anything about bug squashing days?
15:55:41 <kmlussier> Yes!
15:56:00 <kmlussier> #info Bug Squashing Day is Wednesday, June 10
15:56:12 <kmlussier> I hope you all can set aside some time to help out.
15:56:31 <kmlussier> I forgot to add it to the calendar. I'll do so now.
15:56:39 <terran> I have a few people from PINES that I think I'll be able to get to participate that haven't participated before.
15:56:49 <kmlussier> terran: That's awesome!
15:57:12 <kmlussier> If anyone needs a Sandbox, try to get the requests in by the end of the week so that we have a bit of time to get them ready.
15:57:52 <terran> I'd really appreciate it if someone would test this fix I posted for bug squashing day: https://bugs.launchpad.net/evergreen/+bug/1454871
15:57:52 <pinesol_green> Launchpad bug 1454871 in Evergreen "KPAC Hold Notifications - SMS" (affected: 1, heat: 6) [Undecided,New]
15:59:02 <bshum> terran: I'll keep my eye on that one, but probably not till next week.  Maybe that'll be something we can test during bug day.
15:59:09 <bshum> KPAC loves misery.
15:59:19 <bshum> Err, misery loves company.
15:59:44 <terran> bshum +1
16:00:12 <bshum> (also, regrets that I'm late and mostly missed the meeting)
16:00:15 <berick> @who loves misery?
16:00:15 <pinesol_green> mtcarlson loves misery.
16:00:24 <berick> heh
16:00:33 <gmcharlt> heh indeed
16:00:47 <gmcharlt> well, since we've descended into playing with the bot... I think it's a wrap! ;)
16:00:52 <gmcharlt> #endmeeting