15:02:41 <Dyrcona> #startmeeting 2015-07-01 Developers' Meeting
15:02:41 <pinesol_green> Meeting started Wed Jul  1 15:02:41 2015 US/Eastern.  The chair is Dyrcona. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:41 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:41 <pinesol_green> The meeting name has been set to '2015_07_01_developers__meeting'
15:02:51 <Dyrcona> #topic Introductions
15:03:05 <csharp> #info csharp = Chris Sharp, GPLS
15:03:06 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:03:06 <bshum> #info bshum = Ben Shum, Bibliomation
15:03:15 <yboston> #info yboston = Yamil Suarez: Berklee College of Music
15:03:18 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:03:18 <Stompro> #info Stompro = Josh Stompro, Lake Agassiz Regional Library, MN
15:03:18 <Dyrcona> So to introduce yourself, just type #info nick = Name, Affiliation
15:03:22 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:03:23 <miker> #info miker = Mike Rylander, ESI
15:03:30 <Dyrcona> #info Dyrcona = Jason Stephenson, MVLC
15:03:40 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:59 <jboyer-isl> #info jboyer-isl = Jason Boyer, Evergreen Indiana
15:04:44 <Dyrcona> Anyone else?
15:05:16 <Dyrcona> Ok, then moving on.
15:05:21 <Dyrcona> #topic Action Items from Last Meeting
15:05:46 <Dyrcona> Do we usually do topic or info for the items?
15:06:10 <bshum> I usuallly just info the items
15:06:19 <bshum> And re-action them if they get deferred
15:06:29 <Dyrcona> #info Dyrcona to add series and milestone(s) for 2.9 in Launchpad. Done.
15:06:38 <jeff> Dyrcona++
15:06:45 <csharp> Dyrcona++
15:06:55 <Dyrcona> The milestones and series are there, though we haven't used the series, yet.
15:07:25 <Dyrcona> #info Dyrcona to create 2.9 road map and add it to DokuWiki at http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap is also done.
15:07:49 <Dyrcona> #link http://evergreen-ils.org/dokuwiki/doku.php?id=faqs:evergreen_roadmap:2.9 is the Evergreen 2.9 roadmap.
15:08:09 <Dyrcona> #info gmcharlt and eeevil to organize a webstaff client hacking day in July
15:08:35 <Dyrcona> And I leave to gmcharlt or miker to update us on the status of this one.
15:09:26 <miker> organizing still underway. gmcharlt is unavailable today, though
15:09:46 <Dyrcona> Ok, so this is deferred to the next meeting.
15:09:48 <miker> we'll coordinate on the general and dev lists
15:10:10 <jeff> We might have a recap by the next meeting. :-)
15:10:31 <Dyrcona> True, we probably will.
15:10:57 <Dyrcona> But for the sake of form...
15:11:01 <Dyrcona> #action gmcharlt and eeevil to organize a webstaff client hacking day in July
15:11:59 <Dyrcona> So any missing action items?
15:12:14 <bshum> Looked accurate based on the last meeting.
15:12:32 <Dyrcona> Yes, kmlussier++ for moving them to today's agenda.
15:12:45 <Dyrcona> So, do we have any updates for OpenSRF?
15:12:47 <jeff> I'm still on the hook for posting some ideas regarding (at least considering) moving toward more merge commits.
15:12:47 <bshum> Though we may need to go back further and grab some of the in-person meeting ones forward next time.
15:12:57 <bshum> Yeah, i was thinking of the merge commit stuff
15:13:03 <bshum> And some RM reshuffling
15:13:16 <miker> a new opensrf was tagged 7 days ago
15:13:37 <Dyrcona> #topic OpenSRF
15:13:49 <Dyrcona> miker that was 2.4.1?
15:13:51 <bshum> #info OpenSRF 2.4.1 was tagged and released by gmcharlt last week
15:14:01 <bshum> The website was updated with the new stuff and blog release too
15:14:02 <Dyrcona> bshum: thanks.
15:14:05 <jeff> gmcharlt++ miker++
15:14:13 <bshum> Oh maybe not blog
15:14:14 <kmlussier> Should we add those as action items now so that we remember them for next month's meeting?
15:14:19 <Dyrcona> gmcharlt++ miker++
15:14:28 <miker> gmcharlt++
15:14:44 <Dyrcona> kmlussier: Let's add them under new business at the end, even thought they're old business?
15:14:55 <kmlussier> Dyrcona: Sounds good to me.
15:15:37 <bshum> I think the key thing is that there's a tiny important fix for websockets in OpenSRF 2.4.1
15:15:37 <Dyrcona> Ok, so anything else for OpenSRF?
15:15:42 <miker> sorry, boinc client making my machine too slow... suspending you, seti!
15:15:43 <bshum> That's important for web client users/testers
15:16:09 <miker> Dyrcona: nope, that's it for this month re opensrf. 'cept for bshum's note
15:16:31 <Dyrcona> Yep and thanks.
15:16:40 <Dyrcona> Next topic
15:16:47 <Dyrcona> #Evergreen
15:16:52 <Dyrcona> oops.
15:16:55 <Dyrcona> #topic Evergreen
15:16:58 <kmlussier> heh
15:17:13 <Dyrcona> This is my first time actually running a meeting, so if I'm going too fast, let me know. ;)
15:17:41 <Dyrcona> #info JavaScript circ and hold rules removed as of July 1, 2015.
15:17:44 <jeff> No complaints here.
15:17:49 <jeff> Dyrcona++ berick++
15:18:08 <jboyer-isl> Agreed, Dyrcona++ berick++ !
15:18:15 <Dyrcona> Thanks to berick for doing the work. I'm sure it was fun deleting all that code!
15:18:36 * miker shed a single tear for the backend js
15:19:15 <Dyrcona> I recall occasionally having problems getting SpiderMonkey to install, so I won't cry. :)
15:19:25 <jeff> berick++ also for bug 1312297 which I suspect is close to next. I'm reviewing/testing -- any comments on need for tests and/or release notes? Release notes seems like a "for certain".
15:19:25 <pinesol_green> Launchpad bug 1312297 in Evergreen "time to remove the old web-based selfcheck interface" (affected: 4, heat: 18) [Wishlist,Confirmed] https://launchpad.net/bugs/1312297
15:19:43 <Dyrcona> jeff: Yes, that's the next "topic"
15:19:59 <jeff> Ah. I would probably know that if I had the agenda up. Sorry!
15:20:10 <Dyrcona> I'm going to do this one as an info before making an action item.
15:20:14 <Dyrcona> #info RM will look into removing old self check interface.
15:20:42 <Dyrcona> So, I put that I, as RM, would do this in the info, but I really wanted to find out if anyone else wanted to look at it.
15:20:45 <yboston> http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-07-01
15:20:56 <jeff> I'm game, and can make time.
15:21:14 <Dyrcona> jeff: Cool, I was just about to ask if you already had looked at it some.
15:21:40 <Dyrcona> So, does the self check have to go before the remaining JSPAC code goes?
15:22:10 <jeff> After the fun of seek-and-destroy on jspac/craftsman at the conference, I was pulled back to reality for a bit but expect bug 1312309 to be ready for more eyes by mid next week.
15:22:10 <pinesol_green> Launchpad bug 1312309 in Evergreen "to remove last remnants of JSPAC" (affected: 3, heat: 14) [Wishlist,Confirmed] https://launchpad.net/bugs/1312309 - Assigned to Jeff Godin (jgodin)
15:22:28 <bshum> jeff++ # seek and destroy :)
15:22:48 <Dyrcona> Ok that segues into the next item on the agenda.
15:22:59 <jeff> Dyrcona: "have to" depends on how clean you want things, but i think selfcheck should go next, yes. It's also a smaller set of changes than jspac/craftsman.
15:23:00 <Dyrcona> jeff: Do you want action items for those?
15:23:07 <jeff> I will take them, yes.
15:23:17 <jeff> Anyone want to pre-volunteer to review?
15:23:34 <Dyrcona> #action jeff will look into removing old self check interface.
15:23:40 <Dyrcona> I'll review.
15:24:08 <Dyrcona> Though, I think some of it now is just review, isn't it?
15:24:10 <jeff> And, does anyone have input on tests/QA for these mostly web/js removals?
15:24:32 <jeff> selfcheck is review and release notes (which i can craft). i think berick's done the work already.
15:24:33 <Dyrcona> #action jeff will look at removing old JSPAC code.
15:24:55 <Dyrcona> yep. berick++ again.
15:25:43 <Dyrcona> As for tests, I'm not sure what one could except make sure basic functionality of other parts of Evergreen still works.
15:26:24 <Dyrcona> jeff++ for taking those two on.
15:26:59 <jeff> That's good enough for me. If something makes sense to test, I'll do it, but won't stress about the RM not accepting removal of jspac due to lack of tests. :-)
15:27:03 <Dyrcona> The old self check should be fairly simple, 'cause I don't think anything else really touches it.
15:27:43 <Dyrcona> heh
15:27:45 <jeff> I have at least one other question that I might hit the general/dev list with -- removing lots (and LOTS) of images that have been in the web dir for a while that have only ever been used in "stock" by things like jspac/craftsman.
15:28:18 <Dyrcona> Right. Someone might actually have template modifications to use them, but I doubt it.
15:28:31 <jeff> Do we consider the possibility that sites have used those images ("because they were there") in local templates/etc worth not actually removing them from the repo? My thought is that they should go.
15:28:57 <bshum> If their original use was for jspac, etc. I think it's good to kill those off
15:29:10 <bshum> If someone needs the originals, there's still code history to draw from and earlier packages.
15:29:20 <miker> and we're note removing them from the internet :)
15:29:20 <bshum> It's not like they're actually gone forever..
15:29:27 <jboyer-isl> If they're not referenced in the current skin they can go, it's not as if it's difficult for those using them locally to pull a copy out of git. :)
15:29:31 <jboyer-isl> Too slow!
15:29:40 <bshum> And technically, with upgrades, the file will still live on locally
15:29:43 <berick> and they'll still be in the installed web dir
15:29:46 <Dyrcona> And, they'll be warned, if they read release notes.
15:29:46 <bshum> Unless we add something to actually remove them
15:30:03 <Dyrcona> We don't usually do that.
15:30:25 <jeff> My thought on THAT was to address the removal in the release notes.
15:30:55 <Dyrcona> Still good to ask ahead of time as a sort of pre-warning. :)
15:31:09 <miker> +1 to release notes
15:31:18 <yboston> Would a quick warning email to the general list complement the mention in the release notes?
15:31:33 <jeff> "hey, this still is no longer installed -- if you have it kicking around and you don't want to do a clean install of your web dir you might want to clean things up"
15:31:34 <kmlussier> +1 to removing them and addressing it through release notes
15:32:33 <jeff> yboston: possibly a heads-up after the work is tested and merged and the release notes are crafted. less uncertainty that way.
15:32:43 <jeff> yboston++ i'll make a mental note
15:32:46 <Dyrcona> #agreed release notes are a good idea.
15:32:49 <Dyrcona> :)
15:32:54 <bshum> Dyrcona++ :)
15:33:32 <Dyrcona> Anything else on remove jspac and/or the old self check interface?
15:34:27 <jeff> yes.
15:35:16 <jeff> There are other things (like "old bbags interface" and "dtree.js" and "found a few sprintf implementations that we no longer use") that can be pruned. As RM, do you have preference for those having bugs for each logical "thing" ripped out?
15:36:05 <Dyrcona> I think the old bbags interface should possibly be its own bug.
15:36:52 <Dyrcona> The others could maybe be all together on a single, remove old stuff bug, unless they were mostly just around for jspac, in which case I'd say lump them into the jspac bug.
15:37:11 <jeff> I don't want to go crazy scrubbing unused code, but there have been a few obvious targets that I've come across. Okay, I'll do some smaller bugs (which probably will have fewer/no dependencies / pre-reqs for merging).
15:37:40 <bshum> jeff++
15:37:42 <Dyrcona> OK with me.
15:38:01 <jeff> Ah. Nevermind, scratch that, I'll consider a medium "remove some small things" bug unless I come across other things. I'll try and use my judgement based on the guidance here. :-)
15:39:34 <Dyrcona> Anything else before we move on?
15:39:34 <jeff> Does anyone think we should give consideration to removing old unused strings? There are likely to be many with the removal of so many old UIs.
15:39:37 <jboyer-isl> jeff++ # code we don't have doesn't have bugs. :)
15:40:15 <bshum> jeff: that's a good thought
15:40:18 <jeff> Worth it? Not worth it? Something for another time?
15:40:32 * bshum wonders if less strings means faster i18n dance
15:40:39 <Dyrcona> Definitely worth it, if it isn't too time consuming.
15:40:40 <bshum> Even slightly faster is faster....
15:40:47 <jboyer-isl> Cleaning up old strings may be a good idea since there are so many things being cleaned up. I don't think it matters if it's 3-4, but for the remainder of JSPAC and all of the old selfcheck does make it worth looking into.
15:41:21 <jeff> Got it.
15:41:31 <jeff> Okay. I don't have anything else on that. :-)
15:41:48 <jboyer-isl> bshum: I don't imagine it would be noticeable in use, but if we have something like 20% fewer strings that makes it easier for devs to get around (and keeps new translations small)
15:41:56 <yboston> jeff: I want to  learn more about i18n, I could help with deleting osme strings
15:42:23 <kmlussier> jeff++
15:42:36 <jeff> yboston++ thanks!
15:43:01 <yboston> jeff: lets talk about it later
15:43:18 <miker> jeff: heh ... just ran across this in a CVS (yes, CVS) log entry: 2007-01-18 14:42  miker * Open-ILS/xul/staff_client/server/cat/marcedit.xul: removing unused sprintf lib
15:43:40 <miker> apparently we've churned through a few of those...
15:43:56 <Dyrcona> Ok. moving on.
15:43:59 <jeff> miker: i think i found at least three sprintf javascript implementations, one of which was added, then the code using it was removed, then LATER code re-used the sprintf implementation that had been left behind... :-)
15:44:12 <Dyrcona> #info Query dbwells on the conditional negative balances work.
15:44:36 <Dyrcona> So my questions for dbwells are do you think this could get polished up before the alpha?
15:44:46 <Dyrcona> And, would you like some help writing tests, etc.?
15:45:11 <kmlussier> I have put a deadline in my calendar to complete another round of negative balance testing by Wednesday. It's looking promising at the moment.
15:45:15 <jeff> I'd like to volunteer to assist where possible/useful on testing and/or tests.
15:45:45 <Dyrcona> I am also volunteering to help with whatever needs done at this point.
15:46:05 <Dyrcona> I started the mess and feel the least I can do is help to get it done.
15:46:06 <dbwells> the bug is pretty much as stated on the branch, i.e. ready for eyeballs, and still needing tests.  We've done the work of getting at least one interesting test to load, so we're still hoping the others will flow from that more easily, but haven't gotten back to it yet.
15:46:30 <dbwells> When is the alpha, again?
15:46:50 <Dyrcona> The alpha is the 29th of July, so exactly 4 weeks from today.
15:47:09 <Dyrcona> We've traditionally accepted new features up to the beta cut-off.
15:47:23 <dbwells> I think it can make alpha, barring some major setback.
15:48:06 <jeff> Dyrcona++ dbwells++ kmlussier++
15:48:09 <kmlussier> I think it would be nice to shoot for alpha. If the timeline slips a bit, then, it isn't pushed off to another release. And it gives more people to play with scenarios that may have been missed in earlier testing.
15:48:16 <dbwells> I'll plan to push whatever tests I have on next Friday (even if it's still just the one), then others can more easily add to it at that point.
15:48:37 <Dyrcona> dbwells++ kmlussier++
15:48:55 <Dyrcona> For the logs, the beta is planned for August 19.
15:48:58 <dbwells> Of course, if people just want to jump in with tests from scratch, I don't oppose that in any way, either :)
15:49:05 <kmlussier> When it gets in, we can have a nice IRC party where I will gladly hand out desserts to everyone involved in the project. Virtual desserts, of course.
15:49:19 <bshum> Hehe
15:49:22 <kmlussier> See how I said 'when' and not 'if.' :)
15:50:05 <Dyrcona> I think an action or info should come out of this.
15:50:32 <dbwells> I'll action myself for the test stuff.
15:50:34 <kmlussier> Dyrcona: You can give me an action item to finish my testing by next Wednesday.
15:50:44 <kmlussier> Or I guess I can action myself.
15:50:49 <Dyrcona> Ok.
15:50:59 <Dyrcona> you can add the actions yourselves.
15:51:14 <dbwells> #action dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10
15:51:21 <kmlussier> #action kmlussier to complete her testing on the negative balance branch by July 8
15:51:38 * kmlussier works best under deadline pressure.
15:51:53 <Dyrcona> deadlines++
15:52:18 <Dyrcona> #action Dyrcona will follow up with negative balance branch after July 10.
15:52:26 * dbwells works only under deadline pressure ;)
15:53:06 <Dyrcona> Ok. Anything else for negative balances?
15:53:32 <dbwells> nothing here
15:53:33 <Dyrcona> Other than this is going to be huge for so many users.
15:54:01 <kmlussier> negative-balances--
15:54:08 <kmlussier> no-more-negative-balances++
15:54:10 <kmlussier> That's it from me.
15:54:13 <Dyrcona> OK.
15:54:22 <Dyrcona> #topic New and Old Business
15:54:47 <Dyrcona> So earlier we said there were some action items from the face to face meeting that needed to be added.
15:55:07 <Dyrcona> Now's the time to do that.
15:56:13 <yboston> At the meeting we spoke about a test day, and Liam started the planning on that
15:56:34 <yboston> he sent out one email about it
15:56:59 <jeff> #action jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list
15:58:06 <Dyrcona> yboston: I feel iffy giving a vague action to someone who isn't here.
15:58:11 <jeff> with Liam not here to take an action, perhaps an info pointing out that planning is under way?
15:58:25 <yboston> I can follow up with him, I already followed up with him last week
15:58:52 <jeff> now THAT sounds like an action item with your name on it. ;-)
15:59:11 <Dyrcona> #action yboston to followup with ldw about a testing day.
15:59:15 <Dyrcona> :)
15:59:39 <Dyrcona> should probably be a space between follow and up, but English....
15:59:46 <miker> jeff: do your ideas boil down to merg-- ? ;)
16:00:21 * yboston runs off to another meeting
16:00:42 <Dyrcona> So, we're right on the hour, is there any additional new business?
16:01:00 <kmlussier> Was there something about the release schedule too? And maybe selecting an RM earlier?
16:01:27 <kmlussier> I don't recall whose action item it was, but I thought there was some discussion on it.
16:01:33 <bshum> Yeah I think that's mine.
16:02:00 <bshum> #action bshum to work with berick and others on crafting more information about release maintaining and schedules
16:02:26 <jeff> miker: i'm back on the fence, mostly. :-)
16:02:47 <bshum> That's all I can think of today.
16:03:03 <Dyrcona> Ok. Anything else?
16:04:47 <Dyrcona> Hearing nothing else. I'll call the meeting adjourned.
16:04:54 <Dyrcona> #endmeeting