14:00:31 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:31 <pinesol_green> Meeting started Thu Jul  2 14:00:31 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:31 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:01:00 <yboston> The agenda can be found here http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20150702-agenda
14:01:10 <yboston> #topic Introductions
14:01:10 <yboston> Please feel free to start introducing yourselves...
14:01:17 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
14:01:24 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:02:06 <Stompro> #info Stompro = Josh Stompro, LARL
14:02:16 <yboston> they day beofre a long weekend in the summer, might not be the best time to hold a meeting :)
14:02:34 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:03:41 <alynn26> #info alynn26 is Lynn Floyd, Anderson County Library, SCLENDS
14:04:02 <yboston> OK, folks lets start
14:04:16 <yboston> #topic Updates from Content Coordinators
14:04:23 <yboston> if there is anything to report
14:04:27 <yboston> ?
14:04:55 <kmlussier> I don't think I have anything
14:05:00 <yboston> OK, we can move on
14:05:20 <yboston> #topic last meeting's action items
14:05:38 <yboston> #info 1) yboston will reach out to krvmga for another copy of his docs to push to master
14:06:04 <yboston> I have not spoken to krvmga about it again
14:06:04 <kmlussier> Did I see that Stompro was going to work on those docs now?
14:06:09 <yboston> that is what I thought?
14:06:38 <Stompro> I was going to work on the older added content by ID items.
14:06:42 <yboston> I thought krvmga had a work in progress
14:06:56 <yboston> in case you wanted to ask krvmga for it to help you
14:06:59 <yboston> but I could be wrong
14:07:38 <remingtron> looks like krvmga still has the Content Cafe item from 2.7, according to the 2.8 needs page
14:07:45 <kmlussier> I know he started working on them at the DIG hackaway, but I don't know how far he got.
14:07:56 <yboston> Stompro: do you want to follow up with him?
14:08:07 <Stompro> Sure, I'll do that.
14:08:40 <remingtron> Stompro: if krvmga just wants to give you a link to his in-progress stuff, you could post it to the wiki page
14:08:46 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:09:21 <yboston> what should the action item be? not sure of what the content target is?
14:09:40 <remingtron> the 2.7 item is called "Content Cafe Added Content Update "
14:10:12 <yboston> for example, shoudl it be… #action Stompro will work on the older added content by ID items and get work in progress from jim?
14:11:01 <remingtron> yboston: the added content item already has Stompro's name by it, so I'd leave that off for now
14:11:14 <remingtron> just "follow up with jim" seems fine to me
14:11:58 <yboston> so just … #action Stompro will work on  "Content Cafe Added Content Update "?
14:12:19 <yboston> (for some reason I have always been confused by this bit of docuentation)
14:12:26 <yboston> *documentation
14:13:15 <Stompro> Caution, contents may be added content.
14:14:04 <yboston> again, I am still confused, and continue to be confused by this particualr bit on documentation.
14:14:22 <yboston> can someone suggest what the action item text is for this?
14:14:50 <yboston> thankfully this does not happen often, but it always happens with this bit
14:15:14 <kmlussier> Stompro will follow up with krvmga on Added Content documentation?
14:15:30 <Stompro> I'm currently not assigned to look at the content cafe stuff, just the added content by ID... kmlussier, looks good to me.
14:15:37 <yboston> kmlussier: thanks
14:15:46 <yboston> #action Stompro will follow up with krvmga on Added Content documentation
14:16:03 <alynn26> that works
14:16:17 <yboston> my apologies
14:16:41 <yboston> moving on, unless there is soemthign else to be said about this ?
14:16:50 <remingtron> go ahead
14:17:02 <yboston> #info 2) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:17:15 <yboston> no worries if there is no update
14:17:34 <kmlussier> I got as far as pulling out the marc stream importer notes that I'm planning to use for the documentation. So that's progress.
14:17:38 <kmlussier> But, otherwise, nothing to report.
14:17:52 <yboston> cool
14:18:01 <kmlussier> Now that ALA is over, I'm hoping to have some time to finish these things up. If I don't by next meeting, I'll release the tasks to somebody else.
14:18:19 <yboston> OK
14:18:28 <yboston> #info 2) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:18:45 <kmlussier> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:18:48 <yboston> thanks
14:19:12 <yboston> #info 3) remingtron will send out email to list about changing the file suffix in the docs repo to .asciidoc
14:19:24 <remingtron> done
14:19:26 <yboston> :)
14:19:40 <remingtron> people seem to support the idea, no major concerns that I've heard
14:19:41 <yboston> now we need volunteers to try out the change
14:19:48 <kmlussier> remingtron++ #Completing your action items!
14:19:55 <yboston> remingtron++
14:20:07 <remingtron> kmlussier: thanks, it was easier than documentation :)
14:20:08 <alynn26> Remingtron++
14:20:38 <remingtron> should we consider it "decided"? or do we need to discuss it at a larger DIG meeting?
14:20:57 <yboston> good question
14:21:10 <remingtron> I think we can call it decided, just wanted to ask all of you for any last concerns
14:21:11 <Stompro> I would consider it decided, charge forward.
14:21:14 <yboston> I think it is decided, just because the list has a larger audience
14:21:18 <yboston> than most meetings
14:21:20 <alynn26> as someone who uses adoc extension, and from the discussion I say decided
14:21:31 <yboston> we could send out a final email to say that this is the last call to back out
14:21:31 <kmlussier> Yes, if somebody had a concern, they should have raised it on the list.
14:21:51 <remingtron> #agreed We will move forward with changing docs files to use the .adoc extension
14:22:05 <alynn26> #agree
14:22:15 * kmlussier will do her best to break old habits.
14:22:15 <yboston> I would still send another reply to that thread to anounce the change or send in a new email
14:22:31 <remingtron> yboston: sure, give me that action item
14:22:48 <yboston> also, I would have liked to get feedback from Robert about testing out the change
14:22:58 <remingtron> yboston: and another for phase 2: testing
14:22:58 <yboston> remingtron: I will give you an action item
14:23:11 <yboston> OK
14:23:39 <yboston> #action remingtron will send out an email to the Dig list anouncing that a new file extension will be used for AsciiDoc files
14:24:27 <remingtron> #info The dev docs already include one .adoc file that I added
14:24:28 <yboston> did you want to right out the testing action item or feed me your suggestions?
14:24:30 <remingtron> #link http://docs.evergreen-ils.org/dev/_library_settings_editor.html
14:24:41 <remingtron> yboston: sure...
14:24:49 <yboston> sorry, that should have said "write out"
14:25:18 <yboston> remingtron: also,w ould you liek help in the testing? should we have a seconf action item to reach out to robert?
14:25:20 <remingtron> remingtron will begin testing use of and conversion to the .adoc extension
14:25:36 <remingtron> I'll email Robert
14:25:37 <yboston> #action remingtron will begin testing use of and conversion to the .adoc extension
14:25:45 <remingtron> as part of my testing phase
14:26:02 <remingtron> and I'll email the list if I want help, or when phase 3 is ready
14:26:13 <remingtron> (which is probably the big switch)
14:26:31 <remingtron> I won't do anything crazy without warning :)
14:26:56 <yboston> anything else on this topic?
14:28:01 <yboston> OK, moving on
14:28:37 <yboston> #info 4) all update the 2.8 outstanding features list; remove names of those that cannot continue working on assignment; post completed or incomplete files
14:28:59 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:29:08 <yboston> remingtron++ for updating the wiki after ESI made their updates
14:29:53 <remingtron> #info The 2.8 docs wiki page includes sections of remaining needs from past versions
14:30:01 <yboston> remingtron++
14:30:24 <yboston> Should we try to pick up the items that are still pending?
14:30:37 <yboston> among us here? and / or ask on the list?
14:30:53 <remingtron> yboston: what do you mean?
14:31:04 <alynn26> I would ask on the list to see if anyone has any of it documented already.
14:31:06 <yboston> sorry, I mean of version 2.8?
14:31:11 <remingtron> reassign things that are assigned by have stalled?
14:31:24 <yboston> remingtron: that too, reassigned or prod people
14:32:01 <remingtron> it would be great to have a progress report from everyone about their 2.8 assignments
14:32:06 <alynn26> I would prod people
14:32:27 <remingtron> include saying "there's no shame in sharing half-finished files"
14:32:30 <kmlussier> I have a git branch with a work-in-progress on my two pieces. I'll take a look at it to see how much work is left to be done.
14:32:38 <remingtron> "or removing your name"
14:32:44 <yboston> should we email people directly or sned a general email to the list
14:32:45 <yboston> ?
14:32:54 <remingtron> email the list sounds good
14:33:06 <alynn26> I would say both
14:33:09 <kmlussier> Possibly followed up with direct emails?
14:33:17 <remingtron> there you go, both it is!
14:33:30 <remingtron> who wants to do it?
14:33:42 <kmlussier> I can do that
14:33:45 <yboston> remingtron: good point on the half finsished files, that is always good
14:33:57 <alynn26> kmlussier++
14:34:11 <yboston> kmlussier++
14:35:00 <yboston> action draft: kmlussier will send out an email to DIG list to request updates on unfinsished 2.8 new features?
14:35:17 <kmlussier> yboston: Looks good to me
14:35:23 <remingtron> yboston: you're a pro
14:35:35 <remingtron> at drafting action items
14:35:35 <yboston> except when it comes to that added contant thing
14:35:46 <yboston> *content
14:35:50 <remingtron> yboston: well, that's a confusing topic
14:35:57 <yboston> #action kmlussier will send out an email to DIG list to request updates on unfinsished 2.8 new features
14:36:24 <yboston> #idea all will follow up with direct emails to request updates on unfinsished 2.8 new features or to ask for works in progress
14:36:53 <yboston> so far so good?
14:37:07 <remingtron> hm, all will do that?
14:37:20 <remingtron> better if only one person does?
14:37:22 <kmlussier> Yeah, I can take that one too.
14:37:31 <kmlussier> Otherwise, we might have three people contacting one person.
14:37:33 <alynn26> kmlussier++
14:38:00 <yboston> I did not want to assume, so I used "idea"
14:38:04 <yboston> kmlussier++
14:38:13 <remingtron> yboston: clever use of "idea"
14:38:20 <kmlussier> Does more work need to be done on the discoverability enhancements?
14:38:39 <kmlussier> I see a lot of subtopics with no names.
14:38:43 <yboston> #action kmlussier will follow up with direct emails to request updates on unfinsished 2.8 new features or to ask for works in progress
14:39:05 <yboston> yes, that topic is a bit of a rabbit hole
14:39:15 <remingtron> kmlussier: right, I think most are not documented yet
14:39:20 <yboston> I spoke to Stompro and remingtron about it
14:39:34 <remingtron> the release notes are pretty long, could just drop those in somewhere?
14:39:42 <remingtron> yboston: what did we decide?
14:39:51 <yboston> one of them suggested that we shoudl start a new section on semantic web to collect a lot of those new features
14:40:00 <kmlussier> I would be in favor of moving the release notes into hte main docs.
14:40:15 <yboston> in one place, since that might make more sense than trying to shoe-horn them in other palces
14:40:50 <yboston> kmlussier++ what an awsome AND simple idea
14:41:01 <alynn26> Release notes++
14:41:16 <kmlussier> yboston: It really was remingtron's idea, so...
14:41:19 <kmlussier> remingtron++
14:41:29 <remingtron> kmlussier: thanks for the credit :)
14:41:34 <yboston> remingtron++ kmlussier++
14:42:14 <yboston> I can move the content over to a new section, though I may turn to the list for feedback
14:42:16 <remingtron> Stompro: where did you put your Opensearch docs?
14:42:46 <Stompro> In the current opensearch section, it was just a matter of changing a screenshot and adding one sentence.
14:43:13 <Stompro> http://docs.evergreen-ils.org/2.8/_adding_opensearch_to_firefox_browser.html
14:44:13 <remingtron> yboston: go ahead, whoever does the work gets to decide how it's done :)
14:44:36 <remingtron> Stompro: thanks for the link
14:44:44 <yboston> remingtron: I absolutely agree witht hat, but I welcome the feedback
14:45:34 <yboston> #action yboston will move the undocumented content of the 2.8 new feature "TPAC Discoverability Enhancements" to its own section in the docs
14:45:52 <yboston> abything else on this topic?
14:46:00 <remingtron> nope
14:46:01 <yboston> I am excited how close we are to being done with 2.8
14:46:10 <remingtron> yboston: me too!
14:46:13 <kmlussier> And then 2.9 is right around the corner. :)
14:46:20 <remingtron> dig hackfest helped a lot
14:46:20 <yboston> :)
14:46:26 <alynn26> :P
14:46:36 <yboston> #info 6) remingtron will contact Robert Sooullier about updating the docs sites to match the footer of the regular EG site; also to add the CC icon
14:46:49 <remingtron> I forgot all about that!
14:47:00 <remingtron> we decided that it's fine to move forward with the footer change, right?
14:47:14 <yboston> I thought so
14:47:24 <remingtron> great, I'll send that memo off to Robert
14:47:40 <yboston> cool
14:48:02 <yboston> #action remingtron will contact Robert Soullier about updating the docs sites to match the footer of the regular EG site; also to add the CC icon
14:48:22 <yboston> may I move on? (I have a meeting at 3)
14:48:30 <remingtron> go ahead
14:48:33 <yboston> #info 7) kmlussier will add an agenda item tot he web team about updating the doc site footers to match the main site footer, as well as include the CC icon
14:48:45 <kmlussier> We haven't had a web team meeting
14:48:55 <yboston> OK
14:49:05 <yboston> #action kmlussier will add an agenda item tot he web team about updating the doc site footers to match the main site footer, as well as include the CC icon
14:49:46 <yboston> OK, I have 8 more minutes to be at this meeting
14:49:58 <yboston> any other topics we want to cover?
14:50:30 <remingtron> only if people want to volunteer for another 2.8 todo item
14:50:32 <yboston> for example: web docs; re-org?
14:51:18 <remingtron> wait...it looks like all of the 2.8 items are assigned!
14:51:50 <remingtron> anyway, that's all from me for now
14:52:45 <yboston> one quick topic I wanted to bring up was something Stompro broguht up to me
14:53:09 <yboston> He asked me why there was no makefile target for building the docs to HTML
14:53:35 <yboston> we are quite far away from doing that, but I look forward to having that available
14:54:05 <Stompro> I just sent robert an email asking for an updated dump of the build process so I can take a look at it.
14:54:16 <yboston> cool
14:54:28 <yboston> I have not heard back from gmcharlt
14:54:35 <gmcharlt> hmm?
14:54:37 <yboston> about the status of the new DIG VM
14:54:52 <gmcharlt> ah, right - y'all will have it by Tuesday
14:54:56 <yboston> that would give us expereince on how to build the docs
14:55:01 <remingtron> gmcharlt: hurray!
14:55:09 <yboston> gmcharlt++
14:55:14 <Stompro> Vacation reply from Rober says he is out until after July 20th BTW.
14:55:22 <yboston> good to know
14:55:25 <yboston> Stompro++
14:55:28 <remingtron> Stompro: thanks for letting us know
14:55:34 <alynn26> Thanks
14:55:54 <yboston> I hope I learn how to build th docs y myself in HTML & PDF from the experience of helping create the new DIG VM
14:56:17 <yboston> so I need to run off to another meeting
14:56:22 <yboston> any last thoughts/comments?
14:56:28 <remingtron> yboston: nope, thanks for leading!
14:56:31 <remingtron> yboston++
14:56:35 <Stompro> yboston++
14:56:42 <alynn26> ybostom++
14:56:43 <yboston> thank you all
14:56:48 <yboston> #endmeeting