13:01:59 <gmcharlt> #startmeeting Evergreen Web Team meeting, 22 July 2015
13:01:59 <pinesol_green> Meeting started Wed Jul 22 13:01:59 2015 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:59 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:59 <pinesol_green> The meeting name has been set to 'evergreen_web_team_meeting__22_july_2015'
13:02:12 <gmcharlt> #info Agenda at http://wiki.evergreen-ils.org/doku.php?id=webteam:meetings:agenda:2015-07-22
13:02:17 <gmcharlt> #topic Introductins
13:02:22 <gmcharlt> #info Galen Charlton, ESI
13:02:35 <kmlussier> #info Kathy Lussier, MassLNC
13:03:06 <gmcharlt> RoganH has indicated that he may not be able to attend, but is available for task assignments
13:03:12 <gmcharlt> and ditto for bshum
13:03:28 <kmlussier> gmcharlt: Let's assign RoganH with all the tasks.
13:03:44 * rfrasur chuckles
13:03:44 <gmcharlt> inevitable joke is inevitable ;)
13:04:35 <gmcharlt> #topic Status updates / past action items
13:04:47 <gmcharlt> #action At long last, the DIG test VM will be up later this afternoon
13:04:54 <kmlussier> Woo hoo!
13:04:56 <gmcharlt> er
13:04:57 <kmlussier> gmcharlt++
13:05:05 <gmcharlt> #info At long last, the DIG test VM will be up later this afternoon
13:05:24 <gmcharlt> #info A copy of the webserver VM has been created, http://test-www.evergreen-ils.org/
13:05:35 <gmcharlt> it's been used to test an operating system upgrade to Debian Jessie
13:05:51 <gmcharlt> as well as a software upgrade for the Piwik web analystics package
13:06:27 <gmcharlt> bshum is still poking at Piwik, but we should be able to schedule a production OS upgrade for the main webserver, lupin, soon
13:07:00 <gmcharlt> so, one of the incidental things from that: the Piwik data for the past few years is consuming a fair amount of disk space on lupin
13:07:20 <gmcharlt> and bshum and I have been discussing pruning it down to just keeping the past year of analytics
13:08:13 <gmcharlt> on the basis that it will save disk space, that the web statistics data have not been really used, and if they were looked at, there's little reason to keep more than a year of them
13:08:31 <gmcharlt> any thoughts about that before we commit to that position?
13:08:54 <kmlussier> A year of stats seems reasonable to me.
13:08:59 <phasefx> sounds good to me
13:09:57 <rfrasur> Is someone tracking the web stats offline?
13:10:26 <gmcharlt> rfrasur: I'm not sure what you mean by that
13:11:42 <rfrasur> eg. I track the stats for our library website in a spreadsheet monthly, so I don't care if it's not stored past a certain point online and still have access to that info in the future.
13:11:56 <gmcharlt> ah, OK
13:12:17 <rfrasur> I don't know if it matters at all at this point, but I also don't know if it will matter in the future, and it'd be tragic if it did and that info was gone.
13:12:29 <gmcharlt> and no, I don't think anybody's doing that at present
13:13:11 <gmcharlt> and personally, I'm meh on keeping such data indefinitely anyway
13:13:15 <kmlussier> gmcharlt: Remind me. How do we access the stats?
13:13:25 <gmcharlt> (I may have to turn in my librarian card for saying that ;) )
13:13:32 <gmcharlt> kmlussier: webstats.evergreen-ils.org
13:14:00 <rfrasur> lol, gmcharlt, I don't think you have to turn in your librarian card, and I tend to be a packrat when it comes to that kinda thing.  So take my thoughts with that grain of salt.
13:16:20 <kmlussier> Well, I guess the question is whether there's an easy way to keep those stats offline. If somebody has to remember to log in every month to download stats, I'm not sure it would be worth it.
13:17:36 <gmcharlt> if somebody's keen to scrape visit counts, they're free to do so
13:17:49 <gmcharlt> personally identifying information... not so much
13:18:42 * kmlussier isn't keen
13:18:47 <rfrasur> The stats I keep are just visits, unique visitors and pages viewed.  Enough to show trends.
13:19:32 <rfrasur> fwiw...which is probably not much.
13:20:43 <gmcharlt> here's what I think I'll do -- I'll announce in channel once we've set a date for purging old data
13:20:53 <gmcharlt> and if somebody feels inclined to grab summaries, they can do so
13:21:17 <kmlussier> +1
13:21:21 <rfrasur> +1
13:21:40 <gmcharlt> ok, moving on
13:21:48 <gmcharlt> #topic Creative Commons License in web site footer
13:22:57 <kmlussier> This topic came from a discussion at the DIG meeting.
13:23:07 <kmlussier> And I think there were really 2 questions.
13:23:32 <kmlussier> 1. Should the footer used on the doc site match the one on the main evergreen-ils site? As of now, it doesn't.
13:24:19 <kmlussier> 2. Also, we wanted to put the Creative Commons license in the footer of the doc site. But I had raised the question of whether it would be worthwhile to use it on the main evergreen-ils site.
13:24:43 <kmlussier> I also don't know if we really have the authority to add that license to the main site, since the content came from multiple people.
13:24:50 <gmcharlt> short answer: nope
13:25:24 <kmlussier> To both questions?
13:25:26 <rfrasur> lol, gmcharlt: nope to all of it?
13:25:36 <gmcharlt> nope to the second
13:26:08 <gmcharlt> the wiki *is* CC-BY-SA, but that was settled a few years back, as I recall, and when you add content to the wiki, it explicitly tells you that you're licensing any content you add
13:27:11 <kmlussier> That's true. But in the case of the WordPress site, there is no similar statement.
13:27:24 <gmcharlt> as far as the main website is concerned, we could (a) ask for a license grant from past contributors
13:27:38 <gmcharlt> and that's a small enough set of people and institutions that doing so would not be particularly onerous
13:28:06 <gmcharlt> and (b) going forward, set a default license for new content, and make use of a WP plugin to mark individual posts as being under a particular license
13:28:29 <gmcharlt> which could vary by post -- if say, somebody wanted to do an opinion piece and wanted -NC
13:28:51 <gmcharlt> though I think the default should be CC-BY-SA
13:29:22 <gmcharlt> as far as the footer ont he docs website
13:29:35 <kmlussier> It looks like we currently have 34 users with WP accounts. That's not too bad.
13:29:37 <gmcharlt> the immediate thing that strikes me is bumping up the copyright date to -2015
13:30:18 <gmcharlt> and maybe putting in a more prominent link back to the main website
13:31:07 <gmcharlt> as far as making the visual design more consistent, while I think that would be a nice-to-have, I can't say I'm particularly worried about the current state of affairs
13:31:08 <kmlussier> The footer on the docs site is actually very similar to the one on the wiki.
13:31:24 <gmcharlt> indeed
13:31:45 <kmlussier> I'm not as concerned about consistency in the footer. I know, at one time, the EOB had requested that all evergreen-ils.org domains used the logo, which I think is more important.
13:32:46 <gmcharlt> wiki and docs comply with that
13:32:54 <gmcharlt> irc.evergreen-ils.org does not, but that's easy to remedy
13:33:03 <kmlussier> Yes, I was just noticing that. :)
13:33:44 <gmcharlt> webstats... is not something I feel should be promoted, as it exists purely as a utility site
13:33:54 <kmlussier> gmcharlt: Yes, I agree with you there.
13:34:10 <gmcharlt> #action Galen to add a robots.txt to webstats to disallow all crawling
13:34:18 <kmlussier> OK, so it sounds like we're okay with the footers being different, but that we might want to get the logo on irc.evergreen-ils.org
13:34:34 <gmcharlt> #action gmcharlt to get the Evergreen logo and link-back to the main website onto irc.evergreen-ils.org
13:34:49 <gmcharlt> yeah, I think the only change to request of DIG is updating the copyright date
13:35:24 <kmlussier> gmcharlt: Since they will be adding the license there anyway, it's something that can be done at the same time.
13:35:34 <gmcharlt> indeed
13:35:44 <kmlussier> Any opinions on moving forward with the Creative Commons licensing for the WP site? I'm inclined to proceed with it.
13:35:52 <gmcharlt> willl you take the action item of formally communicating that to DIG (re the footer)?
13:35:59 <kmlussier> gmcharlt: Yes
13:36:27 <gmcharlt> #action kmlussier will request that DIG update copyright date on the footer when they update it with the license statement
13:37:05 <gmcharlt> I'm +1 on moving forward with CC license statements for the main website
13:37:12 <kmlussier> I can also look at adding the Creative Commons WP plugin if everyone would like to proceed as gmcharlt outlined. I don't know what the best approach would be for contacting previous contributors to content.
13:37:26 <kmlussier> contributors *of* content
13:37:41 <gmcharlt> we can divvy up directly emailing folks
13:37:55 <kmlussier> Sounds good!
13:37:56 <gmcharlt> as well as posting announcements on the web team list and open-ils-general
13:38:25 <gmcharlt> #action gmcharlt and kmlussier will contact website content contributors to confirm willingness to license their contributions as CC-BY-SA
13:38:44 <gmcharlt> #action gmcharlt to send notification of the license clarification to mailing lists
13:39:00 <gmcharlt> #action kmlussier to find and install a CC License indicator WP plugin
13:39:19 <gmcharlt> ___action RoganH to do all the things (hi Rogan!)
13:39:33 <RoganH> #info RoganH, indentured servant to the web team
13:39:39 <RoganH> Hi!
13:39:52 <RoganH> Sorry for being (very) late.
13:40:03 <gmcharlt> so, moving on
13:40:11 <gmcharlt> #topic Review of website tasks spreadsheet
13:40:12 <gmcharlt> #link https://docs.google.com/spreadsheets/d/1e2n3A0cVxbmbvMnRKTw4Y3Vtl5DkL4vv9eQAfw2CzvM/edit#gid=2
13:43:52 <gmcharlt> so, one thing I've added to the list is making the websites SSL-only
13:44:23 <kmlussier> I sent a note to the list about adding a "Get Help/Get Support" page being on the Completed sheet. I'm not sure the Get Involved page serves the same need, so I would like to move that one back to the Blue Sky sheet.
13:44:38 <gmcharlt> no objections from me
13:44:39 <kmlussier> +1 to SSL only
13:44:57 <RoganH> +1 to SSL only as well
13:45:48 <kmlussier> RoganH: When I move Get Help/Get Support to the Blue Sky section, do you want me to take your name off of it or keep it on?
13:46:38 <RoganH> kmlussier: take it off
13:48:26 <gmcharlt> anything else worthy of comment here?
13:48:54 <kmlussier> Done. I may have tuits to tackle at some point, if something else doesn't catch my interest beforehand.
13:50:53 <gmcharlt> any other new business?
13:51:54 <kmlussier> I was just thinking that somebody should reach out to the 2016 conference planning team to make sure they have a WP account.
13:52:15 <RoganH> I can chat with Tanya and make sure she or someone has one.
13:52:23 <gmcharlt> cool
13:52:42 <gmcharlt> #action RoganH to reach out to the 2016 conference folks re getting them set up with a WP account
13:56:16 <gmcharlt> ok, sounds like we're at an end... so...
13:56:21 <gmcharlt> #endmeeting