15:07:09 <ldw> #startmeeting Evergreen Dev Meeting 2015-08-05
15:07:09 <pinesol_green> Meeting started Wed Aug  5 15:07:09 2015 US/Eastern.  The chair is ldw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:09 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:07:09 <pinesol_green> The meeting name has been set to 'evergreen_dev_meeting_2015_08_05'
15:07:18 <kmlussier> ldw++
15:07:21 <yboston> ldw++
15:08:06 <ldw> Do we need to review last meetings minutes?
15:08:26 <kmlussier> We usually start with introductions.
15:08:28 <berick> #info http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2015-08-05
15:08:32 <kmlussier> Sorry, I forgot to add it to the agenda.
15:08:58 <ldw> #info ldw=Liam Whalen BC Libraries Cooperative
15:09:21 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
15:09:23 <berick> #info berick King County Library System
15:09:24 <phasefx> #info phasefx = Jason Etheridge, ESI
15:09:27 <yboston> ldw: for the future you can type soemthng like "#topic introductions"
15:09:30 <yboston> #info yboston = Yamil Suarez: Berklee College of Music
15:09:39 <ldw> yboston: thanks
15:09:54 <Dyrcona> #info Dyrcona = Jason Stephenson, Merrimack Valley Library Consortium
15:09:57 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:10:19 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:10:27 <miker> #info miker = Mike Rylander, ESI
15:10:28 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:10:30 <jlitrell> #info jlitrell = Jake Litrell, MassLNC
15:10:31 <yboston> ldw: you can soon use this… "#topic Action Items from Last Meeting"
15:10:57 <ldw> #topic Action Items from Last Meeting
15:11:01 <terran> #info terran = Terran McCanna, PINES
15:11:41 <yboston> ldw: no you should quote the action tiem with a "#info prefix"
15:11:55 <yboston> like "#info gmcharlt and eeevil to organize a webstaff client hacking day in July"
15:12:11 <gmcharlt> cue up TARDIS
15:12:16 <ldw> #info gmcharlt and eeevil to organize a webstaff client hacking day in July
15:12:31 <gmcharlt> so speaking of the action item... we still plan to do it
15:12:41 <gmcharlt> but I think realisitically it's going to be in September at this point
15:14:01 <ldw> gmcharlt: are you still willing to lead on that?
15:14:04 <gmcharlt> yes
15:14:20 <ldw> #action gmcharlt to organize webstaff client hacking day in September
15:14:31 <yboston> ldw++
15:14:49 <ldw> #info jeff will look into removing old self check interface.
15:16:21 <ldw> #action ldw will follow up with jeff about removing old self check interface status
15:16:51 <ldw> #info jeff will look at removing old JSPAC code.
15:17:13 <ldw> #action ldw will follow up with jeff about removing old JSPAC code status
15:17:27 <ldw> #info dbwells will hopefully write more neg balances tests and push whatever he has ready on July 10
15:18:07 <dbwells> they done got wrote, mostly by remingtron
15:18:12 <Dyrcona> That one is done.
15:18:54 <ldw> #info dbwells done got wrote'em
15:19:09 <Dyrcona> #info remingtron, too.
15:19:12 <berick> heh
15:19:13 <dbwells> though, apparently nobody actually tried to /run/ them, since the tests immediately failed after getting pushed in (due to a missing setup file)
15:19:40 <gmcharlt> dbwells: something that had existed in your setup but missed being committed?
15:19:49 <dbwells> gmcharlt: yes
15:20:12 <gmcharlt> thought so
15:20:13 <Dyrcona> Well, that's partly 'cause I didn't get to my part.
15:20:53 <ldw> Is there anything else that needs doing on this item?
15:21:27 <kmlussier> I don't think so
15:21:33 <ldw> #info kmlussier to complete her testing on the negative balance branch by July 8
15:21:37 <kmlussier> #info kmlussier's negative balance testing is complete. Remaining issues have been reported in bug 1479107 and bug 1479110
15:21:39 <pinesol_green> Launchpad bug 1479107 in Evergreen "Replace manual void option with an "adjust to zero" option" (affected: 1, heat: 6) [Medium,New] https://launchpad.net/bugs/1479107
15:21:40 <pinesol_green> Launchpad bug 1479110 in Evergreen "Negative balance settings used in combination with one another should interact differently" (affected: 1, heat: 6) [Medium,New] https://launchpad.net/bugs/1479110
15:22:05 <ldw> #info Dyrcona will follow up with negative balance branch after July 10.
15:22:24 <Dyrcona> Well, that's basically done, but bshum did it.
15:22:41 <Dyrcona> #info done did by bshum
15:22:44 <ldw> #info jeff will articulate ideas on merge vs cherry-pick and start discussion/proposal on dev list
15:23:29 <ldw> did this discussion start?
15:23:39 <Dyrcona> No, it hasn't.
15:24:04 <ldw> #action ldw will follow up with jeff on merge vs cherry-pick discussion
15:24:11 <dbwells> Perhaps on test writing day we can get some more eyeballs on the neg. balance tests.  They do the job, but some parts are a little funky, and may need some more thoughts about best practices.
15:24:43 <ldw> #action ldw will looking into integrating neg. balance tests on test writing day
15:24:53 <ldw> #info     :
15:25:05 <ldw> #info     :
15:25:11 <ldw> #info yboston to followup with ldw about a testing day.
15:25:17 <ldw> done
15:25:33 <ldw> #info bshum to work with berick and others on crafting more information about release maintaining and schedules
15:26:02 <berick> no such crafting has occurred that I know of
15:26:27 <ldw> berick: are you still able to work on this with bshum?
15:26:41 <berick> ldw: yes
15:27:16 <ldw> #action berick will work with bshum on crafting more information about release maintaining and schedules
15:27:46 <ldw> now on to OpenSRF relase info?
15:28:34 <berick> ldw: i added a few things to the agenda doc since starting.  may want to refresh
15:28:35 <gmcharlt> there are some pending bugs and enhancements
15:28:45 <ldw> #info OpenSRF release info
15:28:50 <gmcharlt> and I expect to cut a release some time in the next 6 weeks
15:29:04 <gmcharlt> #Info Galen is expecting to cut another OpenSRF release in the next 6 weeks
15:29:25 <ldw> gmcharlt: should I action that?
15:29:49 <gmcharlt> ah, yes please
15:29:55 <Dyrcona> ldw you should probably change the #topic, too.
15:30:09 <ldw> #topic OpenSRF relase info
15:30:21 <Dyrcona> ldw++ # for hanging in there. :)
15:30:25 <ldw> thanks Dyrcona I was mistakenly using #info when I should be using #topic
15:30:49 <ldw> #action gmcharlt will cut an OpenSRF release in the next 6 weeks
15:31:12 <ldw> #topic Evergreen 2.8.3 planned for Aug. 19.
15:31:32 <berick> not much to discuss there.  just wanted to note it.
15:31:58 <ldw> #topic QA Proposal
15:32:04 <berick> the cal. also says that's our 2.9 beta release date..
15:32:09 <berick> oops, wrong topic
15:32:23 <kmlussier> Do we need to go back to the Evergreen update topic for a 2.9 update?
15:32:41 <ldw> #info go back to Evergreen 2.9 update, will resume QA Proposal after
15:32:49 <ldw> #topic Evergreen 2.9 update
15:32:56 <kmlussier> ldw++
15:33:37 <Dyrcona> #info The 2.9 alpha was postponed indefinitely because of questions about the negative balance branch and its release notes.
15:34:32 <berick> Dyrcona: you're still planning an alpha?
15:34:36 <berick> or just going to beta?
15:34:56 <Dyrcona> Well, that's the question that depends on the pending bugs, I guess.
15:35:30 <Dyrcona> The bug concerning settings has basically been resolved through discussion where the consensus seems to be to leave them as they are.
15:36:08 <Dyrcona> The other bug concerns changes to the staff client and dbwells is taking that on.
15:36:14 <kmlussier> Dyrcona: Is that the consensus? I was thinking it was, but I wasn't sure after miker posted his comments.
15:36:49 <miker> I'm fine with general concensus
15:37:02 <kmlussier> miker: OK, thanks!
15:37:25 <kmlussier> I can update the description for those settings to add a little clarity and then update the release notes entry to reflect the consensus.
15:37:58 * Dyrcona was just looking at the comments again.
15:37:59 <dbs> #info dbs = Dan Scott, Laurentian University
15:38:41 <ldw> #action kmlussier to update setting descriptions and then update the release notes to reflect consensus
15:38:59 <Dyrcona> Well, I could do an alpha at any time, but I'd prefer that the negative balances feature and notes be more or less complete.
15:39:32 <kmlussier> Do we have an idea on the timeframe that https://launchpad.net/bugs/1479107 can be done?
15:39:33 <pinesol_green> Launchpad bug 1479107 in Evergreen "Replace manual void option with an "adjust to zero" option" (affected: 1, heat: 6) [Medium,New]
15:40:13 <dbwells> I think any work I can do for the interface pieces won't be complete until close the beta cutoff.
15:41:03 <Dyrcona> I could give it a shot, but I have a tendency to miss things in the staff client.
15:41:30 <berick> kmlussier: that looks a lot like bug 1249398
15:41:31 <pinesol_green> Launchpad bug 1249398 in Evergreen "Clear negative balance billing option" (affected: 3, heat: 18) [Wishlist,Confirmed] https://launchpad.net/bugs/1249398
15:42:01 <kmlussier> berick: We were talking about that the other day.
15:42:05 <berick> my code is probably out of date, though
15:42:30 <berick> almost 2 years old
15:42:33 <kmlussier> They both have different objectives. One clears the negative balance off the record. The other adjusts a bill so that the balance is zero.
15:42:45 <berick> ah, ok
15:42:48 <berick> nevermind, then
15:43:05 <dbwells> I would prefer to see the alpha released as-is, rather than rush/delay things.  Unless we feel like there is nothing else worth testing in the alpha.
15:43:25 <berick> raise your hand if you will install the alpha
15:43:49 <kmlussier> Well, I install master on a regular basis, but I don't need an alpha release to do so. :)
15:43:57 <Dyrcona> I already have, basically. :)
15:44:39 <dbwells> In my experience, the alpha was little more than a dry-run for the benefit of the RM more than anyone else :)
15:44:55 <berick> s/the alpha/the alpha tarball/
15:44:59 <ldw> Dyrcona: do you want an action item regarding an alpha?
15:45:21 <berick> dbwells: true, it can be useful for the RM
15:45:57 <Dyrcona> Do I /want/ one? No, I don't /want/ one. :)
15:46:05 * berick chuckles
15:46:27 <ldw> #info Dyrcona protests an alpha action item ;P
15:46:36 <miker> Dyrcona: thougths on pulling in the sprint2 branch at or around alpha time?
15:47:02 <Dyrcona> miker: Well is sprint2 ready for testing or still work in progress?
15:47:18 <miker> today, WIP, but we're closing it on it
15:47:50 <miker> and, tbh, I think any working code should go in regardless of sprint boundary ... but, that's just my opinion
15:48:22 <kmlussier> Are there pieces of it that could affect functionality in the existing client?
15:49:01 <miker> kmlussier: not yet. we've avoided touching anything that could affect the SC, after the chunking debacle ;)
15:49:05 <kmlussier> IIRC, for sprint 1, there were certain interfaces berick identified as needing extra attention because they might be impacted by the web client work.
15:49:30 <berick> yeah, there were some tpac changes
15:49:46 <berick> that needed confirmation of non-breakage
15:50:34 <miker> there's no crossover in the post-2.8 stuff, afaict. but, I'd be happy if someone put eyeballs on that. a scan of changes to existing files should tell the tale
15:50:36 <gmcharlt> the sprint2 stuff is self-contained with the exception of some things that would (in a minor way) affect the existing *webstaff* circ interface
15:50:40 <gmcharlt> mostly grid improvements
15:50:47 <Dyrcona> Well, I'll take a look at where sprint2 is today and get back to you.
15:50:50 <berick> in general, though, i think we're still in agreement the browser client code has a lower barrier to entry (assuming no external breakage).
15:50:58 <berick> correct me if i'm wrong
15:51:09 * berick would like to see it merged in a lot more frequently
15:51:48 <ldw> #action Dyrcona to investigate sprint2's integration with an alpha release
15:52:06 * dbwells seconds more frequent merges
15:52:28 <bshum> I've been testing sprint2 merges during my last two system builds with recent master.
15:52:37 <bshum> It's not too crazy looking to me anyways.
15:52:58 * bshum would say more but typing on a phone isn't so easy.
15:53:13 * bshum will chat further with Dyrcona on that lookover.
15:55:21 <ldw> Dyrcona: will you set a date for a release/skip an alpha release once you have examined the possibility of a sprint2 merge?
15:55:37 <Dyrcona> Yes.
15:56:26 <ldw> #action Dyrcona to determine if sprint2 can be merged into an alpha release, and will set a date for a release or skip the release depending on his findings.
15:56:46 <ldw> any other 2.9 discussion?
15:57:00 <kmlussier> No, but Dyrcona++
15:57:05 <ldw> Dyrcona++
15:57:21 <dbwells> Dyrcona++
15:57:26 <ldw> #topic QA Proposal - http://georgialibraries.markmail.org/thread/dl7xemr5zzzcfi6f
15:57:53 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:57:53 <kmlussier> I added that topic to the agenda because the status of the QA proposal seems to still be in limbo.
15:58:24 <kmlussier> I added the proposed guidelines to the contributing page after gmcharlt gave it the okay in that thread, but there were concerns raised shortly thereafter.
15:58:53 <ldw> My concerns are not necessary.  Your comment about a developer being able to state why a test is infeasible invalidates my concerns.
15:59:04 <dbwells> I only have a couple minutes before I need to run, but would like more feedback on my proposal for multiple sign-offs in lieu of the "it's too hard to write tests" clause.
15:59:18 <ldw> dbwells: I like that idea.
15:59:57 <dbwells> I think it might keep things a little more objective and self-correcting.
16:00:39 <gmcharlt> well, I think I would like to push back a bit on the notion of sign-offs as being "objective", per se
16:00:55 <ldw> Would it be necessary for us to add a negative sign-off?  Incase a committer feels strongly about a test being needed?
16:01:14 <gmcharlt> which is not to dismiss the proposal of trading additional review in place of a statement that automated tests can't be written for a given patch
16:01:35 <Dyrcona> ldw: That's typically done in a comment on the LP bug.
16:02:42 <dbwells> Certainly not all signoffs are created equal, but more-is-better should generally hold true across the aggregate.
16:02:50 <gmcharlt> also, in my view a statement to the effect that a test is not infeasiable is not meant to be a flat assertion
16:02:57 <gmcharlt> rather, a reasoned argument
16:03:17 <gmcharlt> that said, I'm not wedded that wording
16:04:03 <gmcharlt> but I am in disfavor of frequent use of infeasibility statements OR multiple signoffs purely as a mechanism for folks to avoid writing unit tests
16:04:13 <gmcharlt> or to put it another way
16:04:19 <gmcharlt> - more tests: generally good
16:04:33 <gmcharlt> - seeking out additional reviewers: almost always good
16:04:54 <gmcharlt> - not writing tests for new code or significant bugfixes - AVOID! AVOID!
16:05:37 * kmlussier is in agreement with gmcharlt
16:06:41 <ldw> do we need to have a +1 type vote on this issue?
16:07:01 <gmcharlt> ldw: dbwells: give me one moment to propose a wording change
16:08:47 <pastebot> "gmcharlt" at 64.57.241.14 pasted "revised QA guideline" (5 lines) at http://paste.evergreen-ils.org/22
16:09:59 <dbwells> gmcharlt++ # looks good to me
16:10:03 <kmlussier> +1
16:10:15 <ldw> #info revised QA guideline
16:10:21 <ldw> +1
16:10:29 <terran> +1
16:11:06 <RoganH> +1
16:11:12 <phasefx> +1
16:11:15 <jlitrell> +1
16:11:22 <berick> +1
16:11:49 <dbwells> My main concern was that leaving the judgment call to one person was going to eventually blow up and cause hard feelings, so this solves it, thanks!
16:12:17 <Dyrcona> Y'know, we can do an actual vote.
16:12:26 * ldw looks into voting
16:13:05 <ldw> #startvote Should we accept gmcharlt revised QA guideline
16:13:05 <pinesol_green> Unable to parse vote topic and options.
16:13:08 <gmcharlt> FWIW, when I see resentment arise in other projects regarding this sort of thing... long-term resentment typically has more to do about unwillingness to help cleanup after mistakes, not for making mistakes int the first place
16:13:24 <ldw> #startvote Should we accept gmcharlt revised QA guideline? Yes/No
16:13:24 <pinesol_green> Begin voting on: Should we accept gmcharlt revised QA guideline? Valid vote options are Yes, No.
16:13:24 <pinesol_green> Vote using '#vote OPTION'. Only your last vote counts.
16:13:32 <gmcharlt> #vote Yes
16:13:35 <ldw> #vote Yes
16:13:38 <terran> #vote Yes
16:13:40 <Dyrcona> #vote yes
16:13:45 <berick> #vote yes
16:13:54 <kmlussier> #vote yes
16:13:55 <jlitrell> #vote yes
16:14:00 <phasefx> #vote Yes
16:14:00 <dbwells> #vote Yes
16:14:20 <dbs> #yes
16:15:18 <ldw> last call for voting
16:15:27 <dbs> a proposed friendly amendment would be s/explaining that/explaining why/ but that's minor
16:15:32 <Dyrcona> dbs might want to vote again.
16:15:38 <dbs> #vote yes
16:15:59 <gmcharlt> dbs: yeah, +1, and I think that falls in the realm of a non-controversial erratum
16:17:04 <ldw> #endvote
16:17:04 <pinesol_green> Voted on "Should we accept gmcharlt revised QA guideline?" Results are
16:17:04 <pinesol_green> Yes (10): kmlussier, jlitrell, phasefx, berick, dbwells, Dyrcona, ldw, terran, gmcharlt, dbs
16:17:25 <ldw> #topic Code sanity check appreciated for https://bugs.launchpad.net/evergreen/+bug/1468422
16:17:26 <pinesol_green> Launchpad bug 1468422 in Evergreen "Improve Password Management and Authentication" (affected: 1, heat: 258) [Undecided,New]
16:18:39 <berick> oh, that's me
16:19:04 <berick> so, want to keep some momentum, but also want to avoid doing more work until i get some nod that it's heading in the right direction
16:19:42 <berick> so if anyone can eye/test/etc. i'd appreciate it
16:19:45 <berick> that is all
16:19:49 <dbwells> berick++ # glad to see this moving forward
16:20:53 <kmlussier> berick++
16:21:02 <dbwells> berick: my C chops are basically non-existant, so my eyeballs won't help, but I'll plan to do some basic explosion testing.
16:21:20 <berick> dbwells: well, the DB changes are my main concern
16:21:47 <dbwells> ldw: action me up, good sir!
16:22:01 <dbwells> berick: ah, ok
16:22:29 <ldw> #action dbwells will attempt to explode berick's Password Managment and Authentication improvements
16:22:32 <berick> the C/API stuff is less exotic :)
16:23:06 <gmcharlt> berick: I would be very suspicious of exotic crypto code, even from you! ;)
16:23:48 <ldw> Is there any new business?
16:23:49 <berick> gmcharlt: what's a few rootkits between friends?
16:25:37 <gmcharlt> @quote add <berick> gmcharlt: what's a few rootkits between friends?
16:25:37 <pinesol_green> gmcharlt: The operation succeeded.  Quote #123 added.
16:26:07 <ldw> #endmetting
16:26:11 <ldw> #edmeeting
16:26:16 <ldw> #endmeeting