13:01:10 <Christineb> #startmeeting Acquisitions Interest Group Quarterly Meeting
13:01:10 <pinesol_green> Meeting started Thu Aug 13 13:01:10 2015 US/Eastern.  The chair is Christineb. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:10 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:10 <pinesol_green> The meeting name has been set to 'acquisitions_interest_group_quarterly_meeting'
13:01:18 <Christineb> #topic Introductions
13:01:29 <Christineb> Please feel free to start introducing yourselves...
13:01:34 <Christineb> #info Christineb is Christine Burns @ BC Libraries Cooperative
13:01:49 <ehardy> Elaine Hardy @ PINES
13:02:00 <Bmagic> #info Bmagic @ MOBIUS
13:02:01 <mllewellyn> Mary Llewellyn @Bibliomation
13:02:08 <jihpringle> #info jihpringle is Jennifer Pringle @ BC Libraries Cooperative
13:02:13 <vlewis> In what table is the lost status set?
13:02:21 <bshum> #info bshum is Benjamin Shum, Bibliomation (observing from afar, very far)
13:02:40 <dbs> #info dbs is Dan Scott, Laurentian University (toes just barely in the water of acq)
13:02:40 <dluch> #info dluch @MOBIUS
13:03:01 <mllewellyn> #info mllewellyn Mary Llewellyn, Bibliomation
13:03:36 <jlundgren> #info jlundgren is Jeanette Lundgren, C/W MARS
13:03:58 <Christineb> Welcome everyone :)
13:04:13 <Christineb> The last time the Acquisitions group met was at the Evergreen conference
13:04:50 <Christineb> #topic review previous action items
13:05:15 <Christineb> The official development wishlist has been posted  http://wiki.evergreen-ils.org/doku.php?id=acq:interest-group&#community_acquisitions_resources
13:07:38 <Christineb> does anyone have suggestions how we should attack this list?
13:08:00 <Christineb> the majority of these issues have now been logged in Launch pad
13:08:25 <ehardy> My plan was to get more information from users and then start writing requirements
13:08:29 <mcrawley> I'm late joining the metting, what list are we talking about? the improvements we came up with at the conference?
13:08:33 <ehardy> However, no one responded
13:08:34 <Christineb> The official development wishlist has been posted  http://wiki.evergreen-ils.org/doku.php?id=acq:interest-group&#community_acquisitions_resources
13:09:25 <jihpringle> it would be good to have everyone review the bugs on launchpad, add any additional information they may have and indicate that a bug affects them
13:10:32 <Christineb> I can update the list to include relevant launch pad ticket #'s
13:11:17 <mcrawley> i think i did a few already but having the ticket # would help
13:11:35 <Christineb> #action Christineb to update wishlist doc to include launchpad bug #'s and re-post
13:12:21 <mcrawley> what are the chances of getting any of these improvements any time soon? i thought they were spending all their time on the web based version, which of course doesn't include acq. any time soon
13:12:59 <lstjohn> That would help us out Christine, in writing the requirements doc
13:14:12 <dbs> mcrawley: functionally, acquisitions is actually almost entirely web-based, just a different framework, so theoretically the web staff client should be able to link into web-based acq without too much pain
13:14:46 <dbs> but it would continue with the same look and feel and wouldn't feel very integrated
13:15:07 <lstjohn> We were discussing that development time just this morning, especially for the interface issues that will be resolved with going from dojo to angular - we were figuring 2 to 4 years - but for other "fixes" it depends on community time and money.
13:15:34 <mcrawley> that's a long way out
13:15:44 <dbs> mcrawley: also "they" is whoever is being given resources (either by freeing up people at their own orgs to work on development, or by funding the likes of Equinox or others)
13:15:48 <Christineb> I think if can agree on a top 3 or a top 5 and flesh out good requirements, we could see fixes sooner
13:16:27 <dbs> So a lot of it depends on which organizations are allocating resources and what their priorities are
13:16:29 <ehardy> Christineb: That was what we discussed at the last meeting and in my email with the list
13:17:00 <dbs> lstjohn++ # crossing IRC messages
13:17:52 <mcrawley> I was told at the conference that NC Cardinal would put up some money for acq improvements. Don't know the status on that though
13:18:15 <lstjohn> We wanted to get community consensus on what it was we needed in priority order and then ask the community to fund the project - maybe a pie in the sky idea but has worked for some other Evergreen projects
13:18:32 <ehardy> We voted on that list at the Evergreen conference. The first six are in that order. We could of course change it.
13:19:37 <mcrawley> we should move forward on this ASAP since it takes so much time to get the development done and then for them to add it the next version.
13:20:15 <Christineb> ok, I can update the document with bug #'s and repost later today, can everyone commit to taking a look at the top 6 bugs and adding comments etc??
13:20:32 <mcrawley> we paid for improvements a year ago and they were done but i still don't have them
13:21:07 <jihpringle> do we feel that we can proceed with those top 6 as our top 6 or do we feel we need to poll the community for those that weren't able to attend the conference?
13:21:22 <mcrawley> let's go with these
13:21:41 <ehardy> If enough information is provided on the bugs, I can do my best to get requirements written by the end of October
13:21:48 <Christineb> Yes let's stick with the top 6 we already came up with
13:21:58 <Christineb> ehardy: thank you
13:22:16 <mcrawley> so you want us to add comments. can you set a deadline for that?
13:22:44 <Christineb> is the end of August too soon?
13:22:51 <lstjohn> comments, use cases and descriptions of what you want if not in bugs would be very helpful
13:23:06 <mcrawley> sounds good.
13:23:09 <dluch> I think end of August sounds reasonable
13:23:30 <mcrawley> once Elaine writes the requirements, what then?
13:23:46 <Christineb> #action all participants - add comments, use cases and descriptions of what you want if not in bugs  by end of August 2015
13:23:54 <ehardy> And I can always ask for more info if I need more for the REQs
13:23:58 <Christineb> #action ehardy will try to get requirements written by end of October
13:24:44 <mcrawley> who will fund?
13:25:12 <ehardy> Once we have req we would then see how much  development would cost, then see if we can get money
13:25:27 <Christineb> or see who has development time to contribute
13:25:32 <ehardy> Yes
13:25:47 <mcrawley> will you keep us all posted on the progress?
13:26:17 <Christineb> Yes I will update this page - http://wiki.evergreen-ils.org/doku.php?id=acq:interest-group&#community_acquisitions_resources
13:26:22 <Christineb> as well as posting to the general list
13:26:25 <ehardy> We might have to work on a final version of the reqs after October, but I can try to get a first draft out by then
13:26:42 <Christineb> I think a first draft is enough to get started
13:27:02 <mcrawley> seems like a very long drawn out process to get anything done
13:27:42 <ehardy> If you don't have reqs written properly, you don't get what you want
13:28:00 <mcrawley> yes, i know
13:28:03 <minae> I'm new at this- Can you post the link to Launch Pad here also
13:28:10 <Christineb> Now I wanted to mention, one of the issues we had spoken about in our last meeting has now been fixed
13:28:22 <Christineb> https://launchpad.net/evergreen
13:28:57 <Christineb> https://bugs.launchpad.net/evergreen/+bug/1289486
13:28:58 <pinesol_green> Launchpad bug 1289486 in Evergreen "Cannot Delete Acquisitions Records Queues" (affected: 5, heat: 26) [Undecided,Fix committed]
13:29:25 <lstjohn> Yes, that was great, I danced the dance
13:29:28 <mcrawley> when it is available
13:29:39 <mcrawley> meant to say when is it available?
13:29:54 <lstjohn> it is now
13:29:56 <jihpringle> fixes are available for 2.7 and 2.8
13:30:05 <mcrawley> oh, great?
13:30:16 <Christineb> mcrawley: what version are you on??
13:30:30 <jihpringle> depending on what version you are on your techs should be able to apply the fix
13:30:34 <mcrawley> 2.7.4
13:30:46 <mcrawley> i'll try it
13:31:05 <jihpringle> another one from the list has been done as well: https://bugs.launchpad.net/evergreen/+bug/1361900
13:31:07 <pinesol_green> Launchpad bug 1361900 in Evergreen "Acq: Move Acqusitions Admin Menu" (affected: 3, heat: 14) [Wishlist,Confirmed] - Assigned to Michael Peters (mrpeters)
13:31:29 <Christineb> The acq menu move is a huge improvement
13:31:39 <Christineb> I can't stress how happy this made me :D
13:31:48 <jihpringle> it's slated for 2.9 but we've backported to 2.8 and have been using it since July
13:31:54 <mcrawley> don't know what that one is?
13:33:20 <lstjohn> we are also about to sign off on #1402018 workstation scoping - we've tested it on 2.7.2
13:33:23 <jihpringle> the acquisitions admin menu was moved to be under the Admin menu rather than under Admin -> Server Administration
13:33:29 <Christineb> The Acquisitions Admin menu has been moved directly under Admin instead of having to to into Admin --> Server Admin
13:33:44 <Christineb> lstjohn - that is great news!!
13:35:39 <Christineb> We have asked our techs to try and fix https://bugs.launchpad.net/evergreen/+bug/1463166
13:35:40 <pinesol_green> Launchpad bug 1463166 in Evergreen "When editing copy level information within a selection list (in Acq), a Fund cannot be chosen or assigned." (affected: 5, heat: 24) [Low,Confirmed]
13:35:40 <lstjohn> I wonder if we can backport the admin menu to 2.7?
13:36:08 <jihpringle> you may need a new staff client for it, we tied the change in with our upgrade to 2.8
13:36:51 <lstjohn> well, we'll have to wait until our next upgrade then but that is something to look forward to
13:37:21 <Christineb> The other option for the admin menu move if you are unable to create a new staff client was "2. Replace C:\Program Files (x86)\Evergreen Staff Client Master\chrome\content\main\menu_frame_menus.xul on each installed staff client (assuming you are running master) with the one from this working branch."
13:37:42 <Christineb> so you may want to investigate if you can do it before upgrade
13:37:55 <Christineb> ok so moving on from wishlist??
13:38:03 <lstjohn> I sure will, right after we are done here.
13:38:32 <Christineb> #topic New Business
13:38:57 <Christineb> Anyone have any new business? Issues to discuss? Ah ha moments to share?
13:40:14 <lstjohn> I have a question. When you delete a line item from a purchase order that has not been activated, it deletes the line item from the selection list but not from the OPAC - is this your experience also?
13:40:45 <Christineb> lstjohn - I have seen this happen
13:41:25 <Christineb> when a MARC order file is loaded in "Load MARC Order Records" and Load Items for Imported Records is selected
13:42:28 <Christineb> Is on my to-do list to do some more testing to figure out if this is a bug or desired behaviou
13:42:40 <Christineb> does this scenario match what you are seeing?
13:44:32 <lstjohn> Yes, order records loaded, copies created  - there seems to be a related bug https://bugs.launchpad.net/evergreen/+bug/1269574
13:44:33 <pinesol_green> Launchpad bug 1269574 in Evergreen "ACQ lineitems canceled via EDI not deleting linked bibs/items" (affected: 5, heat: 26) [Medium,Confirmed]
13:44:59 <mcrawley> Just recently had a couple that did not hit B&T's server and needed to re-send but couldn't. Can't remember if it's on our list but I believe I've seen a ticket on it? Anybody know anything about the status of that?
13:45:18 <mcrawley> a couple of PO's that is
13:45:50 <lstjohn> https://bugs.launchpad.net/evergreen/+bug/1218423
13:45:51 <pinesol_green> Launchpad bug 1218423 in Evergreen "Acq: Do we need a feature to resend EDI purchase orders?" (affected: 7, heat: 36) [Wishlist,Triaged]
13:46:02 <minae> Is it possible to set a Fund Code to go over the max amount allotted, such as set Balance Stop Percent greater than 100?
13:46:22 <mllewellyn> We already set our stop percentages above 100
13:46:25 <Christineb> minae Yes you can set the percentage to + 100%
13:46:37 <mcrawley> yes, we had ours set to 110 but have since changed it
13:47:09 <minae> Great - thank you
13:47:14 <Christineb> a lot of our libraries get a 30% discount on the invoice so they use 130% as the full price is entered on order
13:47:19 <mllewellyn> I tell our libraries if they know what percentage discount they expect from their vendors, to add that to the stop percentage
13:48:11 <mcrawley> don't you put the discount price in the PO? we do.
13:48:22 <mllewellyn> no, full price on po
13:48:31 <mllewellyn> discount price on invoice
13:48:44 <Christineb> Yes my libraries do the same - full price on po / discount on invoice
13:48:45 <mllewellyn> that way the item gets the full price
13:49:01 <mllewellyn> so if the item is lost, that's what the patron will be charged.
13:49:15 <Christineb> I may have some notes to add to 1218423
13:49:16 <mcrawley> we enter the full price in the item
13:49:56 <mllewellyn> We let acq do that when the item is created from the PO
13:50:06 <mcrawley> it's easy to update the price and that way we aren't encumbering way more than necessary
13:50:23 <mllewellyn> then the librarian doesn't have to go back and key in the full price.
13:51:10 <lstjohn> On purchase orders, I'd like to be able to edit, ie clone merge and delete a po before it is activated - anyone else?
13:51:36 <Christineb> I would love to be able to delete Purchase orders
13:51:52 <mcrawley> yes, yes and yes
13:52:01 <mllewellyn> there are times I'd like to be able to delete POs too
13:52:23 <Christineb> I think it sort of fits into one of the items on our lsit
13:52:27 <jihpringle> agreed, but I either want it to be impossible or really realy hard to delete an activated PO
13:52:28 <Christineb> ability to set PO status
13:52:39 <mllewellyn> I have some librarians accidentally load the same order more than once. I'd like to be able to delete the duplicates beyond just deleting the lineitems.
13:52:39 <Christineb> agree you should not be able to delete an activated PO
13:52:50 <Christineb> mllewellyn ++++
13:52:54 <Christineb> so many votes
13:52:57 <Christineb> :)
13:53:05 <lstjohn> I'd also like to delete a line item from the PO and not have it deleted from the selection list - or at least have the choice
13:53:10 <mllewellyn> :)
13:53:30 <lstjohn> do we need to put this in the top 6?
13:53:43 <mllewellyn> I've had problems deleting lineitems from a PO only to have it reappear if it's also on a selection list, and vice versa.
13:54:40 <mcrawley> not as important to me as most of the top 6
13:55:51 <Christineb> ok so the Evergreen for academics meeting is going to start shortly
13:55:54 <Christineb> we should probably wrap up
13:56:27 <Christineb> I will send out meeting minutes & action items
13:56:34 <mcrawley> i don't think deleting POs is even on our list, is it? Could be added, but not in top 6
13:56:56 <lstjohn> Will add to list, not in top 6
13:57:08 <Christineb> I will create a lp bug for it, if it doesnt already exist
13:57:30 <Christineb> Thank you for participating
13:57:38 <dluch> Thanks, Christineb!
13:57:40 <mcrawley> good 1st meeting
13:57:45 <mllewellyn> thanks, Christineb
13:57:53 <lstjohn> https://bugs.launchpad.net/evergreen/+bug/1286340
13:57:54 <pinesol_green> Launchpad bug 1286340 in Evergreen "Please add a feature that will allow end-users to delete Purchase Orders" (affected: 7, heat: 34) [Wishlist,Confirmed]
13:57:55 <ehardy> Thanks
13:58:08 <Christineb> lstjohn - THank you
13:58:09 <Christineb> #endmeeting