15:00:43 <Dyrcona> #startmeeting 2015-09-02 - Developer Meeting
15:00:43 <pinesol_green> Meeting started Wed Sep  2 15:00:43 2015 US/Eastern.  The chair is Dyrcona. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:43 <pinesol_green> The meeting name has been set to '2015_09_02___developer_meeting'
15:01:10 <Dyrcona> #info agenda at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-09-02
15:01:28 <Dyrcona> #topic Introductions
15:01:44 <Dyrcona> #info Dyrcona = Jason Stephenson, MVLC
15:01:51 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:02:30 <Stompro> #info Stompro = Josh Stompro, LARL MN
15:02:30 <berick> #info berick = Bill Erickson, KCLS
15:02:52 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:03:23 <jboyer-isl> #info isl-jasonb = Jason Boyer, IN State Lib (Eg IN)
15:03:34 <jboyer-isl> (oops.)
15:03:42 <Dyrcona> heh
15:04:03 <dbs> #info dbs = Dan Scott, Laurentian University
15:04:16 <jeff> @info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:04:17 <pinesol_green> jeff: (info <url|feed>) -- Returns information from the given RSS feed, namely the title, URL, description, and last update date, if available.
15:04:21 <jeff> bah.
15:04:25 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:04:29 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:05:02 <Dyrcona> Stragglers can announce themselves as they show up.
15:05:17 <Dyrcona> #top Action Items from Last Meeting
15:05:22 <Dyrcona> oops.
15:05:37 <Dyrcona> #topic Action Items from Last Meeting
15:06:04 <Dyrcona> #info gmcharlt to organize webstaff client hacking day in September
15:06:07 <yboston> #info yboston is Yamil Suarez - Berklee.edu
15:06:22 <Dyrcona> #info We've now picked a date: Wednesday, 16 September 2015. Will discuss at dev meeting.
15:06:34 <Dyrcona> gmcharlt, you have the floor. :)
15:07:08 <gmcharlt> so, main thing to discuss before we officially announce it is mostly scheduling: does that day happen to be no good very bad not free at all for everybody who isn't me and miker?
15:07:12 <gmcharlt> if not, we'll run with it
15:07:57 <berick> works for me
15:07:58 <jeff> looks good here.
15:08:07 * dbs isn't free at all but realistically that doesn't matter
15:08:26 <jeff> looks like 2.9.0 and monthly maintenance releases are scheduled for that day.
15:08:27 <Dyrcona> It is release day for 2.9.0, 2.8.4, and 2.7.[i forget]
15:08:53 <berick> i would not object to pushing releases ahead or back a day
15:08:54 <miker> #info miker = Mike Rylander, ESI
15:09:13 <Dyrcona> I cannot release on the 15th.
15:09:35 <gmcharlt> how about the 17th for AngularJS day?
15:10:08 <berick> also works for me
15:10:18 <Dyrcona> Day after a release might be better than a day before.
15:10:48 <jeff> 17th also good for me. EOB meeting for one hour that day, if that affects anyone else with interest.
15:11:49 <Dyrcona> 17th works for me.
15:12:01 * gmcharlt imagines that the EOB meeting si less of a blocker for anybody who falls in the intersection
15:12:25 <Stompro> 17th works better for me also.
15:13:30 <gmcharlt> ok, I think that settles it
15:13:33 <gmcharlt> thanks for the feedback!
15:13:43 <gmcharlt> #info AngularJS Day will be scheduled for 17 September 2015
15:13:49 <Dyrcona> beat me to it.
15:14:11 <Dyrcona> #info ldw will follow up with jeff about removing old self check interface status -- Done!
15:14:24 <Dyrcona> I put that as done, since the code branch went in.
15:14:33 <Dyrcona> Any discussion before moving on?
15:14:41 <jeff> nope!
15:14:56 <Dyrcona> ok, then.
15:15:04 <Dyrcona> #info ldw will follow up with jeff about removing old JSPAC code status - Done!
15:15:13 <Dyrcona> Same with this one.
15:15:19 <jboyer-isl> yay!
15:15:43 <Dyrcona> #info ldw will follow up with jeff on merge vs cherry-pick discussion
15:15:59 <Dyrcona> I don't think this one happened, jeff?
15:17:45 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:17:49 <ldw> #info ldw = Liam Whalen, Sitka
15:17:49 <Dyrcona> Does anyone want to have any discussion on the matter before I defer it to next meeting?
15:17:52 <jeff> nope, though ldw did say he wanted to ask me about something.
15:18:17 <ldw> jeff: I wanted to make sure all was well.  Just a follow up to the TODO.
15:18:36 <jeff> my report would be that i've given it some but not a lot of thought, enough to be reconsidering and i have no specific proposal to make at this time. i'd be interested in further (not in this meeting) discussion with anyone else who was interested by the original idea.
15:18:38 <Dyrcona> Is it something we would want to discuss at a future meeting, or should we drop it?
15:18:56 <jeff> no specific followup other than that. drop it from the next agenda unless further discussion brings it back to the agenda.
15:19:26 <Dyrcona> #agree drop it for now. :)
15:19:49 <Dyrcona> #info ldw will looking into integrating neg. balance tests on test writing day
15:20:12 <Dyrcona> ldw: I think that happened more or less.
15:20:49 <ldw> I did not get the neg balance tests personally.  I do not know if someone else worked on it that day.
15:21:09 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:21:16 <Dyrcona> There are some negative balance tests and more can always be added.
15:21:28 <Dyrcona> dbwells or remingtron anything to add?
15:22:29 <dbwells> I think the goal was to reconsider the way they were setup, but that doesn't need to happen with any particular urgency.
15:23:03 <Dyrcona> So, we'll call that one done, too.
15:23:07 <Dyrcona> #info done
15:23:25 <Dyrcona> #info berick will work with bshum on crafting more information about release maintaining and schedules
15:23:41 <berick> no progress to report.
15:24:00 <Dyrcona> Do we want to carry this one forward to the next meeting?
15:24:27 <berick> unless bshum still plans on tackling it, let's take it off the agenda for now
15:24:57 <Dyrcona> Ok.
15:25:18 <Dyrcona> I don't think bshum is here. He said something about another commitment.
15:26:00 <Dyrcona> #info gmcharlt will cut an OpenSRF release in the next 6 weeks-- Will cut on Tuesday, 2015-09-08
15:26:19 <Dyrcona> That looks good to me. Anything to add?
15:27:03 <gmcharlt> not from me
15:27:19 <Dyrcona> Ok. moving on.
15:27:23 <Dyrcona> #info kmlussier to update setting descriptions and then update the release notes to reflect consensus -- Done!
15:28:11 <Dyrcona> Don't think there is much to add there, so moving on....
15:28:16 <Dyrcona> #info Dyrcona to investigate sprint2's integration with an alpha release -- Done: Sprint 2 was integrated for the beta release.
15:28:33 <jeff> sprint2++ Dyrcona++
15:28:42 <Dyrcona> Only thing I can add here is that the tarball install of the web staff client is broken in the beta.
15:28:56 <Dyrcona> You have to do the developer steps to make it work.
15:29:30 <Dyrcona> Which maybe leads to an action item for someone (me) to update the README with web staff client instructions.
15:30:35 <Dyrcona> #action Dyrcona to update README/INSTALL for master to include web staff client installation instructions for developers by 2.9.0 release date.
15:30:49 <Dyrcona> unless anyone objects.
15:31:42 <Dyrcona> The next item looks like the previous but touches on the alpha release schedule.
15:32:00 <Dyrcona> #info Dyrcona to determine if sprint2 can be merged into an alpha release, and  will set a date for a release or skip the release depending on his  findings.
15:32:22 <Dyrcona> #info Done: alpha release was skipped and beta was released on time.
15:32:46 <Dyrcona> Any questions or discussion of that decision?
15:33:51 <Dyrcona> Ok. It's pretty easy when most of the things get done. :)
15:34:20 <Dyrcona> #info dbwells will attempt to explode berick's Password Managment and Authentication improvements
15:35:02 <dbwells> I've started going over it, but nothing substantial to report at this time.  I'll continue working on it.
15:35:31 <berick> dbwells++
15:35:37 <Dyrcona> OK. Does this need to continue as an action item?
15:35:48 <Dyrcona> Indeed. dbwells++ berick++
15:36:04 <dbwells> Dyrcona: I'd be fine with that.
15:36:21 <Dyrcona> All right.
15:36:26 <Dyrcona> #action dbwells will attempt to explode berick's Password Managment and Authentication improvements
15:36:43 <Dyrcona> Gee I could have fixed the spelling.... anyway.
15:36:57 <Dyrcona> So that is it for action items.
15:37:09 <Dyrcona> Moving on to release information.
15:37:20 <Dyrcona> #topic OpenSRF Release
15:37:50 <gmcharlt> pretty much already dicussed, I think
15:37:54 <Dyrcona> gmcharlt mentioned doing a release on 8 Sept. what version will that be?
15:38:12 <Dyrcona> gmcharlt: do you want an action item? :)
15:38:26 <gmcharlt> yeah, I'll take it.. and version will be 2.4.2
15:38:30 <Dyrcona> ok.
15:38:53 <Dyrcona> #action gmcharlt to release OpenSRF version 2.4.2 on 8 September 2015.
15:39:24 <Dyrcona> #topic Evergreen Release(s)
15:39:38 <Dyrcona> So, I'll take an action item right off the bat.
15:39:51 <Dyrcona> #action Dyrcona to release 2.9-rc after the meeting.
15:40:15 <Dyrcona> I just made the tarball this afternoon, loaded it on a test vm with concerto data, and all looks good.
15:40:38 <Dyrcona> I even got it to work with the web staff client. I think that ended up being bad ownership on a directory.
15:41:53 <Dyrcona> So, do we want action items for the maintenance releases in two weeks or is that overkill?
15:42:29 <Dyrcona> I guess that would include 2.9.0 as well.
15:44:10 <berick> since they're monthly, i don't see any need for an agenda item
15:44:42 <berick> though i don't think anyone would complain :)
15:45:46 <Dyrcona> I'm inclined to agree that they aren't needed, plus they're on the calendar.
15:46:40 <Dyrcona> Hmm. I kind botched the topic for the next item in the agenda, and I got my answers already.
15:47:20 <Dyrcona> Unless anyone has anything else to discuss/ask about Evergreen releases, we'll move on...
15:48:16 <Dyrcona> #topic Translations: Should we include metadata changes or not?
15:48:26 <Dyrcona> This is new business.
15:48:44 <Dyrcona> I added this to the agenda before I really understood the process.
15:49:06 <Dyrcona> I am pretty sure that I've had my questions answered on this topic.
15:49:48 <Dyrcona> Does anyone have any questions about translations?
15:51:11 <kmlussier> Other than how do they work? No. ;)
15:51:19 <Dyrcona> :)
15:51:45 <Dyrcona> Well, I might have messed some up at the beta because I tried adding everything at once instead of in two steps.
15:52:07 <Dyrcona> Since dbwells updated that part of the 2.8 release instructions, things became clearer to me.
15:53:01 <Dyrcona> Since I'm just babbling...
15:53:07 <Dyrcona> #topic New Business
15:54:50 <Dyrcona> And, my server picks now to go nuts.....
15:55:06 <Dyrcona> Anyone feel railroaded by how I'm conducting the meeting?
15:55:14 <Bmagic> servergonuts++
15:56:48 <jboyer-isl> No. (That I don’t have much input on any of the current topics is unrelated to running a tight meeting)
15:57:30 <Dyrcona> Does anyone have anything to discuss?
16:00:04 <kmlussier> Just wanted to mention that I am behind schedule in scheduling a Bug Squashing Day. I usually try to schedule one between beta and full release, but I don't think that's happening
16:01:59 <Dyrcona> Ok. I'll adjourn the meeting hearing nothing else.
16:02:03 <Dyrcona> #endmeeting