14:00:32 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:32 <pinesol_green> Meeting started Thu Sep  3 14:00:32 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:32 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:39 <bshum> I know how to add more penalty calculation.  I'm not sure tackling fallthrough on holds matrix would be better... :\
14:00:51 * bshum disappears so that DIG can do without my insanity.
14:00:54 <yboston> #info agenda link: http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_meeting_20150903-agenda
14:00:56 <Stompro_home> #info Stompro_home is Josh Stompro LARL MN
14:01:06 <Christineb> #info Christineb is Christine Burns BC Libraries Cooperative
14:01:06 <yboston> #topic Introductions
14:01:13 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:27 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library
14:01:41 <alynn26> #infor alynn26 is Lynn Floyd, Anderson County Library
14:01:50 <Bmagic> #info Bmagic = Blake GH, MOBIUS - Missouri Evergreen
14:03:33 <yboston> #topic Updates from Content Coordinators
14:03:52 <yboston> I don't think we have any coordinators here now
14:04:07 <yboston> will move on, maybe kmlussier can chime in later
14:04:22 <yboston> #topic last meeting's action items
14:04:30 <yboston> #info 1) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:04:42 <yboston> will postpone for next meeting...
14:04:55 <yboston> #action kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:05:08 <yboston> #info 2) Stompro will create LP bug for teaching the release notes creation bacth file(s) to handle .adoc file suffuxes
14:05:15 <yboston> this was done
14:05:22 <yboston> any comments/questions?
14:05:42 <Stompro_home> lp 1482336
14:05:43 <pinesol_green> Launchpad bug 1482336 in Evergreen "create_release_notes.sh include .adoc files" (affected: 1, heat: 6) [Undecided,New] https://launchpad.net/bugs/1482336
14:05:55 <alynn26> yea! now i do not have to remember to change the file extension:
14:06:12 <kbutler> stompro_home++
14:06:22 <yboston> regretfully I think the code still needs to be updated for the release ntoes creations cript?
14:06:23 <alynn26> stompro_home++
14:06:26 <yboston> *script
14:07:04 <alynn26> one step at a time
14:07:07 <yboston> yes
14:07:14 <yboston> shoudl I move on?
14:07:38 <yboston> moving om
14:07:54 <yboston> #info 3) remingtron will continue testing conversion of all .txt files to the .adoc extension
14:08:21 <yboston> will postpone, because I am not sure if he is around today/now
14:08:34 <yboston> #action remingtron will continue testing conversion of all .txt files to the .adoc extension
14:08:45 <yboston> #info 4) kmlussier will send out an email to DIG list to request updates on unfinsished 2.8 new features
14:08:50 <yboston> this was done
14:08:54 <yboston> kmlussier++
14:09:12 <alynn26> kmlussier++
14:09:15 <yboston> which leads to the next past action
14:09:22 <yboston> #info 5) kmlussier will follow up with direct emails to request updates on unfinsished 2.8 new features or to ask for works in progress
14:09:37 <yboston> not sure if kmlussier did this yet
14:09:49 <yboston> did anyone get a direct email?
14:09:58 <kbutler> I did not, but I had been at the meeting.
14:10:10 <yboston> good
14:10:12 <alynn26> I didn't but i was not expecting one
14:10:13 <kbutler> (I put links to my stuff on the wiki earlier today, so am now actually done)
14:10:25 <yboston> kbutler++
14:10:39 <alynn26> kbutler++
14:10:57 <yboston> #info here is the link to the 2.8 needs http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.8_needs
14:11:53 <yboston> kbutler: do you mind sending an email to the DIG list anouncing that you shared your work with us?
14:12:03 <kbutler> yboston: sure, I can do that.
14:12:33 <yboston> that email will serve as a reminder for me, or somene else, to push it into the docs
14:12:52 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:12:58 <yboston> for now I will postpone kmlussier action item
14:13:01 <remingtron> (sorry so late)
14:13:07 <yboston> ¡¡¡¡¡hooolaaa!!!!
14:14:07 <yboston> remingtron: I already covered your action item about testign out the new suffix
14:14:17 <yboston> I just posponed it for next time
14:14:30 <remingtron> yeah, I haven't done anything with it, so I'm glad you postponed it
14:14:30 <yboston> did you have any updates, or just stick to it being postponed?
14:14:35 <yboston> cool
14:14:44 <yboston> should I move on?
14:14:47 <remingtron> sure
14:15:32 <yboston> #action kbutler will send an email to the DIG list anouncing she posted her 2.8 work for a DIG memebr to add to docs?
14:15:50 <yboston> darn, missed the question mark
14:16:31 <yboston> BTW, anyone here with some 2.8 docs in progress, please send your partial work to the DIG list
14:16:39 <Stompro_home> I started adding links to my in progress work for the older items I'm commited to work on.  After the discussion at the last meeting.
14:17:18 <remingtron> Stompro_home++ #sharing your work
14:17:31 <yboston> Stompro: do you mind sumarizing your link edits to the DIG list
14:17:44 <yboston> I hope it helps to foster collaboration
14:18:05 <Stompro_home> Sure, I will do that.
14:18:49 <yboston> #action Stompro will send a list to DIG list summarizing the 2.8 docs work he has so far shared
14:19:24 <yboston> let me quickly postone my one task
14:19:36 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:19:44 <pinesol_green> [evergreen|Jason Stephenson] LP#1491962 Fix 0847 Live Test - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=12a4f8d>
14:19:55 <yboston> my bad, did not get to it, did get good feedback from DIG at last meeting
14:20:33 <remingtron> when we're ready, I want to add an item to the agenda
14:20:39 <yboston> yes, go ahead
14:20:50 <remingtron> documenting Evergreen 2.9 new features
14:21:12 <remingtron> I haven't thought about it at all, but 2.9 RC is out and that means 2.9.0 is soon!
14:21:20 <yboston> remingtron++
14:21:24 <Stompro_home> remingtron++ I was wondering about that also.
14:21:53 <remingtron> #link http://evergreen-ils.org/documentation/previews/RELEASE_NOTES_2_9_RC.html
14:22:10 <remingtron> there's the release notes, which should include all the new features
14:22:33 <yboston> one thing we need is to create the 2.9 new features DIG wiki page
14:22:58 <remingtron> I can do that today
14:23:13 <yboston> we probably also need to see if we can schedule a hackfest to document new features
14:23:17 <yboston> remingtron++
14:23:40 <yboston> #action remingtron will create the 2.9 new features needing docs wiki page
14:23:48 <remingtron> DIG hackfest always helps make progress
14:24:12 <yboston> remingtron++
14:24:27 <yboston> we can send out a doodle poll to try to narrow down possible dates/times
14:24:28 <alynn26> remingtron++
14:24:38 <yboston> any volunteers to create a doodle poll?
14:24:54 <yboston> you get to come up with dates/times tht work for you, you get to decide tie brakers :)
14:25:15 <jihpringle> I can do it if you give me a general sense of when we want to do it
14:25:16 <yboston> (sorry for my spelling/grammar when I type fast)
14:25:29 <yboston> jihpringle++
14:26:26 <alynn26> Approximently when do we want to do this?
14:26:27 <yboston> let me look over the calendar
14:27:02 <yboston> is it me, or have we often ended up doign things on Fridays?
14:27:18 <kbutler> I think that is true.
14:27:43 <yboston> for the record, EG 2.9.0 is currently scheduled to be released on September 16th
14:27:49 <alynn26> The hackaway is Nov 4th-6th.
14:28:05 <yboston> alynn26++
14:28:19 <remingtron> I'm game to try a DIG hackfest before the 16th
14:28:23 <yboston> me too
14:28:28 <remingtron> to keep the spirit of "document everything before it's released"
14:28:43 <yboston> remingtron++
14:28:46 <Stompro_home> There is the angularjs hack day on the 17th also to think about.
14:28:57 <remingtron> Stompro_home: good reminder
14:28:58 <alynn26> remingtron++
14:29:02 <jihpringle> I'll put out a poll today with dates for the next two weeks
14:29:16 <remingtron> jihpringle: that's sounds great
14:29:27 <yboston> darn, I somehow missed the note on when angular day was
14:29:38 <yboston> was it on the dev list? or just on IRC?
14:29:50 <remingtron> yboston: just during a dev meeting, I think
14:30:00 <yboston> remingtron++
14:30:18 <yboston> darn, I have been attending those
14:30:31 * Dyrcona will add Angular day to the calendar.
14:30:34 <yboston> so jihpringle are you all set?
14:30:38 <yboston> Dyrcona++
14:30:43 <jihpringle> yes
14:30:47 <yboston> merci
14:31:04 <alynn26> jihpringle++
14:31:15 <Stompro_home> jihpringle++
14:31:15 <yboston> #action jihpringle will create a doodle poll for scheduling a DIG ahckfest for 2.9 features
14:31:25 <yboston> remingtron: BTW
14:31:43 <remingtron> jihpringle++
14:31:54 <yboston> remingtron: did you plan to moe the pre 2.8 feature list from the 2.8 page and move it to the new 2.9?
14:31:57 <yboston> just curious
14:32:03 <yboston> *move
14:33:42 <yboston> any other comments or questions about 2.9?
14:34:08 <remingtron> yboston: yes I'll move all old undocumented stuff to the new 2.9 page
14:34:17 <remingtron> including incomplete 2.8 stuff
14:34:22 <yboston> ahh
14:34:31 <remingtron> so each new 2.X page becomes the new master docs needs page
14:34:38 <yboston> very nice
14:34:45 <remingtron> until we find a better way :)
14:34:53 <yboston> :)
14:35:07 <alynn26> :)
14:36:03 <yboston> we are just past the 30 minute mark, did we want to stay on 2.9 or move to old busniess?
14:36:19 <yboston> we can talk about web client docs; re-org
14:36:22 <Stompro_home> the 2.8 page is dead, long live the 2.9 page.
14:36:31 <yboston> Stompro++
14:36:41 <yboston> we can also tackle something new
14:37:09 <remingtron> I'll email the DIG list once the 2.9 page is live, and I'll request that everyone consider working on one before hackfest day to start momentum
14:37:15 <remingtron> thoughts?
14:37:32 <yboston> remingtron: I was going to mention something like that about starting early
14:37:41 <yboston> at least for those that may not be able to make the date
14:37:48 <yboston> remingtron++
14:37:52 <Stompro_home> Sounds good to me.
14:37:59 <alynn26> That works for me.
14:38:15 <yboston> before I forget, let me repeat somethign we talked about last meeting
14:38:22 <remingtron> and I'd recommend making 2.9 stuff the top priority, then continuing with 2.8 and older stuff
14:38:33 <yboston> remingtron++
14:38:47 <yboston> when we do a DIG hackfest, we need to make sure we share our works in progress
14:38:55 <yboston> at the end of the session
14:39:08 <yboston> makes it easier to finish loose ends later on
14:39:14 <alynn26> yboston++
14:39:16 <remingtron> yboston: yes! thanks for repeating!
14:39:18 <remingtron> yboston++
14:39:31 <kbutler> yboston++
14:40:18 <yboston> muchas gracias
14:40:44 <yboston> let me repaste the meetbot "ideas" from last meeting
14:41:30 <yboston> #idea encourage volunteers to submit links to their works in progress on the relevant DIG wiki page
14:41:30 <yboston> #idea possible palces to store works in progress to allow linking back to content include: dropbox, Google docs/drive, Github forks, Github Gists
14:41:31 <yboston> #idea come up with guidelines/suggestions for how to store works in progress or finsished work for DIG to access later on
14:41:32 <yboston> #idea always ask volunteers to share works in progress at the end f DIG hackfest or DIG hack-a-ways
14:42:16 <yboston> remingtron: did I give you an action item for the 2.9?
14:42:35 <yboston> I see it now, I did
14:43:03 <yboston> any other comments or questions?
14:43:47 <jihpringle> for the hack-a-way anyone hosting onsite or entirely online?
14:44:25 <yboston> jihpringle: oops, that is a key question
14:44:49 <alynn26> i would say online with the short turnarround.
14:45:17 <yboston> I have hosted before in Boston, but that of course is not convinient for most folks
14:45:28 <jihpringle> I've sent out the poll so that info will go in a follow up when the date is announced on Tuesday
14:45:29 <remingtron> I can't dedicate a whole day, so I'll be online
14:46:05 <yboston> I agree with alynn26, with this short notice it will probably have to be online
14:46:33 <jihpringle> anyone in the eastern timezone willing to host the hangout or whatever we want to use?
14:46:41 <yboston> dependign on the date that we vote on I can try to book a confernece room here
14:46:47 <yboston> I can host one
14:47:34 <jihpringle> I'll let email you Tuesday morning with the chosen date and we can send a follow up email to the list with connection details
14:48:01 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC (extremely late!)
14:48:11 <yboston> ¡¡¡hooolaaaa!!!!
14:48:13 <alynn26> WElcome
14:48:36 <kmlussier> Hi!
14:48:50 <remingtron> FYI, Monday is an American holiady (Labor Day), so many folks won't be at work
14:49:01 <yboston> good point
14:49:03 <remingtron> (this Monday, Sept 7)
14:49:13 <Christineb> it is a Canadian holiday as well :D
14:49:24 * kmlussier will be at the beach, but can try documenting from there. :)
14:49:37 <jihpringle> I said to the by Monday incase anyone ended up doing the poll on the weekend
14:49:37 <alynn26> Yeah, that going to work.
14:49:55 <jihpringle> otherwise everyone has to complete the poll tomorrow
14:50:41 <remingtron> jihpringle: sounds good
14:51:40 <yboston> good
14:51:49 <yboston> so, to recap
14:52:04 <yboston> 1) we already have a 2.9 hackfest poll out
14:52:07 <yboston> jihpringle++
14:52:28 <yboston> 2) we will soon have a 2.9 docs needed wiki page
14:52:39 <yboston> with 2.9 features as the priority
14:53:05 <yboston> 3) we have folks that have shared their 2.8 works in progress
14:53:14 <yboston> kbutler++ Stompro++
14:53:20 <remingtron> #link http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:2.9_needs
14:53:29 <yboston> remingtron++
14:53:53 <yboston> which means we can start signing up for 2.9 taks early
14:54:06 * kmlussier quickly grabs edit rights on the page so that she can volunteer for conditional negative balances.
14:54:29 <yboston> also, if you make any progress, please preemptively share your work and label the feaure as yours
14:54:33 * remingtron trips over kmlussier's edit rights
14:54:34 <yboston> kmlussier++
14:55:11 <yboston> BTW, during the hackfest we can try to sneak in talk about re-org and web client docs
14:55:25 <kmlussier> remingtron: It's all yours
14:55:31 <yboston> we are down to 5 mins
14:55:37 <yboston> any final questions or comments
14:55:58 <remingtron> yboston: none from me
14:56:02 <kmlussier> I have something
14:56:32 <yboston> go ahead
14:56:59 <kmlussier> I need to scale back on some of my community commitments this year. Therefore, I think it's best if I step down as DIG release coordinator. I'll still be active in DIG, but I need to reduce some of my commitments.
14:57:36 <yboston> thanks for the update
14:57:42 <kmlussier> It's a great role for somebody to take if they are familiar with documentation and also stay up to date with new features and bug fixes going into Evergreen.
14:57:48 <yboston> we will need to find a replacement, even if it takes mreo than one person
14:57:52 <yboston> to equal you :)
14:58:01 <kmlussier> Ha!
14:58:18 <yboston> we need like 2 developers and at least one librarian
14:58:40 <kmlussier> One thing I need to do is document what I've done with this role to make it easier for somebody to do it. And then, of course, they can expand upon it. :)
14:59:00 <remingtron> kmlussier: yes please!
14:59:11 <yboston> shoudl I give you an action item?
14:59:20 <kmlussier> If nobody volunteers, I also have some specific people in mind that I can reach out to.
14:59:26 <kmlussier> yboston: Sure, go ahead.
15:00:24 <yboston> #action kmlussier will document the general wokflow for being DIG release coordinator
15:00:40 <yboston> BTW, we are at the 1 hour mark
15:01:01 <yboston> I can go a bit longer, or we may want to stop here for now?
15:01:31 <yboston> OK, I vote to end now
15:01:45 <remingtron> yboston: +1
15:01:58 <alynn26> +1
15:02:09 <jihpringle> +1
15:02:11 <yboston> kmlussier:  you can mention your stepping down on the list to see if anyone wants to volunteer
15:02:19 <kmlussier> yboston: OK, will do
15:02:57 <yboston> #action kmlussier will send email to list about stepping down as release coordinator; and will ask for volunteer replacement
15:03:21 <yboston> OK folks, will wrap up in a 10 seconds unless there is any final commetns/questions
15:04:04 <yboston> #endmeeting