14:00:53 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:53 <pinesol_green> Meeting started Thu Oct  1 14:00:53 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:54 <jeff> i.e., the differences between a brand new copy and a newly-okay-status copy for hold targeting purposes are slim to none, last i looked.
14:01:02 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20151001-agenda
14:01:07 <dbs> jboyer-isl: not in this case, create_time 2015-09-18, request_time 2015-09-22
14:01:11 <yboston> #topic Introductions
14:01:13 * dbs shuts up
14:01:20 <yboston> Please feel free to start introducing yourselves...
14:01:26 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:40 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:01:42 <Christineb> #info Christineb is Christine Burns @ BC Libraries Cooperative / Sitka
14:01:58 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:29 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library (Hudson, NH)
14:03:22 <yboston> welcome everyone
14:03:24 <yboston> #topic Updates from Content Coordinators
14:03:37 <yboston> I don't think we have any contner coordinators present
14:03:57 <yboston> kmlussier may be around, but she is the process of stepping down
14:04:11 <yboston> *in the process
14:04:22 <yboston> I will move on
14:04:52 <yboston> #topic previous meeting action items
14:04:59 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:05:28 <yboston> kmlussier: did you have anything to add about the lrelease?
14:05:40 <kmlussier> nope
14:05:45 <yboston> OK
14:05:53 <yboston> #info 1) kmlussier will complete the marc stream importer work and check on the status of the RDA docs
14:06:42 <yboston> kmlussier: shoudl I defer this task for next meeting?
14:06:51 <kmlussier> No progress, but maybe we can get one of those off my plate. I think the status of the RDA docs came from last year's hackaway where jihpringle was working on them.
14:07:05 <kmlussier> But I don't think they ever were added.
14:07:50 <yboston> I can defer but not under your name?
14:08:05 <yboston> or just added to one of our to do lists?
14:08:17 <yboston> *add it
14:08:47 <kmlussier> You can defer it then.
14:09:02 <remingtron> jihpringle: any idea if your work was shared anywhere?
14:09:04 <kmlussier> I didn't know if she was around right now.
14:09:28 <yboston> #action need a volunteer to complete the marc stream importer work and check on the status of the RDA docs
14:09:40 <jihpringle> I'm not sure, I would have to go digging - I think it was around some of the cataloguing content we have in the Sitka manuals that isn't in the docs
14:10:13 <yboston> should I asign an action item for  looking into this?
14:10:44 <jihpringle> sure
14:11:26 <Stompro> #info Stompro is Josh Stompro LARL
14:11:43 <yboston> sorry my phone wrang
14:12:29 <yboston> how about this… "jihpringle will research the state of missign RDA content"
14:12:34 <jihpringle> perfect
14:12:51 <yboston> #action jihpringle will research the state of missign RDA content
14:12:57 <yboston> movign on
14:13:07 <yboston> #info 3) kbutler will send an email to the DIG list anouncing she posted her 2.8 work for a DIG memebr to add to docs?.
14:13:15 <yboston> I beleive this was done(?)
14:13:30 <kbutler> Yep, I did that.
14:14:03 <remingtron> kbutler++
14:14:16 <yboston> can't remmber if it has been pushed yet
14:14:29 <kbutler> That I do not know. I totally forgot to look.
14:14:44 <yboston> I can look into it
14:15:07 <yboston> #action yboston will check that kbutler recenlty shared work has been pushed to the repo
14:15:29 <yboston> #info 4) Stompro will send a list to DIG list summarizing the 2.8 docs work he has so far shared
14:16:08 <Stompro> Hmm, I don't think I did this... but I've been keeping all my work in Gists that I link to the doc needs page.
14:16:28 <Stompro> I've got too many in progress now, I need to finish some up.
14:16:28 <yboston> no worries
14:16:42 <Stompro> Going live on the 26th, so I'm not sure I'll have time for a month or two.
14:17:11 <yboston> let us know on the list or directly if there are things that are deady to be pushed
14:17:12 <remingtron> Stompro++ #for sharing via gists
14:17:21 <yboston> *ready
14:17:26 <Stompro> Hehe, Deadly to be pushed. I like it.
14:17:39 <kmlussier> Stompro: Good luck with the go live!
14:17:43 <Stompro> Thanks
14:18:13 <yboston> Stompro++
14:18:25 <yboston> moving on
14:18:34 <yboston> #info 5) yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:18:37 <yboston> will need to defer
14:18:49 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:19:00 <yboston> #info 6) remingtron will create the 2.9 new features needing docs wiki page
14:19:01 <yboston> done
14:19:10 <remingtron> yup
14:19:11 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.9_needs
14:19:25 <remingtron> and it has the backlog from previous versions at the bottom
14:19:30 <remingtron> so it's the master page
14:19:48 <yboston> BTW, shoudl we pull the "backlog" stuff from the 2.8 page
14:19:55 <yboston> so it only apperas on one page?
14:20:00 <yboston> *appears
14:20:10 <remingtron> great idea
14:20:18 <remingtron> I'll do that right now...
14:20:23 * kmlussier needs to update her assignment on that page.
14:20:43 <yboston> #action should I bother with an actionitem?
14:21:01 <kmlussier> Heh
14:21:10 <yboston> oops
14:21:12 <yboston> also, make sure that the two versions have not diverged
14:21:27 <yboston> I wonder how I can erase an action item?
14:22:33 <remingtron> #action yboston will erase the previous action item from the record
14:22:34 <remingtron> :)
14:22:41 <yboston> :)
14:23:24 <yboston> #action remingtron will remove "backloged" features missing docs from 2.8 docs needs, so they only appear in the 2,9 doc needs
14:23:35 <yboston> moving on
14:23:44 <yboston> #info 7) jihpringle will create a doodle poll for scheduling a DIG hackfest for 2.9 features
14:23:49 <yboston> this was done, thanks!
14:24:00 <yboston> moving on
14:24:01 <remingtron> jihpringle++
14:24:09 <yboston> jihpringle++
14:24:11 <yboston> #info 8) kmlussier will document the general wokflow for being DIG release coordinator
14:24:21 <yboston> defar?
14:24:23 <kmlussier> yes
14:24:26 <yboston> defer?
14:24:39 <yboston> #action kmlussier will document the general wokflow for being DIG release coordinator
14:24:46 <yboston> moving on
14:24:50 <yboston> #info 9) kmlussier will send email to list about stepping down as release coordinator; and will ask for volunteer replacement
14:24:52 <kmlussier> One of the reasons I need to step down is because I don't have time, which means I apparently don't have time to find a need release coordinator or document processes. :(
14:25:15 * kmlussier will really do it before the next meeting
14:25:19 <yboston> we need to clone you
14:25:30 <yboston> moving on
14:25:32 <Stompro> Or digitize & copy.
14:25:36 <kmlussier> No, really. My clone would just volunteer for more stuff.
14:25:57 <yboston> so we are done with the previous meeting action items
14:26:50 <remingtron> discuss 2.9 remaining items?
14:26:55 <yboston> looks like the three major topics to cover overall are:  2.9 doc needs; web docs; docs re-org
14:27:16 <yboston> remingtron: yes that is a good topic to address now
14:27:51 <yboston> first off all thanks to every one that helped out for the hackfest
14:28:45 <yboston> just looking over the 2.9 page to refresh my memory
14:28:54 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.9_needs
14:29:50 <yboston> I see 9 completed items
14:30:18 <yboston> I see two items labeled in progress
14:30:41 <yboston> sorry 3 in progress
14:31:09 <yboston> Also see that Lynn signed up for an item, but I don't see a progress report on that page at this point
14:31:47 <yboston> at this point we should all volunteer for the pending 2.9 new features that need docs
14:32:15 <yboston> woudl someone like to volunteer to alert the others on the list of the need for a new push for 2.9 new features?
14:32:24 <remingtron> some of them may not need docs, or may be very small changes
14:32:40 <yboston> good point
14:33:31 <Stompro> I'll take the selfcheck inactivity warning since I've been trying to update the selfcheck docs.
14:33:37 <jihpringle> I can send the email to the list (but probably won't have time to volunteer for any more 2.9 docs)
14:33:49 <yboston> Stompro++
14:33:55 <yboston> jihpringle: works for me
14:34:38 <yboston> #action jihpringle will send out an email to the list to ask DIG memebers to sign up for pending 2.9 new featutres
14:34:39 * kmlussier should start documenting new features while she's testing them.
14:35:17 <yboston> remingtron: about deciding if a new feature/release not entries needs docs. maybe we can team up to make that assesment together?
14:35:37 <yboston> remingtron: so we can save volunteer time?
14:35:52 <remingtron> yboston: yes, I can help with that
14:36:05 <yboston> cool
14:36:54 <yboston> #action yboston & remingtron will asses which 2.9 new features do not require new documentation
14:37:11 <yboston> I'll send you an email
14:37:18 <Stompro> If anyone wants to test out the adding adoc to the release notes commit, that would be appreciated.   LP 1482336
14:37:19 <pinesol_green> Launchpad bug 1482336 in Evergreen "create_release_notes.sh include .adoc files" [Undecided,New] https://launchpad.net/bugs/1482336
14:38:30 <yboston> #action yboston will test and sign-off on Launchpad bug 1482336 - allowing release notes with ".adoc" suffix
14:38:31 <pinesol_green> Launchpad bug 1482336 in Evergreen "create_release_notes.sh include .adoc files" [Undecided,New] https://launchpad.net/bugs/1482336
14:38:46 <yboston> anything else on 2.9 new features?
14:39:21 <remingtron> regarding the .adoc conversion testing, I think we found a reason to halt
14:39:41 <yboston> the git history concern?
14:40:33 <remingtron> yes, git can track history across file name changes, but only if you use an additional command line parameter
14:41:37 <yboston> remingtron: darn, I thought it would do it automatically
14:41:54 <Stompro> How about a gradual approch, new docs and docs that get major changes should move to .adoc format.
14:42:10 <Stompro> Err, extension, not format.
14:42:44 <yboston> what is the parameter?
14:42:53 <remingtron> Stompro: yes, I think we should encourage using .adoc for new files
14:43:17 <remingtron> yboston: the parameter is --follow, like 'git log --follow'
14:43:26 <yboston> have we tested that Robert's ascidoc parsing code can handle it?
14:44:05 <yboston> remingtron: had no idea, but I am no git expert. all tutorial made it sound that renaming would "just work" if I used "git mv"
14:44:55 <remingtron> yboston: I guess it works from some perspectives, but not the git log view
14:44:56 <Stompro> yboston, when something gets included from the root.txt I don't think the parser knows what the file extension was, so it shouldn't matter.
14:45:23 <remingtron> yboston: yes, the official docs already include an .adoc file
14:45:29 <yboston> Stompro: I was just realizing that
14:45:31 <yboston> thanks
14:45:32 <remingtron> and it built fine via Robert's script
14:46:20 <yboston> I guess in the future we may want to change root.txt suffix, but I don't know how pressing that is
14:47:12 <remingtron> yboston: yeah, my conclusion so far is that it isn't pressing, so let's use the gradual approach (new files get .adoc extension)
14:47:46 <remingtron> I'd rather focus on 2.9 features first
14:48:16 <yboston> I agree
14:48:25 <yboston> just thinking out loud
14:48:55 <yboston> BTW, before I forget I had two things to bring up
14:48:58 <remingtron> yboston: thanks for sharing your thoughts
14:49:28 <yboston> #info DIG now has a EG community VM that in the future will be used for building docs
14:50:04 <yboston> we still need to set it up. For now I am the only one with access, besides EG community sysadmins like gmcharlt
14:50:13 <yboston> gmcharlt++
14:50:19 <gmcharlt> speaking of which...
14:50:36 <gmcharlt> I've been poking around at recreating the docbook build steps
14:50:44 <remingtron> gmcharlt++
14:51:00 <gmcharlt> and per yboston's request will be giving shell access to a couple others famiilar with the main docs server
14:51:26 <yboston> gmcharlt++
14:51:38 <yboston> on a less positive note....
14:52:04 <yboston> #info the PDF docs for 2.9 and the master/dev version is not currently building
14:52:14 <yboston> you get a 404 error if you visit the link
14:52:41 <yboston> the good news/bad news of all the new content that we pushed probably broke something in the PDF build
14:53:46 <yboston> I will set a generic action item to have folks look into it
14:53:53 <remingtron> hm, guess we should email Robert to ask what errors he's seeing
14:53:59 <pinesol_green> [evergreen|Mike Rylander] Stamping upgrade script and test file - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=a9298b2>
14:54:00 <pinesol_green> [evergreen|Bill Erickson] LP#838525 libdbi DATE types translated via gmtime - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=2c42d4c>
14:54:01 <pinesol_green> [evergreen|Bill Erickson] LP#838525 DoB as date PGTAP test - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=e174b43>
14:54:02 <pinesol_green> [evergreen|Bill Erickson] LP#838525 Store date of birth as SQL DATE type - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=7159229>
14:54:11 <yboston> #action need volunteers to see why the 2.9 and the master/dev PDF is not being built
14:54:46 <yboston> #action yboston will send Robert an email to check on problems with 2.9 and master PDF
14:56:02 <yboston> I need to attend a meeting at 3 PM EST
14:56:07 <yboston> final thoughts or questions?
14:56:10 <jihpringle> is it just the MassLNC demo server running on 2.9?  (I want to include a link in the email to where people can test features to document if they don't have their own 2.9 server)
14:56:14 <kmlussier> Do we know when it stopped building?
14:56:51 <remingtron> kmlussier: not sure we have that info besides Robert
14:56:55 <kmlussier> Yes. The MassLNC demo server is running 2.9 and the ESI server is running 2.8. We coordinated this time around so that we would have the two stable releases on demo servers.
14:57:07 <remingtron> jihpringle: could point people here: http://wiki.evergreen-ils.org/doku.php?id=community_servers
14:57:23 <yboston> I use a free service that alerts me
14:57:25 <kmlussier> Ugh. I had the last doc commit.
14:57:29 <jihpringle> perfect, thanks
14:57:55 <yboston> It might have been Sunday, which does nto make much sense.
14:58:07 <yboston> I might have missed soem ealier alerts
14:58:39 <remingtron> yboston: thanks for leading, you should get to your other mtg
14:58:46 <yboston> OK
14:58:51 <yboston> was just emailing Rovertt
14:58:55 <yboston> thanks everybody
14:58:59 <yboston> #endmeeting