15:07:37 <dbwells> #startmeeting 2015-10-07 - Developer Meeting
15:07:37 <pinesol_green> Meeting started Wed Oct  7 15:07:37 2015 US/Eastern.  The chair is dbwells. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:37 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:37 <pinesol_green> The meeting name has been set to '2015_10_07___developer_meeting'
15:08:09 <dbwells> #info agenda at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:meetings:2015-10-07
15:08:31 <dbwells> #topic Introductions
15:08:50 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:08:55 <RoganH> #info RoganH = Rogan Hamby, SCLENDS
15:09:00 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:09:04 <dbs> #info dbs = Dan Scott, Laurentian University
15:10:06 <berick> #info berick = Bill Erickson, King County Lib. System
15:10:07 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:10:38 <miker> #info miker = Mike Rylander, Equinox
15:11:03 <dbwells> #topic Action Items from Last Meeting
15:11:28 <dbwells> #info Dyrcona to update README/INSTALL for master to include web staff client installation instructions for developers by 2.9.0 release date.
15:12:00 <dbwells> Dyrcona looks to be away, but pretty sure this got done.  Anyone to confirm that?
15:13:48 <dbwells> #info Status: probably done :)
15:14:18 <dbwells> #info 2) dbwells will attempt to explode berick's Password Managment and Authentication improvements
15:15:31 <dbwells> #info Status: Done.  dbwells updated the bug earlier today to note that initial tests went well, and no intends to do some limited production testing.
15:15:48 <berick> dbwells++ # again for good measure
15:15:58 <dbwells> #info 3) gmcharlt to release OpenSRF version 2.4.2 on 8 September 2015.
15:16:30 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:16:55 <gmcharlt> #info OpenSRF release most likely pushed back to the Hack-away
15:17:21 <dbwells> gmcharlt: thank you for the update
15:18:01 <dbwells> #info 4) Dyrcona to release 2.9-rc after the meeting.
15:18:17 <dbwells> #info Status: Done!
15:18:37 <dbwells> Dyrcona++ # again for good measure :)
15:19:41 <dbwells> I'm skipping the OpenSRF release update topic, since that's covered, I think.
15:19:59 <dbwells> #topic Evergreen Release Updates
15:21:26 <dbwells> I know we're running thin, but do bshum, Dyrcona, or berick have anything to say here?
15:22:32 <berick> nothing to add.  i still expect a monthly release in 2 weeks (unless there's nothing new that needs releasing)
15:22:43 <dbwells> I'll just do a quick summary update, one second.
15:22:54 <kmlussier> I think Dyrcona and bshum are both unavailable at the moment.
15:23:48 <dbwells> #info 2.9.0, 2.8.4, and 2.7.8 were all released on 2015-09-16.  Maintenance releases are scheduled for 2015-10-21.
15:24:56 <dbwells> #topic New Business
15:25:16 <dbwells> #info 1) 2.next Release Manager
15:25:35 <dbwells> any volunteers? :)
15:26:22 <gmcharlt> I am volunteering...
15:26:30 <gmcharlt> to conduct the vote :)
15:26:39 <berick> gmcharlt+- :)
15:26:44 <kmlussier> heh
15:26:50 <dbwells> I was worried about that '...'
15:26:57 <kmlussier> Ha! I thought we had a RM for a second.
15:27:04 <gmcharlt> specifically, I'm willing to do the legwork to put out the formal call
15:27:13 <dbwells> We really just need a volunteer send out a call for proposals.
15:27:13 <kmlussier> gmcharlt++
15:27:22 <gmcharlt> with an eye (say) to having the election/conformation around the itme of the Hack-away
15:27:26 <dbwells> gmcharlt++ # thanks
15:27:42 <kmlussier> Is the hack-a-way a bit late for electing the RM?
15:27:46 <kmlussier> It's a later hack-a-way than usual this year.
15:28:37 <dbwells> #action gmcharlt to do the legwork to put out the formal call for RM volunteers/proposals
15:28:53 <gmcharlt> kmlussier: it's a bit late, but not unduly so IMO
15:29:00 <RoganH> It's a little later but not outrageously so.
15:29:58 <kmlussier> I'm just thinking back to what I've heard from other RM's that it really is a short timeframe to get a release together. But you all would know better than me on that score.
15:31:51 * jeff arrives
15:32:48 <dbwells> If somebody proposes a really concrete timeline which needs the extra days, we could always expedite things.  But really, a few weeks probably won't make or break things in the end.
15:33:24 <dbwells> #info tentative plans will be to elect the next RM during the Hack-a-Way
15:33:46 <dbwells> #info 2) Evergreen hack-a-way (kmlussier)
15:34:06 <dbwells> kmlussier: you have the floor
15:34:27 <gmcharlt> (right - if this were say Koha's RM, the delay would be much more of a problem, giving the different patch review processes)
15:34:49 <kmlussier> The hack-a-way is coming up and we need to get a good handle on numbers so that we can prepare locally.
15:35:11 <kmlussier> RoganH just sent out an email with the wiki page -
15:35:11 <kmlussier> http://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2015-agenda
15:35:40 <RoganH> And kmlussier caught my sloppy non editing on it.
15:35:56 <kmlussier> We're asking attendees to add their names so that we can get a good count of who will be there.
15:36:12 <kmlussier> Also, virtual attendees are welcome to add their names there too.
15:37:28 <Bmagic> #info Bmagic is Blake GH, MOBIUS
15:37:38 <kmlussier> Hotel accommodations need to be made by the 15th to guarantee the group rate.
15:38:30 <kmlussier> We also have a Google spreadsheet where people can add their travel plans. The sooner we have that info, the easier it will be to arrange transporation.
15:38:56 <kmlussier> That's all I have. But RoganH and I are both here to answer any questions you may have.
15:39:19 <berick> https://docs.google.com/spreadsheets/d/1FsYv8wHww1eKrFUkn_Ur0s0w5-6waxZeWfTU3u6ay38/edit#gid=0
15:39:38 <kmlussier> berick++
15:39:54 <dbwells> kmlussier: Do you anticipate that virtual attendance will work well with your planned setup?  Still trying to figure out what we can do.
15:39:54 * berick will add a link to that from the wiki page
15:39:56 <RoganH> I'll add that to the wiki as well.
15:40:05 <RoganH> Or berick can :)
15:40:08 <berick> heh
15:40:17 <kmlussier> dbwells: It should be the same as we've done in previous years - a Google Hangout.
15:40:29 <kmlussier> dbwells: You won't be able to make the trip this year?
15:40:53 <RoganH> We've tried using some others and they weren't as reliable as Google Hangouts unfortunately.
15:41:01 <dbwells> kmlussier: It's unlikely :(  But still trying.
15:41:03 <jeff> and/or "just" a large block of reserved time and irc/email.
15:41:43 <kmlussier> Yeah, the large block of time is the difficult piece, isn't it?
15:42:34 <jeff> perhaps offtopic, but the travel expense is usually the killer.
15:43:03 <dbwells> kmlussier++ # Hack-a-Way planning
15:43:08 <kmlussier> jeff: Yeah, I was just about to mention that. If anyone's place of work doesn't reimburse for travel, yboston has mentioned that he has space at his place in Boston for one or two people to stay.
15:43:41 <kmlussier> It is a bit of a distance from Danvers, but I drive through Boston on my way to Danvers and could provide transportation if it's needed.
15:44:02 <kmlussier> RoganH++
15:44:11 <RoganH> kmlussier++
15:44:13 <kmlussier> RoganH been handling most of the details. :)
15:44:30 <dbwells> Well, that's all for the agenda.  Any other topics before we adjourn?
15:47:05 <dbwells> #endmeeting