14:01:51 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:01:51 <pinesol_green> Meeting started Thu Dec  3 14:01:51 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:51 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:51 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:02:02 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20151203-agenda
14:02:10 <yboston> #topic Introductions
14:02:16 <yboston> Please feel free to start introducing yourselves...
14:02:23 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:02:34 <Christineb> #info Christineb is Christine Burns BC Libraries Cooperative / Sitka
14:02:44 <jihpringle> #info jihpringle is Jennifer Pringle BC Libraries Cooperative / Sitka
14:04:31 <yboston> looks like we might have a small crowd today?
14:04:49 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:04:55 <dbs> #info dbs is Dan Scott, Laurentian University
14:05:03 <kmlussier> Sorry, I was making my lunch.
14:05:03 <dbs> (but only one eye on IRC)
14:05:43 <yboston> we have 5 and a half present. Should I proceed?
14:06:04 <kmlussier> sure
14:06:07 <yboston> OK
14:06:25 <yboston> #topic previous meeting action items
14:06:50 <yboston> #info 1)need a volunteer to complete the marc stream importer work and check on the status of the RDA docs
14:07:26 <maryj> #info maryj is Mary Jinglewski, Equinox Software
14:07:26 <yboston> unless someone here is ineterested int aking this action item I will move on
14:07:40 <kmlussier> yboston: We have a volunteer for the marc stream importer work. I just need to follow up with him.
14:08:01 <yboston> kmlussier: should I retire the action item for now?
14:08:30 <kmlussier> sure
14:08:33 <yboston> OK
14:08:34 <yboston> moving on
14:08:43 <yboston> #info 2) jihpringle will research the state of missing RDA content
14:09:20 <yboston> jihpringle: anything to add? should I just postpone until next meeting?
14:09:25 <jihpringle> sorry, we've had a crazy busy few months and I haven't had any time
14:09:34 <yboston> I wil postpone then
14:09:37 <jihpringle> I should have more time in the next month or so
14:09:50 <yboston> #action jihpringle will research the state of missing RDA content
14:10:09 <yboston> #info 3) yboston will check that kbutler recently shared work has been pushed to the repo
14:10:11 <yboston> done
14:10:13 <yboston> moving on
14:10:23 <yboston> #info 4) Codey Kolasinski of C/W MARS has volunteered to work with kmlussier on the MARC stream importer docs
14:10:46 <yboston> kmlussier: this is what you meant. should I just defer?
14:11:17 <yboston> I wil postpome it for now
14:11:23 <kmlussier> Yes, I'll see Codey next week
14:11:34 <yboston> #action Codey Kolasinski of C/W MARS has volunteered to work with kmlussier on the MARC stream importer docs
14:11:47 <yboston> #info 5) yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:11:59 <yboston> needs to be deffered
14:12:10 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:12:18 <yboston> #info 6) kmlussier will document the general workflow for being DIG release coordinator
14:12:37 <kmlussier> Defer for now, but I plan to do it before the next point release goes out.
14:12:43 <yboston> OK
14:12:57 <yboston> #action kmlussier will document the general workflow for being DIG release coordinator
14:13:05 <yboston> #info 7) jihpringle will send out an email to the list to ask DIG members to sign up for pending 2.9 new features
14:13:30 <yboston> jihpringle: anything to add? should I just defer until next meeting?
14:13:47 <yboston> or maybe this happned?
14:13:52 <jihpringle> didn't I do that ahead of the DIG hackaway?
14:14:05 <yboston> you might have, I just don't rember
14:14:09 <yboston> *remember
14:14:16 <yboston> I'll take you word
14:14:54 <yboston> I can move on
14:15:09 <yboston> #info 8) alynn26 will write to the DIG list to start discussion on DIG priorities before the next release in March
14:15:28 <yboston> since she is not here, I will defer
14:15:42 <yboston> #action alynn26 will write to the DIG list to start discussion on DIG priorities before the next release in March
14:16:03 <yboston> that is the end of the previous action items
14:16:32 <jihpringle> yboston: I just checked and the 2.9 email definitely went out ahead of the DIG hackaway so that can be marked as complete
14:16:53 <yboston> jihpringle: nice
14:17:17 <yboston> I see soem items int he "new business" section for this meeting
14:17:34 <yboston> #topic new business
14:17:48 <yboston> #info 1) Decide on January meeting date
14:18:25 <yboston> I will be flying around our usual meeting time
14:18:47 <yboston> we need to pick a differnt date or have a sustitute facilitator
14:18:58 <yboston> *substitute
14:19:21 <yboston> I can set up a doodle poll the first week of janaury
14:19:30 <yboston> *January
14:19:48 <kmlussier> A different date is okay with me.
14:19:56 <jihpringle> me too
14:20:12 <Christineb> me too
14:20:30 <yboston> #action yboston needs to create a doodle poll and share it with the list to pick a date/time for January DIG meeting
14:21:23 <yboston> #info Should we plan to have a web docs hackfest?
14:21:36 <yboston> sorry, that shoudl have said "web clients" doc
14:22:05 <maryj> No time like the present to start.
14:22:10 <kmlussier> Yes, I think we should try to get the web client circ docs into good shape for the 2.10 release.
14:22:24 <yboston> I am all for it
14:22:47 <yboston> coudl I get a volunteer to set up a doodle poll?
14:22:58 <jihpringle> I can do that
14:23:00 <kmlussier> I also started reviewing the docs Michelle Purcell submitted a while back so that those can be merged into master.
14:23:32 <yboston> jihpringle: thanks
14:23:58 <jihpringle> I'm assuming late January/February if 2.10 is scheduled for March
14:24:34 <yboston> yes
14:24:38 <yboston> I was just thinking that
14:25:52 <yboston> any thoughts from those here of when we shoudl shoot for the hackfest? or should we make the poll broad enough to see which of the two months works better for for folks?
14:26:17 <kmlussier> Could we shoot for January? Then, if there is still work to be done, we have more time to schedule another one if we need to.
14:26:39 <maryj> I agree with kmlussier. Always good to have some time to followup after a hackfest.
14:26:44 <kmlussier> I could take an action item to review/update the existing wiki page at http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:webclient
14:26:54 <yboston> kmlussier: OK
14:27:12 <yboston> lets shoot for January
14:27:32 <jihpringle> I'd prefer February over January - January is already mostly full for us
14:27:44 <yboston> #action jihpringle will carete a doodle poll for scheduling a web clients doc hackfest to happen in January
14:28:17 <yboston> jihpringle: two options
14:28:46 <maryj> suggested compromise: doodle poll for late Jan/early Feb?
14:28:51 <yboston> jihpringle: 1) make the poll cover both January and february and let the majority rule
14:29:07 <maryj> yboston++
14:29:13 <jihpringle> that works for me
14:29:30 <yboston> jihpringle: 2) I can make myself avialbale to assi your folks to have a secong mini hackfest in february
14:29:39 <yboston> *assist
14:29:47 <jihpringle> option 1 sounds good
14:29:49 <jihpringle> I'm assuming we're looking at an all day event?
14:30:08 <jihpringle> but thanks for the offer yboston
14:30:39 <yboston> let's shoot for an all dat event, but of course folks may only be able to give a hlaf day or a few hours
14:31:24 <yboston> the we shoudl plan for another hackfest to prep for the 2.10 release sometime in March
14:32:22 <yboston> any comments or questions related to this topic or in genreal?
14:32:49 <jihpringle> do we want to poll for a date for the 2.10 hackfest now as well?
14:33:06 <yboston> maybe not, since I am not sure if the date will slip
14:33:24 <yboston> #action kmlussier will update the wiki page for web client docs
14:33:49 <yboston> but we can decide that as a group if we want to start planing that hackfest
14:34:07 <yboston> let me look up the release date on the community calendar
14:35:15 <kmlussier> I don't think the 2.10 dates are on the calendar yet.
14:35:25 <yboston> BTW, looks like the calendar is not showing up on this page https://evergreen-ils.org/communicate/calendar/
14:35:29 <yboston> kmlussier: thanks
14:35:48 <yboston> so in that case I humbly suggest that we wait to plan that hackfest
14:36:24 <yboston> kmlussier: usually we can start documenting by the beta release? (I can never remember)
14:36:39 <kmlussier> The dates are in the bottom of this email http://markmail.org/message/bbdo7pf4ersxpqrb
14:36:55 <yboston> kmlussier: also, let me know if you want help with testing the documentation for docs release manager
14:36:56 <kmlussier> yboston: Yes, beta is new feature cutoff, so we can start documenting then.
14:37:15 <yboston> #link  http://markmail.org/message/bbdo7pf4ersxpqrb
14:37:39 <yboston> Schedule
14:37:40 <yboston> -------------------------------------
14:37:41 <yboston> * 5 February 2015: feature slush - at this point in the release, all
14:37:42 <yboston> significant feature branches should have LP bugfixes and pull
14:37:44 <yboston> requests. I would reserve the right to bump any new feature branches
14:37:45 <yboston> that come in after this date to the fall 2016 release.
14:37:47 <yboston> * 19 February 2015: feature freeze - no non-bugfix patches to be pushed
14:37:48 <yboston> * 25 February 2015: beta release
14:37:49 <yboston> * 10 March 2015: release candidate
14:37:50 <yboston> * 17 March 2015: 3.0.0 released
14:38:11 <yboston> to recap...
14:38:39 <yboston> we have convered plans for web client docs, we started thinking of 2.10 new features
14:39:04 <yboston> another general topic that matters is thinking about a docs reorganization when we have time
14:39:31 <yboston> we might need to have samples of reorg docs ready to further that discussion
14:39:38 <yboston> which we don't have right now
14:40:04 <yboston> any comments or questions on this or any topic?
14:40:10 <maryj> yboston, may I ask in what way might the docs be reorganized?
14:40:22 <yboston> maryj: excellent question
14:40:46 <yboston> here is the link for that project
14:40:49 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014
14:40:55 <maryj> thank you, yboston!
14:41:14 <yboston> there has been a desire to reorganize the docs for various reasons
14:41:52 <yboston> one common reason is to split the docs to have parts meant for server admins versus front line staff
14:42:42 <yboston> some want to split the docs so that we have sections just for highly techinical unix/DB system adminsitrators versus Evergreen adminstrators
14:43:26 <yboston> hope this makes some sense so far
14:44:21 <maryj> yboston, it makes total sense. Seems to be the #1 request when I'm visiting EG libraries - break it down by role.
14:44:31 <jihpringle> maryj there are a few suggestions here: http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:comments
14:44:43 <maryj> jihpringle++
14:44:44 <jihpringle> that page is linked to the one yboston posted
14:45:32 <yboston> jihpringle++
14:46:05 <yboston> we might want to plan another meeting just to talk about re-organization in 2016
14:46:07 <maryj> I don't have any further questions about the reorg except may if there is interest in establishing a timeline for this?
14:46:36 <maryj> Has anyone thought about including this as an Evergreen conference panel/informal meeting/etc?
14:47:15 <jihpringle> I think it would be a good topic for the conference
14:47:27 <maryj> Definitely.
14:48:09 <yboston> I was thinking that we spend an hour during the conference docs hackfest on it (if not more time than that)
14:48:38 <jihpringle> yboston ++
14:48:42 <maryj> yboston - you may need to bring some sticky notes.....
14:48:45 <maryj> yboston++
14:49:06 <yboston> #idea meet about docs reorganization during DIG hackfest at next conference
14:49:21 <jihpringle> it may also be an idea to tie the re-org to the web client docs
14:49:50 <jihpringle> since we're going to be editing most of the content anyways
14:49:53 <yboston> jihpringle: wow, that is a great idea
14:51:21 <kmlussier> I think the key is to create the docs in small enough chunks so that they can be easily reorganized at any time.
14:51:32 <yboston> I wil make this an action item, to keep discussing using the web client docs as an excuse to think about/try a docs re-org
14:51:33 <kmlussier> Or you could organize them in a couple of ways at the same time.
14:52:34 <yboston> #action yboston will add agenda item fro discussing docs re-org tied to web cleint docs
14:52:38 <maryj> I wonder if a tag heirarchy could be implemented for each small chunk of documentation so you could remix them into the different types of organizing that kmlussier is talking about....
14:53:43 <phasefx> just curious, is it easy to do "Did you know?" style sidebars, etc. with asciidoc
14:53:45 <yboston> maryj: I am not 100% sure what you mean by "tag heirarchy"
14:54:40 <maryj> Heirarchy might be a wrong term; better term might be "controlled vocabulary" for the tags.
14:54:45 <maryj> ^yboston
14:54:47 <yboston> maryj: though with AsciiDoc we can create smoll docs files that we include in the main docs. There shodl not be an issue in puling the same content twice. For exmaple, if we are mocking up experiments
14:55:13 <kmlussier> phasefx: You can do admonition blocks. Not sure it's really the same thing.
14:55:18 <maryj> yboston: okay! No worries, whatever is simpler. :)
14:55:51 <kmlussier> Hey, look, they have something called sidebar blocks. Never tried that. http://www.methods.co.nz/asciidoc/chunked/ch16.html
14:56:59 <phasefx> kmlussier: that looks similar to what I had in mind, at least one of the examples in their documentation.  Was musing use of those for more technical tidbits
14:57:14 <phasefx> An Example Sidebar
14:57:30 <yboston> phasefx: technical tidbits have always been a concern
14:57:34 <kmlussier> phasefx: I sometimes use the TIP admonition block for "Did you know?" type things.
14:58:12 <yboston> BTW, we are basically at the 1 hour mark
14:58:30 <yboston> we should start wrapping up soon
14:58:58 <maryj> Are there further new business items, yboston?
14:59:25 <yboston> no more new busniess
14:59:33 <yboston> *business
14:59:50 <yboston> any final questions or comments on this or any other topic?
15:00:13 <maryj> nope; will be mulling things over until the next meeting
15:00:40 <yboston> Ok folks, thanks for coming
15:00:44 <yboston> jihpringle++
15:00:57 <yboston> (for your volunteering)
15:01:00 <yboston> #endmeeting