14:01:17 <yboston> #startmeeting 2015-12-18 - Evergreen for academics monthly meeting.
14:01:17 <pinesol_green> Meeting started Fri Dec 18 14:01:17 2015 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <pinesol_green> The meeting name has been set to '2015_12_18___evergreen_for_academics_monthly_meeting_'
14:02:00 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen_for_academics:2015-12-18
14:02:12 <yboston> please start introducing yourselves
14:02:20 <Christineb> #info Christineb is Christine Burns BC Libraries Cooperative / Sitka
14:02:23 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music
14:02:25 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:02:36 <yboston> #chair kmlussier
14:02:36 <pinesol_green> Current chairs: kmlussier yboston
14:02:38 <mdriscoll> #info mdriscoll is Martha Driscoll, NOBLE
14:02:39 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:02:41 <jeffdavis> #info jeffdavis is Jeff Davis, BC Libraries Cooperative
14:03:09 <jlundgren> #info jlundgren is Jeanette Lundgren, C/W MARS
14:03:22 <krvmga> #info krvmga = Jim Keenan, C/W MARS
14:03:24 <jihpringle> #info jihpringle is Jennifer Pringle BC Libraries Cooperative / Sitka
14:04:13 <yboston> Hello everyone. Today we will focus on the topic of reserves
14:04:28 <krvmga> a favorite!
14:04:33 <yboston> and kmlussier will lead the way with my help (if needed)
14:04:44 <kmlussier> Hi everyone! :)
14:04:55 <sandbergja> I'm excited!
14:05:30 <kmlussier> I thought it would be good just to start with a general discussion on how people are handling reserves with Evergreen since it doesn't have specific reserves functionality. What are you all using?
14:05:41 <krvmga> syrup
14:06:22 <mdriscoll> syrup
14:06:23 <krvmga> the course reserves software created by art ryno
14:06:32 <krvmga> (sp?)
14:06:41 <Christineb> one of our libraries uses "bookbags" created by laurentian
14:06:48 <sandbergja> We are indexing professor name and course number in MARC fields for searching, and then using item buckets/copy editor to move 'em around and apply appropriate circmods
14:06:49 <kmlussier> Just a note that the Syrup course reserves system lives at http://git.evergreen-ils.org/?p=Syrup.git;a=summary
14:06:57 <kmlussier> #link http://git.evergreen-ils.org/?p=Syrup.git;a=summary
14:07:59 <yboston> we use a homemade reserves system using PHP and MySQL. It orignally was meant to work with Horizozn, but then we updated it to work with EG by using direct DB calls. It mostly just uses a copy's barcode
14:08:42 <kmlussier> Christineb: When you say you're using bookbags from Laurentian, what exactly does the code do to work with the bookbags in Evergreen?
14:09:04 <kmlussier> Also, I know there's a link to that code somewhere, but I can't recall where it is
14:09:39 <jeffdavis> The code is here (more or less): https://github.com/dbs/library
14:09:49 <kmlussier> jeffdavis++ #Thanks!
14:09:58 <jeffdavis> Based on my question to dbs the other day, Laurentian themselves are using a newer, Python-based homegrown app.
14:10:01 <jeff> dbs stated yesterday that Laurentian now uses https://github.com/dbs/course-reserves
14:10:05 <kmlussier> #link https://github.com/dbs/library
14:10:18 <Christineb> old post from Dan Scott - https://coffeecode.net/archives/250-Current-state-of-academic-reserves-support-for-Evergreen.html
14:10:48 <kmlussier> #link https://github.com/dbs/course-reserves
14:11:01 <jeffdavis> The app that we are using is just a PHP + SQLite web app for recording & searching course name, instructor name, and a link to an Evergreen bookbag that contains the materials on reserve.
14:12:02 <kmlussier> Oh, I see. So the code creates the listing page, but then the bookbags themselves are just typical Evergreen bookbags. Is that right?
14:12:15 <jeffdavis> yep
14:13:52 <kmlussier> sandbergja: Could you explain your process a little more. The copies themselves are attached to the MARC record for the course rather than a record with bib information?
14:14:32 <kmlussier> Also, if other people have questions, feel free to ask them.
14:15:30 <sandbergja> Sorry, I wasn't clear.  We take an ordinary MARC record with bib information, and add course information to it in custom 9xx fields.
14:15:39 <sandbergja> Here's an example: http://libcat.linnbenton.edu/eg/opac/record/507772?expand=marchtml#marchtml
14:15:59 <sandbergja> 971 field contains our professor's name, and 972 contains the title of the course
14:16:13 <kmlussier> mdriscoll and krvmga can chime in, but in broad strokes, Syrup is a third-party system, but it tightly integrates with Evergreen so that it can look up instructors from the Evergreen database and then look up copies by barcode when adding them to the course.
14:16:27 <jeffdavis> sandbergja: Do you have a custom search index for those fields?
14:16:48 <sandbergja> jeffdavis: yes -- it was set up before my time
14:17:19 <kmlussier> sandbergja: Ah, I see now. When titles go off of reserves then, do you need to remove those local fields?
14:18:02 <sandbergja> Yes, in theory.  I suspect that we miss a few, though. :-)
14:18:03 <kmlussier> #info C/W MARS and NOBLE are using Syrup
14:18:28 <mdriscoll> sandbergja: are you able to get circulation stats by professor?
14:18:38 <kmlussier> #info A library in Sitka uses code from dbs that creates a course listing for reserves that are kept in bookbags
14:18:53 <horganl> I was just wondering if users are satisfied with the functions currently provided locally.  We are a noble library using syrup and like it pretty well except we would like it more integrated into evergreen
14:19:04 <sandbergja> mdriscoll: Yes, I was able to put together something in the reporter.
14:19:22 <krvmga> horganl: this is what we'd like to see as well
14:19:48 <kmlussier> #info Linn-Benton Community College uses MARC record with course information in local fields and manages copy parameters in buckets
14:20:06 <kmlussier> #info Berklee uses a homemade reserves system using PHP and MySQL
14:21:36 <kmlussier> Yes, to add on to what horganl is asking, are your local solutions working for you? What works well or doesn't work well? And, generally, would you like to see more baked-in functionality in Evergreen or are you okay with what you're doing now?
14:21:46 <kmlussier> Sorry, lots of questions in one post.
14:22:25 <jeffdavis> The one library using reserves at Sitka is reasonably satisfied AFAIK, but I think potential new members of the consortium would be happier with a more integrated reserves module (it's the kind of think post-secondary libraries ask about when they're looking at an ILS).
14:23:32 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:23:35 <kmlussier> jeffdavis: Yes, I agree that a more integrated reserves module would make Evergreen more attractive to academic libraries.
14:23:48 <mdriscoll> We use a seperate installation of syrup for each consortia member so from a sysadmin point of view it is cumbersome to do that, especially when it comes to updates.
14:24:08 <remingtron> #info Calvin College is using Syrup, with several customizations and bug fixes
14:24:30 <sandbergja> We're pretty happy with ours, but it does rely on a lot of staff time.
14:24:43 <horganl> And you can not look at the data at the item level from within syrup
14:25:49 <kmlussier> remingtron: I would love to see what you have for customizations and bug fixes sometime. For a future discussion.
14:26:13 <remingtron> kmlussier: sure, happy to discuss sometime.
14:26:17 <krvmga> mdriscoll: we do the same in C/W MARS. it can be a bit of a maintenance nightmare
14:26:56 <jeffdavis> Are there other limitations/missing features with Syrup that folks are running into?
14:27:29 <jeffdavis> (Not to get into a long discussion of bugs or whatever.)
14:27:54 <kmlussier> jeffdavis: What I hear most is we want something that better supports consortium the way Evergreen does and overall tighter integration.
14:28:09 <mdriscoll> We have run into issues with muli-branch libraries using one instance of Syrup.
14:28:23 <kmlussier> Usually, when there's a problem, it boils down to the fact that, as much as we've integrated it with Evergreen, it still is really a separate system.
14:28:49 <jeff> Can anyone elaborate what is meant by "tighter integration" or how you'd like to look at "data at the item level from within syrup"?
14:29:28 <mdriscoll> I would define tighter integration as using the existing evergreen tables wherever possible instead of duplicating copy data, user data etc.
14:29:31 <kmlussier> jeff: From my perspective, I would like to see course reserves baked into Evergreen using Syrup as its foundation.
14:30:37 <kmlussier> jeff: I think we could make integration tighter in other ways while keeping it a third-party system, but I think I would rather see it as something you can enable with a setting or two (or more).
14:31:37 <jeff> glossing over things like shared tables / reduced time to set up, what kinds of things are not possible currently?
14:33:12 <horganl> When you look at the item you can tell it is on reserve by the copy location but not for what course, instructor, or semester.
14:33:32 <jeff> Can you give any examples of the issues with multi-branch libraries, or the problems that have boiled down to Syrup being a distinct system?
14:33:42 <jeff> horganl: Ah! Thanks!
14:34:00 <horganl> If there needs to be a change to the circ modifier you can't go there directly from clicking on the link in syrup
14:34:14 <kmlussier> As mdriscoll mentioned, we're copying data over that is already in the Evergreen database. So as things get updated in Evergreen, they don't get updated in Syrup, which can be confusing for staff since they retrieved the data from Evergreen and don't understand why it doesn't get updated in both places.
14:35:25 <mdriscoll> Syrup is associated with a branch so when searching for a professor, it won't find users in another org unit.  This is a problem for one of our multi-campus libraries.
14:35:49 <horganl> One of the issues with Multi-branch libraries pertains to adding the instructor.  All of our instructors have to be entered in one directory even if they teach on the other campus
14:35:52 <krvmga> mdriscoll: we have the same issue
14:36:36 <kmlussier> jeff: Does that answer your questions?
14:36:37 <horganl> It becomes a training issue for staff....
14:36:49 <jeff> kmlussier: think so! thanks for obliging!
14:37:04 <kmlussier> jeff: np
14:37:12 <jeff> kmlussier++ mdriscoll++ horganl++ krvmga++
14:37:38 <jihpringle> do people have training resources they currently use for training staff that are publicly available of that they would be willing to share?
14:37:46 <kmlussier> During the hack-a-way, some of the MassLNC folks looked at what we thought it would take to do the work to get course reserves into Evergreen.
14:37:50 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=scratchpad:course_reserves
14:38:54 <sandbergja> MassLNC++
14:39:01 <kmlussier> jihpringle: That's a good question. Does anyone have anything they can share now?
14:39:17 <kmlussier> Or maybe if something they can send to the list at a later time?
14:40:29 <sandbergja> jihpringle: here is the documentation that our circ staff uses for our custom-field workaround solution: https://docs.google.com/document/d/1t5X7E6DsIXowBBv_6Q2s0PSdnfmB6Pkdqg1rSUgw2SY/edit?usp=sharing
14:41:07 <sandbergja> as I said, ours is a time-intensive process
14:41:21 <jihpringle> thanks sandbergja
14:41:26 <kmlussier> jihpringle: I don't think it's used for training, but artunit wrote up some docs for us on Syrup at http://git.evergreen-ils.org/?p=Syrup.git;a=tree;f=docs;h=52dd2dfe05fc8ad6892053080e29251658d246e7;hb=HEAD that can be useful for seeing how it works.
14:42:03 <kmlussier> Actually, it's nicely formatted here: http://git.evergreen-ils.org/?p=Syrup.git;a=blob_plain;f=docs/syrup.html;hb=HEAD
14:42:41 <jihpringle> that's great for getting an idea of how it works, thanks
14:43:02 <horganl> Not sure our documentation is current we have changed how we do things since we came up.  One of the parts I really like about syrup is that we can control how the course and instructor appear for all records.
14:43:35 <kmlussier> What MassLNC is planning to do, hopefully with local resources, is to see if we can do the work to get course reserves as a baked-in part of Evergreen.
14:43:42 <horganl> In the past and Eng 101 course might be entered in multiple ways
14:43:51 <krvmga> masslnc++
14:44:19 <Christineb> masslnc++
14:44:32 <kmlussier> We were thinking it would entail two projects. One would be to create a reserves schema for course information and the interfaces around managing reserves.
14:44:45 <jihpringle> masslnc++
14:45:30 <kmlussier> But there is also a second project that we think will be useful to lots of sites, which is a way to store copy parameters and then easily revert them when an item is pulled off of reserves. We think this would be useful for display materials, summer reading, etc.
14:46:00 <krvmga> kmlussier: that would be useful
14:46:02 <kmlussier> Syrup already does this for us with our reserves materials, but I think its functionality extends beyond reserves.
14:47:00 <kmlussier> We have some draft requirements for the latter project, but they are already dated as I have some feedback to incorporate in them.
14:47:15 <kmlussier> But I'll share them to give you all an idea of how we envision it working http://masslnc.org/node/3181
14:48:18 <kmlussier> I had hoped to have more requirements available in time for this meeting, but I'm still working on them.
14:48:56 <kmlussier> We will be sharing them with the community as we go along, though, and I can report back at future meetings too.
14:49:31 <kmlussier> But before I leave off, I have a question. If there were just one thing that would improve your reserves workflow, whatever you are using, what would it be?
14:50:12 <kmlussier> Since we're looking at putting reserves in Evergreen, it would be good to see if we are making workflows easier for people.
14:52:11 <jihpringle> kmlussier: do you have an EG release you plan to target for the integration or is it too early for that?
14:52:24 <kmlussier> jihpringle: It's too early for that. Definitely NOT 2.10. :)
14:52:53 <krvmga> 2.12 sounds good. :)
14:53:37 <kmlussier> jihpringle: At this point, I need to finish up the functional requirements so that the tech people can look at them and give us a realistic estimate. But krvmga is probably close.
14:53:41 <yboston> so, we need to start talking about our next meeting
14:54:37 <yboston> and any action tiems that we need to identify
14:54:52 <kmlussier> yboston: Will we be doing a specific topic for the next meeting too?
14:55:10 <yboston> offically, I am not the one that decides that
14:55:32 <yboston> personally I wanted to suggest that we talk about reserves gain next time
14:55:32 <jihpringle> i really like the specific topic meeting, I think this one worked really well
14:55:41 <yboston> *again
14:55:56 <yboston> but I am open to finding another topic
14:55:56 <jihpringle> +1 course reserves
14:56:08 <yboston> also, do we want to meet again in January or wait for february?
14:56:19 <krvmga> yboston: i second that. in the meantime, everyone will have more of a chance to look at what is at the links given.
14:57:01 <yboston> so quickly, shoudl we target Janaury or february for next meerting?
14:57:19 <jihpringle> my vote is for february
14:57:34 <mdriscoll> I vote for February
14:57:39 <kmlussier> I have no opinion, but if it is January, can we do it after the 15th? That's when I'll be meeting with local folks about reserves.
14:57:46 <yboston> #action yboston will email the list with a copy of the meeting minutes
14:57:48 <krvmga> february +1
14:58:37 <yboston> could I get a volunteer to run a Doodle poll for February dates?
14:58:48 <jihpringle> sure
14:58:55 <yboston> I will email the  list witht he meeting minutes and update the wiki
14:58:56 <yboston> thanks
14:59:37 <yboston> #action jihpringle will create a doodle poll for the next group meeting in February
14:59:37 <kmlussier> Thanks yboston!
14:59:51 <yboston> also, we seem to be in agreement on reserves as the topic?
15:00:13 <krvmga> yes, it seems so.
15:00:18 <yboston> I normally like to always check with the general list, but I want to give credit to those that make it to the IRC meetings
15:00:53 <yboston> #agreed the next group meetings topic will be reserves again
15:01:04 <yboston> any final comments or questions?
15:01:11 <krvmga> yboston++
15:01:14 <jihpringle> is there a list anywhere of the regular meeting days for othergroups, DIG, EOB etc. ? nothing is on the EG calendar for feb at the moment and I don't want to double book
15:01:15 <krvmga> kmlussier++
15:01:21 <sandbergja> kmlussier++
15:01:38 <yboston> let me look
15:01:41 <kmlussier> yboston++
15:01:47 <jihpringle> thanks
15:02:13 <kmlussier> jihpringle: EOB meets regularly (can't recall the day now) so I'm sure there's something scheduled.
15:02:26 <kmlussier> Developer meeting's on the 3rd
15:02:37 <yboston> I need to add the next Board meeting, there is also a standing academics meeting in the calendar that we don't have to stick to. (We could delete that automatic entry)
15:03:03 <yboston> the Board usually meets the 3rd Thursday of the month
15:03:28 <jihpringle> good to know, thanks
15:04:08 <yboston> #endmeeting