14:00:15 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting.
14:00:15 <pinesol_green> Meeting started Wed Jan 20 14:00:15 2016 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting_'
14:00:23 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20160120-agenda
14:00:30 <yboston> #topic Introductions
14:00:38 <yboston> Please feel free to start introducing yourselves...
14:00:40 <krvmga> #info krvmga = Jim Keenan, C/W MARS
14:00:48 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:02 <sandbergja_> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:02:11 <yboston> I will wait another meeting before starting
14:03:41 <yboston> OK
14:04:02 <yboston> we have a small crew today
14:04:19 <krvmga> small crew, big hearts :)
14:04:21 <yboston> any one here planning to participate on the web client docs on Friday?
14:04:27 <sandbergja_> krvmga++
14:04:31 <yboston> krvmga++
14:04:44 <krvmga> i will not be able to :(
14:05:02 <sandbergja_> I was planning on participating to some extent, but it's a somewhat busy week
14:05:13 <yboston> thanks, just curioius
14:05:21 <yboston> *curious
14:06:07 <yboston> I'll send an email on Friday morning with some info, like the wiki page for web docs
14:06:15 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:webclient
14:07:17 <yboston> I'll go through the old action items to retire a few, and we can then discuss other topics
14:07:32 <yboston> #topic previous action items
14:07:52 <yboston> soem of them I will just postpone if the person is not here
14:07:57 <yboston> #action jihpringle will research the state of missing RDA content
14:08:08 <yboston> #action Codey Kolasinski of C/W MARS has volunteered to work with kmlussier on the MARC stream importer docs
14:08:18 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:08:22 <yboston> (my bad)
14:08:33 <yboston> #action kmlussier will document the general workflow for being DIG release coordinator
14:08:56 <yboston> #action alynn26 will write to the DIG list to start discussion on DIG priorities before the next release in March
14:09:17 <yboston> #action kmlussier will update the wiki page for web client docs
14:09:30 <yboston> #action yboston will add agenda item fro discussing docs re-org tied to web cleint docs
14:09:33 <yboston> (my bad)
14:09:49 <kmlussier> yboston: Yikes! I'll take care of that last action item by tomorrow morning at the latest.
14:10:04 <yboston> I skipped a couple past action items that I know were compelted
14:10:04 * kmlussier returns to being busy doing other things
14:10:07 <yboston> kmlussier: thanks
14:10:38 <yboston> BTW< thanks to sandbergja for starting the ball rolling again (with others) on docs re-organization
14:11:11 <yboston> any comments or questions so far?
14:11:17 <sandbergja_> Thanks!
14:11:28 <yboston> on any of the action items above or another topic?
14:11:59 <sandbergja_> I was interested in talking about reorg, but it can happen later in the meeting
14:12:06 <krvmga> me, too
14:12:47 <yboston> we can swithc to that in a second. I had a goal to talk a bit about the web client hacking and we already spoke a little abotu it
14:13:16 <sandbergja_> sounds good to me
14:13:18 <yboston> liek I said I will send out a link in the morning. I will also start a Google hangout in the morning
14:13:52 <yboston> the wiki page will have login info for a test serve that can be used to document the web client
14:14:09 <yboston> #link https://webby.evergreencatalog.com/eg/staff/
14:14:58 <yboston> I think that is about it. We might want to check in the morning to verify what everyone will work on
14:15:52 <yboston> at this point we can switch to talking about the re-org
14:16:34 <yboston> #topic docs re-org
14:16:50 <yboston> go ahead
14:16:59 <sandbergja_> I think that there was a lot of excitement when we talked about it on the mailing list
14:17:12 <krvmga> when i originally talked about this idea, i was thinking of "books" for different staff
14:17:15 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014
14:17:15 <krvmga> evergreen circ
14:17:19 <krvmga> evergreen cataloging
14:17:23 <krvmga> evergreen acquisitions
14:17:25 <sandbergja_> The tricky thing is to convert that excitement into some actual commitment to assist with the (huge) project
14:17:25 <krvmga> etc
14:17:33 <dluch> #info dluch is Debbie Luchenbill, MOBIUS (who had connection probs, sorry)
14:17:43 <yboston> (hello!)
14:18:02 <sandbergja_> krvmga: that's what I had in mind as well
14:18:13 <krvmga> great!
14:18:41 <yboston> dluch: here is a link to the IRC log starting at 2 PM EST so you can see what you missed (not much)
14:18:42 <yboston> http://irc.evergreen-ils.org/evergreen/2016-01-20#i_223787
14:18:50 <dluch> I am really excited about the re-org project!
14:18:54 <dluch> Thanks, yboston!
14:19:07 <sandbergja_> dluch: So great to hear that!
14:19:13 <yboston> sandbergja: I agree
14:19:33 <sandbergja_> What I'd like to take away from this DIG meeting: a rough idea of when we should meet to talk in-depth about the re-org process
14:19:58 <sandbergja_> I can then send out a Doodle poll and identify a time to start planning this out in earnest
14:20:38 <krvmga> sandbergja: do you have a specific interest?
14:20:42 <sandbergja_> 2) I'd also just like some general feedback on how to get more people involved in this project, and what directions we all think this project should go
14:20:56 <yboston> sandbergja_: these are all great questions
14:21:13 <dluch> Doodle poll sounds good.
14:21:14 <sandbergja_> Re: time, do you think early February would be a good time?  Should we wait a little while?
14:21:33 <krvmga> maybe, if there are people with specific interests, they can be the initial compilers of the area documentation.
14:22:24 <sandbergja_> krvmga: So perhaps at this next meeting, we can identify some participants who would be interested in compiling the cataloging section, the local sysadmin section, etc.?
14:22:38 <krvmga> sounds good
14:22:49 <yboston> early February may work, the only concern is that since we are just having a web client hack fest that soem folks may want soem more downtime
14:22:50 <sandbergja_> cool!
14:23:05 <sandbergja_> yboston: good point.
14:23:10 <yboston> we can still see the amount of energy available by the poll participation
14:23:53 <sandbergja_> that's true
14:24:41 <sandbergja_> looking at the Evergreen calendar, it looks like 2.10 Beta release is coming out at the end of February; do you think that'd impact people's availability?
14:24:45 <yboston> sadly, all of the concerns you have apply to any DIG endeavor
14:24:56 <sandbergja_> :-(
14:25:06 <yboston> sandbergja_:  yes, it will impact us :(
14:25:20 <yboston> it also impacts ANY open source project
14:25:50 <sandbergja_> well, why don't I send out a doodle poll consisting of times during weeks 2 and 3 of February
14:26:04 <yboston> then again, helpng with a re-org might come so naturaly to new folks that it could become a gateway to having more vlounteers in general
14:26:07 <dluch> Weeks 2 and 3 are perfect timing for me at least.  ;-)
14:26:43 <sandbergja_> yboston: true!  That'd be awesome!
14:26:51 <yboston> one concern I have is that it is already very hard to keep up with docuemnting new features, woudl ahte that the re-org slows us down
14:26:56 <yboston> but it might be OK
14:27:32 <yboston> I would prefer that we treat this re-org like a formal projects, at least as much as we can
14:27:53 <yboston> by laying out the key requirments and risks
14:28:19 <yboston> as well as breaking down some tasks so that new volunteers can easily contribute
14:28:30 <sandbergja_> That makes sense
14:28:53 <sandbergja_> I could draft a document with requirements, risks, and tasks on the wiki
14:29:07 <yboston> BTW< it is such a paradox the effor it takes to collect bite size documentation bugs and create easy to follow insrtuctions
14:29:11 <dluch> That would be great
14:29:38 <sandbergja_> And our first meeting could involve looking through that and some concrete planning based on that discussion
14:29:51 <yboston> sandbergja_:  make sense to me
14:30:06 <Christineb> #info Christineb is Christine Burns from BC LIbraries Cooperative
14:30:10 <Christineb> late for meeting
14:30:25 <Christineb> yboston - I plan on participating in web client doc hackaway on Friday
14:30:56 <yboston> Christineb: I was about to send you a link to the IRC log, but I think you may have seen it already
14:31:14 <yboston> here it is anyway, so you can see what we have said so far
14:31:15 <yboston> http://irc.evergreen-ils.org/evergreen/2016-01-20#i_223787
14:31:15 <Christineb> yes thank you, just catching up now
14:31:21 <Christineb> awesome thank you
14:31:28 <yboston> Christineb: excellent
14:31:48 <Christineb> Jennifer Pringle is also planning to participate in the hackaway on Friday
14:32:00 <yboston> Christineb: double excellent
14:32:12 <dluch> sandbergja_: that sounds great
14:32:32 <yboston> on the topic of the re-org, just had a crazy idea, but maybe somebody else had it already
14:32:57 <yboston> should we try to document the web client using the proposed new re-org
14:33:35 <yboston> instead of addign it in the special section of the preview? it might make things worse, but having soem new content to play with might be helpful to try out the new re-org
14:33:49 <krvmga> interesting idea
14:34:11 <sandbergja_> I'm all for having a place to try out the new re-org and making sure it works for people
14:34:19 <jihpringle> yboston++
14:34:38 <sandbergja_> yes, yboston++
14:34:40 <dluch> yes! yboston++
14:35:40 <sandbergja_> how hard would that be to achieve technically?
14:35:52 <yboston> #idea use the new re-org layout for storing the new web client docs
14:36:05 <yboston> my rough understanding is...
14:36:26 <yboston> that Robert Soulliere would need to do some config set ups on his docs server
14:36:41 <yboston> to handle a new set of templates for the new re-org
14:37:05 <yboston> though we might want to have a final decision on the re-org style before we start this, though we can just do soemtests
14:37:10 <yboston> *some tests
14:38:38 <yboston> in some ways it might not be that differnt from when Robert set ups the docs foreach new version of EG
14:39:13 <yboston> lets talk about sandbergja_ list of concers, which are very important
14:39:28 <yboston> 1) when to meet next 2) how to get more people involved
14:40:00 <yboston> I added 3) what risks shoudl we address, I would also add 4) do we have a final re-org that we can follow
14:40:33 <sandbergja_> I feel like we got some consensus around (1)
14:40:41 <yboston> any other cocnenrs or ideas that we should keep in mind, that perhaps sandbergja_ and I can add to the re-org page in preparation for the eventual re-org meeting?
14:41:00 <krvmga> i have no others atm
14:41:53 <yboston> hold on, let me see again the dev caelndar to see when DIG shoudl be working on docuemntating new features
14:44:04 <yboston> I believe that DIG could startw orkign on new features as early as Friday February 19th. That is the day of "feature freeze"
14:44:44 <yboston> I think I prefer that we meet before that, but skip th enext couple of weeks to give DIG time
14:45:32 <sandbergja_> sounds good to me
14:46:00 <yboston> sandbergja_:  go ahead and set up a poll for the next meeting
14:46:08 <yboston> concerning re-org
14:46:18 <yboston> can I add an action item for you?
14:46:22 <yboston> (sa)
14:46:25 <sandbergja_> please do!  Thanks!
14:46:27 <yboston> (sandbergja_ )
14:47:03 <yboston> #action sandbergja_ will create a doodle poll to pick a time in february to discuss docs re-org on both the DIG and general list
14:47:33 <yboston> sandbergja_: learn from y mistakes, make sure to mention a deadline for closing the poll. I often forget to mention that
14:47:51 <sandbergja_> thanks for the advice!  I'll do that!
14:48:17 <yboston> can I assing to you and or somebody else to list some requirements on the re-org wiki page?
14:48:47 <sandbergja_> Feel free to give me that action item; I'm also happy to collaborate with somebody else
14:49:40 <yboston> #action sandbergja_ will update the reorg wiki page with a list of project requirements & goals
14:50:07 <yboston> any other comments or questions on this topic?
14:50:23 <krvmga> none from me atm
14:50:28 <dluch> nope
14:50:40 <sandbergja> nope!
14:50:54 <sandbergja> thanks for facilitating this, yboston
14:51:11 <yboston> I need a moment to link to your email thread to this meeting
14:52:35 <yboston> #link http://libmail.georgialibraries.org/pipermail/open-ils-general/2016-January/012602.html  --- [OPEN-ILS-GENERAL] Early stages: re-organizing the official documentation
14:53:12 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:audience_focused_layout -- Draft of Audience-Focused Layout
14:53:47 <yboston> I wanted to get some early feedback on that draft layout fromt hsi crowd
14:53:50 <yboston> *this
14:54:19 <yboston> I see a book geared to cataloging, circulation, acquisitions
14:54:51 <yboston> are there books that we may be missing? I ask becuase I am cocnerned that we might end up with a lot of books, but maybe that is still the way to go
14:55:09 <yboston> or some books that are seprate now we might want to combine in the future?
14:55:13 <jihpringle> I think we need one on local system admin as well (closed dates editor, ect.)
14:55:21 <krvmga> i'm sure there are missing ones but i wouldn't worry about that just yet
14:55:37 <sandbergja> I agree with krvmga
14:55:42 <sandbergja> and jihpringle
14:55:45 <sandbergja> :-)
14:56:11 <sandbergja> And we will also have to figure out if we want a book for just a regular patron!
14:56:29 <dluch> Yeah, I'm with jihpringle on that, with local admin stuff
14:56:37 <yboston> I don't want to spend a lot of energy about the futurer, but I want at some point to spend time on considering the groth of the docs just so we are not blinsided by anything
14:56:38 <sandbergja> But maybe that discussion should happen at the next re-org meeting, after we have established the requirements for the project
14:57:05 <yboston> I just wanted to get a little feedback :)
14:57:46 <yboston> OK, we are almost at the hour mark
14:57:52 <yboston> any final comments or questions?
14:59:18 <yboston> OK, I will wrap up. Thank you everyone for participating
14:59:27 <Christineb> thank you
14:59:37 <dluch> Thank you!
14:59:44 <yboston> #endmeeting