14:00:41 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:41 <pinesol_green> Meeting started Thu Feb  4 14:00:41 2016 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:41 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:00:53 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20160204-agenda
14:01:02 <yboston> #topic Introductions
14:01:09 <Christineb> #info ChristineB is Christine Burns BC Libraries Cooperative / Sitka
14:01:09 <yboston> Please feel free to start introducing yourselves...
14:01:18 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:19 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:01:35 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:01:47 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:02:53 <yboston> let's begin
14:03:16 <remingtron> yboston: FYI, I just added an item under New Business to the wiki agenda
14:03:20 <remingtron> (sorry for late addition!)
14:03:30 <yboston> #topic past meeting action items
14:03:35 <yboston> (no worries)
14:03:44 <yboston> #info jihpringle will research the state of missing RDA content
14:03:52 <yboston> any updates or should I defer?
14:04:07 <jihpringle> please defer
14:04:11 <yboston> no problem
14:04:23 <yboston> #action jihpringle will research the state of missing RDA content
14:04:40 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:04:45 <yboston> I am deffering this again
14:04:47 <yboston> :(
14:04:59 <yboston> #info kmlussier will document the general workflow for being DIG release coordinator
14:05:10 <yboston> in case she is around, but if not I will defer
14:05:40 <yboston> #action kmlussier will document the general workflow for being DIG release coordinator
14:05:58 <yboston> #action alynn26 will write to the DIG list to start discussion on DIG priorities before the next release in March
14:06:18 <yboston> I am deferring Lynn action too since she is not here or on IRC
14:06:27 <yboston> #info kmlussier will update the wiki page for web client docs
14:06:33 <yboston> this was done, kmlussier++
14:06:44 <yboston> #info yboston will add agenda item fro discussing docs re-org tied to web cleint docs
14:06:48 <yboston> this was done
14:06:56 <yboston> #info sandbergja_ will create a doodle poll to pick a time in february to discuss docs re-org on both the DIG and general list
14:06:57 <yboston> done
14:07:06 <yboston> #info sandbergja_ will update the reorg wiki page with a list of project requirements & goals
14:07:07 <sandbergja> Yes!  It's Feb. 10th
14:07:10 <yboston> I beleive this was done?
14:07:22 <yboston> sandbergja++
14:07:26 <sandbergja> Yes, you can find it at http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:requirements#requirements
14:07:57 <yboston> #link https://evergreen-ils.org/communicate/calendar/
14:08:06 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:requirements#requirements
14:08:30 <sandbergja> I have to say, I was excited by the number of new folks who answered the doodle poll
14:08:35 <yboston> that is the last action item from the previous meeting
14:08:46 <dluch> #info dluch is Debbie Luchenbill, MOBIUS (late again, sorry)
14:08:56 <remingtron> welcome Debbie!
14:09:35 <dluch> Thanks!  :-)
14:09:45 <yboston> ¡hola!
14:10:04 <yboston> let's move to new items
14:10:40 <yboston> #topic new business
14:10:46 <yboston> #info discuss docs re-org and web client docs to see how they can influence the other
14:11:30 <yboston> this topic I beleive came about a discussion on IRC about using new web client docs in the re-organized version of the docs
14:11:42 <yboston> does this ring a bell to anyone?
14:12:27 <sandbergja> I think it'd be a great idea, but am not quite sure how we'd go about it
14:12:47 <sandbergja> especially since we haven't officially agreed on a new structure for the docs
14:13:02 <remingtron> I vote to keep the same structure as the current staff client docs, to help staff who are transitioning from that to the web client
14:13:09 <yboston> this is more of a long term thing or to be used as sample text
14:13:09 <remingtron> (at least at first)
14:13:15 <dluch> Oh, yeah, the discussion is starting to come to mind
14:13:17 <yboston> for the re-org
14:14:16 <yboston> my very rough idea is that when we do decide where to put "copy buckets" in the re-org docs, that we use the web client docs
14:14:23 <yboston> since by that time it might be officailly released
14:14:25 <yboston> OR
14:14:59 <yboston> if we are creating a sample version of the re-org docs to get feedback, that we may want to try out web client docs too by using that content
14:15:08 <yboston> this might be more trouble than it is worth
14:15:21 <yboston> again, we can shelve this crazy idea for now
14:15:54 <yboston> though I still wanted to keep putting the web docs in the special section we are suign now, I would not change that
14:16:15 <jihpringle> if we're going to have to touch all of the documentation while updating it for the web client (at least screenshots) it makes sense to me to re-arrange it at the same time
14:16:41 <dluch> agreed.
14:16:59 <remingtron> jihpringle: I think that would complicate the updating process a lot
14:17:40 <remingtron> maybe it's a good time, though, to be asking "Which re-org book does this section belong in?"
14:18:07 <remingtron> that would give us a rough outline for the re-org project
14:18:13 <dluch> the "web client" book would be my thought
14:18:40 <sandbergja> remingtron: I agree.  Perhaps we can start tagging specific bits of documentation with a possible audience?
14:18:42 <jihpringle> I was thinking we would add the re-documented sections to the new books as we updated them and then release the new books at the same time as the official web client release (when we drop the staff client)
14:19:54 <yboston> I think doing the re-org might be hard enough  to pull off without adding the web client element, though it was my goofy idea inthe first place
14:20:06 <yboston> at keast in the very short term for the sake of making progress witht he re-org
14:20:35 <yboston> though I am glad that my idea made a bit of sense
14:21:14 <yboston> we can shelve this for now anf bring it up at the re-org meeting
14:21:23 <yboston> or we can keep talking about it too
14:22:43 <sandbergja> Is there a way we could choose a middle road?
14:23:03 <yboston> I bet we could find something
14:23:19 <yboston> it might be more obvious after we have made more progress flshing out the plan for the re-org
14:23:22 <sandbergja> e.g. for new Web Client documentation, we request that folks add a [NOTE] saying "For Local Sysadmins" or something?
14:23:26 <yboston> as well as how far along the web client is
14:23:53 <sandbergja> and then we can grep for those when we actually do reorganizing work?
14:24:31 <yboston> that sounds like a good idea. Off the top of my head, I would use the double slash (//) which are comments in AsciiDoc
14:24:53 <remingtron> I think the current docs make it pretty easy to separate the staff client sections into re-org books
14:25:09 <remingtron> see this link for a basic outline:
14:25:12 <remingtron> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:audience_focused_layout
14:25:50 <sandbergja> remingtron: that is a good point; my idea might be more trouble than it is worth.
14:26:02 <remingtron> sandbergja: still a cool idea :)
14:28:09 <yboston> do we want to move on to remingtron other "new" topic, or stay on this topic?
14:28:31 <sandbergja> I'm happy to move on
14:29:03 <yboston> besides remingtron's topic, which is short, we can go back to the web clients or the re-org
14:29:20 <yboston> since they are the other makor topics outstanding, besides preparing for the next release
14:29:30 <sandbergja> I have some re-org questions for after remingtron's topic
14:29:39 <yboston> good
14:29:41 <yboston> #info Who will create the 2.10 Docs Needs page?
14:30:05 <yboston> remingtron: I don;t expect this to be too
14:30:07 <yboston> hard
14:30:15 <yboston> I may be able to do it
14:30:33 <yboston> unles someone wants to get some wiki editing practice and want to colaborate with me
14:30:44 <remingtron> I think kmlussier has created these pages in the past
14:30:49 <jihpringle> I'd be happy to help
14:30:58 <yboston> oops, I thought it was you
14:31:52 <yboston> remingtron: there is a page that you often update? am I crazy?
14:31:52 <jihpringle> we're about to start looking at 2.10 for our next upgrade and so will be going through our docs to update them for 2.10
14:31:58 <yboston> (don't answer)
14:32:15 <kmlussier> I'm happy to hand over that task to somebody else. I usually wait until the beta release, at which time we should know all of the features that made it into the release.
14:32:17 <yboston> jihpringle: would you like some help from me?
14:32:27 <jihpringle> sounds good
14:33:26 <yboston> for the record, the beta release is listed as Thursday, February 25 as of now
14:33:32 <yboston> but that could change
14:33:52 <jihpringle> I'll aim to create the page at the end of February, but will watch for a date change for the beta release
14:34:08 <yboston> jihpringle: to be clear, should I assign it to just you?
14:34:11 <jihpringle> yes
14:34:38 <yboston> excellent (did not think you needed help, just wanted to be sure)
14:34:50 <remingtron> One priority we should have is to provide good web client docs for anything that's "production ready" in 2.10
14:35:04 <remingtron> which at least includes the Circ Desk interfaces
14:35:06 <sandbergja> jihpringle++
14:35:09 <yboston> #action jihpringle will create the 2.10 Docs Needs page
14:35:17 <remingtron> according to this link:
14:35:18 <remingtron> #link http://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:2.10
14:35:33 <yboston> shoudl we make it an action item to have a DIG member check with the devs about what is productionr eady for 2.10?
14:36:03 <remingtron> I can't remember what gmcharlt (the release manager) said his goals were
14:36:19 <remingtron> but I think it was only circ desk use.
14:36:29 <jihpringle> will there be a web client test server for 2.10?  We're not planning to release the web client to our libraries until we make the final switch so it won't be part of our test server
14:36:47 <jihpringle> ^^ community web client test server for 2.10
14:38:03 <remingtron> Here's gmcharlt's "plan for 2.10":
14:38:06 <remingtron> #link http://georgialibraries.markmail.org/thread/wlnvqe53umjjevae
14:38:26 <yboston> we can hope that the "webby" server would get updated for us to use
14:38:58 <remingtron> which brings us back to yboston's question about checking with the devs
14:39:31 <yboston> I can volunteer to check in with the devs around the time of the beta release
14:39:32 <remingtron> I think yes, someone should probably ask gmcharlt or whomever has power over webby
14:39:47 <remingtron> yboston++
14:40:02 <jihpringle> yboston++
14:40:22 <gmcharlt> well, it won't be webby, which is primarily for testing by the funding partners for the web staff client sprints, but we can update the ESI-hosted demo server to 2.10 closer in
14:40:45 <yboston> #action yboston will check in with 2.10 release manager (gmcharlt ) about havign Webby ready for us to use and confirmation of what is produciton ready in the web client
14:41:00 <gmcharlt> strike that action item, please, per my statement above
14:41:00 <yboston> damm I typed too slow
14:41:09 <gmcharlt> heh
14:41:12 <yboston> gmcharlt: do you know how?
14:41:27 <gmcharlt> just an #info, I guess at this point
14:41:40 <yboston> OK
14:42:38 <yboston> #info webby wil not be used for 2.10 DIG work,  the ESI-hosted demo server can be updated to 2.10
14:42:55 <yboston> gmcharlt: what is the URL for that server or its nickname?
14:43:28 <yboston> anyway, any other commetns or questiosn on this topic?
14:43:41 <gmcharlt> see http://wiki.evergreen-ils.org/doku.php?id=community_servers&s[]=demo
14:43:55 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=community_servers&s[]=demo
14:43:59 <yboston> gmcharlt: thanks
14:44:19 <yboston> #link http://demo.evergreencatalog.com/
14:44:46 <yboston> OK, we have about 15 minutes left
14:44:50 <remingtron> yboston: so, a main requirement of the DIG 2.10 needs page is documenting Circ web client stuff, right?
14:45:15 <yboston> good question
14:45:33 <yboston> I think under the assumption that circ...
14:45:55 <yboston> will be productionr eady, then the circ parts of the web client would need to be documented
14:47:33 <remingtron> okay, just trying to summarize all of this in my brain
14:47:41 <sandbergja> One question about DIG 2.10 needs: gmcharlt mentioned in his plan that 2.10 would "document ways to use SIP2 more securely"
14:48:02 <sandbergja> is that something DIG should create?
14:48:11 <gmcharlt> sandbergja: that's on my todo list to write a draft of
14:48:12 <yboston> excellent queston, I noticed that too
14:48:36 <sandbergja> gmcharlt++
14:50:02 <yboston> anything else on this topic or another one?
14:50:15 <sandbergja> Planning for docs re-org meeting on Wednesday
14:50:19 <yboston> yes
14:50:34 <yboston> we shoudl probably send out a reminder for the meeting
14:50:46 <yboston> with IRC tips
14:50:58 <sandbergja> IRC_tips++
14:51:03 <sandbergja> I can send a reminder
14:51:12 <sandbergja> Also, I'm happy to facilitate that (unless yboston or remingtron would like to), but would have to learn a little bit more about MeetBot
14:51:33 <krvmga> sandbergja++
14:51:47 <yboston> #action sandbergja wil send out a reminder about the re-org meeting to the main list and DIG list
14:52:13 <yboston> sandbergja: would you like to co-lead so you can get some practice?
14:52:29 <sandbergja> yboston: that sounds great!
14:52:34 <yboston> I can train you beforehand in case you want to lead it yourself
14:53:09 <sandbergja> either way!
14:53:33 <sandbergja> I would definitely appreciate your guidance either way, yboston. :-)
14:53:34 <remingtron> I probably can't attend that meeting, but I'll read the meetbot log and related emails, etc.
14:53:50 <yboston> to be safe lets just co-lead, but reach out to me next week so we can talk about what you normally do when facilitating. the more people that learnt he better
14:54:17 <yboston> one action Item I woudl add, which I can take on
14:54:50 <yboston> is to reach out to Robert, to see what he can start on to prepare us to have a brand new configuration on the docs server to try out the re-org
14:55:02 <yboston> or somethign along those lines
14:55:05 <yboston> thoughts?
14:55:16 <sandbergja> Sounds good to me
14:55:19 <remingtron> yboston: do we already have a test DIG server?
14:55:21 <krvmga> good idea.
14:55:35 <yboston> remingtron: it is not set up
14:55:36 <gmcharlt> indeed, that's available
14:55:56 <yboston> I mean, not sure if all the tool chain is installed
14:56:05 <gmcharlt> and setting it up to host the reorg would be a possibility
14:56:23 <yboston> gmcharlt++
14:56:56 <yboston> gmcharlt: when could I reach out to look into this?
14:57:18 <yboston> gmcharlt: I wouldliek to get Robert involved, just to make sure we move over all of the right configs/templates
14:58:10 <yboston> anyway, we are done to a couple of meetings?
14:58:14 <yboston> any last thoughts or questions?
14:58:19 <yboston> *minutes
14:58:23 <gmcharlt> yboston: let's catch up next week
14:58:27 <yboston> OK
14:58:31 <yboston> gmcharlt++
14:58:53 <yboston> last words?
14:58:59 <remingtron> nope, thanks yboston
14:59:03 <remingtron> yboston++
14:59:05 <krvmga> famous last words?
14:59:08 <sandbergja> yboston++
14:59:14 <krvmga> yboston++
14:59:17 <yboston> adios
14:59:22 <yboston> #endmeeting