14:01:58 <yboston> #startmeeting EG Academics group meeting -- reserves
14:01:58 <pinesol_green> Meeting started Fri Feb 12 14:01:58 2016 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:58 <pinesol_green> The meeting name has been set to 'eg_academics_group_meeting____reserves'
14:02:06 <yboston> #chair kmlussier
14:02:06 <pinesol_green> Current chairs: kmlussier yboston
14:02:17 <yboston> #topic introducitons
14:02:25 <yboston> *introductions
14:02:28 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:02:40 <Christineb> #info Christineb is Christine Burns - BC Libraries Cooperative / Sitka
14:02:50 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative / Sitka
14:02:51 <Kathy> Kathy Ellerton, University College of the North, Manitoba
14:02:56 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:03:01 <yboston> #info yboston is Yamil Suarez - Berklee Colleg of Music - Boston, MA
14:03:03 <jlundgren> #info jlundgren is Jeanette Lundgren, C/W MARS
14:03:03 <mdriscoll> #info mdriscoll is Martha Driscoll, NOBLE
14:03:17 <ruthsad> Ruth Sadlier Master's College & Seminary
14:03:21 <suzanne> #info suzanne is Suzanne Paterno, NOBLE
14:03:24 <yboston> here is the agenda...
14:03:35 <yboston> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen_for_academics:2016-02-12
14:03:37 <dbwells> #info dbwells is Dan Wells, Hekman Library (Calvin College)
14:04:17 <kmlussier> Nice! We have a lot of people here today. :)
14:04:17 <Sue> #info Sue is Sue Morin, College of the Rockies Library, Cranbrook, BC, Canada
14:05:50 <kmlussier> #topic Reserves Discussion
14:06:24 <kmlussier> We had a reserves discussion at our last academic interest group meeting and talked about how different libraries are handling reserves right now.
14:07:00 <kmlussier> I mentioned at that meeting that the MassLNC folks were working on a project to move our current reserves system, Syrup, into Evergreen proper.
14:07:12 <kmlussier> Although, I'm not sure 'move' is the right word since interfaces would need to be rebuilt.
14:07:33 <kmlussier> We've made a lot of progress since that meeting in drawing up some requirements of what we would like to see and in creating mockups
14:08:01 <kmlussier> #link http://masslnc.org/node/3181
14:08:25 <Sue> COTR Library is currently using bookbags to create reserve list by course code and we then post the link on the library's homepage, seems to be working for us
14:08:50 <kmlussier> We're hoping to send these out as a formal Request for Comment from the community, but I still have some final bits and pieces I would like to finish up.
14:09:39 <kmlussier> Sue: Yup, and libraries that are using bookbags and who like the way they work will still be able to do so.
14:10:21 <kmlussier> I know there were a multitude of ways people are handling reserves.
14:11:33 <kmlussier> But I am curious to know if others might be interested in using a more fully featured reserves system if we were to build it into Evergreen.
14:12:33 <sandbergja> kmlussier: We would be!
14:12:45 <dbwells> We are definitely interested, and currently using Syrup.
14:12:46 <Sidy> Could you please explain what you mean by Fully Featured Reserves System?
14:13:16 <Anne_> We are also very interested in a full featured reserves system
14:14:06 <Kathy> We are currently changing location and checkout time period for reserves. Would be interested in a full reserves system.
14:15:13 <kmlussier> Sidy: I guess the best way to describe is to point what we've drawn up right now. We've never used bookbags to handle reserves, but some things we like about this system is that the system knows that these are reserves lists. So, for example,  when you pull up the catalog record in a normal search, users can easily see what course the item belongs to.
14:16:32 <Sidy> Thank you!
14:17:04 <kmlussier> So, I'm not sure the best way to review these requirements over IRC, but we've basically broken it up in three distinct sections.
14:17:34 <kmlussier> We have a set of admin interfaces that we see being built in AngularJS, and I tried my best to fit the style of the interfaces being built for the web client right now.
14:18:54 <kmlussier> We would basically set up departments, terms (which are tied to dates) and courses. And then each course can have a set of sections. For anyone currently using Syrup (I think dbwells is the only one here today), the section was previously called course sites in Syrup.
14:19:03 <kmlussier> But we found that terminology a bit confusing.
14:20:06 <kmlussier> There is some prelinary work that goes into setting up the Departments and courses. But, once that's done, staff would basically be adding a Term and then sections from semester-to-semester.
14:20:16 <sandbergja> kmlussier: First of all, thanks for preparing this document!
14:20:20 <kmlussier> And the items you put on reserves get added to that course section.
14:20:39 <kmlussier> sandbergja: You're welcome! I think the mock-ups can say more than I can say in here. :)
14:20:49 <sandbergja> I was wondering if there were a way to build this system to accommodate "permanent reserves"
14:21:03 <kmlussier> sandbergja: Can you explain what you mean by that?
14:21:11 <sandbergja> most of our books don't change at all term to term
14:21:43 <sandbergja> so we don't want to have to go through the workflow of taking 'em off and then putting 'em back on each term
14:22:07 <kmlussier> sandbergja: So they stay on the same section from term to term?
14:22:34 <kmlussier> And those course lits don't deviate at all?
14:22:46 <kmlussier> Sorry, that should be lists, not lits
14:22:51 <sandbergja> For many of our courses, yes
14:23:38 <suzanne> the MASSLNC approach oulw let you duplcate the sections or you could run the section for multiple terms
14:23:52 <kmlussier> sandbergja: Yes, I think that's the case with some of our academics too (maybe mdriscoll or jlundgren can confirm that for me), and I think the way we approached that was by having the easy way to roll over to the next semester.
14:25:04 <kmlussier> Yes, the first part of what suzanne is what happens when you do the term rollover. It duplicates the section, but keeps the old one there so that they're available for statistics
14:25:41 <suzanne> but the items themselves don't have to come off reserves
14:25:49 <kmlussier> But maybe what we could have is the ability to set up a term that is ongoing? Meaning it has no end date?
14:25:56 <mdriscoll> Yes our libraries want to roll material to the next semester
14:26:32 <mdriscoll> Or copy a course to another term and edit
14:27:41 <suzanne> the copying will be done by the system not by a staff member
14:27:48 <kmlussier> I'm thinking though, if you have the ability to NOT choose an end date, you could identify fall / spring terms for those courses that are not happening all the time. But you could also have a term call ongoing meaning that the title is always on reserve for that course.
14:27:49 <suzanne> which makes a "term changeoew"
14:28:06 <kmlussier> sandbergja: Do you think either of those two approaches would work?
14:28:26 <sandbergja> Yes to both!
14:28:41 <kmlussier> Excellent! :)
14:29:13 <kmlussier> Were there other thoughts or questions on how those admin interfaces would work?
14:29:30 <kmlussier> At some point, I would also like to draw up some sample workflows to go along with them.
14:30:10 <sandbergja> I'm also curious about how it looks when the same book is on reserve for different sections, but that's mainly because I don't have any experience with Syrup
14:30:34 <kmlussier> Yes, I know that happens with our libraries too.
14:31:26 <kmlussier> The title would appear on the list for each of the classes.
14:32:05 <suzanne> there;s an example on the mock ups of what the item page would look like.
14:32:13 <kmlussier> On the catalog record, we want to make sure it displays each of those classes too. And that's not something that Syrup did either. We need to make sure it doesn't clutter up the display too much.
14:32:33 <kmlussier> suzanne: Yes, but I haven't done a mock-up yet showing what it looks like for multiple courses.
14:33:01 <kmlussier> I'm curious. Is an item typically only on reserve for one or two classes, or does the number get a lot higher than that?
14:33:20 <kmlussier> Is it likely to be on reserve for 3,4 or 5 classes at the same time?
14:34:22 <sandbergja> We often have materials on reserve for 5+ sections of the same class, but usually not for several different courses
14:35:27 <kmlussier> OK, that's good to know. In looking at the mock-up we display the Course Code there.
14:36:20 <kmlussier> We had been talking here about including a mouseover there that could provide more details about the course. So there we could list the multiple sections, instructors, etc.
14:36:24 <suzanne> if there are multiples it could be a mouse over type thing or with a link for more [...]
14:36:27 <kmlussier> I had forgotten to put that piece into hte requirements.
14:36:56 <kmlussier> I saw the word "mouseover" in my notes, but I couldn't remember what we wanted to do there. It's all coming back to me now! :)
14:37:21 <kmlussier> I'll be sure to try to mock that up, because we do want to handle that display well.
14:38:58 <kmlussier> Once we move beyond the admin pieces, we are trying to incorporate the public display bits into the current catalog design as much as possible. We see a separate place to search reserves for those libraries that want to use it.
14:39:10 <sandbergja> One other question we had on our end would be initial setup of this system: would there be a way to upload CSV files of item barcodes, course sections, etc. rather than typing every single barcode into a client interface?
14:39:17 <kmlussier> And the course reserve lists themselves would basically be on our current search results page, but with some design elements removed.
14:39:59 <kmlussier> sandbergja: I think that would be doable. It might not be something to include in the first iteration, but maybe a next step in the development.
14:40:22 <kmlussier> But, since that functionality is already available in some other interface, it may turn out that it isn't a very difficult thing to add on.
14:40:48 <kmlussier> sandbergja: BTW, these are all very good ideas and questions! :)
14:40:51 <sandbergja> Good point; I just am pretty unfamiliar with Web Client capabilities at this point!
14:41:30 <suzanne> we did talk about using copy buckets to upload items and then using Item Status to add them to a course.
14:41:48 <kmlussier> suzanne: Yes, good point!
14:41:54 <suzanne> Item Status can take in a list of barcodes in a csv.
14:42:06 <sandbergja> Yes!  That sounds awesome.
14:42:34 <sandbergja> item_status++
14:43:39 <kmlussier> We see copy buckets as being a very good partner in reserves, especially for those items that go on and off reserves. They could be saved in a bucket to handle parameter udpates that may be needed. And, as suzanne mentioned, we could add those items to a reserves list and vice versa.
14:45:13 <kmlussier> Any other questions on the way the project is progressing so far? Or workflows that need to be accommodated?
14:46:08 <jihpringle> kmlussier: do you have a deadline for when you want feedback on the requirements by?
14:46:38 <kmlussier> jihpringle: Not yet. I still have work to do and, once it's done, I'll be sending out an email looking for feedback that will have a deadline.
14:46:46 <jihpringle> great
14:46:54 <kmlussier> jihpringle: If you have any further feedback, feel free to send it along at any time.
14:47:20 <ruthsad> what would happen with items that were off reserve for a semester but were not part of the circulating collection - could they remain in reserves but not be active?
14:48:18 <kmlussier> ruthsad: Well, they wouldn't be in an active course section, active meaning that it's part of a term that's happening now, so, if a user is searching for active courses, it won't show up.
14:49:13 <ruthsad> right
14:49:22 <kmlussier> ruthsad: But if you keep them in the reserves copy location, then if a student does a title search of the catalog, for example, they will show on the catalog record as being in reserves unless you change that copy location.
14:49:43 <kmlussier> The course information shouldn't display on the record, because we only want that to display if the course is active at that time.
14:50:32 <kmlussier> ruthsad: Does that answer your question?
14:50:39 <ruthsad> yes thanks
14:50:44 <kmlussier> Great!
14:51:25 <kmlussier> We're at the 50 minute point in the meeting now. Are there any other questions? I wanted to leave some time for yboston to talk about upcoming meetings and topics.
14:52:09 <sandbergja> kmlussier++
14:52:27 <Christineb> kmlussier++
14:52:34 <jihpringle> kmlussier++
14:53:11 <kmlussier> Well, thanks for all of the feedback so far! It will help us fine-tune the project.
14:53:25 <kmlussier> Also suzanne++ for serving as my backup memory on some of the questions. :)
14:53:45 <kmlussier> yboston: Do you want to take over the meeting from here?
14:54:06 <yboston> I need a moment
14:54:29 <kmlussier> I could do a song and dance in the meantime.
14:54:40 <yboston> so do we want the next meeting to be about reserves again (I don't mind)
14:55:02 <yboston> also, when do we want to meet again, next months, two months from now?
14:55:42 <kmlussier> I don't know how others feel, but I wouldn't mind moving on to another topic for the next meeting.
14:56:05 <kmlussier> With the caveat that I will be sending something out to the general list shortly with our semi-final version of the reserves requirements.
14:56:20 <yboston> we can ask on the mailing list the date/time and the topic
14:56:48 <yboston> thouts?
14:56:54 <yboston> *thoughts
14:57:08 <kmlussier> If we wait two months, we'll be bumping up against conference time. It might be better to plan for something in March.
14:57:11 <Christineb> if we are discussing a new topic I think we could have the meeting sooner
14:57:11 <suzanne> that sounds good for us at NOBLE
14:57:24 <jihpringle> i'd be in favour of March as well
14:57:25 <Christineb> +1 next meeting in March
14:57:43 <suzanne> march is good here too
14:57:51 <ruthsad> March is good
14:57:59 <Kathy> March is fine.
14:58:31 <yboston> OK, sounds like march would work, we can decide the topic thorugh the email list
14:58:49 <jihpringle> yboston: do you want me to do a doodle poll to narrow down the date?
14:58:55 <yboston> sure!
14:59:02 <kmlussier> jihpringle++
14:59:13 <yboston> I can send out an email with the minutes and a call for topics
14:59:34 <yboston> #action jihpringle will create a doodle poll for decidign the academics group meeting in march
15:00:07 <yboston> any thougths if I should sent separate emails on minutes vs picking the next topic?
15:00:51 <kmlussier> I think they all could be bundled in the same email
15:00:56 <yboston> thanks
15:01:06 <yboston> OK, we reached the hour mark
15:01:19 <yboston> should we wrap up? any very final comments or questions?
15:01:21 <jihpringle> yboston: here's the poll link
15:01:23 <jihpringle> http://doodle.com/poll/gpcn6wg59hcweupm
15:01:57 * kmlussier will take the poll now rather than forgetting about it like I did last time.
15:02:19 <yboston> Ok folks, thanks
15:02:25 <yboston> #link http://doodle.com/poll/gpcn6wg59hcweupm
15:02:30 <yboston> #endmeeting