14:01:16 <sandbergja> #startmeeting docs re-org update meeting
14:01:16 <pinesol_green> Meeting started Mon Mar  7 14:01:16 2016 US/Eastern.  The chair is sandbergja. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:16 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:16 <pinesol_green> The meeting name has been set to 'docs_re_org_update_meeting'
14:01:23 <sandbergja> #chair yboston
14:01:23 <pinesol_green> Current chairs: sandbergja yboston
14:01:34 <sandbergja> Welcome, everyone!
14:01:47 <sandbergja> Here's the agenda for today's meeting
14:01:51 <sandbergja> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:agenda_2016-03-07
14:02:04 <sandbergja> Let's get started with introductions
14:02:09 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:16 <alynn26> #info alynn26 is Lynn Floyd, Anderson County Library, SCLENDS
14:02:17 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:02:32 <meme> #info meme is Meme Marlow, Worch Library Ohio
14:02:36 <Christineb> #info Christineb is Christine Burns - BC Libraries Cooperative / SItka
14:03:13 <sandbergja> Great; glad to have you all here
14:03:23 <sandbergja> #topic Updates from circulation re-org group
14:03:40 <sandbergja> I'm curious to hear about any progress or roadblock y'all have run into!
14:03:59 <Bmagic> #info Bmagic is Blake GH, MOBIUS
14:05:15 <sandbergja> It's also fine if there are no updates; I know we are all busy :-)
14:05:44 <meme> Since I was not at last one, what were we supposed to have done...
14:06:06 <meme> I am assuming you are talking about the updates from the groups?
14:06:49 <sandbergja> Yes, thanks for asking, meme.  We were going to start looking at what documentation already exists for front-line circ staff + client sysadmins
14:07:32 <sandbergja> And start putting together some tables of contents for what we'd want to see in a Front-line circ manual or a staff client sysadmin manual
14:07:51 <meme> Ok, thanks for the info...
14:08:06 <meme> I did not do that..
14:08:12 <Christineb> some links to existing documentation have been added for client sys admins
14:08:45 <sandbergja> Yeah, let's move on to looking at the client sys admin ToC
14:08:53 <sandbergja> #topic Updates from client sysadmin group
14:09:08 <sandbergja> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:system_admin
14:09:14 <sandbergja> Here's what we've come up with so far
14:09:52 <sandbergja> All the links are to existing documentation that provides a basis for what we'd like to see in a client sysadmin manual
14:10:25 <sandbergja> christineb++ jihpringle++ remingtron++ for all your help with this
14:11:45 <jihpringle> I haven't had much time to look at this so far, but looking at it today I wonder if the sys admin manual is the best place for info on building staff clients
14:12:35 <sandbergja> Good point!  Where would we like to see that information?
14:13:25 <jihpringle> in a manual aimed at sys admins outside of the staff client (not sure how to best word that)
14:13:51 <jihpringle> I just don't think that most people using the admin functions in the staff client are going to be the ones building the clients
14:14:35 <sandbergja> Good point
14:14:49 <remingtron> jihpringle: "command line" or "shell access" are keywords for server-level admin
14:15:37 <sandbergja> So maybe it should have a crosslink into the "command line" manual that says "if you are a Mac user, the instructions for building the client are here."
14:15:42 <sandbergja> or something along those lines?
14:15:54 <alynn26> I was thinking more of the lines of Staff Client Administration, and then Server-Level Administration. To me there is the dividing fact of who has command line acess.
14:16:05 <jihpringle> agreed
14:16:25 <sandbergja> That makes sense
14:16:35 <jihpringle> I think calling this one Staff Client Administration more clearly describes who it is intended for
14:17:39 <sandbergja> building a mac client does require a bunch of command line work
14:17:52 <sandbergja> although not on a server
14:18:52 <jihpringle> I suspect we will need a manual for everthing that is done outside of the staff client
14:19:04 <sandbergja> That makes sense
14:19:24 <meme> At the server level?
14:19:30 <sandbergja> So a "in-client" book and an "out-of-client" book?
14:19:41 <sandbergja> ^an "in-client"
14:19:44 <alynn26> those would include things like installing the staff Client, Troubleshooting access, and etc.
14:19:56 <krvmga> #info krvmga = Jim Keenan, C/W MARS
14:20:00 <krvmga> sorry to be late :(
14:20:14 <jihpringle> alynn26 would you include those as in or out of client?
14:20:15 <sandbergja> krvmga: no worries
14:21:14 <alynn26> install staff client - Out
14:21:26 <jihpringle> I'd put installing the staff client as in-client since staff with local system administrator perms can perform that function
14:21:28 <alynn26> Troubleshooting access - both
14:22:31 <meme> But in some libraries the installation would be handled by a differnet person as the one setting up the permissions....
14:22:39 <alynn26> maybe it should be in both locations.
14:22:57 <jihpringle> i'd vote for bothm or in one with a link to the other
14:22:58 <krvmga> it's all 1s and 0s; doesn't cost extra to do it in both places. :)
14:23:03 <alynn26> Meme that is true.
14:23:08 <sandbergja> here's another complication: the developer tools in the staff client.  Yes, they are technically in the staff client, but they are weird stuff like consoles and stuff that most local sysadmins would rarely, if ever, use.
14:23:09 <alynn26> :)
14:23:55 <sandbergja> would those be in the "in client" book or the "out of client" book?
14:24:11 <sandbergja> or both?
14:24:18 <krvmga> i'd have installed the client in the "out" book and troubleshooting the client in both
14:24:24 <alynn26> I would mainly focus things on the admin menu items, the developer tools are in a whole different location.
14:24:37 <krvmga> i agree with alynn26 on that.
14:24:39 <jihpringle> agreed
14:24:46 <meme> I think both should be in out of client as in my library anyway, the tasks are handled by differnt people
14:24:58 <meme> Trouble shooting in both though.
14:25:38 <krvmga> three are two troubleshootings: troubleshooting the installation and figuring out problems with the interface while you're working with it.
14:25:50 <krvmga> three=there (fumble fingers)
14:26:44 <meme> I think both should be in both. That way if issues while setting up in staff client can determine if in installation or interface.
14:26:50 <alynn26> Troubleshooting installation of the server, should be its own book.
14:27:17 <krvmga> alynn26++
14:27:31 <sandbergja> I guess it would be helpful to know -- as far as the client installs go -- who actually does that work in most libraries?
14:27:52 <alynn26> troubleshooting installing and connecting the staff client in both.
14:27:56 <sandbergja> Is it someone with shell access, someone who is an admin, or even just a regular person at the circ desk
14:28:05 <krvmga> i don't see a problem with having it in both places
14:28:30 <sandbergja> what about at the start of each book?
14:28:39 <krvmga> an appendix?
14:28:58 <alynn26> here it is the IT department (Me) as staff don't have that access. In other places I help with it could be anyone.
14:28:58 <sandbergja> Since acq people will also need to know how to get started with the staff client and troubleshoot if it can't connect, as will circ, etc.
14:29:47 <krvmga> a prologue, then (as in something about hobbits)
14:29:54 <alynn26> it's the registering the Workstation, that is usually done by only done by the local sys admins.
14:30:11 <jihpringle> or maybe we need a getting started book that is linked to at the beginning of all the other books
14:30:38 <alynn26> That would be a good book.
14:30:41 <krvmga> a getting started book strikes me as a good idea
14:30:43 <sandbergja> good idea, jihpringle!
14:30:50 <alynn26> jihpringle++
14:33:30 <jihpringle> I would also vote to move most, if not all, of the acq admin into the acq book (maintaining funds, providers etc.) otherwise you'll have acq staff who have to refer to two books for regular acq functions
14:34:02 <krvmga> +1
14:34:07 <Christineb> +1
14:34:25 <sandbergja> +1
14:34:33 <meme> +1
14:34:56 <alynn26> The goal I am thinking is to have it available in both locations.  We keep one set of documents, point the various locations to that same set of documents.
14:35:29 <jihpringle> we could have a page for acq admin in the staff client admin book that is just a link to the acq admin docs in the acq manual
14:35:52 <alynn26> so, when we comple the acq docs the admin functions are there, and when we compile the admin docs they are there also.
14:36:38 <sandbergja> But the tone of the docs are really focused more toward acquisitions staff, not sysadmins?
14:38:30 <alynn26> that is true, they should be as they would be the primary user of the docs.
14:38:36 <jihpringle> agreed
14:39:13 <sandbergja> Cool!  I think we are having a great discussion.
14:39:42 <sandbergja> I think we will probably have a lot of these conversations of which-book-does-it-go-in
14:39:48 <sandbergja> as this project progresses
14:40:32 <sandbergja> I did want to talk a bit about the survey; any more thoughts on the client sysadmin book, or should we move on?
14:40:34 <alynn26> especially as we move into some of the other areas Circ and Cataloging.
14:40:44 <sandbergja> alynn26, very true!
14:41:02 <sandbergja> I have to say that most of my sysadmin work is troubleshooting circ issues
14:41:11 <alynn26> Mine too.
14:41:20 <jihpringle> do we have a date by which we'd like the table of contents to be complete (at least in a draft form)?
14:41:22 <sandbergja> but most of our circ supervisor's work is also troubleshooting circ issues...
14:41:23 <alynn26> MeMe welcome back
14:42:26 <sandbergja> quick poll: does everyone think we could get a draft of the sysadmin book in the next month?
14:43:01 <meme> We can try...
14:43:40 <jihpringle> I think so
14:43:54 <krvmga> i think so
14:44:03 <alynn26> +1
14:44:21 <krvmga> i don't think i'm being overly optimistic when i say that
14:44:33 <sandbergja> So, how does everyone feel about an early April deadline for the sysadmin book, and an early May deadline for the circ book?
14:44:48 <jihpringle> sounds good to me
14:44:55 <krvmga> we've got the evergreen conference in april
14:45:10 <krvmga> that will limit my participation a bit
14:45:19 <sandbergja> Oh, yes!  Good point.
14:45:38 <sandbergja> We should also figure out a time to meet up then
14:45:46 <sandbergja> Perhaps informally?
14:45:55 <sandbergja> at the EG conference, I mean
14:46:01 <krvmga> how many of us will be at the conference?
14:46:03 <krvmga> me
14:46:05 <sandbergja> I will
14:46:16 <alynn26> me.
14:46:18 <jihpringle> I will
14:46:33 <meme> I will not be.. There will be others there from our consortium..
14:46:50 <krvmga> i think it would be great for us to get together
14:46:53 <meme> We are COOL , Consortium of Ohio Libraries
14:47:04 <krvmga> you ARE cool, meme
14:47:16 <krvmga> :)
14:47:44 <krvmga> could we get together informally one time after the official day is done?
14:48:15 <alynn26> i think that would be a good idea.
14:48:20 <jihpringle> agreed
14:48:29 <sandbergja> I like that; perhaps one of us could research the local bars/etc to find a good (fun) place to meet?
14:49:03 <krvmga> as the time gets closer, we can firm up the details
14:49:13 <sandbergja> sounds good
14:49:32 <sandbergja> let's chat about the survey really quickly
14:49:37 <sandbergja> #topic Survey
14:49:45 <jihpringle> I think the questions look really good
14:49:54 <sandbergja> me too!
14:50:00 <krvmga> me, too. i sent a couple of suggestions separately.
14:50:14 <sandbergja> alynn26: are you still up for putting it on surveymonkey?
14:50:31 <sandbergja> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:survey-questions
14:50:32 <alynn26> Yep, have a draft done already.
14:50:36 <sandbergja> nice!
14:50:41 <sandbergja> alynn26++
14:50:42 <krvmga> alynn26++
14:50:42 <alynn26> https://www.surveymonkey.com/r/GF7FFJT
14:51:06 <sandbergja> It's really pretty!
14:51:13 <meme> Wow..good job.
14:51:34 <alynn26> Any additional questions, are changes
14:52:05 <alynn26> or changes
14:52:05 <sandbergja> I think it looks great
14:52:13 <Christineb> looks great!!
14:52:23 <Christineb> alynn26++
14:52:23 <jihpringle> alynn26++
14:52:36 * krvmga opens survey
14:52:44 <krvmga> this looks really good.
14:52:48 <meme> Did you want to include the follow up comments at the end?
14:53:20 <meme> Anything else you want to say about evergreen documentation?
14:53:21 <krvmga> does #7 take care of that?
14:53:45 <krvmga> maybe it's not enough
14:53:46 <sandbergja> Not necessarily
14:53:52 <meme> I was just comparing to original..
14:54:00 <krvmga> i'm all in favor of comments
14:54:03 <sandbergja> They might have something really good to say about the docs, which they wouldn't really put in #7
14:54:21 <alynn26> That i can add.
14:54:27 <sandbergja> Thanks!
14:54:31 <krvmga> i'd be happy to see an extra unrequired comment at the end.
14:54:45 <sandbergja> How long should we keep the survey open?  Until start of April?
14:54:49 * alynn26 edits survey quickly.
14:54:58 <krvmga> are we making #7 mandatory?
14:55:11 <krvmga> not against it; just asking
14:55:17 <jihpringle> I don't think #7 should be mandatory
14:55:25 <meme> If you did early april, then you can discuss at conference
14:56:11 <sandbergja> Just spotted one other potential change.  On #4, should they be allowed to choose only one answer?
14:56:34 <krvmga> in the event there is not a lot of response, can we be flexible and leave the survey open (i.e. to some promotion at the conference)?
14:57:01 <meme> Good thinking on promoting survey at conference.
14:57:11 <jihpringle> I'd be tempted to leave it open for longer, ie. post conference
14:57:19 <krvmga> since it says "go to first"; can't go to two people first :)
14:57:30 <alynn26> I was thinking about #4 and looking at it, for me it depends on what I am looking for.
14:57:32 <krvmga> (unless they're sitting right by each other maybe :) )
14:57:45 <alynn26> Is it something I know in the docs then the docs I head to first.
14:58:00 * krvmga thinks alynn26 makes a good point.
14:58:03 <meme> Can we switch to ratings, first, second and third?
14:58:19 <alynn26> We can switch it. to ratings if you want.
14:58:27 <jihpringle> I like the idea of ratings
14:58:29 <sandbergja> +1
14:58:38 <alynn26> I made #7 not Mandatory.
14:58:42 <krvmga> meme's idea is good, i think
14:58:47 <krvmga> +1
15:00:07 <krvmga> shall we vote to release the survey into the wild after that change?
15:00:17 <sandbergja> Let's do it!
15:00:21 <jihpringle> if we want to promote it at the conference do we want the end date to be something like June 1st?
15:00:23 <meme> +1
15:00:27 <Christineb> +1
15:00:29 <alynn26> Ol, be looking for it in your email
15:00:35 <krvmga> sandbergja++
15:00:42 <krvmga> :)
15:00:53 <sandbergja> +1 to June 1st as deadline
15:01:00 <meme> +1
15:01:01 <krvmga> i'd put the end day in early May maybe
15:01:18 <krvmga> but maybe that's too soon
15:01:37 <sandbergja> Well, we can be sure to pester people to take it, and set it to early May
15:01:40 <jihpringle> if we want to promote it at the conference I think we need to give staff a few weeks after to get it out to libraries, especially in consortiu,
15:01:40 <krvmga> May 20?
15:02:01 <krvmga> that's about 4 weeks after the conference
15:02:05 <jihpringle> May 20 sounds good to me
15:02:15 <sandbergja> Any objections to May 20?
15:02:21 <meme> none..
15:02:27 <sandbergja> #agreed the survey will be due May 20
15:02:39 <sandbergja> Cool, thanks everyone for a great meeting!
15:02:47 <krvmga> thanks everyone!!
15:02:53 <sandbergja> and thanks for all your work on this project!
15:02:54 <krvmga> sandbergja++
15:02:57 <krvmga> meme++
15:02:59 <meme> Thanks...
15:03:01 <krvmga> jihpringle++
15:03:04 <jihpringle> sandbergja++
15:03:07 <krvmga> alynn26++
15:03:12 <sandbergja> #endmeeting