#evergreen: Evergreen Development Meeting, 6 April 2016

Meeting started by gmcharlt at 15:00:37 US/Eastern (full logs).

Meeting summary

    1. Agenda is http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-03-06 (gmcharlt, 15:00:45)

  1. Introductions (gmcharlt, 15:00:55)
    1. Galen Charlton, ESI (gmcharlt, 15:01:10)
    2. Jason Etheridge, ESI (phasefx, 15:01:20)
    3. Jeff Davis, Sitka (jeffdavis, 15:01:24)
    4. Kathy Lussier, MassLNC (kmlussier, 15:01:33)
    5. Rogan Hamby, ESI (rhamby, 15:01:36)
    6. Jason Stephenson, MVLC (Dyrcona, 15:01:42)
    7. Jason Boyer, ISL (JBoyer, 15:01:57)
    8. berick Bill Erickson, KCLS (berick, 15:02:26)
    9. Brahmina Burgess, Sitka (brahmina, 15:02:28)
    10. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:02:37)
    11. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:02:50)

  2. OpenSRF release (gmcharlt, 15:03:58)
    1. miker Mike RYlander, ESI (miker, 15:05:20)

  3. Evergreen release (gmcharlt, 15:06:07)
  4. Conference hackfest ideas page (gmcharlt, 15:10:52)
    1. http://wiki.evergreen-ils.org/doku.php?id=dev:hackfest:eg2016 (gmcharlt, 15:11:00)

  5. Call for Release Manager for 2.11 (gmcharlt, 15:12:26)
    1. RM nominations and self-nominations accepted through 15 April (gmcharlt, 15:12:42)
    2. Vote to be held in #evergreen week of 18 April (gmcharlt, 15:12:55)

  6. Follow-up on search discussion (gmcharlt, 15:15:15)
  7. npm is failing to install Node.js packages on Ubuntu 14.04 (gmcharlt, 15:19:01)
    1. : https://github.com/npm/npm/issues/12196#issuecomment-205855393 (Dyrcona, 15:20:37)
    2. ACTION: Dyrconra to write up bug report for nodejs installation item on Ubuntu 14.04 (gmcharlt, 15:21:04)
    3. https://github.com/nodesource/distributions also looks interesting (gmcharlt, 15:22:30)

  8. Change supported Ubuntu distros (gmcharlt, 15:22:48)
    1. https://bugs.launchpad.net/opensrf/+bug/1551090 for OpenSRF too (bshum, 15:24:05)
    2. ACTION: Dyrcona will work on Xenial Xerus Evergreen and OpenSRF support between now and the EG conference (gmcharlt, 15:25:29)

  9. Dropping Debian Squeeze support (gmcharlt, 15:28:25)
    1. https://bugs.launchpad.net/evergreen/+bug/1559121 (gmcharlt, 15:28:32)
    2. We are all agreed that nobody expect the Spanish Inquisition!!! (er, that Debian Squeeze support is to be dropped) (gmcharlt, 15:32:04)

  10. Minimum Pg version to support (gmcharlt, 15:32:18)
    1. Pg 9.1 support is deprecated as of EG 2.10.x, and will be removed in 2.11.0 (gmcharlt, 15:32:37)
    2. AGREED: PostgreSQL 9.3 will be the minimum required version for Evergreen 2.11 (gmcharlt, 15:49:44)
    3. ACTION: gmcharlt will send an email to the mailing lists announcing the Pg dependency change (gmcharlt, 15:49:58)
    4. bshum = Ben Shum (bshum, 16:03:46)
    5. Bmagic = Blake GH, MOBIUS (Bmagic, 16:04:44)
    6. ACTION: Various folks will do more detailed evaluation/testing of Sqitch prior to the EG conference, with an eye towards having more informed discussions (gmcharlt, 16:06:26)
    7. DPearl = Dan Pearl, C/W MARS (DPearl, 16:08:39)
    8. dbs = Dan Scott, Laurentian University (dbs, 16:09:14)
    9. jlitrell = Jake Litrell, MassLNC (jlitrell, 16:14:38)


Meeting ended at 16:14:42 US/Eastern (full logs).

Action items

  1. Dyrconra to write up bug report for nodejs installation item on Ubuntu 14.04
  2. Dyrcona will work on Xenial Xerus Evergreen and OpenSRF support between now and the EG conference
  3. gmcharlt will send an email to the mailing lists announcing the Pg dependency change
  4. Various folks will do more detailed evaluation/testing of Sqitch prior to the EG conference, with an eye towards having more informed discussions


Action items, by person

  1. Dyrcona
    1. Dyrcona will work on Xenial Xerus Evergreen and OpenSRF support between now and the EG conference
  2. gmcharlt
    1. gmcharlt will send an email to the mailing lists announcing the Pg dependency change
  3. UNASSIGNED
    1. Dyrconra to write up bug report for nodejs installation item on Ubuntu 14.04
    2. Various folks will do more detailed evaluation/testing of Sqitch prior to the EG conference, with an eye towards having more informed discussions


People present (lines said)

  1. gmcharlt (80)
  2. Dyrcona (35)
  3. kmlussier (24)
  4. miker (22)
  5. berick (20)
  6. bshum (17)
  7. jeffdavis (9)
  8. JBoyer (6)
  9. pinesol_green (6)
  10. jeff (5)
  11. dbs (5)
  12. brahmina (3)
  13. dbwells (2)
  14. jlitrell (2)
  15. rhamby (2)
  16. phasefx (1)
  17. krvmga (1)
  18. Bmagic (1)
  19. remingtron (1)
  20. DPearl (1)


Generated by MeetBot 0.1.4.