14:00:59 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
14:00:59 <pinesol_green> Meeting started Thu May  5 14:00:59 2016 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:59 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
14:01:20 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20160505-agenda
14:01:36 <yboston> #topic Introductions
14:01:37 <yboston> Please feel free to start introducing yourselves...
14:01:46 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
14:01:59 <Christineb> #info Christineb is Christine Burns @ BC Libraries Cooperative / Sitka
14:02:01 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:02:12 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
14:02:57 <Glen_> Hi, Glen from Ann Arbor.  Hello again!  Just sitting in.
14:03:17 <yboston> Glen_:  welcome
14:03:30 <yboston> I will wait one more minute before starting
14:04:16 <terran> #info
14:04:16 <remingtron> Glen_: welcome!
14:04:45 <terran> #info terran is Terran McCanna, PINES (just lurking)
14:04:57 <yboston> #topic last meeting's action items
14:05:05 <yboston> #info jihpringle will research the state of missing RDA content
14:05:17 <yboston> postpone or do you have somethign to report?
14:05:35 <jihpringle> postphone, I'll look into it once our upgrade is finished
14:05:49 <yboston> #action jihpringle will research the state of missing RDA content
14:05:51 <yboston> thanks
14:06:15 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the docs
14:06:31 <yboston> I am just goign to pre-emtively postpone that one :(
14:06:39 <yboston> #info kmlussier will document the general workflow for being DIG release coordinator
14:07:00 <yboston> I am not sure if she is aorund so I will postpone for now
14:07:11 <yboston> #action kmlussier will document the general workflow for being DIG release coordinator
14:07:21 <yboston> #info alynn26 will write to the DIG list to start discussion on DIG priorities before the next release in March
14:07:38 <yboston> I don’t hink Lynn is here but I am tempted to let this drop for now
14:08:08 <yboston> unless I hear otherwise I wil drop this action item
14:08:41 <yboston> the two next items were taking care of by jihpringle
14:08:59 <yboston> oen was an old doodle poll and the other was about updating the wiki page for new EG 2.10 features
14:09:06 <yboston> jihpringle++
14:09:18 <yboston> #info everyone please submit feedback to doc re-org agenda page http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:reorg_2014:agenda_2016-03-07
14:09:40 <yboston> If you have not provided feedback to thsi page feel free to do those
14:09:44 <yboston> *do so
14:10:10 <yboston> that is the end of the last meetign action items
14:10:51 <yboston> BTW, the “new business” section of the meeting agenda is outdated
14:11:02 <jihpringle> do we want to send a final reminder out to the lists about the doc reorg survey closing?
14:11:10 <yboston> sure
14:11:25 <yboston> is there someone that would like to colunteer?
14:11:32 <yboston> *volunteer
14:11:48 <jihpringle> sure
14:12:46 <jihpringle> I'll send it tomorrow and remind everyone they have two weeks left to complete it
14:12:58 <yboston> #action jihpringle will send out final reminder out to the lists about the doc reorg survey closing
14:13:02 <yboston> jihpringle++
14:13:05 <jihpringle> I have May 20th written down as the  deadline
14:13:10 <yboston> OK
14:13:16 <sandbergja> jihpringle++
14:13:40 <yboston> so under old busniess we had 2 topics and I added a third
14:13:51 <yboston> 1) Progress on Web Client docs
14:14:01 <yboston> 2) Progress on Docs Reorganization project
14:14:11 <yboston> 3) Progress on documenting late releases new features
14:14:29 <yboston> did we want to talk about the “old” business or do we want to talk about something else?
14:15:21 <yboston> on the topic of 2.10 features I am glad we put a dent on it during conference
14:15:28 <yboston> but we have more to do
14:15:45 <yboston> Here si where we stand http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.10_needs
14:16:27 <jihpringle> three more of them are complete, they're just not showing in the docs yet
14:16:30 <yboston> BTW, if anyone has partial work left over, feel free to send it in to the list
14:16:58 <yboston> if you let me/us know which ones we can update the page
14:17:08 <jihpringle> the ones we worked on at the conference
14:17:29 <jihpringle> I'll email you after
14:17:36 <yboston> thanks
14:18:13 <yboston> #action jihpringle will email yboston or maling list with 2.10 docs that were completed
14:19:19 <yboston> did we want to move on to another topic from the old busniess list, a compeltely different topic, or stay on the conference DIG work?
14:19:48 <yboston> BTW, I was really happy witht he collaboration we had going at the conference
14:20:55 <yboston> perhpas we can end early today if there is no strong need/desire to cover a particular topic right now
14:21:39 <yboston> BTW< one thing that came up from bshum is that he wants to change the wording of the attributions page
14:21:49 <yboston> LP 1578719
14:21:51 <pinesol_green> Launchpad bug 1578719 in Evergreen "Change attributions page in docs to list DIG contributors" [Low,Triaged] https://launchpad.net/bugs/1578719
14:22:10 <yboston> he mentioned it to me, and I agree the change makes sense (foolow link for more info)
14:22:19 <yboston> I just wanted to run it by the DIG group
14:22:29 <jihpringle> I think it makes a lot of sense
14:22:42 <sandbergja> Agreed
14:23:17 <yboston> sandbergja: Hello, I did not realize you were here
14:23:35 <yboston> did you want to talk about the re-org? any git comments or questions?
14:23:42 <sandbergja> just got here!
14:23:43 <yboston> I do have a git related comment for the group now that you are here
14:24:04 <sandbergja> I had some git confusion, but I think I should just work on it with you over email, yboston
14:24:05 <yboston> seems like the 2.10 HTML is not building properly
14:24:23 <yboston> the cahnges sandbergja made to the attributions page are not showing up
14:24:58 <jihpringle> do we have access to the build log for it?
14:25:28 <yboston> only Robert
14:25:43 <yboston> it is building fine on dev amd on the “docs-testing” server
14:25:52 <sandbergja> I could ask Robert to see if we can troubleshoot the issue together
14:25:53 <yboston> http://docs.evergreen-ils.org/dev/attributions.html - here is the main dev version
14:26:10 <sandbergja> I was very curious about that myself!
14:26:27 <yboston> http://docs.evergreen-ils.org/2.10/attributions.html - this is the main 2.10 version
14:26:47 <jihpringle> that explains my issue too, my additions are showing in dev
14:26:55 <yboston> http://docs-testing.evergreen-ils.org/docs/2.10/attributions.html - here is the testing 2.10
14:26:56 <remingtron> I would expect the page to be blank if there was a build error
14:27:11 <remingtron> are we sure it was backported to 2.10?
14:27:12 <yboston> I can email Robert and icnlude you all to be on the same page
14:27:30 <jihpringle> I don't know how it works for these docs, but with ours if it runs into a problem it just keeps the last version that worked
14:27:50 <yboston> yes, the commits are there, unless a newer commit somhow undud the changes. then againt he testing server grabbed it correctly
14:28:16 <remingtron> yboston: you are right, git.evergreen-ils.org shows the updated file
14:28:24 <remingtron> here's the 2.10 version: http://git.evergreen-ils.org/?p=Evergreen.git;a=blob;f=docs/attributions.txt;h=3e6c629f3d64a43b53be4ba1ac0aa110bd9d67c2;hb=rel_2_10
14:29:02 <yboston> BTW, normally I just email Robert directly and usually CC remingtron
14:29:17 <yboston> but I wanted to share my thought more openly since more folks are learning git :)
14:29:27 <jihpringle> yboston++
14:29:28 <yboston> just wanted to share my thought process
14:29:52 <remingtron> yboston: good plan
14:30:00 <remingtron> more communication is good!
14:30:02 <yboston> for example, it is helpful to check the actual doc server to make sure changes made it in
14:30:12 <sandbergja> I appreciate that!
14:30:22 <yboston> also usually when there is a problem it catch it when the PDF version does not get built
14:30:28 <yboston> but this time it is getting built
14:31:53 <yboston> I just checked the PDFs, and they are behaving like the HTML version
14:32:01 <yboston> dev has the change, but not 2.10
14:32:11 <yboston> I will set an action item
14:32:54 <yboston> #action yboston will email Robert to check in on the HTML & PDF build of the docs to see why soem changes are not shsowing up; will CC verious DIG members
14:33:52 <yboston> any other commetns or topics?
14:34:00 <yboston> FYI, I might take a minute to add some placehodler topics just for the meetbot minutes at the end of the meeting
14:34:17 <yboston> I almost forgot...
14:34:32 <yboston> gmcharlt++ gmcharlt++
14:34:58 <remingtron> yboston: I have a topic
14:35:05 <remingtron> ideas that came up at the conference
14:35:06 <yboston> for setting up the http://docs-testing.evergreen-ils.org
14:35:13 <yboston> go ahead
14:35:27 <yboston> #topic confernece ideas
14:35:32 <yboston> darn
14:36:06 <yboston> (go ahead)
14:36:18 <remingtron> #idea Add links in docs to Sitka doc videos on youtube
14:37:15 <remingtron> #idea Investigate fixing the Help menu link on the XUL client (just needs HTML help/doc files in the right place)
14:37:15 <jihpringle> I'll have a list of the ones that are still accurate for 2.10 by next week
14:38:06 <remingtron> #idea Work on integrating docs links into the Web Client
14:38:10 <remingtron> jihpringle++
14:39:26 <remingtron> here's a page explaining the XUL client help files:
14:39:28 <remingtron> #link http://wiki.evergreen-ils.org/doku.php?id=scratchpad:custom_help
14:39:56 <remingtron> That's all from me, just a bunch of ideas
14:41:36 <jihpringle> I really like the idea of getting the docs integrated into the client (whether current, web or both)
14:42:49 <yboston> I suggest that we come up with a very short proposal for the list and for robert of how we would add teh stika videos
14:43:04 <yboston> just a short write up which URL would be used and what label.
14:43:39 <yboston> are we thinking of linking tot he sitka channel or point to soemspecific videos?
14:43:48 <yboston> any volunteer(s)?
14:44:00 <remingtron> specific videos on related docs chapters, if possible
14:44:14 <jihpringle> in our own docs we're adding links to specific videos to the relevant areas of the doc
14:44:28 <yboston> sounds like I have to look at the SITKA docs
14:44:37 <remingtron> jihpringle: do you have an example docs page to share?
14:44:42 <remingtron> with a video link?
14:44:48 <jihpringle> I'm grabbing one right now
14:44:55 <jihpringle> we just started adding them on Tuesday
14:45:15 <jihpringle> http://docs.sitka.bclibraries.ca/Sitka/sitka_2_10/html/circulation-check-out.html#circ-checkout-precat
14:45:30 <jihpringle> we coded it so that the link opens in a new tab
14:45:57 <remingtron> jihpringle++
14:45:59 <remingtron> very nice
14:46:02 <jihpringle> so it's easier for the user to go back to the manual
14:46:26 <jihpringle> thanks :)
14:46:52 <yboston> jihpringle++
14:47:17 <yboston> we might need to keep track of which verison of EG the videos apply to
14:47:27 <yboston> though I don’t think that is a huge deal
14:47:39 <jihpringle> I'm currently putting together a spreadsheet to track that :)
14:48:56 <jihpringle> I'm working on figuring out which ones we made in 2.8 will still be correct for 2.10 (any videos that show functionality that wasn't changed in 2.10 we're adding to our 2.10 docs)
14:49:00 <yboston> Do you mention the version targetted int he videos? I would suggest goign forward to put a small not in the video desctipion with the version number
14:49:09 <yboston> (easier said than done)
14:49:19 <jihpringle> some of them have that in the video or the description
14:49:44 <yboston> cool
14:50:16 <yboston> I wonder how the links would behave in the PDF and epub version. I hoep they work, but I would still want to proceed if they don't
14:50:54 <jihpringle> they work in our pdf
14:50:57 <yboston> one mroe thing, does Sitka have plans to delete any older videos? concerned abotu “link rot” inthe future
14:51:03 <jihpringle> (I just tested)
14:51:09 <yboston> excellent on the testing
14:51:30 <jihpringle> no, we have no plans to delete the videos
14:51:36 <yboston> cool
14:51:52 <jihpringle> at this point we figure even it if it's not current for us it may be for someone else
14:52:01 <yboston> sitka++
14:52:06 <yboston> jihpringle++
14:52:20 <jihpringle> we may put something in the description to indicate that the videos are out of date for our members
14:52:30 <yboston> makes sense
14:52:33 <jihpringle> Christineb is the one who made most of the videos
14:52:36 <jihpringle> Christineb++
14:52:50 <yboston> Christineb++
14:53:16 <Christineb> :)
14:53:31 <yboston> any ideas of how to proceed with this idea?
14:54:04 <yboston> should we ask on the DIG list to see if anyone objects or just has any warnings?
14:54:20 <yboston> shoudl we start with a few links as a test?
14:54:29 <Christineb> We have asked our members for video suggestions - we could also ask DIG if they have any suggestions for short videos
14:54:44 <jihpringle> we should ask PINES about including their videos too
14:54:45 <yboston> shoudl we just discuss it further at the next meeting?
14:55:05 <jihpringle> I think that's a good idea
14:55:24 <jihpringle> we'll have everything organized on our end by then
14:55:37 <yboston> ok
14:56:27 <yboston> #action yboston add agenda item for discussing integrating Sitka/Pines/etc videos in the main docs for next meeting
14:56:51 <yboston> we are almost at the hour mark, any final comments or questions?
14:57:31 <jihpringle> are we going to have doc reorg meeting at some point?
14:58:06 <yboston> I think we just need to schedule one
14:58:29 <yboston> sandbergja: thoughts?
14:59:32 <Christineb> I will have more time to contribute after our upgrade
14:59:50 <yboston> looks like she is busy
15:00:02 <yboston> jihpringle: could you ping her about it?
15:00:09 <jihpringle> will do
15:00:12 <yboston> thanks
15:00:27 <jihpringle> np
15:00:34 <yboston> OK folks, I will wrap up
15:01:05 <yboston> #topic troublehoot EG 2.10 doc build
15:01:26 <yboston> #topic make changes to docs attributions section
15:01:32 <yboston> #endmeeting