#evergreen: Evergreen Developer Meeting, 1 June 2016

Meeting started by jeffdavis at 15:03:11 US/Eastern (full logs).

Meeting summary

    1. Agenda: http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-06-01 (jeffdavis, 15:03:30)

  1. Introductions (jeffdavis, 15:03:52)
    1. jeffdavis = Jeff Davis, Sitka (jeffdavis, 15:04:02)
    2. Bmagic = Blake GH, MOBIUS (Bmagic, 15:04:15)
    3. Dyrcona = Jason Stephenson, MVLC (Dyrcona, 15:04:16)
    4. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:04:18)
    5. jlitrell = Jake Litrell, MassLNC (jlitrell, 15:04:29)
    6. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:05:03)
    7. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:05:07)
    8. berick Bill Erickson, KCLS (berick, 15:05:20)

  2. Action Items from Last Meeting (jeffdavis, 15:06:31)
    1. brahmina = Brahmina Burgess, Sitka (brahmina, 15:07:37)
    2. DONE: Dyrcona to write up bug report for nodejs installation item on Ubuntu 14.04 - resolved upstream by npm folks (jeffdavis, 15:08:38)
    3. DONE: Dyrcona will work on Xenial Xerus Evergreen and OpenSRF support between now and the EG conference - thanks to Dyrcona, csharp, and bshum (jeffdavis, 15:11:10)
    4. DONE: gmcharlt will send an email to the mailing lists announcing the Pg dependency change (jeffdavis, 15:11:33)
    5. gmcharlt = Galen Charlton, ESI (gmcharlt, 15:12:01)
    6. IN PROGRESS: evaluation/testing of Sqitch (jeffdavis, 15:16:26)
    7. miker = Mike Rylander, ESI (miker, 15:16:40)
    8. ACTION: developers to continue looking at Sqitch, particularly release-building options (jeffdavis, 15:17:01)

  3. OpenSRF release (jeffdavis, 15:17:42)
    1. jeff == Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:22:13)
    2. ACTION: gmcharlt to review a few outstanding OpenSRF patches/pull requests (jeffdavis, 15:22:58)
    3. New OpenSRF releases for both 2.4 and 2.5 are expected before ALA Annual in late June (jeffdavis, 15:25:50)

  4. Evergreen release (jeffdavis, 15:28:12)
    1. ACTION: miker will email the list with a proposed schedule for 2.11 and a list of pending bugs/pullrequests (jeffdavis, 15:35:23)
    2. ACTION: dbwells will email the list with an introduction to the 2.11 release manager and buildmasters (jeffdavis, 15:35:47)
    3. ACTION: dbwells will send an introductory email to the 2.11 release manager and buildmasters (jeffdavis, 15:36:39)

  5. Defining Bug Fixes and New Features (jeffdavis, 15:38:55)
    1. https://bugs.launchpad.net/evergreen/+bug/1501781/comments/38 (Dyrcona, 15:39:32)
    2. ACTION: gmcharlt and Dyrcona to summarize results of this discussion on the wiki for future use by release maintainers (jeffdavis, 16:02:07)

  6. Mentoring new developers in the community (jeffdavis, 16:02:46)
    1. Discussion deferred to next dev meeting (jeffdavis, 16:02:53)

  7. Recent config changes affecting ingest speed (jeffdavis, 16:03:02)
    1. ACTION: dbwells to create a bug report for discussing some proposed ingest speed improvements (jeffdavis, 16:06:39)

  8. Feedback for New Features Under Development (jeffdavis, 16:10:07)


Meeting ended at 16:16:58 US/Eastern (full logs).

Action items

  1. developers to continue looking at Sqitch, particularly release-building options
  2. gmcharlt to review a few outstanding OpenSRF patches/pull requests
  3. miker will email the list with a proposed schedule for 2.11 and a list of pending bugs/pullrequests
  4. dbwells will email the list with an introduction to the 2.11 release manager and buildmasters
  5. dbwells will send an introductory email to the 2.11 release manager and buildmasters
  6. gmcharlt and Dyrcona to summarize results of this discussion on the wiki for future use by release maintainers
  7. dbwells to create a bug report for discussing some proposed ingest speed improvements


Action items, by person

  1. dbwells
    1. dbwells will email the list with an introduction to the 2.11 release manager and buildmasters
    2. dbwells will send an introductory email to the 2.11 release manager and buildmasters
    3. dbwells to create a bug report for discussing some proposed ingest speed improvements
  2. Dyrcona
    1. gmcharlt and Dyrcona to summarize results of this discussion on the wiki for future use by release maintainers
  3. gmcharlt
    1. gmcharlt to review a few outstanding OpenSRF patches/pull requests
    2. gmcharlt and Dyrcona to summarize results of this discussion on the wiki for future use by release maintainers
  4. miker
    1. miker will email the list with a proposed schedule for 2.11 and a list of pending bugs/pullrequests


People present (lines said)

  1. jeffdavis (65)
  2. gmcharlt (31)
  3. Dyrcona (26)
  4. miker (24)
  5. berick (15)
  6. dbwells (14)
  7. kmlussier (13)
  8. jeff (10)
  9. pinesol_green (6)
  10. jlitrell (1)
  11. Bmagic (1)
  12. brahmina (1)
  13. remingtron (1)


Generated by MeetBot 0.1.4.