15:01:00 <yboston> #startmeeting DIG Monthly Meeting Evergreen Documentation Interest Group (DIG) Monthly Meeting
15:01:00 <pinesol_green> Meeting started Tue Aug  9 15:01:00 2016 US/Eastern.  The chair is yboston. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <pinesol_green> The meeting name has been set to 'dig_monthly_meeting_evergreen_documentation_interest_group__dig__monthly_meeting'
15:01:08 <yboston> The agenda can be found here http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20160809-agenda
15:01:16 <yboston> #topic Introductions
15:01:26 <yboston> Please feel free to start introducing yourselves...
15:01:36 <yboston> #info yboston is Yamil Suarez @ Berklee College of Music - DIG meeting facilitator
15:01:42 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
15:01:44 <dluch> #info dluch is Debbie Luchenbill, MOBIUS/Missouri Evergreen
15:01:57 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:02:59 <yboston> BTW, Kathy said she is not able to participate today
15:03:34 <Christineb> #info Christineb is Christine Burns BC Libraries Co-op / Sitka
15:05:04 <yboston> OK, my timer went off. we can start
15:05:14 <yboston> thank you all for coming
15:05:19 <yboston> #topic last meeting's action items
15:05:31 <yboston> #info jihpringle will research the state of missing RDA content
15:05:40 <yboston> #action jihpringle will research the state of missing RDA content
15:05:45 <yboston> (since she is not here)
15:05:51 <Christineb> jihpringle - is on vacation :)
15:05:59 <yboston> very nice
15:06:03 <yboston> #action yboston will move the undocumented content of the 2.8 new feature “TPAC Discoverability Enhancements” to its own section in the doc
15:06:13 <yboston> my bad again
15:06:28 <yboston> #action kmlussier will document the general workflow for being DIG release coordinator
15:06:54 <yboston> #info jihpringle will email yboston or maling list with 2.10 docs that were completed
15:07:04 <yboston> not sure if this was done, so I will pass it forward
15:07:13 <yboston> #action jihpringle will email yboston or maling list with 2.10 docs that were completed
15:07:21 <yboston> #info yboston will email Robert to check in on the HTML & PDF build of the docs to see why soem changes are not shsowing up; will CC verious DIG members
15:07:35 <yboston> I did do this, but I forgot to check earlier to make sure nothing else had broken
15:07:46 <pinesol_green> [evergreen|Bill Erickson] LP#1587639 Vandelay authority update editor/edit_date - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=43f06ef>
15:07:47 <pinesol_green> [evergreen|Bill Erickson] LP#1587639 Vand. authority updates PGTAP - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=720cb43>
15:07:48 <pinesol_green> [evergreen|Bill Erickson] LP#1587639 Vand. authority updates release notes - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=ada5bc4>
15:07:49 <pinesol_green> [evergreen|Mike Rylander] LP#1587639 Avoid double-update of editor/edit_date - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=744c0e7>
15:08:02 <kmlussier> yboston: Looks like I find it easier to continue handling Release notes than to document the process. ;)
15:08:07 <kmlussier> Keep it on my list of action items.
15:08:30 <yboston> no problem
15:08:50 <yboston> also, I just checked and all PDf fiels are being built and are accesible
15:09:00 <yboston> that is is for past meeting action items
15:09:45 <yboston> #topic new business
15:10:08 <yboston> #info discuss integrating Sitka/Pines/etc videos in the main docs
15:10:34 <yboston> not sure if there has been any other discussion about it
15:10:54 <dluch> I was just reading about this in last meeting's minutes.  Very exciting. (I say while procrastinating editing a cataloging with parts video.)
15:11:24 <yboston> I have not looked over theminutes, though usually I try before each meeting
15:11:53 <yboston> do we want to discuss it now, I can find alink tot he original discussion in the previous meeting minutes
15:12:03 <yboston> we can also choose to discuss it on the mailing list
15:13:10 <yboston> here are the minutes…http://evergreen-ils.org/meetings/evergreen/2016/evergreen.2016-05-05-14.00.html
15:13:10 <Christineb> we have added video links to our docs - example http://docs.sitka.bclibraries.ca/Sitka/current/html/bills-adjusttozero.html
15:13:27 <dluch> It seemed like a lot of the discussion last time was on how to make sure the videos are still relevant to the current release?
15:14:09 <dluch> Christineb++
15:14:52 <yboston> Her is the raw log…http://evergreen-ils.org/meetings/evergreen/2016/evergreen.2016-05-05-14.00.log.html
15:15:39 <yboston> this link jumps stright tot he videos part...http://irc.evergreen-ils.org/evergreen/2016-05-05#i_246231
15:16:45 <sandbergja> Perhaps we could write a script that goes through all the ASCIIDoc and searches for the string "youtube"
15:17:11 <sandbergja> And then we can have somebody volunteer to look through the output of that report for each new release
15:17:37 <sandbergja> just comparing it against release notes, and investigating further if it seems like there may be a change?
15:17:40 <yboston> sandbergja: that is a pretty good idea
15:17:41 <Christineb> for our Sitka videos- we have created a spreadsheet to track the version they were created in
15:18:06 <Christineb> so when new features are released we can quickly see which videos will need to be recorded
15:18:49 <yboston> there are no easy answers for docs, havign videos is great but they add another layer to our work of making sure the docs are accurate. no good deed goes unpunished :)
15:19:13 <yboston> Christineb++ SITKA++
15:19:28 <Christineb> when we record the videos we also document our "script" this makesfuture re-records easier
15:19:38 <yboston> very ni e
15:19:42 <yboston> *nice
15:19:51 <sandbergja> Christineb++
15:19:55 <remingtron> Christineb: smart!
15:20:07 <dluch> Oh, that's very smart
15:20:29 * dluch takes notes
15:21:20 <sandbergja> also, scratch my original idea; Sitka is totally on top of it!  We'd just need to figure out a way to update the youtube links in the official docs any time Sitka changes youtube links
15:21:26 <yboston> to play devil’s advocate, is this going to make use have too muh work todo for each release?
15:22:23 <yboston> again as devil’s advocate, shoudl we just mention in multiple places to check SITKA for video content?
15:22:50 <yboston> then again, I do run into old videos for software and I can still find old videos helpful
15:23:47 <remingtron> it might be a better approach to provide an easy path to the videos without embedding links
15:24:29 <remingtron> maybe even trying to map the Acq docs to an Acq video playlist, which includes older Acq videos that might still be relevant, let the user decide
15:25:03 <yboston> For example, would a footer or header note in the docs site about where to find the SITKA  fit your idea?
15:25:30 <Christineb> what if other DIG contributors create videos?
15:25:48 <yboston> Christineb: good point
15:26:17 <Christineb> will Youtube allow you to create a playlist of videos from multiple creators?
15:26:50 <remingtron> Christineb: that was my next question. Like "DIG recommends these videos"
15:26:50 <Christineb> if yes - we could create a DIG playlist on the BC Libraries Co-op channel
15:26:52 <yboston> I don’t see anything wrong with picking a section to try out addign videos to see how much complexity it adds, and/or how much it increases the burden of handling new releases
15:27:32 <tsbere> Christineb: Just poking in to say "as far as I know, yes" as I have watched several such playlists before on channels. Dunno how to make them, though.
15:27:48 * tsbere leaves the meeting alone again
15:28:01 <Christineb> tsbere - I think you are correct - I will investigate further
15:28:42 <yboston> Christineb: should I give you an action item for that? your call
15:29:12 <dluch> Just did a quick look at some YouTube channels and agree with tsbere.  Looks like it should be possible, though I don't know how to do it
15:29:13 <Christineb> yes
15:29:20 <yboston> OK
15:30:06 <Christineb> ok I think it's actually pretty easy to do
15:30:07 <yboston> #action Christineb will investigate creating a Youtube playlist that incorporates SITKA videos and videos from non-SITKA sources
15:31:10 <remingtron> yboston: yes, I think a generic link to videos could work, though I'd love something more cool, like a floating sidebar widget :)
15:31:21 <yboston> do we want to conintue this topic or picki it up again next meeting, and or on the list?
15:31:31 <yboston> remingtron: makes sense
15:31:35 <Christineb> one thing - the benefit of using direct links to specific videos is quick access to desired info
15:31:50 <yboston> absolutely
15:32:05 <Christineb> if we direct them to a DIG recommended playlist they will have to search again / scroll to find desired video
15:32:28 <yboston> sadly yes
15:32:31 <dluch> True
15:32:36 <remingtron> Christineb: true, our real goal is "Click here to see how to do this specific task"
15:33:25 <remingtron> Christineb: any idea if your docs video links have been clicked?
15:33:42 <Christineb> I will get click stats for next meeting
15:34:18 <Christineb> we only added the specific video links during our last upgrade (May)
15:35:41 <yboston> did we want to pick a particualr section to test out addign the links?
15:37:07 <yboston> we can decide later too
15:38:08 <remingtron> I guess I'd rather focus on making sure features from 2.10 and 2.11 are covered, and maybe try to add a video link while we're in there.
15:38:09 <Christineb> maybe the patron related videos?
15:38:25 <Christineb> remingtron++
15:38:30 <yboston> either of those ideas sound fine to me
15:38:38 <remingtron> (I mean, that we should focus on writing docs for new features, not focus on videos for new features)
15:39:23 <yboston> remingtron: I agree with this, the videos are nice but I would choose text over videos
15:39:58 <yboston> though I do think videos can be extremly helpful, though it is hard to do a full keyword search on the contents of a video
15:40:05 <yboston> atkeast with our set up
15:41:06 <remingtron> should we talk a bit about 2.10 and 2.11 (coming soon)?
15:41:34 <yboston> yes
15:42:01 <yboston> #topic  2.10 & 2.11
15:42:16 <yboston> need to look up when 2.11 is expected
15:42:43 <yboston> does anyone know if this is the version with the staff client ready for primte time?
15:43:14 <yboston> I see that august 17th is the beta and feature beta freeze for 2.11
15:43:15 <remingtron> yboston: I haven't heard any decrees about web client yet
15:43:45 <yboston> looks like September 7th is the projected 2.11 release date
15:45:16 <yboston> I guess we should plan a DIG hackfest for that release between the beta and the release
15:45:48 <yboston> can I get a volunteer to set up a Doodle poll?
15:46:08 <sandbergja> yboston: I can do that!
15:46:20 <yboston> thanks!
15:46:28 <remingtron> yboston: hackfest, good idea!
15:46:52 <yboston> #action sandbergja will conduct a doodle poll picking a date to work on 2.11 new features
15:47:10 <yboston> remingtron: thanks
15:47:57 <yboston> BTW, we are down to the last 13 minuts if we stick to ending on time
15:48:02 <yboston> *minutes
15:48:48 <yboston> One thing I added to today’s agenda, but in the wrong spot is that I need to step down from the position of DIG meeting facilitator
15:49:13 <yboston> my library might end up switching ILS, though we may end up staying with evergreen
15:50:04 <yboston> I am being asked to get involved in another open source community for our arhcives dpartment (Fedora Commons) so my time has gotten more limited
15:50:31 <yboston> I just wanted to start the process of finsing a replacemnt for me as facilitator
15:50:45 <yboston> we don’t have to do it right now
15:51:27 <remingtron> hmmm, thanks for the warning
15:51:28 <yboston> besides that, do we have last comments or questions on any topic now that we have 10 minutes left?
15:52:12 <sandbergja> yboston: I think we're all being really quiet because we're all secretly a little sad that you won't be facilitating these meetings :-(
15:52:24 <yboston> thaks
15:52:26 <yboston> thanks
15:52:29 <remingtron> that's no secret!
15:52:34 <remingtron> I'll be sad!
15:52:35 <dluch> Yes, what sandbergja said.
15:52:38 <kbutler> yboston :(
15:52:50 <dluch> yboston++
15:52:54 <sandbergja> yboston++
15:53:08 <yboston> muchas gracias
15:53:09 <remingtron> yboston++
15:53:11 <phasefx> yboston++
15:53:23 <kbutler> yboston++
15:53:38 <sandbergja> Switching gears, there is one topic that I'd like to get some input on
15:53:48 <yboston> go ahead
15:54:04 <sandbergja> So, I have dropped the ball on docs re-org
15:54:16 <sandbergja> and would like to get those conversations started again
15:54:41 <sandbergja> and wanted to see if folks had any suggestions for what that process might look like
15:55:18 <yboston> good question
15:55:35 <sandbergja> Currently, we have a rough ToC for a "System Administration from the Staff Client" book, with materials from the current official docs and other sources
15:55:45 <sandbergja> (and a few bits that would need to be written)
15:56:02 <yboston> one thign that is not a concer is that it looks liek the web client will not be “ready” in a couple of weeks, because it if was that would have an impact on the re-org
15:56:13 <sandbergja> and some functional requirements and some survey feedback
15:56:52 <yboston> we also have a test server that could be used for dispalying re-org experiments
15:59:02 <yboston> I would suggest that we again try another re-org specific meeting and/or a new email list thread
15:59:09 <yboston> thoguh of course that is soemthign you have done before
15:59:21 <remingtron> sandbergja: it wouldn't take much work to create a new root.txt just for that new book, generate the html, and go from there
15:59:38 <remingtron> yboston: does anyone else have access to the new DIG test server?
15:59:54 <yboston> Right now I think only Galen adn I have access.
16:00:17 <yboston> try reaching out to him for access, and of course tell him I can verify that we want to give you access
16:00:53 <sandbergja> Well, why don't we get a new root.txt file onto that server somehow, generate a sysadmin-from-the-staff-client manual using our ToC, and use that to generate some excitement
16:01:04 <sandbergja> a proof-of-concept type thing!
16:01:34 <remingtron> sandbergja: good plan. you want to ask for server access too?
16:01:36 <sandbergja> And then we can have a meeting that focuses on debriefing what works/doesn't work about that manual
16:01:53 <sandbergja> remingtron: I am happy either way
16:02:08 <yboston> sandbergja: that idea make sense, I had a similar idea before
16:02:29 <sandbergja> great minds think alike!
16:02:31 <yboston> though I think we need to set up a new git branch for these experiments or set up a new repo altogether?
16:02:33 <sandbergja> :-P
16:03:16 <remingtron> yboston: right, a working repo branch could work
16:03:18 <yboston> not sure how the DIG test serve is set up. I know it is pulling from our main Git repo a cuple of times a day
16:03:34 <yboston> I can email Galen
16:03:56 <sandbergja> Thanks, yboston!
16:03:56 <yboston> #action yboston will email Galen to give remingtron and sandbergja access to DIG test server
16:04:07 <remingtron> yboston: thanks!
16:04:18 <yboston> #link docs-testing.evergreen-ils.rog
16:05:08 <remingtron> yboston: typo, should be ".org"
16:05:28 <yboston> oops, copied it from an email, tis time not my fault :)
16:05:36 <remingtron> :)
16:05:41 <yboston> #link http://docs-testing.evergreen-ils.org
16:06:23 <yboston> anything else before we wrap up?
16:06:36 <remingtron> just a plea
16:06:56 <yboston> go ahead
16:07:02 <remingtron> if anyone has time, take a look at the 2.10 needs and let's try to document more things! thanks all!
16:07:12 <remingtron> #link http://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.10_needs
16:07:52 <yboston> #action for all: try to document outstanding EG 2.10 new features
16:08:18 <yboston> OK folks, I will wrap up
16:08:29 <yboston> #endmeeting