15:01:20 <kmlussier> #startmeeting Evergreen Development Meeting, 10 August 2016
15:01:20 <pinesol_green> Meeting started Wed Aug 10 15:01:20 2016 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:20 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__10_august_2016'
15:01:41 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-08-10
15:01:52 <kmlussier> Please introduce yourselves with the #info command.
15:01:57 <miker> #info miker = Mike Rylander, ESI
15:02:01 <DPearl> #info DPearl = Dan Pearl, C/W MARS
15:02:05 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:02:17 <agoben> #info agoben is Anna Goben, Evergreen Indiana
15:02:21 <berick> #info berick Bill Erickson, KCLS
15:02:40 <JBoyer> #info JBoyer Jason Boyer, Evergreen Indiana
15:02:43 <gmcharlt> #info gmcharlt = Galen Charlton, ESI
15:02:43 <Dyrcona> #info Dyrcona Jason Stephenson, C/W MARS
15:02:58 <dbwells> #info dbwells is Dan Wells, Hekman Library (Calvin College)
15:03:02 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:04:07 <kmlussier> I'll move forward in the agenda, but feel free to introduce yourself if you arrive late.
15:04:14 <kmlussier> #topic Action Items from Last Meeting
15:04:53 <kmlussier> #info developers to continue looking at Sqitch, particularly release-building options. Bug #1521693 has been updated. berick is putting it on the back-burner for now.
15:04:55 <pinesol_green> Launchpad bug 1521693 in Evergreen "Investigate using Sqitch for database change management" [Wishlist,New] https://launchpad.net/bugs/1521693
15:05:14 <kmlussier> gmcharlt to review a few outstanding OpenSRF patches/pull requests
15:05:18 <kmlussier> Any updates gmcharlt?
15:05:40 <gmcharlt> kmlussier: still on my plate; I will cut a 2.5-alpha on Friday
15:06:02 <gmcharlt> #action gmcharlt will cut OpenSRF 2.5-alpha on 12 August
15:06:16 <kmlussier> gmcharlt: Thanks!
15:06:24 <kmlussier> miker will email the list with a proposed schedule for 2.11 and a list of pending bugs/pullrequests
15:06:31 <kmlussier> That was done, miker, right?
15:06:39 <miker> the schedule is out
15:07:16 <miker> the list, I churned through a bit yesterday
15:07:44 <miker> I'll be trying to set aside some time friday to build a "please look at these" list
15:07:55 <miker> I've pinged a couple folks privately about a few
15:08:02 <miker> and have been pinged about a couple
15:08:07 <kmlussier> #info miker emailed a 2.11 schedule to the list and is working through pending bugs/pullrequests.
15:08:40 <kmlussier> #action miker will build a "please look at these list" of pullrequests.
15:09:02 <kmlussier> dbwells will email the list with an introduction to the 2.11 release manager and buildmasters
15:09:13 <kmlussier> dbwells: Did that happen? I can't recall.
15:09:32 <dbwells> That was a bogus action item, only the one after that is real.
15:09:48 <jeff> that one was just a decoy...
15:09:58 <kmlussier> Oh, I see. I'm so easily fooled by decoys. :)
15:10:04 <dbwells> The wiki is updated :)
15:10:24 <kmlussier> #info dbwells sent an introductory email to the 2.11 release manager and buildmasters
15:10:27 <kmlussier> dbwells++
15:10:31 <jeff> figment of our collective imagination... like my appearance here.
15:10:44 <kmlussier> gmcharlt and Dyrcona to summarize results of this discussion on the wiki for future use by release maintainers.
15:11:02 <kmlussier> "This discussion" refers to guidelines for bug fix vs.new feature.
15:11:08 <kmlussier> Any updates gmcharlt and Dyrcona?
15:11:19 <gmcharlt> no; considered us reminded
15:11:29 <Dyrcona> yeah, hasn't happened, yet.
15:12:10 <kmlussier> #action gmcharlt and Dyrcona to create guidelines on the wiki to determine what is a bug fix vs. new feature.
15:12:24 <kmlussier> I changed the action item a bit to help next month's meeting facilitator.
15:12:46 <Dyrcona> I'm sure you'll thank yourself in the future. :)
15:12:58 <kmlussier> #info dbwells created a bug report with proposed changes for ingest speed improvements. The changes have been pushed.
15:13:15 <dbwells> gmcharlt++ and miker++ for getting it wrapped up
15:13:16 <kmlussier> Dyrcona: If you look at the last item on the agenda, you'll see I have no intention of being next month's meeting facilitator. ;)
15:13:31 * gmcharlt volunteers in advance to faciliate
15:13:44 <kmlussier> gmcharlt++
15:13:48 <DPearl> gmcharlt++
15:14:02 <kmlussier> gmcharlt: I can hand over the controls right now if you want practice.
15:14:19 <kmlussier> #topic OpenSRF Release Info
15:14:39 <gmcharlt> so yeah...
15:14:59 <gmcharlt> #info OpenSRF 2.5-alpha to be cut 12 August
15:16:05 <bshum> gmcharlt: Are you planning to do anything about mod_perl and moving that over as a dependency in Evergreen instead of OpenSRF?
15:16:30 <gmcharlt> hmm
15:16:42 <miker> bshum: what's the aim?
15:16:52 <gmcharlt> I think general release of 2.5.0 can wait to occur when EG 2.11 is released
15:16:58 <gmcharlt> so we could do it then
15:17:04 <bshum> miker: The reason I ask is cause we have conflicting decisions to make over how mod_perl is done right now.
15:17:31 <miker> I'm still not following, sorry
15:17:31 <bshum> Basically we have to add something to enable it for Jessie and Trusty builds
15:17:34 <gmcharlt> and my preference is to have mod_perl end up on the Evergreen side; there's nothing in OpenSRF itself that requires mod_perl
15:17:59 <bshum> There's a bug now with apache where it used to ship on, but it's been off lately, and people get errors trying to start Evergreen later cause it's disabled
15:18:14 <Dyrcona> Does OpenSRF even really need Apache?
15:18:18 <bshum> Moving it from OpenSRF to Evergreen is just a related issue, to making sure it's turned on in the first place
15:18:33 <miker> Dyrcona: it does for the gateway/translator/websockets stuff
15:18:41 <miker> but not mod_perl specifically
15:18:42 <bshum> I don't really care where we have it, just so long as it gets turned on somewhere.
15:18:43 <gmcharlt> for context: bug 1579219
15:18:44 <pinesol_green> Launchpad bug 1579219 in OpenSRF "don't require mod_perl as an OpenSRF dependency" [Wishlist,New] https://launchpad.net/bugs/1579219
15:19:34 <bshum> And other context https://bugs.launchpad.net/opensrf/+bug/1585042
15:19:35 <pinesol_green> Launchpad bug 1585042 in OpenSRF 2.4 "Enable mod_perl by default for new OpenSRF installations for Debian Jessie and Ubuntu Trusty" [Medium,New] - Assigned to Galen Charlton (gmc)
15:20:16 <miker> I'm agnostic, as I won't likely be the implementor
15:20:39 <gmcharlt> I'm more than happy to do the implementation
15:21:15 <kmlussier> gmcharlt: Can I add that as an action item for something to be done in time for the .0 release?
15:21:51 <gmcharlt> kmlussier: sure
15:22:40 <kmlussier> #action gmcharlt to move the mod_perl dependency from OpenSRF to the Evergreen side in time for the 2.5.0 release
15:23:00 <kmlussier> Is there anything else to discuss for OpenSRF?
15:23:48 <kmlussier> Going once, going twice...
15:23:54 <kmlussier> #topic Evergreen 2.11 update
15:24:12 <kmlussier> miker: Anything to add to what you reported above?
15:24:22 <miker> yes, a little
15:24:37 <miker> first, dbwells quietly release the alpha last monday
15:24:43 <miker> er, weds
15:24:56 <miker> it builds!
15:25:15 <miker> second, I have 2 questions for the room
15:25:27 <miker> 1) merging the webclient branch
15:25:35 * miker gets link
15:25:52 <miker> http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/gmcharlt/webstaff-sprint3
15:26:33 <miker> sprint 3 (admin/reports) is done now. we may be able to slip in one more html -> ng UI update in the next week or so
15:27:02 <dbwells> (7/29 was the alpha build date, and the downloads page was updated)
15:27:16 <miker> would anyone like some time to play with the branch before it's merged?
15:27:34 <miker> IOW, shall we merge it post-beta, as an exception
15:27:37 <kmlussier> For the alpha release, should a message go out on the list so that people know about it?
15:27:51 <miker> kmlussier: it should have, and that's on me
15:28:07 <miker> I can send one out
15:28:16 <kmlussier> miker: OK, I'll add that as an action item.
15:28:44 <kmlussier> miker: Also, we'll be looking at the sprint 3 branch here, but I don't know how much testing we can do before Wednesday. I've already used some of the admin interfaces.
15:29:04 <kmlussier> #action miker to send message to e-mail list announcing alpha release.
15:30:15 <miker> re merging webclient, I'm happy with waiting a bit ... but, as always, it's preproduction.  we will be backporting significant bug fixes, though, as agreed to before
15:30:23 <miker> opinions on timing?
15:30:26 <dbs> #info dbs is Dan Scott, Laurentian University
15:30:47 <kmlussier> miker: Do you have an idea of whether many sites are using the web client in production?
15:31:20 <miker> I don't believe there are many. maybe 1 or 2? none that I'm positive do use it
15:31:20 <kmlussier> I think it affects the decision on whether we merge post-beta. If people are using it in production, there may be a higher chance of breakage happening for them at .0 release time.
15:31:38 <Dyrcona> I'd prefer sprint3 going in at/before the beta rather than after.
15:31:58 <JBoyer> I'd think the sooner the better provided all of the existing interfaces are still in the XUL client. If someone is using a pre-pro client in production, they should be paying enough attention to hit the testing rather hard on this update.
15:32:26 <miker> JBoyer: they do exist
15:32:30 <gmcharlt> we could send an olly-olly-oxen-free to open-ils-general
15:33:09 <kmlussier> Looks like we just lost most of the ESI crew
15:33:11 <Dyrcona> Ok. Who tripped over the phone line? ;)
15:33:19 <JBoyer> And I thought I might be knocked off because of the weather here, heh.
15:33:20 <gmcharlt> was it something I said? ;)
15:33:30 <miker> doh... quassel core went sad
15:34:08 <dbwells> I haven't perused the code in a while now, but if it is generally true that the chance of the merge breaking existing client interfaces is low, I think merging sooner is better.
15:34:20 <miker> gmcharlt: we can, though I'm inclined to vote with Dyrcona and JBoyer ... and dbwells :)
15:34:50 <JBoyer> Plus there's the fact that alphas are generally unstable, now's the best time to find where the problems lie.
15:34:51 <miker> dbwells: it's exceedingly low (though not non-zero)
15:34:53 <gmcharlt> miker: yeah, I was thinking more in terms of identifying the folks who then get asked to TEST, TEST, and MOAR TEST :)
15:34:58 <kmlussier> I'm inclined to agree that we should merge before beta. I can commit to putting some testing in by next week.
15:35:10 <miker> gmcharlt: +1
15:35:17 <gmcharlt> but yeah, I'm also in favor in merging before beta
15:35:40 <kmlussier> Who would like to volunteer to send a message out to the list to get testers?
15:36:30 <miker> I'll do it while I announce alpha
15:37:07 <kmlussier> #action miker to send message to list seeking help to test web client sprint 3
15:37:24 <kmlussier> Any other updates for 2.11? Other areas where help is needed?
15:37:37 <miker> second question: we have 5 weeks between beta and GA ... would anyone like to steal a week from RC and make it 4, giving us 2 more weeks until beta?
15:38:20 <JBoyer> +1
15:38:32 <miker> reason being: folks (including me) have been focusing on bug fix branches recently
15:38:33 <kmlussier> +1
15:38:45 <miker> so, thee will likely be fewer bugs to merge post-beta
15:38:48 <miker> there
15:39:01 <miker> preexisting bugs, that is
15:39:10 <Dyrcona> +1
15:39:12 <kmlussier> Any objections to moving beta back a week?
15:39:49 * berick does not object
15:39:52 <kmlussier> miker: The new beta date would be August 24?
15:39:54 <miker> (I'd still like to merge sprint3 by mid-next-week)
15:40:18 <miker> kmlussier: yes. I'll reply to the schedule email to announce that, barring objections
15:40:32 <kmlussier> I feel like this release snuck up on me, so the extra week will be nice.
15:40:48 <miker> kmlussier: ME TOO
15:40:56 <miker> it's been a summer...
15:41:25 <kmlussier> OK, hearing no objections, it looks like it will be August 24
15:41:33 <kmlussier> #info New 2.11 beta release date to be August 24.
15:41:57 <kmlussier> Anything else before we move on to the next topic?
15:42:08 <miker> nope, thanks
15:42:25 * kmlussier updated the dev calendar with the new beta date.
15:42:51 <kmlussier> #topic 2016 Hack-a-way update
15:43:03 <kmlussier> JBoyer, agoben: You have the floor.
15:43:40 <agoben> Things are in good shape; we're contracted for the space as shared before.
15:43:57 <agoben> A couple of options for lodging that you should be aware of:
15:44:22 <agoben> a) The block has to be called on if you want to get into it (and it is for the lower cost rooms)
15:45:17 <agoben> Alternately, the facility has some houses.  If interested, I can facilitate participation in a group reservation for one of the houses.  There would be 6 private suites included at $75/night for interested parties.
15:46:05 <agoben> Also, if there's anything in particular participants really do or don't want to see on the schedule for evenings, please send them my way.
15:46:37 <kmlussier> Adding a link to the wiki page with the lodging info:
15:46:40 <kmlussier> #link http://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2016
15:47:28 <agoben> I can get the travel doc put together for participants next week.
15:47:35 <kmlussier> Does anyone have any questions for agoben?
15:48:06 <kmlussier> The option for a house is interesting. I assume the $75 rate is lower than the rate for a typical hotel room?
15:48:11 * kmlussier doesn't remember seeing it anywhere.
15:48:35 <JBoyer> Depending on the room they normally range from $94 to 154.
15:48:45 <agoben> Yes, the pricing at the Inn ranges between $80 and $200/night depending on which room type you select.
15:49:17 <kmlussier> JBoyer / agoben: Thanks!
15:49:32 <kmlussier> Any other questions about the hack-a-way.
15:50:40 <kmlussier> #topic Mentoring new developers in the community
15:51:27 <kmlussier> I added this topic as a follow-up to the discussion we had at the last hack-a-way regarding growing contributors in the community and then the e-mail thread where I suggested a mentoring program.
15:52:21 <kmlussier> I never applied for the grant because there didn't seem to be much interest from developers, but I still would like to pursue the topic a bit. Not to be resolved today, but maybe as a precursor to a discussion for the November hack-a-way.
15:54:00 <kmlussier> Basically, I'm curious to people's thoughts on starting some type of mentoring program, and, if so, what you all think would be effective. Is the program I proposed something that would be workable or do you all think it's more effective to do programs like GSoC as we've done in the past?
15:55:37 <kmlussier> I personally feel like GSoC and Outreach (formerly OPW) weren't particularly effective, which is why I was suggesting an alternate approach.
15:55:57 <kmlussier> #link http://markmail.org/message/xts3sxx2zakad7mw
15:56:13 <Dyrcona> I like the idea of a bootcamp. However, it may be too much for us to do as its own event.
15:56:35 <kmlussier> Dyrcona: Too much because of time constraints?
15:56:44 <Dyrcona> Perhaps, it could be done at the hack-away or as part of the hackfest at the conference?
15:57:27 <Dyrcona> kmlussier: Yes, more or less.
15:57:53 <gmcharlt> I think it could be done attached to the conference or hackfest
15:57:59 <Dyrcona> I'm also not sure how much interest there is on the part of those being mentored.
15:58:15 <gmcharlt> but as something that gets its own day (or two?) with nothing else going on
15:58:38 <kmlussier> gmcharlt: Yes, I agree. If we do something, the participants should be able to focus on it.
15:59:13 <kmlussier> Dyrcona: When you see see there might not be interest, do you mean not much interest in being mentored or something else?
15:59:39 <DPearl> That's a lot of material to cover in one day.  I think I'm more in favor of canned tutorial with exercises that could be done at the learner's pace.
16:00:07 <DPearl> That could be accessed any time, so the on-ramp is available on demand.
16:00:11 <Dyrcona> kmlussier: I don't hear a lot of people asking about how to get started coding for Evergreen. It comes up in IRC from time to time, but is there enough interest for a stand alone, multi-day event?
16:00:58 <kmlussier> Well, it might be something that could start with an in-person boot camp and then continue remotely. I think there is a value to getting to seeing things in person.
16:01:41 <kmlussier> Dyrcona: When I originally posed the question, most of  the interest came from people who were interested in learning more. But you might be right.
16:02:35 <kmlussier> We're at the one-hour mark, but I just wanted to put the question out there to get people started in thinking about it. Maybe we can talk some more about it as we get closer to the hack-a-way.
16:03:14 <kmlussier> I'm also willing to try to find some other grant to help us fund something if we need to cover travel expenses, time spent by mentors, canned presentations, etc.
16:03:25 <JBoyer> Something else to think about might be where to advertise such a thing? There may be interest if there were more awareness.
16:03:53 <dbwells> remingtron and I recently gave some Evergreen tech. overview presentations at Code4Lib midwest.  Could be used as part of a tech primer "course" of some sort.
16:03:56 <kmlussier> JBoyer: Before getting to advertising it, I think we need to start with who the best audience is.
16:04:16 <JBoyer> kmlussier, sure, those two things are related.
16:04:20 <kmlussier> dbwells: Awesome! Is that something you would be willing to post to the wiki?
16:04:21 <Bmagic> #info Bmagic = Blake GH, MOBIUS
16:04:53 <kmlussier> JBoyer: My thought was that working with people already working with libraries is better. I think that's what the problem was with programs like GSoC. There was no reason to continue with the project once the internship was done.
16:05:06 <kmlussier> But I could be wrong on that.
16:05:10 <JBoyer> Makes sense. (worked for me!)
16:05:20 <kmlussier> OK, I want to wrap things up.
16:05:31 <Dyrcona> Yeah. I think doing something at the conference is a decent place to start.
16:05:42 <kmlussier> #topic Volunteer to organize / lead the September 7, 2016 meeting
16:06:16 <dbwells> kmlussier: It's very much an amalgamation of existing content, so I am not sure how much value the slides have all on their own, but I'll find a place for them on the wiki somewhere.
16:06:21 <kmlussier> gmcharlt volunteered to lead the next meeting. gmcharlt do you also want to be responsible for sending out meeting notices & creating the agenda, or do you want another volunteer to handle that?
16:06:33 <kmlussier> dbwells++ #Thanks!
16:06:35 <gmcharlt> kmlussier: I'll take care of it all
16:06:42 <kmlussier> gmcharlt++
16:06:59 <JBoyer> gmcharlt++
16:06:59 <kmlussier> #action gmcharlt will lead the September 2016 meeting.
16:07:19 <kmlussier> Does anyone have anything else before we end the meeting?
16:08:02 <kmlussier> #endmeeting