15:00:53 <gmcharlt> #startmeeting Evergreen Development Meeting, 6 October 2016
15:00:53 <pinesol_green> Meeting started Wed Oct  5 15:00:53 2016 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:53 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__6_october_2016'
15:01:03 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2016-10-05
15:01:06 <gmcharlt> #topic Introductions
15:01:16 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:27 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:01:27 <Dyrcona> #info dyrcona = Jason Stephenson, C/W MARS
15:01:37 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:01:39 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
15:01:48 <abowling> #info abowling = Adam Bowling, Emerald Data Networks
15:02:31 <jeffdavis> #info jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka)
15:02:39 <miker> #info miker = Mike Rylander, Equinox
15:02:58 <csharp> #info csharp = Chris Sharp, GPLS
15:03:11 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:03:17 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:04:01 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:04:08 <gmcharlt> OK
15:04:10 <bshum> #info bshum = Ben Shum, evergreener
15:04:18 <berick> #info berick Bill Erickson King County (KCLS)
15:04:22 <gmcharlt> #topic Action items from previous meeting
15:05:12 <gmcharlt> #info gmcharlt has not yet cut OpenSRF 2.5-alpha; am now targetting a release of the alpha before the Hack-a-way, with goal of releasing 2.5.0 during it
15:05:28 <gmcharlt> #action gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
15:06:00 <gmcharlt> at this point, all current and new pullrequests that are added in the next two weeks will be looked at
15:06:21 * miker warms up his pullrequest-adding fingers
15:06:33 <gmcharlt> if there are questions, let's hold them for the OpenSRF release section of the agenda
15:06:49 <gmcharlt> next action item: miker, you were to make a please-look-at-me list of pull requests
15:07:11 <miker> heh ... I did, for some folks. they looked, I merged some
15:07:42 <miker> and then there was 2.11 :)
15:07:46 <gmcharlt> #info miker coordinated some pullrequest review during the 2.11 release process
15:08:16 <gmcharlt> next up, Dyrcona and I were to create guidelines for distinguishing sheep from lions^W^W^W bug fixes from new features
15:08:30 <gmcharlt> so, I think we'll just carry that over, Dyrcona?
15:08:50 <Dyrcona> Yeah, we could discuss it at the hackaway.
15:09:40 <dbs> #info dbs = Dan Scott, Laurentian University
15:09:52 <gmcharlt> OK, I've gone ahead and added that to the list of discussion topics
15:10:21 <gmcharlt> #info Creating guidelines for distinguishing bugfixes from new features is now on the hackaway agenda
15:11:24 <gmcharlt> next up - moving mod_perl from OpenSRF to Evergreen can still happen in OpenSRF 2.5.0, but  may need to be deferred to 2.12/3.0 on the Evergreen side
15:11:47 <gmcharlt> I'm inclined to just have furhter discussion take place in LP (bug 1579219, specifically)
15:11:47 <pinesol_green> Launchpad bug 1579219 in OpenSRF "don't require mod_perl as an OpenSRF dependency" [Wishlist,Triaged] https://launchpad.net/bugs/1579219
15:12:01 <gmcharlt> next up: miker to send message announcing alpha release
15:12:12 <miker> I would prefer it /not/ happen in a patch-level release, btw
15:12:18 <gmcharlt> and well, GENERAL RELEASE happened
15:12:19 <miker> re opensrf and mod_perl
15:12:23 * csharp agrees
15:12:29 <gmcharlt> yup
15:12:58 * abowling agrees, too
15:13:15 <gmcharlt> next up - web client sprint 3 testing... is underway
15:13:42 <gmcharlt> and finally, here I am, leading the September^W October development meeting
15:13:53 <gmcharlt> so, I think that does it for action items
15:13:55 <kmlussier> :)
15:13:58 <gmcharlt> so, let's move on
15:14:17 <gmcharlt> #topic OpenSRF release info
15:14:21 <gmcharlt> and, to repeat myself
15:14:36 <gmcharlt> #info gmcharlt has not yet cut OpenSRF 2.5-alpha; am now targetting a release of the alpha before the Hack-a-way, with goal of releasing 2.5.0 during it
15:14:36 <gmcharlt> #action gmcharlt to cut OpenSRF 2.5-alpha before hack-a-way
15:15:12 <gmcharlt> #info the window for OpenSRF pullrequests for inclusion in 2.5.0-alpha will be open until 24 October
15:16:42 <gmcharlt> any questions or comments before we move on to Evergreen?
15:17:31 <gmcharlt> https://www.youtube.com/watch?v=0Wi8Fv0AJA4
15:17:52 <gmcharlt> OK
15:17:56 <gmcharlt> #topic Evergreen release
15:18:19 <gmcharlt> miker: dbwells: I hear allegations that there was an Evergreen release of some note recently. Is this true?
15:18:40 <miker> as it happens, it is!
15:18:58 <kmlussier> miker++ dbwells++
15:19:07 <miker> it happened essentially on time (thanks, dbwells) and then I promptly went on vacation before announcing it
15:19:20 <kmlussier> :)
15:19:23 <miker> which I finally did yesterday :)
15:19:34 <Bmagic> miker++ dbwells++
15:19:39 <kmlussier> Should the announcement go on the blog too?
15:19:54 <Dyrcona> miker++ dbwells++
15:19:59 <miker> kmlussier: I actually thought your press release would be better there...
15:19:59 <abowling> miker++ dbwells++
15:20:16 <gmcharlt> well, we've got a couple audiences
15:20:54 <gmcharlt> I could put together a traditional announcement for the blog, then the PR could be distributed once that's up?
15:20:59 <gmcharlt> I can get the post up this afternoon
15:21:08 <kmlussier> miker: Sure, I can do that. Generally, I think of the press release as being for an external audience. Not sure what the blog's audience really is.
15:21:35 <miker> gmcharlt: sure, if you want to just steal the email, go for it. I'm not sure I have a blog login
15:21:52 <dbwells> Overall, I felt like the first go at a split manager/builder went well.  There are areas to improve, but I would support keeping the same structure for the next release.
15:21:55 * kmlussier was just about to hit 'Send' on press release e-mails, but will hold off.
15:22:17 <gmcharlt> #action gmcharlt will post blog announcement of 2.11 this afternoon
15:22:28 <dbwells> I can think of one or two things I would do differently, which I can pass along to the next person.
15:22:29 <gmcharlt> #action kmlussier will start sending the press release out thereafter
15:23:08 <miker> dbwells: I agree ... and have other thoughts. :) we should set aside some specific time at the hackaway to discuss in more detail (after dust settling occures)
15:23:23 <dbwells> miker: sounds good
15:24:05 <gmcharlt> miker: dbwells: I've added a topic to the hack-a-way agenda for that
15:24:14 <miker> gmcharlt++
15:24:54 <dbwells> another thrilling round of "don't do what Dan did"
15:24:57 <gmcharlt> so, on to maintenance releases
15:25:04 <gmcharlt> miker: dbwells: y
15:25:16 <gmcharlt> y'all are prepared to do a 2.11.1 later this month?
15:25:46 <miker> I will be out of pocket on the normal date ... if I'm to be involved it'll need to slip a week
15:26:15 <miker> which, really, isn't terrible -- there are several bug fixes to test and pull in, and .0 is not a brown bag
15:26:34 <dbwells> I should be available to handle 2.11.1.
15:26:45 <dbwells> If need be.
15:27:15 <dbwells> 10/19?
15:27:35 <gmcharlt> dbwells: yeah
15:28:34 <gmcharlt> #info 2.11.1 and 2.10.8 will be released on 10/19
15:28:44 <gmcharlt> so, I think that takes us to new business
15:28:51 <gmcharlt> #topic Hack-a-away
15:29:08 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2016-agenda
15:29:12 <dbwells> I will plan on rolling it unless miker asks me to hold off at that time.
15:29:19 <gmcharlt> dbwells++
15:29:22 <miker> dbwells: cool
15:30:14 <gmcharlt> anything to say about the hack-a-way itself?
15:30:39 <kmlussier> I think the EOB was looking for some guidelines on when they could be pulling people for their meetings.
15:30:56 <miker> so, I've been asked by the EOB, many of whom plan to attend the hack-a-way, if we could identify some times when it would be ...
15:31:10 <kmlussier> miker: Jinx!
15:31:11 <miker> heh ... what kmlussier said :)
15:31:19 <abowling> as the lone (former) local, if you have any logistical questions about town (i.e. getting around, eating, etc.), feel free to ping me
15:31:43 <abowling> *the lone local in the meeting
15:32:05 <miker> basically, will there be some built-in down times, or times (like full group discussion times) when meetings should be avoided, and if so, can we try to identify those times
15:33:17 <kmlussier> I've only been to two hack-a-ways, but my recollection is that we generally meet at the beginning of the day, maybe after lunch, and maybe at the end of the day. Is that about right?
15:33:29 <kmlussier> Of course, I don't know what start of day means.
15:33:44 <gmcharlt> start of coffee?
15:33:50 <miker> kmlussier: coffee+15min?
15:33:55 <Dyrcona> Sounds 'bout right.
15:34:01 <kmlussier> gmcharlt: I'll need coffee long before start of day if I'm supposed to be functional.
15:34:22 <gmcharlt> my gut feeling is that mid-afternoon is a good time to allow people to trickle away
15:34:30 <miker> so, before lunch, and mid-afternoon?
15:34:37 <miker> man, I'm just typing too slow today
15:35:18 <miker> I wasn't at the last one, but I recall mid-afternoon being a good target at the ones before
15:35:19 <kmlussier> That's because you have your pullrequest-adding fingers on. They type more slowly.
15:35:30 <csharp> is it an open or closed meeting?
15:35:42 * kmlussier does not know.
15:35:56 * csharp may not go even if it's open, but was wondering
15:36:38 <miker> probably open ... no request for an executive session has been made
15:36:46 <csharp> ok thanks
15:37:08 <miker> ...YET!
15:37:10 <miker> ;)
15:37:14 <gmcharlt> ok, so I think we have enough for an #info - before lunch and mid-afternoon?
15:37:33 <miker> yes. I have observed and will report
15:37:35 <miker> thanks!
15:38:32 <gmcharlt> #info The hack-a-way will arrange time so that periods before lunch and mid-afternoon are reserved for individual and small-group activities (easing ability of EOB members to meet)
15:38:46 <gmcharlt> so, moving on
15:38:53 <gmcharlt> #topic Evergreen.next release manager
15:39:04 <gmcharlt> I note that this interesets with one of the top items on the hack-a-way agenda
15:39:21 <gmcharlt> namely, Browser client – path to completion and release of a 3.0 in 2017
15:39:58 <miker> first, we're going to build a wall ... wait
15:41:14 <miker> whoever ends up the .next RM will (if all goes even just OK) get to usher in the web client and 3.0 ... so, here's a call for names
15:41:41 * miker points at the ring, waits for hats
15:41:44 <kmlussier> miker: Do we know for sure it's going to be 3.0? I know, that's for discussion at the hack-a-way.
15:41:48 <dbwells> Sorry for being slow, but am confused about the meeting reserved times.  They seem a little broad.  What times will the developer discussions be?
15:42:22 <miker> kmlussier: there is no "sure", but that's the plan, and seems very achievable right now
15:42:25 <kmlussier> I know we often wait until the hack-a-way before formally electing a release manager, but I always like trying to find somebody as soon as a release is done to give them more time to work on the release.
15:43:10 <gmcharlt> dbwells: times like start to mid-morning, after lunch, late afternoon before close
15:43:16 <kmlussier> I should say 'as soon as the previous release is done.'
15:43:46 <miker> kmlussier: right, me too :)
15:44:54 <dbwells> gmcharlt: It seems to me that those are all the worse times.  But I don't think its a very big deal, and will be quiet now :)
15:45:10 <miker> well, the ring remains prepared to accept hats ... shall we just pick it up officially at the hack-a-way?
15:45:39 <kmlussier> Does somebody want to put an e-mail out to see if there is a volunteer? I think that's what we've done a few times in the past.
15:45:41 <dbwells> The Hack-a-way is really pretty close, I think it makes enough sense to wait.
15:46:06 <gmcharlt> I have a suggestion for splitting the difference
15:46:10 <miker> kmlussier: how about right before the hack-a-way?
15:46:36 <gmcharlt> now that the cat has been belled, we can give people time to think about it
15:46:47 <kmlussier> Cat has been belled?
15:47:02 <gmcharlt> then I could send out the call for nominations on the 17th, closing on the 28th, with decision to be made second day of the hackawya
15:47:19 <dbwells> kmlussier: my thoughts exactly! :)
15:47:21 <gmcharlt> kmlussier: cat as in asking people to seriously think about it
15:47:41 <csharp> @band add The Belled Cats
15:47:42 <pinesol_green> csharp: Leave me alone, I'm busy right now.
15:47:52 <jeffdavis> https://en.wikipedia.org/wiki/Belling_the_cat explains all
15:48:21 <jeffdavis> +1 to gmcharlt's proposal
15:48:24 <kmlussier> +1
15:49:19 <miker> +1
15:49:37 * miker waits for everyone to finish the wiki page
15:50:22 <dbwells> +1
15:50:31 <phasefx> +1
15:50:40 <remingtron> +1
15:50:48 <jeff> +1
15:50:51 <csharp> +1
15:51:18 <gmcharlt> #action gmcharlt will send out a call for RM nominations on 10/17, closing on 10/28, with voting to occur second day of hack-a-way
15:51:43 <gmcharlt> OK, then finally
15:51:49 <gmcharlt> #topic Feedback request - bug 1629108
15:51:49 <pinesol_green> Launchpad bug 1629108 in Evergreen "Metarecord constituents search result page should use standard search code" [Undecided,New] https://launchpad.net/bugs/1629108 - Assigned to Blake GH (blake-j)
15:51:57 <gmcharlt> #link https://bugs.launchpad.net/evergreen/+bug/1629108
15:52:17 <Bmagic> Thats me
15:53:38 <Dyrcona> If it leads to more consistent search results, then I'm for it.
15:54:07 <Bmagic> After many hours of looking at the brokeness of metarecords, I found that one of the root causes is the search code. Metarecord constituent search page does not use the standard search routine.
15:54:08 <miker> the "from_" prefix gives me a twitch, but I don't have a better suggestion ATM
15:54:23 <Bmagic> miker: that was your suggestion, lol
15:54:44 <miker> hat's why I have nothing better, I guess :)
15:55:10 <gmcharlt> part_of_metarecord?
15:55:14 <Bmagic> https://bugs.launchpad.net/evergreen/+bug/1403907/comments/24
15:55:14 <pinesol_green> Launchpad bug 1403907 in Evergreen "E-resources not included in ver 2.7.1 Group formats and editions search" [Medium,Confirmed] - Assigned to Blake GH (blake-j)
15:55:22 <miker> consituents_of() ;)
15:56:08 <gmcharlt> "constituents" might be conflated with the notion that it has something to do with monograph parts or boundwiths
15:56:16 <miker> so, yes, I like the implementation ... and I'm not good at naming things. :)
15:56:23 <miker> gmcharlt: aye
15:56:35 <gmcharlt> so I (mildly) prefer names that including "metarecord" or "metabib"
15:56:56 <gmcharlt> but naming aside, I think the current patch looks like a reasonable direction to pursue
15:57:10 <miker> Bmagic: I'm impressed at just how /little/ code it took, esp inside the mod_perl. solid work
15:57:13 <miker> that's my feedback
15:57:25 <gmcharlt> agreed
15:57:26 <Bmagic> glad to hear it
15:57:55 <Bmagic> it isn't much code change, but it took some time to find those little places... :)
15:58:01 <csharp> Bmagic++
15:58:05 <gmcharlt> my only other feedback at the moment is it would be nice to either squawk if the filter values contain non-numeric values, or silently drop them
15:58:13 <gmcharlt> i.e., to catch it before it generates an SQL error
15:58:19 <jeff> minor, but not so minor that i'm not taking time to say it: i realize that the total number of changed lines (once whitespace is included) will grow, but it would be nice to avoid the "if (0)" method of commenting out now-dead code in OpenILS::EGCatLoader::Search::load_rresults
15:58:39 <dbs> jeff++
15:58:54 <miker> jeff: +1, yes
15:58:58 <gmcharlt> indeed (although I'm assuming that the current patch is more a proof-of-concept than a final, polished version)
15:58:59 <Bmagic> jeff: oh for sure, I left it there so that it wouldn't look like I changed that entire block
15:59:11 <jeff> (though in this case, with gitweb as the diff tool, it did make the simplicity of the change more apparent.)
15:59:44 <Bmagic> that is what I was going for
15:59:56 <gmcharlt> great
16:00:06 <gmcharlt> so, Bmagic, do you have the feedback you were looking for?
16:00:17 <Bmagic> Yep, just making sure it was the "right" direction
16:00:25 <gmcharlt> OK
16:00:37 <gmcharlt> so, now that 3600 seconds (or so) have passsed...
16:00:45 <gmcharlt> #endmeeting