13:00:09 <sandbergja> #startmeeting Evergreen Documentation Interest Group (DIG) Meeting 2016-12-07
13:00:09 <pinesol_green> Meeting started Wed Dec  7 13:00:09 2016 US/Eastern.  The chair is sandbergja. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:09 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:09 <pinesol_green> The meeting name has been set to 'evergreen_documentation_interest_group__dig__meeting_2016_12_07'
13:00:16 <sandbergja> Welcome, everyone!
13:00:30 <sandbergja> You can find today's agenda here:
13:00:36 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20161207-agenda
13:00:58 <sandbergja> #topic Introductions
13:01:02 <sandbergja> Glad you are here; please let us know who you are!
13:01:06 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
13:01:21 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
13:01:30 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:01:33 <kbutler> #info kbutler is Kate Butler, Rodgers Memorial Library
13:01:37 <dluch> #info dluch is Debbie Luchenbill, MOBIUS (Missouri Evergreen)
13:02:24 <sandbergja> Thank you everyone for coming!
13:02:45 <sandbergja> Did anybody have anything they'd like to add to the agenda?
13:03:43 <sandbergja> If not, I think we can quickly go over old business, and then get to the main portion of today's discussion.
13:04:07 <sandbergja> #topic Previous action items
13:04:15 <sandbergja> #info  jihpringle will research the state of missing RDA content
13:04:45 <jihpringle> it's on my to do list but unfortunately never seems to make it to the top
13:05:00 <sandbergja> No worries!  Should we just defer?
13:05:04 <jihpringle> yes please
13:05:16 <sandbergja> #action jihpringle will research the state of missing RDA content
13:05:30 <sandbergja> #info  kmlussier will document the general workflow for being DIG release coordinator
13:05:47 <kmlussier> #info kmlussier has started to document the process at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:release_notes_process
13:06:03 <sandbergja> Awesome!  Thanks, kmlussier!
13:06:09 <kmlussier> I documented how the acknowledgements are done, but I need to add other pieces.
13:06:35 <kmlussier> In the meantime, I'm hoping to get a new volunteer to serve as release coordinator for the next release. I think I"ll have my hands full.
13:06:46 <sandbergja> I'm sure!
13:06:54 <kmlussier> I'll put out a call on the list, but if there is anyone interested, feel free to ping me.
13:07:13 <sandbergja> kmlussier: Would you like me to put any action items down for you?
13:07:39 <kmlussier> Sure, you can put me down for putting a call out on the list to find a volunteer to be DIG release coordinator.
13:08:14 <sandbergja> #action kmlussier will put a call out on the list to find a volunteer to be DIG release coordinator
13:08:19 <sandbergja> Thanks!
13:08:27 <sandbergja> #info jihpringle will email yboston or mailing list with 2.10 docs that were completed
13:09:43 <jihpringle> I thought I sent something after our upgrade in May
13:09:44 <sandbergja> jihpringle: Should I put this for next time?
13:09:53 <sandbergja> sorry, never mind!
13:10:25 <sandbergja> Let's leave this be, then!  Thanks, jihpringle!
13:10:29 <jihpringle> np
13:11:47 <sandbergja> #info  Christineb will investigate creating a Youtube playlist that incorporates SITKA videos and videos from non-SITKA sources
13:12:01 <sandbergja> Christineb: where you able to figure out more about Youtube playlists?
13:12:07 <sandbergja> ^were you able
13:13:38 <sandbergja> We can just leave that action item for now.
13:13:41 <sandbergja> #action Christineb will investigate creating a Youtube playlist that incorporates SITKA videos and videos from non-SITKA sources
13:13:48 <sandbergja> #info  sandbergja will conduct a doodle poll picking a date to work on 2.11 new features
13:13:56 <sandbergja> I did this, but then didn't publicize the date very well.
13:14:10 <sandbergja> Thanks to the few folks who did help with those docs regardless!
13:14:32 <sandbergja> Perhaps we need to schedule another one, though?  Thoughts?
13:14:51 <dluch> Another date would probably be a good idea
13:15:14 <sandbergja> Thanks, dluch!
13:15:37 <sandbergja> Would anybody be able to work on this?
13:16:21 <jihpringle> scheduling or the docs?
13:16:39 <sandbergja> scheduling and publicizing a hack-a-way for 2.11 docs
13:17:01 <jihpringle> I can run a doodle poll and then publicize it
13:17:01 <sandbergja> sorry about not being clear!  I don't want to burden anybody with doing all of the 2.11 docs!
13:17:11 <jihpringle> when do we want to hold it?
13:17:16 <sandbergja> thanks, jihpringle!
13:17:23 <kmlussier> jihpringle++
13:17:30 <sandbergja> jihpringle++
13:18:00 <jihpringle> I don't know about others, but we're pretty booked up for December and January already
13:19:06 <dluch> We are, too
13:20:01 <sandbergja> And academic and school libraries will be on break for some of that time, too. :-(
13:20:10 <sandbergja> It looks like mid-February is when we'd need to start documenting the 2.12 features
13:20:32 <sandbergja> kmlussier: correct me if I'm wrong; I am not really up on the release process
13:20:57 <kmlussier> Not that I want to divide our attention too much, but is there any possibility of combining 2.11 features with a web client hack day?
13:21:20 <sandbergja> That sounds reasonable to me
13:21:42 <kmlussier> sandbergja: Yes, by February 22, we should know all the features that need to be documented for 2.12
13:22:13 <sandbergja> Would it be too much of a strain to do a 2.11/web client hack day in early February, and a 2.12 hack day in late February/early March?
13:23:53 <Christineb> I missed this earlier - can we bump it to next agenda I will investigate before our next meeting - >  Christineb will investigate creating a Youtube playlist that incorporates SITKA videos and videos from non-SITKA sources
13:24:12 <sandbergja> Christineb++
13:24:21 <sandbergja> thanks; I'm excited to see what you find out
13:24:40 <jihpringle> I think if we gave everyone lots of notice doing a 2.11/web client day in early February and a 2.12 hack day in early March would work
13:24:57 <kmlussier> sandbergja: If there is a lot of advanced notice for both, I don't think it would be a strain. People can plan around dates if they know ahead of time that something is coming up.
13:25:27 <kmlussier> Aw, jihpringle beat me to it. :)
13:25:35 <sandbergja> Okay!  Let's plan on that, then. :-)
13:26:04 <jihpringle> I'll send out doodle polls for both today and ask people to people to respond by Dec 21st
13:26:19 <sandbergja> jihpringle++
13:26:25 <sandbergja> #action jihpringle will schedule and publicize a 2.11/web client hack day for early February
13:26:26 <jihpringle> then we can have the days in the calendar before the end of December
13:26:35 <sandbergja> that would be excellent
13:26:46 <dluch> jihpringle++
13:27:03 <sandbergja> #info  yboston will email Galen to give remingtron and sandbergja access to DIG test server
13:27:12 <sandbergja> This is done.
13:27:20 <sandbergja> yboston++ gmcharlt++
13:27:37 <sandbergja> Thanks for the updates, everyone!
13:27:39 <sandbergja> #topic Progress on documenting new features in Evergreen 2.11
13:27:44 <sandbergja> I think we have this pretty well sorted out, so I'll move on.
13:28:02 <sandbergja> #topic Finding a new DIG Facilitator
13:28:19 <sandbergja> Let me start out by saying :-(
13:28:30 <sandbergja> And that I miss yboston already!
13:29:17 <sandbergja> What should the process be for finding a new DIG Facilitator?
13:29:41 <sandbergja> Should we put a call out to the email lists, similar to what kmlussier is doing for the DIG release coordinator?
13:30:34 <kmlussier> In some ways, I'm inclined on holding off on my call until we have a DIG facilitator. I think it's more important that we find someone to lead the group first.
13:32:01 <kmlussier> I just looked at the e-mail list archive to see how it was handled before. It looks like Karen tapped yboston to be facilitator before she notified that she had to step down.
13:32:19 <kmlussier> No, wait, I'm wrong on that.
13:33:06 <kmlussier> He had already been filling in for her while she was out on maternity leave. I think a more formal call on the DIG list would make sense.
13:33:13 <kmlussier> Unless there is anyone here who would like to volunteer now?
13:34:14 <kmlussier> <crickets>
13:34:24 <sandbergja> It was worth a try, though!
13:34:44 <sandbergja> I would be happy to put out a call
13:35:32 <sandbergja> And I can also facilitate meetings until we have a more permanent DIG facilitator, if folks would be okay with that
13:35:50 <kmlussier> Yes, that makes sense. In the meantime, people can feel free to poke other people directly if they think they would be good for the role.
13:35:57 <kmlussier> sandbergja: No arguments from me! :)
13:37:04 <pinesol_green> [opensrf|Galen Charlton] LP#1648188: example HAProxy configuration - <http://git.evergreen-ils.org/?p=OpenSRF.git;a=commit;h=b1d19c8>
13:37:07 <sandbergja> #action sandbergja will put out a formal call for DIG facilitator
13:37:08 <kmlussier> I'll also hold off on the release coordinator call. I don't want to put out too many calls for volunteers at the same time and possibly distract somebody's attention away from the facilitator positions.
13:37:20 <sandbergja> Fair enough!
13:37:22 <dluch> Thanks for facilitating us for now, sandbergja!
13:37:28 <sandbergja> No problem!
13:37:29 <dluch> sandbergja++
13:37:34 <kbutler> sandbergja++
13:37:37 <jihpringle> sandbergja++
13:37:37 <kmlussier> sandbergja++
13:38:04 <sandbergja> Thanks, everyone!
13:38:37 <sandbergja> #topic Progress on Documentation-related bugs in launchpad
13:38:47 <sandbergja> Switching gears a bit
13:39:01 <sandbergja> This is more for my information.  Is anybody super-actively working on these?
13:39:19 <sandbergja> #link https://bugs.launchpad.net/evergreen/+bugs?field.tag=documentation
13:40:17 <sandbergja> And what should their priority be compared to all the other stuff that DIG works on?
13:40:21 <kmlussier> No. It might be nice to highlight those for Bug Squashing day in case there are any DIG folks who want to help out on the doc side of things.
13:41:27 <sandbergja> So we can informally put out the word that "there are docs bugs too" next time the bug squashing day publicity comes around?
13:41:57 <kmlussier> It might be a good start.
13:42:30 <sandbergja> That sounds good to me!
13:42:40 <sandbergja> Thanks for the info.
13:42:45 <sandbergja> #topic Progress on Web Client docs
13:42:51 * kmlussier sometimes files those bugs just as a reminder that there is a simple doc change she wants to change, but it doesn't help.
13:43:25 <sandbergja> Thanks again to jihpringle for helping us get some time scheduled to work on these
13:43:35 <sandbergja> Does anybody have some updates or observations on Web client docs?
13:44:07 <kmlussier> I think we're getting to the point now, with the web client, that we really need to buckle down on getting these docs done. The February hack date will help.
13:44:37 <kmlussier> But I'm guessing that we'll want to include it in the 2.12 hack date too just because we're hoping the web client gets much production use for the next release.
13:46:07 <sandbergja> That's exciting!
13:46:20 <dluch> I agree, kmlussier
13:46:33 <jihpringle> do we have any web docs publicly accessible currently?
13:46:53 <sandbergja> jihpringle: a few
13:46:55 <kmlussier> This could probably be updated - https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:webclient
13:47:15 <sandbergja> #link http://docs.evergreen-ils.org/2.11/_web_client_preview.html
13:47:49 <sandbergja> Here's a question: how much documentation do you think a library would need when adopting the Web client after using the XUL client?
13:48:01 <kmlussier> sandbergja: I could probably take an action item to update the web client doc needs page. I spend a lot of time in the web client.
13:48:16 <sandbergja> kmlussier++
13:48:36 <sandbergja> A lot of screens are very similar in XUL client vs. Web client
13:48:40 <kmlussier> sandbergja: A lot of the interfaces are very similar to the xul ones, so they may not need the docs to transition. But there are a few others that are different, particularly in cataloging.
13:49:08 <jihpringle> this may not be a question we're ready to answer, but are we planning to a have a separate book for the webclient or have the webclient docs within the 2.12 book with the staff client docs?
13:49:21 <kmlussier> I'm thinking the Holdings View is a bit different from holdings maintenance. Also, the volume/copy editor has a lot of differences.
13:49:45 <sandbergja> #action kmlussier will update the web client doc needs page
13:50:01 <kmlussier> jihpringle: Eventually, it should take the place of the staff client docs. The current structure, IMO, should be temporary while people are still moving from one to the other.
13:50:31 <sandbergja> That's helpful; thanks all for the conversation.
13:50:55 <sandbergja> #topic Progress on Docs Reorganization Project
13:51:06 <sandbergja> We actually have some reorganized docs!
13:51:29 <sandbergja> These are by no means complete, just conversation starters to get people excited about the project again. :-)
13:51:37 <sandbergja> Here's a manual for local sysadmins:
13:51:39 <kmlussier> Yay! sandbergja++
13:51:43 <sandbergja> #link http://docs-testing.evergreen-ils.org/docs/reorg/staffclient_sysadmin/
13:51:55 <sandbergja> And a small one for front-line circ staff:
13:52:00 <sandbergja> #link http://docs-testing.evergreen-ils.org/docs/reorg/circulation/
13:52:50 <sandbergja> I'm hoping to get the Docs Reorg group back together at some point to look these over, and try to figure out where to go from here
13:53:11 <sandbergja> But am also more than happy to take suggestions now as well. :-)
13:54:55 <kmlussier> At a first glance, it looks good, but I would need more time to look at it before giving specific feedback.
13:55:16 <sandbergja> That makes sense. :-)
13:55:38 <sandbergja> Did anybody have any topics for our last five minutes?
13:56:51 <sandbergja> Thanks again to everybody for all the crucial documentation work you do!
13:57:03 <sandbergja> And for making time to join today's meeting
13:57:22 <sandbergja> Best wishes for the rest of the week!
13:57:26 <dluch> Thank you, sandbergja!
13:57:37 <sandbergja> #endmeeting