13:06:16 <dbwells> #startmeeting Evergreen Development meeting, 10 January 2017
13:06:16 <pinesol_green> Meeting started Tue Jan 10 13:06:16 2017 US/Eastern.  The chair is dbwells. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:16 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:06:16 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__10_january_2017'
13:06:28 <kmlussier> dbwells++
13:06:56 <dbwells> #info Agenda https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-01-10
13:07:07 <dbwells> #topic Introductions
13:07:26 <dbwells> #info dbwells is Dan Wells, Hekman Library (Calvin College)
13:07:38 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
13:07:38 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:07:45 <abowling> #info abowling is Adam Bowling, Emerald Data Networks
13:07:50 <DPearl> #info DPearl is Dan Pearl, C/W MARS Inc.
13:07:56 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
13:08:18 <Dyrcona> #info Dyrcona is Jason Stephenson, C/W MARS
13:08:47 <berick> #info berick Bill Erickson, KCLS
13:09:01 <dbwells> feel free to continue to introduce yourself as we go
13:09:06 <JBoyer> #info JBoyer is Jason Boyer, IN State Lib, Evergreen IN
13:09:11 <dbwells> #topic Action items from last meeting
13:09:47 <dbwells> "gmcharlt will release OpenSRF 2.5-alpha today"
13:11:12 <dbwells> I see it on the downloads page, and not sure if gmcharlt is around, so just going to info it done
13:11:40 <dbwells> #info gmcharlt released OpenSRF 2.5-alpha on 12/7/16 as planned
13:12:07 <dbwells> kmlussier: anything to note on the feedback soliciting?
13:12:44 <kmlussier> I didn't get to that action item. I'll have to defer it for next month's meeting.
13:12:47 <kmlussier> I'll send something out this week.
13:12:56 <dbwells> okay, thank you
13:13:22 <dbwells> #info kmlussier will post to open-ils-dev soliciting feedback on the release process documentation (carry over)
13:14:04 <dbwells> sorry, let me action that
13:14:17 <dbwells> #action kmlussier will post to open-ils-dev soliciting feedback on the release process documentation
13:14:32 <dbwells> #topic OpenSRF release info
13:15:03 <dbwells> #info OpenSRF 2.5-alpha was release on 7 December 2016
13:15:14 <dbwells> Does anyone else have comment on that?
13:15:56 <dbwells> as a reminder, gmcharlt is hoping for testing of three aspects:
13:15:58 <dbwells> 1. the proxy configurations
13:16:04 <dbwells> 2. bundling and chunking
13:16:10 <dbwells> 3. TZ changes
13:16:51 <dbwells> #topic Evergreen release info
13:17:02 <dbwells> #topic state of Arabic translation
13:17:39 <dbwells> phasefx: Might you be available for a quick update?  Not seeing the others in channel.
13:18:36 <kmlussier> I know there has been a lot of discussion on this over the past week. I think Nawjo may have found a solution that works for him locally.
13:20:24 <dbwells> #info some progress has been made on Arabic support with some localized changes
13:20:51 <kmlussier> There has been talk of including support in 2.12, but I don't know if anyone is actively working on it.
13:20:56 <kmlussier> Nobody has added it to the roadmap.
13:22:01 <dbwells> okay, we'll move on for today
13:22:08 <dbwells> #topic Hatch updates
13:22:17 <dbwells> berick: anything?  (or anyone else)
13:23:15 <berick> nothing since the last meeting.  one idea, though..
13:23:42 <berick> the code includes a variety of fixes we probably want regardless of whether you're using hatch
13:24:04 <berick> i'll add this to the bug, too
13:24:27 <kmlussier> berick: Is everything for hatch right now under bug 1646166?
13:24:27 <pinesol_green> Launchpad bug 1646166 in Evergreen "Hatch 2.12 Omnibus" [Undecided,New] https://launchpad.net/bugs/1646166 - Assigned to Bill Erickson (berick)
13:24:28 <berick> but we probably want to merge the webstaff bits before all of the Hatch-y bits are all done
13:24:37 <berick> kmlussier: yes
13:24:52 <dbwells> That's interesting, I didn't realize that.  I also agree.  How much work would it be to fork them out?
13:25:33 <berick> dbwells: so, i simply mean merge the whole Evergreen working branch code
13:25:56 <berick> nothing to fork out
13:26:44 <berick> would be great to get it merged before 2.12
13:26:47 <kmlussier> berick: You mean the one you listed in comment #1? working/user/berick/lp1646166-hatch-2.12-omnibus?
13:26:56 <dbwells> oh, I see now
13:27:11 <berick> kmlussier: yes
13:27:15 <dbwells> sorry, didn't even realize the bug already had two branches on it.
13:27:30 <kmlussier> berick: I didn't address it in my web client e-mail from last week, but that was mostly an oversight. Do you consider this as a must-have branch for production use of the web client?
13:27:53 <berick> kmlussier: if we want anyone to test Hatch in production, yes
13:28:06 <berick> otherwise, not a showstopper, I don't think, but a nice to have
13:28:18 <berick> so we can start smoothing over any bugs introduced i this code
13:28:27 <berick> and fix a few along the way
13:28:48 <kmlussier> OK, I think I'm going to stop short of calling it a showstopper, but I agree that it would be better to have it in there.
13:30:20 <kmlussier> And we had people (including me) who volunteered to test it during the last meeting. I don't know if jeff or gmcharlt had a chance to look at it, but I know I didn't.
13:30:44 <gmcharlt> #info gmcharlt = Galen Charlton, back from a competing meeting
13:31:01 <csharp> kmlussier: not a showstopper for 2.12, but I would consider it one for 3.0 (first web client GA release)
13:31:05 <kmlussier> @blame competing meetings.
13:31:05 <pinesol_green> kmlussier: competing meetings. is NOT CONNECTED TO THE NETWORK!!!
13:31:16 <csharp> #info csharp = Chris Sharp, GPLS
13:31:19 <kmlussier> csharp: Yes, definitely.
13:31:41 <phasefx> #info phasefx = Jason Etheridge, Equinox
13:32:12 <dbwells> #info berick suggests we merge the Evergreen branch on bug #1646166 soon, and not necessarily wait for the Hatch-side code to be completed
13:32:12 <pinesol_green> Launchpad bug 1646166 in Evergreen "Hatch 2.12 Omnibus" [Undecided,New] https://launchpad.net/bugs/1646166 - Assigned to Bill Erickson (berick)
13:32:40 <berick> and I'll add some comments to the bug explaining that as well
13:32:59 <dbwells> phasefx: would you like us to go back to talk about the Arabic translation work being done?
13:33:09 <phasefx> dbwells: backtracking, re: Arabic, I was fishing for help for Nawjo and seeing if it could jumpstart Arabic support in EG
13:34:15 <phasefx> if he has a bulk of translations done, then it sounds like it's just a matter of figuring out the best way to make right-to-left CSS locale-sensitive
13:34:48 <dbwells> okay, thanks for the details
13:35:33 <dbwells> #topic New Business
13:35:36 <phasefx> so, mostly just offering him a voice at the community table; I have no other impetus
13:36:20 <dbwells> yes, small pond today, I think, but good to keep pushing the word out there
13:36:26 <dbwells> #topic February meeting date (kmlussier)
13:36:34 <miker> #info miker = Mike Rylander, still on a phone meeting... but lurking
13:37:52 <kmlussier> miker and I (and possibly Dyrcona) have a conflict for the February meeting date. We don't need to be there for the meeting to go on, but maybe we should reschedule it.
13:38:15 <jeff> +1 to re-schedule
13:38:28 <gmcharlt> I can take care of doing the rescheduling dance
13:38:41 <kmlussier> gmcharlt++
13:38:44 <gmcharlt> (which, just so you all know, is a waltz)
13:38:44 <dbwells> kmlussier: I think it is important to have the RM there :)
13:38:56 <kmlussier> Well, that was my thought. :)
13:39:03 <gmcharlt> #action gmcharlt will send out a scheduling poll for the Feb. dev meeting
13:39:10 <kmlussier> Especially so close to beta release.
13:39:22 <dbwells> gmcharlt++
13:39:43 <dbwells> #topic Feedback for New Features Under Development
13:40:11 <dbwells> Nothing is listed, so the floor is open to anyone who wants to solicit feedback.
13:41:11 <jeffdavis> I'd appreciate any feedback on ebook API integration
13:41:20 <jeffdavis> bug 1541559
13:41:20 <pinesol_green> Launchpad bug 1541559 in Evergreen "OneClickdigital API integration" [Wishlist,New] https://launchpad.net/bugs/1541559 - Assigned to Jeff Davis (jdavis-sitka)
13:42:07 <jeffdavis> the bug outlines my approach, there hasn't been much response on that so far (perhaps in part because it's a work in progress and the working branch is a bit of a mess...)
13:42:46 <Dyrcona> jeffdavis: I've been meaning to mention something about that. I stumbled across it on PrePan....Just a sec'.
13:43:31 <dbwells> jeffdavis: wow, that's a lot of commits for one feature branch :)  Not that there is anything wrong with that.
13:43:56 <jeffdavis> yeah, I'll put together a consolidated branch with fewer commits in the near future, hopefully that will make it easier to look at :)
13:43:57 <Dyrcona> jeffdavis: I know you're working in JavaScript mostly, but have you seen this: https://metacpan.org/pod/distribution/WebService-ILS/Readme.pod
13:44:43 <jeffdavis> Dyrcona: oh, interesting! No that's completely new to me
13:45:35 <Dyrcona> I was looking at Prepan to see how people go about proposing and as I was browsing, I came across the proposal for the above.
13:47:05 <jeffdavis> I'll have a look at it
13:47:58 <Dyrcona> I'm not sure how complete it is. The POD seems to be a bit lacking.
13:49:00 <dbwells> Dyrcona++
13:49:42 <dbwells> interesting that it targets the same two services.  If nothing else, it might help confirm or clarify direction.
13:50:00 <Dyrcona> Yeah.
13:50:25 <csharp> Dyrcona: ooooh
13:50:25 <jeffdavis> Yeah. Unfortunately for me, that part of my code is the part that's working, it's the UI that I need to finish fleshing out. :)
13:50:42 <Dyrcona> jeffdavis++
13:50:53 <csharp> jeffdavis: there's a lot of interest over here, but not a lot of time - maybe be able to take a look at it post-upgrade
13:51:24 <kmlussier> jeffdavis: Are there specific pieces of it we can help out with?
13:51:25 <Dyrcona> Yeah, time is my shortest commodity at the moment. "So much to do....So much to do..."
13:51:26 <dbwells> jeffdavis: I probably wouldn't be able to merge your branch, since we don't subscribe to the services.  Is any part testable without subscription?
13:51:52 <jeffdavis> My current plan is to get the key UI bits working over the next couple of weeks, then share that with some basic documentation.
13:52:14 <jeffdavis> There is a test module which will be usable for seeing how it works without having subscribed to OverDrive or OneClickdigital's APIs.
13:52:40 <jeffdavis> although of course testing against live external systems would be important for including it in a release :)
13:53:19 <jeffdavis> kmlussier: not so much specific pieces until the above is done. Hoping that devs can weigh in if there are issues with the approach outlined in the LP bug, otherwise just wanted to raise awareness of this work.
13:53:37 <kmlussier> If I wanted to test it against our Overdrive, would I need to sign up for an API key ahead of time?
13:54:06 <jeffdavis> Yes. My attempts to arrange shareable vendor API access for testing have not panned out so far.
13:54:37 <kmlussier> OK, I'll try to go about doing that in preparation for testing. There's a lot of interest here too. :)
13:55:26 <dbwells> Well, I'd say awareness has been raised.  Thanks for bringing it up.  Anything else before I end the meeting?
13:55:40 <kmlussier> Yes
13:56:23 <kmlussier> I just wanted to remind everyone that I would like to schedule a web client hacking day to get more work done on the web client before the beta release.
13:56:34 <kmlussier> The Doodle poll is at http://doodle.com/poll/r77w6ci3a5urcyrz
13:57:22 <kmlussier> Please fill it out before the end of the day tomorrow.
13:57:46 <kmlussier> That's all.
13:57:54 <dbwells> Alright, that's a wrap.  Thanks, all.
13:57:57 <dbwells> #endmeeting