15:00:32 <sandbergja> #startmeeting Evergreen Documentation Interest Group (DIG) Meeting
15:00:32 <pinesol_green> Meeting started Thu Jan 19 15:00:32 2017 US/Eastern.  The chair is sandbergja. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <pinesol_green> The meeting name has been set to 'evergreen_documentation_interest_group__dig__meeting'
15:00:42 <sandbergja> Welcome, everyone!
15:00:51 <sandbergja> You can find today's agenda at https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig_meeting_20170119-agenda
15:01:00 <sandbergja> remingtron: thanks very much for putting the agenda together!
15:01:29 <sandbergja> #topic Introductions
15:01:33 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:01:41 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
15:01:49 <kbutler> #info kbutler is Kate Butler, Rodgers Library (Hudson, NH)
15:02:00 <jlundgren> #info jlundgren is Jeanette Lundgren, C/W MARS
15:02:58 <sandbergja> Thank you everyone for coming!
15:03:15 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
15:03:25 <sandbergja> #topic Old Business
15:03:54 <sandbergja> kmlussier will put a call out on the list to find a volunteer to be DIG release coordinator
15:04:16 <sandbergja> And actually, I am happy to volunteer for this once we find a new DIG facilitator. :-)
15:04:34 <kmlussier> Yes, no call was required. sandbergja++
15:04:52 <sandbergja> sandbergja will put out a formal call for DIG facilitator
15:05:09 <sandbergja> I did this, but have not received any emails :-(
15:05:40 <sandbergja> jihpringle was kind enough to schedule and publicize a 2.11/web client hack day for early February
15:05:52 <sandbergja> kmlussier will update the web client doc needs page
15:06:18 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative
15:06:20 <sandbergja> The web client doc needs page is looking really nice, y'all
15:06:36 <kmlussier> I think remingtron took care of my action item. Thanks remingtron! :)
15:06:42 <remingtron> no problem
15:07:30 <sandbergja> jihpringle: did you have a chance to research the state of missing RDA content?  Or should I defer?
15:07:37 <jihpringle> please defer
15:08:06 <sandbergja> Sure!
15:08:15 <sandbergja> #action jihpringle will research the state of missing RDA content
15:08:30 <sandbergja> #action Christineb will investigate creating a Youtube playlist that incorporates SITKA videos and videos from non-SITKA sources
15:08:38 <sandbergja> I think that covers all the old business!
15:08:45 <sandbergja> Thanks everyone for all your hard work!
15:08:51 <sandbergja> #topic Finding a new DIG Facilitator
15:08:52 <jihpringle> Christineb says it's possible
15:09:10 <sandbergja> Oooh!  That's good to hear!
15:09:25 <jihpringle> she can add videos from other consortia to a playlist, people just need to send her the links
15:10:14 <sandbergja> jihpringle: Could you remind me if there are specific criteria she's looking for in videos that we send to her?
15:10:58 <jihpringle> and we could put a link to the playlist on the website or we could create a Evergreen Youtube channel and have the credentials shared with relevant people
15:11:15 <jihpringle> if we do the Evergreen channel we could have multiple playlists
15:11:40 <jihpringle> no specific criteria other than videos that people think will be useful to others
15:11:56 <jihpringle> and they need to be able to shared via creative commons license
15:12:12 <sandbergja> Very nice!
15:12:19 <sandbergja> Thanks for the update!
15:12:58 <sandbergja> Can I put an action item for everybody to send useful Creative Commons-licensed videos to Christineb?
15:13:42 <jihpringle> yes
15:14:07 <jihpringle> we can start with a shared playlist and then if there is lots of interest we can always create an Evergreen Channel
15:14:36 <sandbergja> #action Everybody will send useful, Evergreen-related, Creative Commons-licensed videos to Christineb
15:14:51 <Christineb> christine.burns@bc.libraries.coop
15:15:26 <sandbergja> Thanks for all your work on this, Christineb!
15:15:56 <sandbergja> I'm going to move us back to talking about finding a new DIG Facilitator
15:16:17 <sandbergja> I have sent out two emails: one to the DIG email list, one to both DIG and the general list
15:16:39 <sandbergja> I didn't get any takers, but I also might have been too formal and intimidating with my emails.
15:17:51 <sandbergja> I am happy to continue facilitating meetings in the meantime, but I won't be at the 2017 conference, so it would be great to have somebody more permanent by then
15:18:17 <sandbergja> Any ideas about how to best continue the search?
15:18:39 <kmlussier> I've been thinking about this a bit. If nobody steps up as an official facilitator, we might want to consider a more informal structure as is done with the developers.
15:18:58 <kmlussier> One person should probably be in charge of sending out meeting reminders, because, otherwise, the meetings are forgotten.
15:19:27 <kmlussier> The agenda would be a communal effort. And people could volunteer to facilitate on a meeting-by-meeting basis depending on the time they have available.
15:19:58 <kmlussier> I think it's preferred to have a designated facilitator to keep the meetings running smoothly. But it may be another way to approach things if we don't get a volunteer.
15:20:52 <jlundgren> Is it possible to do some training/recruiting at the conference?  bit of a learning curve to just jump in.
15:21:17 <remingtron> jlundgren: training on running an IRC meeting? or on something else?
15:21:53 <jlundgren> helping with documentation.  IRC seems like the *easy* part...
15:22:48 <kmlussier> Do we have a DIG hackfest on the pre-conference day?
15:23:12 <sandbergja> jlundgren: do you mean more logistical things, like troubleshooting AsciiDoc, understanding how the documentation is put together, contributing documentation via git, etc.?
15:23:13 <kmlussier> jlundgren: Actually, the facilitator role doesn't have to do a lot with the documentation part. It's mostly the keeping the meetings and agendas going piece.
15:24:03 <jlundgren> sanbergja: yes!
15:25:21 <kmlussier> If we have a hackfest, we usually do a lot of that there. If we don't have a hackfest, then maybe a couple of us can put something together?
15:26:15 <sandbergja> And the conference organizers do seem to be planning for a docs hackfest
15:26:16 <remingtron> jlundgren: before the conference, there are some AsciiDoc cheat sheets and tutorials listed on the wiki
15:26:19 <remingtron> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:dig#asciidoc_for_evergreen_22_and_later
15:27:03 <kmlussier> Yeah, ok, I just dug up the e-mail from Joe. http://georgialibraries.markmail.org/thread/7bplnxc3vpdwlsxg
15:27:32 <sandbergja> Oh!  Ha!  I knew there was an agenda item I was forgetting!
15:27:36 <sandbergja> Thanks kmlussier!\
15:28:16 <sandbergja> We should also figure out who would be a good contact person for the hackfest. :-)
15:28:20 <sandbergja> I totally forgot about that
15:29:07 <sandbergja> Anybody who would be willing to do that piece?
15:29:49 <kmlussier> I would like to suggest that we run things a little informally between now and the conference. And, if we aren't able to get somebody before April, we try to pin somebody down at the conference.
15:30:07 <kmlussier> Who from DIG is planning to attend the conference? I'll be there. Anyone else?
15:30:26 <remingtron> I'm planning on attending the conf
15:30:26 <jlundgren> I will be there
15:31:45 <remingtron> lynn floyd is presenting, so she'll be there
15:32:08 <sandbergja> Would the three of you be willing to collaborate on planning the conference Hackfest, including being in touch with the conference organizers?
15:32:38 <jlundgren> absolutely.  I can help with coordination.
15:32:59 <sandbergja> Thanks!
15:33:00 <kmlussier> Yes, I could work on it. My only hesitation is that I don't know how much time I can spend at the DIG hackfest since it occurs at the same time as the dev hackfest.
15:33:16 <remingtron> kmlussier: that's my concern also
15:33:29 <sandbergja> Fair enough
15:33:31 <kmlussier> But I can get involved in pre-planning and can help with a presentation on git or asciidoc if it's at a specific time.
15:34:20 <sandbergja> I think that sounds pretty solid
15:35:40 <sandbergja> So can I put down an action item about planning the hackfest (even if you won't be able to attend the whole thing)?
15:36:02 <kmlussier> yes for me.
15:36:10 <sandbergja> remingtron: would you prefer that I include you or not in that action item?
15:38:06 <remingtron> sandbergja: hm, not for now I think
15:38:11 <sandbergja> Sure!
15:38:37 <remingtron> (sorry, I was poking around EG's github, forgot we were in a meeting)
15:38:42 <sandbergja> #action jlundgren and kmlussier will plan a hackfest for the 2017 conference, including being the contact people for the conference chairs
15:38:43 <kmlussier> heh
15:38:46 <remingtron> :-P
15:38:52 <sandbergja> :-)
15:39:24 <sandbergja> #topic Progress on Web Client docs
15:40:09 <sandbergja> We're chipping away at them!  And the upcoming hackfests will help as well
15:40:10 <dluch> Sorry I'm late, everyone!
15:40:16 <sandbergja> No worries!  Welcome!
15:40:19 <remingtron> Lots of the chapters on the list don't need to be changed
15:40:22 <remingtron> dluch: welcome!
15:40:45 <remingtron> so, this is the fun stage of quickly reading a chapter and saying "DONE!"
15:40:58 <remingtron> (or NO CHANGE is probably better)
15:41:54 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:webclient
15:41:57 <kmlussier> remingtron: Are you referring to the chapters for Dojo interfaces, like acq?
15:42:24 <remingtron> yes, if screenshots don't need updating
15:43:01 <remingtron> and also chapters like "14. Describing your organization"
15:43:27 <remingtron> but that brings me to a big question...
15:43:39 <remingtron> WHERE should the web client docs go?
15:43:51 <remingtron> replace existing docs, or do we need both for a while?
15:44:37 <dluch> I think we'd need both for a while
15:44:40 <kmlussier> We've been putting them in that special Web Client Preview section, which is problematic because it adds a heading level to the docs.
15:44:49 <kmlussier> I think we definitely need both for 2.12.
15:45:14 <kmlussier> For 3.0? I don't know. The xul client will be deprecated, but people may still be using it.
15:46:09 <remingtron> What if we make web client changes in the master/2.12 docs, and people can use 2.11 staff client docs for XUL specific things?
15:47:08 <kmlussier> remingtron: That might be a good idea. I'm hoping that any new features coming with 2.12 don't make changes to the xul staff client, so the old docs should still be good.
15:47:14 <dluch> Aren't there XUL client changes in 2.12, too, though?
15:47:21 <dluch> Oh, lol
15:48:29 * kmlussier looks at the roadmap - https://wiki.evergreen-ils.org/doku.php?id=faqs:evergreen_roadmap:2.12
15:48:32 <sandbergja> For the 2.12 docs, should we totally remove the XUL-specific documentation?
15:49:04 <sandbergja> Or deprecate it in its own little section (akin to the "Preview" section the Web client docs are in right now)?
15:49:56 <kmlussier> The concern I have with the subsection is that issue with the additional heading. If the docs are already used up all its heading levels, moving it to a preview section can be problematic.
15:50:00 <remingtron> sandbergja: I would propose we overwrite XUL stuff with web client stuff, rather than duplicate it
15:50:53 <kmlussier> I think it will make the docs cleaner too. Of course, we could provide a link from the 2.12 staff client page to the 2.11 client docs.
15:51:05 <sandbergja> Sounds good to me!
15:51:40 <remingtron> another problem with duplicating large chunks of the docs is that we rely on the auto-generated section titles; copying a section with identical title would result in a "_title_2", and the link going to "_title" would go to the other section
15:52:25 <remingtron> kmlussier: that sounds good enough of a solution for now
15:52:40 <sandbergja> #agreed We will replace XUL client documentation with Web client documentation for the 2.12 docs
15:53:28 <sandbergja> #topic Requirements for the Web Client
15:53:34 <sandbergja> gmcharlt has answered this already
15:53:42 <sandbergja> remingtron: thanks for posing the question!
15:54:11 <remingtron> you're welcome
15:54:20 <sandbergja> Would somebody be willing to ASCIIDoc-ize gmcharlt's email and put it into the docs?
15:56:11 <kmlussier> crickets :)
15:56:15 <kmlussier> sandbergja: I can do that.
15:56:22 <sandbergja> kmlussier++
15:56:27 <sandbergja> thanks so much!
15:56:56 <sandbergja> #topic Updating the DIG Roles document
15:57:15 <sandbergja> I'm thinking that if we're going to adopt a more informal structure for the time being, we can defer this conversation
15:58:16 <sandbergja> Did anybody else have any news or questions to close the meeting?
15:58:43 <abneiman> sandbergja: one quick thing
15:59:25 <abneiman> I will be sending my XUL v Webby list to the DIG list, probably this afternoon but maybe tomorrow.
15:59:43 <sandbergja> abneiman++
15:59:49 <remingtron> abneiman++
15:59:53 <sandbergja> That will be great to have!
16:00:01 <kmlussier> abneiman++
16:00:05 <dluch> abneiman++
16:00:19 <sandbergja> Thanks everybody for a good meeting!
16:00:25 <sandbergja> #endmeeting