13:02:45 <kmlussier> #startmeeting 2017-03-28 Evergreen 3.0 Release Manager Election
13:02:45 <pinesol_green> Meeting started Tue Mar 28 13:02:45 2017 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:45 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:45 <pinesol_green> The meeting name has been set to '2017_03_28_evergreen_3_0_release_manager_election'
13:02:51 <kmlussier> #topic Introductions
13:02:57 <kmlussier> Please introduce yourselves with #info
13:03:05 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
13:03:13 <phasefx> #info Jason Etheridge, Equinox
13:03:23 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
13:03:44 <Dyrcona> #info Jason Stephenson, C/W MARS
13:03:45 <berick> #info berick Bill Erickson, KCLS
13:03:49 <JBoyer> #info JBoyer is Jason Boyer from the IN State Library
13:03:51 <gmcharlt> #info Galen Charlton, EOLI
13:04:21 <dbwells> #info dbwells is Dan Wells, Hekman Library (Calvin College)
13:04:28 <rhamby> #info Rogan Hamby, EOLI
13:04:49 <remingtron> #info remingtron is Remington Steed, Hekman Library (Calvin College)
13:05:07 <Bmagic> #info Blake GH, MOBIUS
13:05:12 <csharp> #info csharp is Chris Sharp, GPLS
13:05:33 <abneiman> #info abneiman Andrea Buntz Neiman, EOLI
13:05:40 <kmlussier> #topic Release Manager Election
13:06:02 <kmlussier> #info Galen Charlton has been nominated for 3.0 Release Manager.
13:06:08 <kmlussier> #link http://markmail.org/message/myn75cfyzg6gldll is his proposal
13:06:27 <kmlussier> gmcharlt: Do you have anything to add to the proposal?
13:06:33 <gmcharlt> kmlussier: I do
13:06:39 <gmcharlt> #info Proposed 3.0 schedule - http://paste.evergreen-ils.org/77
13:06:59 <gmcharlt> so, this follows the typical schedule, more or less, with the following changes
13:07:14 <gmcharlt> - intentionally allowing a bit more time, and setting an early October release date accordingly
13:07:22 <gmcharlt> - suggesting dates for the "Feedback Fests"
13:07:59 <kmlussier> +1 to feedback fests!
13:08:26 <dbs> #info Dan Scott, Laurentian University
13:09:27 <gmcharlt> the primary release priority would be, of course, completion of the web staff interface and recommendation that it start being used in full production capacity
13:09:34 <gmcharlt> with a concurrent deprecation of the XUL client
13:10:10 <gmcharlt> questions regarding the proposal?
13:11:28 <kmlussier> I have a question about the schedule for translators, which is the same question I raised at the most recent dev meeting. Will there be opportunity to give more time for translators to do their work beyond the .0 release and maybe generate the translations again before .1?
13:12:46 <gmcharlt> I think we can do that, pending discussions on whether we can readily add more translation branches into LP
13:13:12 <kmlussier> Also, are you planning to be buildmaster, or should we be putting out a call for somebody to take on that role?
13:13:28 <gmcharlt> I intend to put out a separate call
13:13:42 <remingtron> When would an alpha release be cut, if desired? Would that be on Sept 1 also?
13:14:44 <gmcharlt> around then, yes — and to be honest, I currently view the alpha release primarily as a translation milestone
13:15:16 <bshum> gmcharlt: When you're talking about "add more translation branches into LP", are you talking about series-based translation support?
13:15:23 <gmcharlt> bshum: yes
13:15:37 <bshum> Okay, just making sure I understood the target
13:16:07 <kmlussier> Does anybody else have more questions for gmcharlt regarding release goals, timelines or anything else related to the release?
13:17:26 <Dyrcona> These feedback fests: You're hoping to get help reviewing pull requests, right? I mean, you aren't planning to review every pull request yourself?
13:17:41 <terran> #info terran is Terran McCanna, PINES
13:17:45 <gmcharlt> heck no, re doing it by myself
13:18:07 <kmlussier> Ha!
13:18:17 <gmcharlt> the idea is to arrange a particular set of time where as many people as possible are reviewing pull requests
13:18:52 <gmcharlt> with emphasis on (a) getting at least some feedback to all of them and (b) identifying the ones that perhaps need breaking up
13:19:07 <gmcharlt> I envision my role during the process as much more nudging than direct patch reviewing
13:19:09 <Dyrcona> OK. Sounds good.
13:19:27 <kmlussier> And hopefully removing the pullrequest when the patch is determined to not be ready?
13:19:34 <gmcharlt> yeah
13:19:40 <kmlussier> OK, I'm going to leave another minute for questions, and if nobody speaks up, I'll start the vote.
13:20:57 <kmlussier> #startvote Should gmcharlt be 3.0 Release Manager? yes, no, abstain
13:20:57 <pinesol_green> Begin voting on: Should gmcharlt be 3.0 Release Manager? Valid vote options are yes, no, abstain.
13:20:57 <pinesol_green> Vote using '#vote OPTION'. Only your last vote counts.
13:21:07 <bshum> #vote yes
13:21:08 <csharp> #vote yes
13:21:10 <JBoyer> #vote yes
13:21:10 <terran> #vote yes
13:21:15 <berick> #vote yes
13:21:17 <phasefx> #vote yes
13:21:18 <Dyrcona> #vote yes
13:21:24 <abneiman> #vote yes
13:21:42 <rhamby> #vote yes
13:21:42 <kmlussier> #vote yes
13:21:46 <dbs> #vote yes
13:21:46 <jeff> #vote yes
13:21:57 <remingtron> #vote yes
13:22:49 <kmlussier> #endvote
13:22:49 <pinesol_green> Voted on "Should gmcharlt be 3.0 Release Manager?" Results are
13:22:49 <pinesol_green> yes (13): kmlussier, JBoyer, abneiman, jeff, berick, remingtron, phasefx, Dyrcona, terran, csharp, bshum, dbs, rhamby
13:22:55 <kmlussier> Congratulations gmcharlt!
13:23:05 <JBoyer> gmcharlt++
13:23:07 <csharp> gmcharlt++
13:23:13 <gmcharlt> thank you all for your turst
13:23:17 <gmcharlt> er, trust
13:23:27 <gmcharlt> (good thing I did not promise a typo-free release)
13:23:29 <rhamby> we welcome our new overlor... er, release manager
13:23:33 <csharp> @karma turst
13:23:33 <pinesol_green> csharp: turst has neutral karma.
13:23:40 <kmlussier> Does anyone have any other questions or things to say before we wrap up?
13:23:45 <jeff> gmcharlt++
13:23:58 <kmlussier> gmcharlt: What? No typo-free release? Now you tell us!
13:23:59 <gmcharlt> just to raise the question, which doesn't need to be answered immediately
13:24:20 <gmcharlt> for 2.12 and 2.11... who will be/continue as RMaints?
13:25:16 <kmlussier> I can be 2.12 release maintainer for herding cats, but maybe we need somebody else to fill in as buildmaster?
13:25:36 <kmlussier> Since gmcharlt will be a little busy with 3.0
13:25:43 <gmcharlt> indeed
13:26:03 <gmcharlt> I can make the call for buildmasters be inclusive of both 3.0 and the maintenance releases
13:26:23 * kmlussier could probably learn to build a release, but it might take more time away from gmcharlt thank if he built the release himself.
13:26:57 <dbwells> #vote yes (sorry, had to step away for a minute)
13:27:09 <miker> #vote yes
13:27:18 <miker> phone call distracted me, sorry!
13:27:57 <kmlussier> #action gmcharlt to put out call for buildmasters for both 3.0 and maintenance releases
13:28:03 <kmlussier> Anything else?
13:28:18 <gmcharlt> miker: you'll continue as 2.11 rmaint?
13:29:19 <miker> gmcharlt: aye
13:29:27 <gmcharlt> kmlussier++
13:29:29 <gmcharlt> miker++
13:29:33 <mmorgan> gmcharlt++ kmlussier++ miker++
13:29:49 <kmlussier> #endmeeting