#evergreen: Development meeting, 3 May 2017

Meeting started by gmcharlt at 15:01:33 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-05-03 (gmcharlt, 15:01:41)

  1. Introductions (gmcharlt, 15:01:56)
    1. Galen Charlton, EOLI, 3.0 RM (gmcharlt, 15:02:04)
    2. DPearl is Dan Pearl, C/W MARS Inc. (DPearl, 15:02:12)
    3. Dan Scott, Laurentian University (dbs, 15:02:16)
    4. abowling = Adam Bowling, Emerald Data Networks (abowling, 15:02:19)
    5. Rogan Hamby, Equinox (rhamby, 15:02:19)
    6. Jason Etheridge, EOLI (phasefx, 15:02:22)
    7. Kathy Lussier, MassLNC (kmlussier, 15:02:27)
    8. Jason Stephenson, C/W MARS (Dyrcona, 15:02:35)
    9. remingtron is Remington Steed, Hekman Library (Calvin College) (remingtron, 15:02:38)
    10. dbwells = Dan Wells, Hekman Library (Calvin College) (dbwells, 15:02:49)
    11. berick Bill Erickson, KCLS (berick, 15:02:50)
    12. csharp is Chris Sharp, GPLS (csharp, 15:02:58)
    13. jeffdavis = Jeff Davis, BC Libraries Cooperative (Sitka) (jeffdavis, 15:03:45)

  2. Action items from previous meeting (gmcharlt, 15:04:55)
    1. Bmagic = Blake GH, MOBIUS (Bmagic, 15:06:16)
    2. ACTION: Galen will send out a call for patch authors to use open-ils-dev to introduce new features. (gmcharlt, 15:06:23)

  3. OpenSRF release info (gmcharlt, 15:15:05)
    1. bug 1684970 warrants a release of 2.5.1 this month (gmcharlt, 15:15:33)

  4. Evergreen releases (gmcharlt, 15:18:13)
    1. 2.12.1, 2.11.4, and 2.10.11 were released on 19 April (gmcharlt, 15:18:27)
    2. 2.10.11 is the last bugfix release for 2.10.x, which is now security only (gmcharlt, 15:18:44)

  5. Statement of responsibilities of core committers (gmcharlt, 15:25:15)
    1. https://wiki.evergreen-ils.org/doku.php?id=contributing:core_committer_responsibilities (gmcharlt, 15:25:17)
    2. VOTE: Voted on "Shall the statement of committer responsibilities linked above be adopted?" Results are, Yes: 12 (gmcharlt, 16:00:47)
    3. AGREED: https://wiki.evergreen-ils.org/doku.php?id=contributing:core_committer_responsibilities is adopted as a statement of committer responsbilities (gmcharlt, 16:01:01)
    4. ACTION: gmcharlt will start thread on moving forward with investigation of replacing LP (gmcharlt, 16:02:31)
    5. Patches for bug 1685840, bug 1681095, and bug 1411699 are commended to the dev community for general attention and testing (gmcharlt, 16:04:57)


Meeting ended at 16:05:12 US/Eastern (full logs).

Action items

  1. Galen will send out a call for patch authors to use open-ils-dev to introduce new features.
  2. gmcharlt will start thread on moving forward with investigation of replacing LP


Action items, by person

  1. gmcharlt
    1. gmcharlt will start thread on moving forward with investigation of replacing LP


People present (lines said)

  1. gmcharlt (93)
  2. dbs (37)
  3. dbwells (20)
  4. Dyrcona (17)
  5. kmlussier (16)
  6. pinesol_green (15)
  7. bshum (9)
  8. abowling (7)
  9. phasefx (7)
  10. Bmagic (6)
  11. csharp (5)
  12. jeffdavis (5)
  13. DPearl (2)
  14. berick (2)
  15. remingtron (2)
  16. rhamby (2)
  17. jeff (1)


Generated by MeetBot 0.1.4.