14:01:27 <kmlussier> #startmeeting 2017-05019 - Evergreen Web Team Meeting
14:01:27 <pinesol_green> Meeting started Wed May 10 14:01:27 2017 US/Eastern.  The chair is kmlussier. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:27 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:27 <pinesol_green> The meeting name has been set to '2017_05019___evergreen_web_team_meeting'
14:01:50 <kmlussier> Oops. Looks like I messed up the date. :(
14:01:58 <kmlussier> #info Agenda is available at https://wiki.evergreen-ils.org/doku.php?id=webteam:meetings:agenda:2017-05-10
14:02:36 <kmlussier> #topic Introductions
14:02:43 <kmlussier> Please introduce yourselves as follows:
14:02:49 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:02:57 <jlundgren> #info jlundgren is Jeanette Lundgren, C/W MARS
14:03:04 <graced> #info graced is Grace Dunbar, Equinox Open Library Initiative
14:03:19 <collum_> #info collum is Garry Collum, Kenton County Public Library
14:03:25 <DianeD> DianeD is Diane Disbro, Missouri Evergreen
14:03:28 <sallyf> #info is Sally Fortin, Equinox Open Library Initiative
14:03:28 <alynn26> #info alynn26 is Lynn Floyd, Anderson County Library
14:03:44 <ericar> #info ericar is Erica Rohlfs, Equinox Open Library Initiative
14:04:10 <terran_> #info terran_ is Terran McCanna, PINES
14:04:13 <ggrae> #info ggrae is Angela Simmons-Jones, Houston County Public Library System in Georgia
14:04:27 <ohiojoe> #info ohiojoe is Joe Knueven, Germantown PL, Consortium of Ohio Libraries
14:04:45 <abneiman> #info abneiman is Andrea Buntz Neiman, Equinox
14:05:08 <kmlussier> Great, it's good to see new names in here!
14:05:32 <rhamby> sorry about that quassel decided to die on me suddenly
14:05:45 <kmlussier> People who wander in late can introduce themselves as they arrive.
14:05:53 <kmlussier> rhamby: Likely story. ;)
14:06:04 <rhamby> #info rhamby = Rogan Hamby, Equinox
14:06:07 <gmcharlt> #info gmcharlt is Galen Charlton, EOLI
14:06:21 <rhamby> kmlussier: I never avoid meetings you're running, that's how I end up volunteered for extra things
14:06:34 <kmlussier> rhamby: Darn! You weren't supposed to figure that out?
14:06:54 <kmlussier> Before we start, I would like to give some background for those who are new to a web team meeting...
14:07:08 <kmlussier> The web team is responsible for the ongoing care and feeding of the Evergreen web site, for keeping content up to date, and for ensuring that the content meets the needs of the Evergreen community.
14:07:24 <kmlussier> The team hasn't met in about two years, and web site contributors have been updating content and addressing technical issues.
14:07:42 <kmlussier> By meeting regularly again, I'm hoping we can re-focus on adding new content to the site, if needed, keeping the blog up to date, and possibly thinking of the site design.
14:07:52 <kmlussier> If you're new to the web team meeting and found out about it via the general list, I recommend you sign up for the web team list.
14:08:04 <kmlussier> #link http://list.evergreen-ils.org/cgi-bin/mailman/listinfo/evergreen-web-team
14:08:19 <kmlussier> We have a good turnout today, so welcome! I'm glad you all could join us!
14:08:57 <kmlussier> We do have some very old action items remaining from a meeting that I'm going to run through now, but I think we can dispense with all but a couple of them so that we can all start fresh.
14:09:16 <kmlussier> #topic Action Items from Previous Meetings
14:09:27 <kmlussier> #info gmcharlt has put an Evergreen logo and link back to the main web site on irc.evergreen-ils.org
14:09:36 <kmlussier> As a note of explanation, several years ago, the Evergreen Oversight Board requested that all pages that fall within the evergreen-ils.org domain contain an Evergreen logo with a link to the main site.
14:09:44 <kmlussier> gmcharlt++
14:09:59 <kmlussier> #info kmlussier has contacted all but one of the people who has a WordPress account to ask if they give consent to license the content under CC BY-SA. 24 of the 37 people with accounts have consented.
14:10:30 <kmlussier> If anyone knows any of the remaining folks on the list, I would appreciate help in reaching out.
14:10:38 <kmlussier> The list is available at https://docs.google.com/spreadsheets/d/1dJvPa2OxwSO7m_-8WN0qGJ7bYBM-VPyYAmB4jNg2Dd8/edit?usp=sharing.
14:10:55 <kmlussier> I do have on follow-up question from this action item.
14:11:08 <kmlussier> Some of the account-holders are listed as having 0 posts on the site. This could mean one of two things:
14:11:20 <kmlussier> They may have contributed to the site by creating/editing WordPress pages, which isn't reflected in this number.
14:11:30 <kmlussier> Or they may have never contributed any content, meaning that the consent isn't really needed in the end.
14:11:40 <kmlussier> I'm wondering how important it is to get consent from those users if we ultimately aren't able to reach them.
14:12:56 <rhamby> kmlussier: worst case scenario we can put language on those pages that the content is exempt from the wider CC license but I would either do that or remove it, not automatically consider it in the license
14:13:03 <dbs> It's a risk calculation. How likely is it for one of those users to take legal action or be upset if we make their content available.
14:13:33 <dbs> I would say the likelihood is low. And if we can flag pages where they've contributed, we could mark them as such?
14:14:05 <abneiman> not sure of the legalities, but we want to make sure we carefully document that there was a good-faith effort to contact them -- "X webteam member contacted Y content owner at Z email address on Date", etc.
14:14:13 <graced> Also, based off who is left on the list I think we can come close to tracking everyone down.
14:14:15 <dbs> #info dbs is Dan Scott, Laurentian
14:14:16 <rhamby> dbs: I think we're having the same thought from different angles, risk is low but we can't include their content under the CC w/o their assignment of it IMO
14:14:21 <kmlussier> Yeah, so it's easy for me to see which blog posts those authors contributed to. But, through the admin interface, I can't really see what pages they may have edited.
14:14:31 <kmlussier> Can somebody else find that information through the database?
14:14:44 <dbs> abneiman++ # yep
14:14:48 <rhamby> kmlussier: at least in the US their just editing leaves it still as a derivative work and they have no say in it's copyright status
14:14:53 <kmlussier> graced: Yes, I agree most we should be able to track down.
14:15:07 <kmlussier> graced: But there is still one person I haven't been able to find contact information for.
14:16:10 <kmlussier> OK, well my hope is to get a response from most, if not all, the people. If there are any left, we can revisit. Thanks for the feedback!
14:16:48 <kmlussier> So the next outstanding action item I'm going to turn into a new action item assigned to me.
14:16:59 <kmlussier> #action kmlussier to send notification of license clarification to the mailing list after getting more responses from current authors on the CC BY-SA licensing.
14:17:28 <kmlussier> And then we have a few other action items that are either done or no longer relevant.
14:17:34 <kmlussier> #info RoganH (aka rhamby) did indeed get the 2016 conference folks set up with WordPress accounts
14:17:42 <kmlussier> rhamby++
14:17:48 <kmlussier> Would somebody like to take an action item to set up the 2018 conference folks with WordPress accounts?
14:17:58 <rhamby> I'll volunteer for it again
14:18:04 <kmlussier> rhamby: Thanks!
14:18:13 <rhamby> I'm on the conference list so easy enough to do
14:18:35 <kmlussier> #action rhamby to contact 2018 conference folks to get WordPress accounts to manage the conference site.
14:18:47 <kmlussier> #info webstats has been disabled on the web site, negating the need to add a robots.txt to disallow crawling.
14:19:00 <kmlussier> Any questions about the old action items before I move on?
14:19:45 <kmlussier> #topic Evergreen Community Tutorials
14:20:01 <kmlussier> Christineb asked me to raise this question
14:20:11 <kmlussier> #link https://www.youtube.com/playlist?list=PLdwlgwBNnH4riThcmOwvdLTddsn435RcJ
14:20:41 <kmlussier> IG (the Documentation Interest Group) would like to add a link to the tutorials from the web site.
14:20:48 <kmlussier> Sorry, that should be DIG, not IG
14:21:26 <kmlussier> Christineb wanted to know if we have a preference for placing the link.
14:21:36 <kmlussier> Her thoughts were either add it to the Documentation menu or add it to the wiki page at https://evergreen-ils.org/eg-documentation/
14:21:41 <kmlussier> Any thoughts on that?
14:21:55 <rhamby> my gut reaction is to add it to the documentation menu
14:22:20 <kmlussier> I think it will get the most visibility there.
14:22:35 <rhamby> that was my thought
14:22:43 <DianeD> how about create a new tab?
14:22:58 <DianeD> something like "Circ Helps"
14:23:33 <DianeD> I know all the videos aren't about circ but then circ people wouldn't need to search for help
14:23:44 <kmlussier> DianeD: By new tab, do you mean the dropdown menus along the top?
14:23:47 <graced> OOC, who curates that channel - just BC Coop? Will it be actively curated for content and kept up to date?
14:24:06 <DianeD> Yes - a new option along the top
14:24:22 <kmlussier> graced: That's the plan. DIG is working to keep that content up to date from what I understand.
14:24:42 <graced> cool, I like plans
14:25:02 <rhamby> I'd prefer the branding be a bit more Evergreen centric and it does need to be up to date (the 2.9 upgrade video can probably go)
14:25:27 <kmlussier> DianeD: My only concern with the new tab is that we generally have categories listed up there with links fitting that category underneath. In this case, it's just the one link.
14:25:30 <rhamby> but I really like the idea of the video series and much karma to the dig folks for it
14:25:46 <kmlussier> Merchandising is currently the exception to that rule. At one time, I was thinking we might expand that section.
14:26:15 <rhamby> to be fair if we progress with plans for a site overhaul some of that might get moved around
14:26:29 <DianeD> we could put more stuff for circ in a circ link
14:26:29 <abneiman> agreed with adding it under the doc menu; also that menu is only 4 items currently so it won't be crowded/hard to find
14:26:55 <rhamby> +1 to doc menu for now (might get changed during site overhaul)
14:27:03 <Christineb> I can give perms to anyone that wants the ability to update the playlist
14:27:10 <Christineb> sorry just jumping in on another call
14:27:27 <kmlussier> rhamby: Good point. For now, then, I think we might want to keep it within the current info architecture, but maybe we rethink the way the site is organized with an overhaul.
14:27:45 <collum_> Is there an active wordpress plugin to pull in youtube channels automatically?
14:27:59 <kmlussier> collum_: Probably
14:29:17 <rhamby> Christineb: I'll gladly take an invite to the channel maintenance to help out with it
14:29:39 <kmlussier> collum_: Would you like to take an action item to investigate YouTube plugins to see if there is a way to better integrate those into the site?
14:29:49 <collum_> Will do.
14:29:55 <kmlussier> collum++
14:30:07 <bshum> Just circling back to an earlier topic, but this paste shows a quick query I assembled on the wordpress database to count out who has made page edits in wp_posts (aka, wordpress pages and posts):  https://pastebin.com/7k0PmwSm
14:30:28 <bshum> You can cross that against the users with accounts to eliminate users who have not exercised their access.
14:30:39 <kmlussier> #action collum to investigate YouTube WordPress plugins to see if there is a better way to integrate the tutorials into the evergreen-ils.org site.
14:30:52 <kmlussier> bshum++
14:31:07 <kmlussier> I'll take an action item to do that cross checking.
14:32:06 <kmlussier> To finish up on this topic, I would say we should put the link in the documentation menu for now, explore the YouTube plugin, and keep in mind of alternate ways of organizing it if/when we overhaul the site.
14:32:11 <kmlussier> Are there any objections to the above?
14:33:18 <graced> +1 to the plan
14:33:32 <rhamby> +1 for great justice
14:33:32 <kmlussier> OK, moving on then
14:33:50 <kmlussier> #topic New and blue sky projects
14:34:02 <kmlussier> #link https://docs.google.com/spreadsheets/d/1e2n3A0cVxbmbvMnRKTw4Y3Vtl5DkL4vv9eQAfw2CzvM/edit?usp=sharing
14:34:59 <kmlussier> This is a spreadsheet where we were tracking tasks that we wanted to do on the web site and, in some cases, what we were actively working on.
14:35:01 <alynn26_> +1
14:35:46 <kmlussier> The In-Progress has some in-progress tasks with people assigned to them. If your name is assigned to one of these tasks, I'm asking that you update the progress if there is any to report.
14:36:22 <kmlussier> Or, if you are no longer willing to work on the task, I'm asking that you remove your name and maybe set it back to New so that it's eligible for somebody else to work on.
14:37:12 <kmlussier> Given that this is the first time we've met in a while and that there are new people involved, I'm guessing there are new things people want to add to the list.
14:39:21 <kmlussier> I'm thinking maybe we should work over the next month on updating this list. Updating progress, removing assginments when needed, and adding new projects to the New tab.
14:39:47 <kmlussier> And then when we meet again in June, we could look at what's there, prioritize, and try to find some volunteers to work on some items.
14:40:22 <dbs> gmcharlt: LDAP (or the like) as common auth backend for wiki & website could also serve as the backbone of dev tools replacements (LP, gitolite, etc) - I had suggested that in the context of the dev discussions, but fun to see it here too
14:40:31 <kmlussier> Does that approach work for anyone? Does anyone have any burning projects they would like to make sure gets on there?
14:40:55 <gmcharlt> dbs: indeed
14:41:06 <rhamby> I'll do some research towards some of the blue sky issues I'm interested in and add them to in progress
14:41:24 <graced> kmlussier: I think that works - do you want to put any constraints on our crazy ideas?
14:41:31 <ohiojoe> +1 to the approach suggested
14:42:00 <kmlussier> graced: Good question.
14:42:22 <kmlussier> Given our next item on the agenda, I think we need to keep in mind that we may be doing a site overhaul.
14:43:03 <kmlussier> So the constraints I have in mind are that, when working with this list, we work within the current architecture. Adding content is great, researching plugins to support that content is okay too.
14:43:22 <kmlussier> But, for now, I think we should avoid moving content all over the place.
14:43:37 <graced> seems reasonable
14:43:43 <kmlussier> But those are my own thoughts. Does anyone else have suggestions for constraints?
14:45:17 <rhamby> I'd like to put the web site overhaul a bit up front in that we need to make sure that other things (e.g. youtube plugins) work with it.
14:46:00 <kmlussier> rhamby: So what you're saying is focus just on the content right now and no new plugins until an overhaul is done?
14:46:38 <rhamby> kmlussier: or at least don't settle on anything like plugins until we know our course on the overhaul (i.e. have picked a theme and can know compatability)
14:46:52 <kmlussier> My only concern with that is if the overhaul takes a very long time, in which case we're waiting to do new things.
14:46:58 <rhamby> that doesn't preclude research but I'd hate to work on implementing something and find the work broken by the overhaul
14:47:35 <rhamby> we can fast track an overhaul :)
14:47:36 <kmlussier> Sure, so let's include them on the list, but maybe when we prioritize next month, we can put those a little later in the process.
14:48:14 <kmlussier> To wrap up this discussion then, I'll take an action item to send an email to the webteam list asking people to add content to that spreadsheet.
14:49:26 <kmlussier> #action kmlussier to send email to webteam list inviting web site tasks spreadsheet with new features they want to see on the site.
14:50:05 <kmlussier> #topic New Wordpress Theme for Evergreen web site
14:50:21 <kmlussier> A couple of people have commented to me that they think it is time to change the WordPress theme for the site. A new theme will provide a new look and feel for the site.
14:50:35 <kmlussier> I wanted to start by putting that question out there to see if there is general consensus that we should consider changing the theme for the site.
14:50:42 <kmlussier> If there is, then we can discuss volunteers for working on it.
14:50:49 <rhamby> I volunteer as tribute.
14:50:50 <kmlussier> What do you think?
14:51:08 * rhamby thinks his opinion is known
14:51:12 <graced> I think we need a new look/theme and I volunteer to work on it
14:51:26 <kmlussier> rhamby: And I didn't even twist your arm. Or graced's.
14:51:41 <rhamby> I'm in a volunteering mood today.  Lord help me.
14:52:01 <kmlussier> OK, we have two people who have voiced their support to this idea. They also happen to be the two people who suggested the idea to me.
14:52:04 <kmlussier> What do others think?
14:52:06 <collum_> You can put me on the list, as well.
14:52:19 <kmlussier> rhamby: If I had know that, I would have paused before volunteering for my previous action items.
14:52:52 <DianeD> we need to ask the questions - who uses the website, what service does it provide, how to entice more people to use it
14:52:53 <rhamby> kmlussier: let's not debase this rare moment
14:53:11 <jlundgren> I volunteer to help as well
14:53:55 <kmlussier> DianeD: Do you think we need to ask those questions before deciding whether to look into new themes. Or are you saying we need to do it as part of the process?
14:54:12 <ohiojoe> I think a fresh theme isn't a bad idea.  I like the idea of something to coincide with the 3.0 release (unless we try to do something more ambitious by then)
14:54:13 <DianeD> part of the process
14:54:22 * kmlussier also notes that she hasn't heard any objections yet.
14:54:34 <kmlussier> DianeD: In that case, can I add you to the volunteer list as well?
14:54:47 <kmlussier> Also, who is leading this project.
14:54:55 * kmlussier hopes the answer is not the web team chair.
14:55:01 <DianeD> Yes - but not in any technical aspect
14:55:13 <kmlussier> Not that I object, but it's a matter of tuits.
14:55:27 <rhamby> I was involved in the last discussion about the audience and all that and don't want to carry that bias over so I'd rather work with someone else leading it.
14:55:56 <ohiojoe> And I'd be willing to help as well
14:56:26 <kmlussier> graced: I'm also thinking the Outreach messaging discussion can play into this if we're talking about coinciding with a 3.0 release.
14:56:29 <rhamby> We've had the discussion about audience before but I think it's revisiting with fresh eyes.
14:56:37 <graced> I'll volunteer to head it up if no one else is keen on leading
14:56:44 <rhamby> graced++
14:56:46 <kmlussier> Thank you graced.
14:56:49 <kmlussier> graced++
14:56:55 <jlundgren> graced++
14:57:02 <ohiojoe> graced++
14:57:03 <collum_> graced++
14:57:10 <graced> kmlussier: Much as I'd like, we can't make you do ALL the things
14:57:21 <graced> :)
14:57:29 <kmlussier> :)
14:57:40 <DianeD> I can be the lowly enduser who fixes computer problems by turning the thing off and on again  but wants to reach other endusers.
14:57:42 <kmlussier> We do have a test server available where I think playing can happen. http://test-www.evergreen-ils.org/
14:57:55 <kmlussier> DianeD: I think it's important we have that perspective.
14:58:13 <kmlussier> I think the test server needs some WordPress updates, though.
14:58:48 <kmlussier> graced: Do you think it will be possible for your group to meet and report back in time for our June meeting?
14:59:00 <kmlussier> Or, maybe not meet, but discusss.
14:59:21 <graced> Barring vacation scheduling issues... yes I think so
14:59:28 <kmlussier> Great.
14:59:43 <kmlussier> #action graced to head team to investigate new web site theme.
15:00:05 <collum_> Same credentials on test server and real server?
15:00:38 <kmlussier> #action rhamby DianeD ohiojoe collum jlundgren to work on team to investigate new web site theme
15:00:44 <kmlussier> If I missed anyone, let me know.
15:01:04 <kmlussier> collum_: I think so, but I don't know how old the user data is on that system.
15:01:59 <kmlussier> gmcharlt: Would it be easy to update the test server with fresh data?
15:02:08 <gmcharlt> kmlussier: sure
15:02:32 <kmlussier> gmcharlt: Would you be willing to do an update on it?
15:02:44 <dbs> (ignore this) We should totally rewrite the website in Angular to match our AngularJS-based 3.0 release!
15:02:54 <kmlussier> dbs: Stop!
15:02:58 <graced> bad dbs, no cookie
15:03:05 <rhamby> dbs: I've actually been looking at angular embedded in wordpress lately ....
15:03:07 <collum_> dbs++
15:03:23 <kmlussier> OK, I'm moving on to the next topic before this idea goes too far.
15:03:34 <gmcharlt> kmlussier: yep, I'll take the action itme
15:03:40 <kmlussier> gmcharlt++
15:04:03 <kmlussier> #topic Meeting Schedule
15:04:28 <kmlussier> Can we set the regular meeting time to the second Wednesday of the month at the same time or do folks want me to do another Doodle poll?
15:04:55 <graced> I'd prefer a poll for a regular time....
15:05:18 <abneiman> +1 to graced's suggestion
15:05:38 <kmlussier> OK, I'll do so.
15:05:45 <kmlussier> Anything else before we wrap up?
15:05:53 <kmlussier> Sorry to be 5 minutes late.
15:06:12 <DianeD> thank you for doing this!
15:06:18 <kmlussier> #endmeeting