15:00:31 <gmcharlt> #startmeeting Evergreen Develpment Meeting, 7 June 2017
15:00:31 <pinesol_green> Meeting started Wed Jun  7 15:00:31 2017 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <pinesol_green> The meeting name has been set to 'evergreen_develpment_meeting__7_june_2017'
15:00:37 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-06-07
15:00:42 <gmcharlt> #topic Introductions
15:00:47 <gmcharlt> please introduce yourselves...
15:00:49 <DPearl> DPearl = Dan Pearl, C/W MARS Inc.
15:00:54 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:00 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:01:19 <berick> #info berick Bill Erickson, KCLS
15:01:19 <DPearl> #info DPearl = Dan Pearl, C/W MARS Inc.
15:01:41 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:01:51 <JBoyer> #info JBoyer = Jason Boyer, IN State Library
15:01:54 <miker> #info miker = Mike Rylander, EOLI
15:02:09 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:03:04 <Dyrcona> #info Dyrcona = Jason Stephenson C/W MARS
15:03:54 <gmcharlt> #topic Action items from previous meeting
15:04:24 <gmcharlt> #info gmcharlt sent an email to open-ils-dev requesting feedback on the copy tags / digital bookplates feature
15:04:44 <gmcharlt> #info gmcharlt sent a note to open-ils-general giving a heads-up on the potential project to replace LP
15:05:02 <gmcharlt> both of which resulted in... not much (or any) feedback :)
15:05:18 <gmcharlt> but JBoyer++ for raising his discovery regarding Angular scoping to open-ils-dev
15:05:29 <gmcharlt> so... there's that
15:06:05 <gmcharlt> on the other hand, in the latter case I suppose it means we can just proceed and ask for feedback once we have something to show, I suppose
15:06:18 <gmcharlt> so, any questions re those updates before I move on?
15:06:22 * phasefx has pitchfork and torch if you want something destructive re: launchpad :)
15:06:33 <gmcharlt> heh
15:07:15 <gmcharlt> so moving on
15:07:15 <JBoyer> I'm working on an OpenSRF bug re: the fork() bug that jeffdavis and I keep running into, but I haven't had time to write it up yet.
15:07:24 <gmcharlt> #topic OpenSRF update
15:08:06 <gmcharlt> so, speaking of that bug, I know berick has been looking at it as well
15:08:11 <gmcharlt> any insight so far?
15:08:37 <gmcharlt> also, request to jeffdavis and/or JBoyer: could one of you go ahead and write up an LP?
15:08:55 <gmcharlt> if it turns out to be an Evergreen bug proper rather than an OpenSRF one, it's easy enough to move it
15:09:02 <miker> this is the fork failure turning listener into drone bug, yes?
15:09:08 <JBoyer> No insight, but I have (had for a couple days...) an LP tab open in my browser for it.
15:09:31 <berick> miker: no, it's not clear if fork() is related.
15:09:35 <berick> just one of a few theories
15:09:45 <berick> we need some logging from affected systems
15:09:46 <JBoyer> miker, no. This is undefined values making it into calls to syswrite.
15:10:03 <dbs> #info dbs = Dan Scott, Laurentian University
15:10:06 <miker> ah, ok, thanks
15:10:26 <JBoyer> (IRC Log search for Server.pm and 307 should pull up a short list of hits)
15:10:41 <gmcharlt> JBoyer: would you accept an action item to pull together a writeup for LP?
15:11:15 <JBoyer> Consider my judo-chop-action-button pressed,
15:11:21 <gmcharlt> whee!
15:11:22 <JBoyer> er, yes.
15:11:32 * berick can add a logging patch if that would be helpful
15:11:51 <JBoyer> berick++
15:11:52 <gmcharlt> #action JBoyer will write up known details of the syswrite-to-oblivion issue for LP
15:12:26 <gmcharlt> so, unless there's more, sounds like that's it for OpenSRF; needless to say, this seems like something that woujdl warrant a 2.5.1 when it gets tracked down
15:12:29 <JBoyer> My primary concern is that I've only ever seen this in production, where logs are already xbox-hueg.
15:13:15 <gmcharlt> #topic Evergreen update
15:13:50 <gmcharlt> #info Evergreen 2.10.12, 2.11.5, 2.12.2, all security releases, came out on 24 May
15:13:51 <gmcharlt> #link https://evergreen-ils.org/security-releases-evergreen-2-10-12-evergreen-2-11-5-and-evergreen-2-12-2/
15:14:59 <gmcharlt> #info Evergreen 3.0 keeps chugging along; flurry of bugfix work going on at the moemnt
15:15:08 <gmcharlt> any other updates regarding the releases?
15:15:51 <gmcharlt> if not... moving on
15:15:59 <gmcharlt> #topic Feedback regarding the feedback fest
15:16:06 <gmcharlt> #info First feedback fest concluded on 5/19
15:16:14 <gmcharlt> #info Results at https://evergreen-ils.org/evergreen-3-0-development-update-6-feedback-fest-results/
15:16:35 <gmcharlt> so, my questions to folks:
15:16:43 <gmcharlt> did you find this a useful exercise?
15:17:05 <gmcharlt> are there things we could do to do it better, giving that there's a second one slated to occur in August?
15:17:54 <miker> I found it useful ... I don't have suggestions for improvement ATM
15:18:21 <berick> ditto
15:18:43 <JBoyer> Same
15:19:12 <miker> or, not any that we collectively have time for (build a tool! :) )
15:19:25 <phasefx> I found it useful; I liked you just throwing stuff my way.  Maybe we could benefit from a bug dispenser to make random suggestions :) I know one community that did with getting folks to judge works during a competition where you couldn't possibly look at everything
15:20:15 <gmcharlt> phasefx: interesting - do you recall details of that / have a link?
15:20:47 * gmcharlt also notes that one of the features of the Koha dashboard is a link to a random bug
15:21:05 <phasefx> gmcharlt: it was Interactive Fiction community, a piece of software had a list of all the contestants, and a would-be judge would pull a lever and get a handful to look at
15:22:04 <JBoyer> @oprah bugs
15:22:05 <pinesol_green> JBoyer: http://wonder-tonic.com/geocitiesizer/content.php?theme=2&music=6&url=evergreen-ils.org
15:22:31 * gmcharlt blinks
15:22:36 <gmcharlt> MOVING ON... :)
15:22:52 <gmcharlt> thanks for the feedback folks
15:23:06 <gmcharlt> #topic Update on project to investigate alternatives to Launchapd and Gitolite
15:23:17 <gmcharlt> #link https://wiki.evergreen-ils.org/doku.php?id=dev:2017_new_tools
15:23:41 <gmcharlt> Dyrcona: how are your experiments with gitlab coming along?
15:24:07 <gmcharlt> dbs: did you mention another possible translation management tool recently? if so, what was it?
15:24:13 <dbs> weblate
15:24:19 <Dyrcona> Well, I can confirm that after you make a configuration change, gitlab will accept pushes of the Evergreen repo.
15:24:35 <dbs> I'll add it to the wiki page and organize a new "translation tools" section
15:24:49 <gmcharlt> dbs++
15:25:06 <Dyrcona> I've not had much time to experiment, but we appear to lose some of the fine-grained control over repositories, so we may need to revisit how we manage branches at the moment.
15:28:36 <gmcharlt> ok
15:29:09 <gmcharlt> are we at a point where it would make sense to stand up a VM on the community's server, put gitlab there, and open up for more testing?
15:30:53 <miker> I don't see a reason not to mirror our current git setup over to gitlab, if that can be done
15:31:18 <gmcharlt> indeed
15:31:32 <Dyrcona> It's more like reflected in a pond than mirrored.
15:31:45 <miker> :)
15:32:00 <gmcharlt> ok
15:32:21 <gmcharlt> I won't set a formal action item just now (unless somebody is raring to go), but something to keep in mind over the next few weeks
15:32:32 <gmcharlt> any other discussion on tool replacement?
15:33:21 <gmcharlt> moving on
15:33:28 <gmcharlt> #topic Proposal to create a development dashboard
15:33:46 <gmcharlt> #link https://evergreen-ils.org/evergreen-3-0-development-update-8/
15:34:02 <gmcharlt> #info Koha dashboard is at http://dashboard.koha-community.org/
15:34:34 <gmcharlt> so, any thoughts about whether it would be useful to pursue this, and if so, what we want want displayed in a dashboard?
15:36:56 <Dyrcona> Should it wait until we've decided on a bug tracker?
15:37:01 * berick was going to say that
15:37:06 <Dyrcona> If we're planning to ditch Lp, that is.
15:37:09 <berick> i like the idea of dashboard, though
15:37:21 <Dyrcona> Yeah, I like the idea, too.
15:37:52 <dbs> Yep, like a friendly front end to a bug tracker
15:38:13 <gmcharlt> yeah, writting an interface to a bug tracker twice seems inefficient :)
15:38:16 <phasefx> and i like the idea of snapshots exposed as periodic blog posts/newsletters
15:39:42 <gmcharlt> ok
15:39:48 <gmcharlt> thanks for the feedback
15:40:06 <gmcharlt> any other topics to discuss or bug feedback before we close the meeting?
15:42:22 <gmcharlt> ok
15:42:27 <gmcharlt> thanks, everybody!
15:42:30 <gmcharlt> #endmettings
15:42:32 <gmcharlt> er
15:42:35 <gmcharlt> #endmeeting