#evergreen: Evergreen Development meeting, 2 August 2017

Meeting started by gmcharlt at 15:00:30 US/Eastern (full logs).

Meeting summary

    1. Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-08-02 (gmcharlt, 15:00:38)

  1. Introductions (gmcharlt, 15:00:42)
    1. kmlussier is Kathy Lussier, MassLNC (kmlussier, 15:00:50)
    2. gmcharlt = Galen Charlton, Equinox, RM (gmcharlt, 15:00:53)
    3. DPearl = Dan Pearl, C/W MARS Inc. (DPearl, 15:01:01)
    4. phasefx = Jason Etheridge, Equinox (phasefx, 15:01:04)
    5. dbwells = Dan Wells, Hekman Library (Calvin Collge) (dbwells, 15:01:20)
    6. JBoyer = Jason Boyer, IN State Library (JBoyer, 15:01:31)
    7. Dyrcona = Jason Stephenson, C/W MARS Inc. (Dyrcona, 15:01:35)
    8. jeffdavis = Jeff Davis, Sitka (jeffdavis, 15:02:14)
    9. abowling = Adam Bowling, Emerald Data Networks (abowling, 15:02:19)
    10. berick Bill Erickson, KCLS (berick, 15:02:22)
    11. cesardv = Cesar Velez, Equinox (cesardv, 15:02:32)
    12. , rhamby = Rogan Hamby, Equinox Open Library Initiative (rhamby, 15:02:59)
    13. remingtron = Remington Steed, Hekman Library (Calvin College) (remingtron, 15:03:50)

  2. Past action items (gmcharlt, 15:03:54)
    1. ACTION: berick will tidy up his patch for bug 1697029 and mark it for submission (gmcharlt, 15:12:31)
    2. ACTION: gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF (gmcharlt, 15:12:50)

  3. OpenSRF release (gmcharlt, 15:13:06)
    1. miker = Mike Rylander, EOLI (doh!) (miker, 15:15:48)

  4. Evergreen releases (gmcharlt, 15:19:59)
    1. Evergreen 2.11.7 and 2.12.4 released on 28 July (gmcharlt, 15:20:18)
    2. Second feedback fest will run from 7 to 11 August (gmcharlt, 15:20:49)
    3. ACTION: gmcharlt will send out the list of pull requests (for recordkeeping purposes) on Friday (gmcharlt, 15:21:08)
    4. Reminder - feature slush is 18 August. Slush means that major enhancements should at least have a plausible pull request in place by that date (gmcharlt, 15:22:13)

  5. Project to investigate alternatives to Launchpad and Gitolite (gmcharlt, 15:36:11)
    1. https://github.com/gitlabhq/gitlabhq/pull/3597 Fork Pull Requests work in Gitlab (cesardv, 15:42:13)
    2. ACTION: Dyrcona will write some doc on how workflows might change with a switch to GitLab (gmcharlt, 15:43:13)

  6. XUL client bug and backporting policy (gmcharlt, 15:44:31)
    1. ACTION: gmcharlt will send a proposed XUL patch policy to open-ils-dev for feedback (gmcharlt, 15:55:39)

  7. Core Infrastructure Initiative Badge Program (gmcharlt, 15:56:25)
    1. https://github.com/coreinfrastructure/best-practices-badge/blob/master/doc/criteria.md (kmlussier, 15:57:31)
    2. https://www.talater.com/upup/ (miker, 16:18:10)


Meeting ended at 16:26:52 US/Eastern (full logs).

Action items

  1. berick will tidy up his patch for bug 1697029 and mark it for submission
  2. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
  3. gmcharlt will send out the list of pull requests (for recordkeeping purposes) on Friday
  4. Dyrcona will write some doc on how workflows might change with a switch to GitLab
  5. gmcharlt will send a proposed XUL patch policy to open-ils-dev for feedback


Action items, by person

  1. berick
    1. berick will tidy up his patch for bug 1697029 and mark it for submission
  2. Dyrcona
    1. Dyrcona will write some doc on how workflows might change with a switch to GitLab
  3. gmcharlt
    1. gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
    2. gmcharlt will send out the list of pull requests (for recordkeeping purposes) on Friday
    3. gmcharlt will send a proposed XUL patch policy to open-ils-dev for feedback


People present (lines said)

  1. gmcharlt (102)
  2. miker (78)
  3. JBoyer (35)
  4. kmlussier (26)
  5. berick (22)
  6. Dyrcona (21)
  7. pinesol_green (10)
  8. jeffdavis (7)
  9. csharp (5)
  10. cesardv (3)
  11. phasefx (3)
  12. abowling (2)
  13. remingtron (2)
  14. rhamby (2)
  15. abneiman (1)
  16. DPearl (1)
  17. Bmagic (1)
  18. dbwells (1)


Generated by MeetBot 0.1.4.