15:01:28 <gmcharlt> #startmeeting Evergreen development meeting, 6 September 2017
15:01:28 <pinesol_green> Meeting started Wed Sep  6 15:01:28 2017 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:28 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__6_september_2017'
15:01:38 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-09-06
15:01:45 <gmcharlt> #topic Introductions
15:01:47 <Dyrcona> #info Dycona is Jason Stephenson, C/W MARS
15:01:52 <DPearl> #info DPearl is Dan Pearl, C/W MARS
15:01:53 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox, 3.0 release manager
15:01:58 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:02:04 <rhamby_> #info rhamby_ is Rogan Hamby, Equinox
15:02:05 <berick> #info berick Bill Erickson, KCLS
15:02:07 <jeff> #info jeff is Jeff Godin, Traverse Area District Library (TADL)
15:02:22 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:03:51 <cesardv> #info cesardv = Cesar Velez, Equinox
15:03:58 <JBoyer> #info JBoyer is Jason Boyer, IN State Library, Evergreen Indiana
15:04:04 <abneiman> #info abneiman = Andrea Neiman, Equinox
15:04:54 <gmcharlt> #topic Action items from previous meeting
15:05:16 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:05:51 <miker> #info miker = Mike Rylander, EOLI
15:05:52 <gmcharlt> #info berick submitted cleaned up patch for bug 1697029
15:05:54 <pinesol_green> Launchpad bug 1697029 in OpenSRF "Service Listeners Crash when Using an Undefined Value for Syscalls" [High,New] https://launchpad.net/bugs/1697029
15:06:02 <gmcharlt> berick: is that one ready to have a pull request tag slapped on it?
15:06:26 <berick> gmcharlt: probably, i got a little lost in all the other conversation
15:06:49 <gmcharlt> ok, I've gone ahead and added it
15:06:54 <berick> great, thanks
15:07:35 <gmcharlt> #action gmcharlt  will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:07:41 <gmcharlt> ^^ carrying over from last meeting
15:07:54 <gmcharlt> #info gmcharlt sent out list of pull requests for feedback fest
15:08:12 <gmcharlt> Dyrcona: any updates on investigating GitLab?
15:08:37 <Dyrcona> No. I've not really had the time.
15:08:47 <gmcharlt> fair enough
15:08:58 <Dyrcona> I still have a gitlab test vm running, though
15:08:59 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:09:00 * gmcharlt is thinking that I might help out with that process after release of 3.0.0
15:09:24 <gmcharlt> #info gmcharlt sent out proposed XUL bugfix merge policy for 3.0 - thread here: http://libmail.georgialibraries.org/pipermail/open-ils-dev/2017-August/010400.html
15:09:50 <gmcharlt> so, any questions about previous action items?
15:10:44 <kmlussier> nope
15:10:45 <gmcharlt> if not, moving on
15:10:51 <gmcharlt> #topic OpenSRF releases
15:11:08 <gmcharlt> so, I think we're just about ready, if not past ready, to cut an OpenSRF 2.5.1
15:11:24 <gmcharlt> with particular bugs of note to deal with including
15:11:43 <gmcharlt> bug 1709710, for which there's now a patch for improving bundling/chuking
15:11:43 <pinesol_green> Launchpad bug 1709710 in OpenSRF "Default ejabberd max_stanza_size can be exceeded when chunking (MARC)XML-heavy responses" [Undecided,Confirmed] https://launchpad.net/bugs/1709710
15:11:57 <gmcharlt> bug 1697029, for which there's also a patch
15:11:58 <pinesol_green> Launchpad bug 1697029 in OpenSRF "Service Listeners Crash when Using an Undefined Value for Syscalls" [High,New] https://launchpad.net/bugs/1697029
15:12:09 <gmcharlt> and also some needed improvements to the nginx config example
15:12:33 <gmcharlt> I also want to bring up bug 1708048
15:12:33 <pinesol_green> Launchpad bug 1708048 in OpenSRF "Add support for Debian 9 Stretch" [Undecided,New] https://launchpad.net/bugs/1708048
15:13:12 <gmcharlt> where, in the particular, the changes to finding shared libraries as of Stretch suggest to me that it would be worth cutting an OpenSRF 2.6.0
15:13:33 <gmcharlt> to deal with them, and have that be the minimum required version for Evergreen 3.0.0
15:13:39 <gmcharlt> thoughts on all of this?
15:14:08 <Bmagic> It sounds fine to me. 2.5.1 and 2.6.0 ?
15:14:36 <gmcharlt> yeah
15:14:47 <Dyrcona> I wonder if stretch support should wait. We may encounter more issues later.
15:15:09 <miker> a thought:
15:16:28 <miker> feature-wise, 2.5.1 is the minimum, really... but, because 2.6.0 will change the config file, and 3.0 is psychologically a "big" release, it makes sense to include the "big" change of config file adjustments
15:17:14 <miker> so with a release note that says "use 2.6.0, unless you can't. here's how to use 2.5.1: ..." I'd be on board
15:17:48 <miker> IOW, 3.0.0 is not conservative by default, but can be made so with (really pretty minor) changes to the opensrf.xml
15:17:48 <berick> do we have a clear path to 2.6.0?  can't tell from the bug.
15:18:52 <miker> berick: we do ... "use libtool as intended, with a 'lib' prefix for .so files so ldconfigure will work, remove rpath, and adjust the config file"
15:19:21 <JBoyer> Stretch was only released in June, I'm fine with punting on them until the next release cycle in case we run into more trouble.
15:19:36 <miker> it's the specific spelling of those things that is opaque to me ATM
15:19:49 <berick> miker: thanks
15:20:15 <Dyrcona> Well, basically, I think we need to name the libaries so that they come out as libosrf... and so on.
15:20:30 <gmcharlt> I'd prefer to not wait until 3.1 for Stretch support; such support in 3.0.0 might be (I acknowledge) experimental, but should stabliize soon enough
15:20:32 <JBoyer> miker, gmcharlt, would it be unreasonable to strive for a "./configure;make;make install" style installation for 2.6 while we're making big changes anyway? I know that was mentioned in the Gentoo thread and it immediately caught my attention.
15:20:58 <gmcharlt> at least as far as the C libraries are concerned, it should be pretty clearly something that either works or doesnt work
15:21:46 <miker> JBoyer: if we can have a beta 2 with stretch support, for a solid-ish test period, would you be OK with that?  (also, we can always pull back with a simple enough change if release day is looming and we're still seeing problems)
15:22:07 <berick> in general terms, having to rebuild osrf to install eg 3.0 does not seem crazy to me.
15:22:15 <miker> Dyrcona: right ... we're going out of our way to have .so's named just so, and ldconfig hates us for that
15:23:09 <miker> libtool writes symbols /inside/ the file, too, though.  we need to not override that, not just the filesystem name
15:23:17 <JBoyer> miker, it's ok with me; I don't run Debian. ;) I just want to make sure there's plenty of time for testing and it does *feel* like early days, admittedly for the previous reason.
15:24:48 <Dyrcona> If stretch support can wait until after the beta, I'll make it a point to look at those bugs next week.
15:25:09 <miker> JBoyer: re './configure;make;make install', how do you mean?  I feel like it's pretty much that already, no?
15:25:16 <gmcharlt> Dyrcona: yeah, it can certain wait until after today's beta
15:25:54 <gmcharlt> and thanks for the offer
15:26:20 <Dyrcona> I've been meaning to build a stretch vm, so bug squashing week gives me a good reason.
15:26:53 <miker> berick: we have you to blame^Wthank for the current makefile stuff, right? (looking for eyeballs with background for assistance only. promise!)
15:27:17 <gmcharlt> so, I think to sum up: we'll keep the Stretch option open for now, and second beta (more on that later) would be the go/no-go for that
15:27:44 <gmcharlt> so, I'm going to push forward in the agenda
15:27:47 <gmcharlt> #topic Evergreen release
15:27:50 <JBoyer> I mean literally that. Conforming to whatever library locations various supported OS's expect and not requiring --any-switches unless you want to enable something experimental like Python or Java.
15:28:03 <JBoyer> (And I'm too slow at typing,...)
15:28:28 <berick> miker: hm, no, that was..   arg, worked w/ dbs
15:28:37 <gmcharlt> #info Evergreen 3.0 feature freeze was 1 September
15:29:00 <gmcharlt> #info newpot has been run courtesy of bshum; we're now in string sluh
15:29:11 <gmcharlt> #info Evergreen 3.0 beta will be cut today by dbwells
15:29:13 <gmcharlt> dbwells++
15:29:30 <gmcharlt> #info Bug Squashing Week is 11-15 September
15:30:29 <jeff> berick: you're thinking of kbeswick / Kevin Beswick, I believe.
15:30:38 <gmcharlt> so, I mentioned a second beta - given the larger than usual (?) last-minute merges, and given the overall release goal of 3.0 as supported for production for the web staff client, I'd like to cut a second beta around 20 September
15:30:59 <berick> jeff: yes!  thanks.
15:31:00 <gmcharlt> with primary goals being (a) more bug fixes and (b) Stretch support
15:31:23 <gmcharlt> with RC still slated for 27 September
15:31:35 <gmcharlt> and (at the moment) rel_3_0 not being branched before the RC
15:31:38 <gmcharlt> thoughts?
15:31:44 <miker> +1
15:31:45 <JBoyer> +1 to b2 and putting off the Stretch decision until then.
15:31:46 <kmlussier> +1
15:31:54 <jeff> +1
15:32:01 <dbwells> +1
15:32:04 <Bmagic> +1
15:32:19 <Dyrcona> +1
15:32:20 <jeff> (would it be appropriate to say that Debian 9 support in Evergreen 3.0 remains as a "stretch goal"?)
15:32:30 * kmlussier groans
15:32:44 <Bmagic> lol
15:32:46 <berick> +1 # and groan
15:32:50 <gmcharlt> ... it was inevitable
15:32:58 <JBoyer> Is there a kick command for the bot? :p
15:33:16 <Dyrcona> No ops in the channel. ;)
15:33:57 <miker> (JBoyer: I think that really does work... with the exception of the stretch-exposed problems. we've just never had any install instructions that say that.  I haven't tried it in a while, though.)
15:34:23 <Dyrcona> It works and everything ends up scatter around in /usr/local
15:34:34 <JBoyer> If it does work (I'll try it out soon, I may try to help re: Stretch also) I think it should become the new install instructions.
15:34:50 <gmcharlt> #agreed a beta2 will be cut on or around 9/20, with webstaff bugfixes and stretch support as goals
15:35:03 <Dyrcona> I don't think it should be the new instructions. It's messy on a typical system.
15:35:18 <gmcharlt> #alsoagreed jeff is now on pun watch
15:36:14 <gmcharlt> any other general questions/concerns about the Evergreen release before we move on?
15:36:20 <miker> Dyrcona: well, right. we cordon our mess of in /openils for a reason ;)
15:36:52 <miker> s/of/off
15:37:52 <gmcharlt> so, moving on
15:37:55 <gmcharlt> #topic Hatch
15:37:57 <JBoyer> I may be conflating a desire to make source installation easier all around with better prep for ongoing and "you should just use these" packages.
15:39:11 <gmcharlt> berick: thoughts on what is required (and what assistance would help) to get some better packaging of Hatch and to get the Chrome plugin in the Google App store?
15:39:31 <berick> gmcharlt: yes, bug #1708757
15:39:31 <pinesol_green> Launchpad bug 1708757 in Evergreen "Publish Hatch to Chrome web store" [Wishlist,New] https://launchpad.net/bugs/1708757
15:40:08 <berick> to get started, a developer account  needs to be created
15:40:13 <berick> presumably owned by the community
15:40:37 <gmcharlt> berick: easy enough to create a foo@evergreen-ils.org address that has a few folks on it
15:40:51 <jeff> berick: how possible is "owned by the community"? have you looked into that hurdle at all?
15:40:58 <berick> and we need some simple icons just to get started
15:41:07 <berick> jeff: have not looked.
15:41:21 <gmcharlt> ^^ might be something that outreach committee and/or webteam folks could help with
15:41:34 <gmcharlt> looks like there's a $5 signup fee
15:41:40 * kmlussier reads up
15:42:13 <berick> also possible to link google groups to a developer account, but I think we still need the initial shared account
15:42:18 <gmcharlt> (and I think I can safely say that reimbursement for that wouldn't be hard to get)
15:42:27 <berick> s/shared/community owned/
15:42:48 <berick> yeah, $5 fee to set up
15:43:02 <Bmagic> can we pay in bitcoin?
15:43:20 <berick> heh, .00005 bitcoins
15:43:43 <kmlussier> I don't know much about Google developer accounts. Does it have to be just one account or is there a possibility that multiple accounts can be given admin access?
15:44:08 <gmcharlt> looks like there's a "group publishing" option
15:45:02 <gmcharlt> hmm, but each member of a group would be obliged to pay the $5 developer fee
15:45:42 <kmlussier> Oh, so better to have a shared account.
15:45:47 <Bmagic> it looks like the only difference is that we wouldn't share a single login/pass
15:45:48 <gmcharlt> (admittedly, $5 each is not exactly a huge bar, as presumably only a few people need to be directly involved in building updates)
15:45:58 <kmlussier> This sounds more like a developer thing than an outreach or web team thing, but I can be overruled. :)
15:46:15 <berick> kmlussier: i think gmcharlt was referring to the icons, maybe?
15:46:15 <gmcharlt> kmlussier: well, my suggestion was specifically about getting some icons
15:46:31 <Bmagic> changing passwords would need to be communicated or shared in some way
15:46:45 <kmlussier> Oh, sorry, I missed that comment. Sure, actually, I think we can help with that.
15:46:51 <berick> kmlussier: https://developer.chrome.com/webstore/publish#provide-store-content
15:47:22 <gmcharlt> berick: for now, shall you and I kickstart the process, starting with a chromestore@evergreen-ils.org address (or whatever)?
15:47:40 <berick> gmcharlt: yes, sounds good
15:47:54 <Bmagic> +1 #get it started
15:48:01 <gmcharlt> kmlussier: and can you accept an action item to help wrangle the images?
15:48:18 <kmlussier> yes
15:48:29 <berick> kmlussier++ gmcharlt++
15:48:44 <gmcharlt> #action berick and gmcharlt will get a shared Google Web Store account started
15:49:04 <gmcharlt> #action kmlussier will wrangle creation of necessary icons/logos for the store and Hatch app
15:49:16 <gmcharlt> berick: anything else needed?
15:49:58 <berick> gmcharlt: no, that should get things moving at least.
15:50:04 <gmcharlt> great
15:50:15 <gmcharlt> so moving on in the agenda
15:50:23 <gmcharlt> #topic Possible Hack-A-Way prep videos
15:50:32 <gmcharlt> Bmagic: you have hte floor
15:50:34 <Bmagic> At the last hack-a-way, there was talk of getting folks up to speed on contributing to the project. Thoughts of adding another day to the hack-a-way of "class". I have been working on some videos with that in mind
15:51:47 <Bmagic> Maybe some videos would help get folks started, not a replacement of "class" but something. I just thought I would bring it up here for thoughts.
15:53:18 <berick> i haven't watched the videos yet, but I love the idea
15:53:27 <Bmagic> One of the big hurdles, is installing the Evergreen server. My direction here is to skip that part and show how to get a test server running with almost no effort
15:54:00 <Bmagic> Then show how to edit the code on the running server and affect change, using easy-to-install tools for windows
15:54:39 <Dyrcona> I have seen the videos, and other than the Windows part, I like 'em. ;)
15:55:11 <kmlussier> Bmagic++
15:55:24 <Bmagic> I was goinng to use this bug 1642036
15:55:25 <pinesol_green> Launchpad bug 1642036 in Evergreen "Web Staff Client - Group Members Don't Display" [Undecided,Confirmed] https://launchpad.net/bugs/1642036
15:55:45 <Bmagic> looked easy to squash on camera and record the process
15:57:08 <Dyrcona> Bmagic++
15:57:16 <Bmagic> Anyone know someone looking for this sort of thing?
15:57:46 <kmlussier> Not at the moment, but it will be nice to have it handy when new developers pop in.
15:57:49 <gmcharlt> well, sounds like the sort of thing that can be given a home in a couple places
15:57:51 <DPearl> I would have wanted this when starting out.  Hell!  I'd watch them now!
15:57:53 <gmcharlt> wiki, obviously
15:58:11 <gmcharlt> maybe part of the dev doc project that dbwells and remingtron our working on?
15:58:27 <Bmagic> gmcharlt: that came to mind as well
15:58:50 * stephengwills timidly raises his hand.  Sound useful for validation too.
15:58:55 <Bmagic> There is no reason that I have to be the only one making the videos, if anyone has ideas, etc
15:59:59 <Bmagic> for the minutes first: https://vimeo.com/230985351  second:  https://vimeo.com/231611654
16:01:09 <Bmagic> That's all I have, thanks for your time.
16:01:16 <gmcharlt> thanks!
16:01:26 <jeff> Bmagic++
16:01:34 <cesardv> Bmagic++ those will be helpful
16:01:36 <gmcharlt> any other last-minute topics?
16:02:01 <berick> Bmagic++
16:03:01 <cesardv> since we now have Jquery, can we have jquery-ui in the OPAC?
16:03:21 <gmcharlt> cesardv: sounds like an excellent question to raise on open-ils-dev
16:03:34 <berick> gmcharlt: may just a reminder this page exists https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda
16:03:43 <berick> s/may/maybe/
16:03:46 <gmcharlt> ah, yes
16:03:57 <gmcharlt> #info 2017 Hack-A-Way agenda is https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda
16:04:10 <gmcharlt> #info Hack-a-Way will run 7-9 November in Indianapolis
16:04:33 <cesardv> gmcharlt: 10-4, open-ils-dev
16:04:36 <JBoyer> Yes, I promise we're putting it on this year, agoben and I have been out of the office a lot and communications have been sparse.
16:04:58 <gmcharlt> JBoyer: we'll just hang out in your offices as a fallback plan ;)
16:05:14 <kmlussier> I sure hope you're putting it on because the plane tickets have already been booked!
16:05:14 <JBoyer> I have 4 chairs. ;)
16:05:28 <Bmagic> dibs
16:05:28 <gmcharlt> OK, thanks all!
16:05:29 * kmlussier claims a chair.
16:05:32 * berick has inn reservation, not plane tix yet
16:05:39 <gmcharlt> #endmeeting