14:01:44 <ohiojoe> #startmeeting 2017-09-07 Documentation Interest Group Meeting
14:01:44 <pinesol_green> Meeting started Thu Sep  7 14:01:44 2017 US/Eastern.  The chair is ohiojoe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:44 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:44 <pinesol_green> The meeting name has been set to '2017_09_07_documentation_interest_group_meeting'
14:01:58 <ohiojoe> please introduce yourselves, paste "#info <username> is <name> <affiliation>" to identify who you are and what organization, if any, you represent
14:02:28 <sandbergja> #info sandbergja is Jane Sandberg, Linn-Benton Community College
14:02:37 <ohiojoe> #info ohiojoe is Joe Knueven, Germantown Public Library, COOL
14:02:39 <jihpringle> #info jihpringle is Jennifer Pringle, BC Libraries Cooperative (Sitka)
14:04:30 <ohiojoe> anyone else?  :-)
14:04:49 <dluch> Sorry, I'm here...having IRC issues
14:05:11 <ohiojoe> no worries, please introduce yourself for the sake of the record
14:05:18 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
14:06:04 <ohiojoe> next month I'll need to remember to actually use the topic command for introductions...
14:06:09 <dluch> #info dluch is Debbie Luchenbill, MOBIUS
14:06:12 <BAM_> #info BAM is Benjamin Murphy, NC Cardinal
14:07:45 <ohiojoe> #topic Ongoing Business
14:08:13 <ohiojoe> #topic Progress on documentiong new features in Evergreen 2.12 (and previous)
14:09:59 <ohiojoe> Does anyone have any updates on this?  My recollection is that action items 6 and 7 came out of our discussion about this last month
14:11:22 <ohiojoe> and I can sadly report, that local events during the last several weeks lead to me neglecting to act on my particular action item there..
14:11:40 <jihpringle> we haven't had anytime recently to contribute back but all of our docs have been updated to 2.12 if anyone wants/has the time to copy from them
14:11:51 <sandbergja> ohiojoe: no worries; I only got around to finishing my piece this morning
14:12:14 <sandbergja> jihpringle++
14:12:56 <ohiojoe> jihpringle++
14:13:40 <dluch> I've pretty much neglected my plans for contributing, too.  Sorry
14:13:43 <kmlussier> I haven't been able to devote much time to docs over the past month either.
14:13:49 <dluch> jihpringle++
14:14:38 <ohiojoe> No worries, well, moving along then
14:14:39 <sandbergja> I'm curious -- how did the recent web client day go?
14:15:01 <sandbergja> Sorry that I wasn't able to participate; that day turned out to be way busier than I expected. :-(
14:15:07 <kmlussier> Sadly, I don't think there was much activity. It was my first day back from vacation, and I didn't send out a reminder until late morning.
14:15:37 <kmlussier> It was also the day of the maintenance release, and I ended up focusing on the release instead of docs.
14:15:51 <kmlussier> I have no vacations coming up before the next web client day, and I plan to promote it more heavily.
14:16:18 <ohiojoe> I had wanted to use it as a nudge to get moving on docs work too, but ended up at an out of town meeting instead..
14:16:51 <kmlussier> #info Next web client documentation day is September 27
14:18:14 <ohiojoe> #topic Progress on Docs Reorganization Project
14:18:17 <sandbergja> kmlussier: Thanks for your promotion work!
14:19:15 <sandbergja> We got some pretty positive feedback on the general direction of the docs reorg project!
14:19:36 <kmlussier> Yes, it all looked good! sandbergja++
14:19:50 <dluch> Yes!  sandbergja++
14:20:05 <ohiojoe> Yeah, I saw that on the general list.  I don't think I saw anything that looked like less than positive feedback
14:20:15 <jihpringle> sandbergja++
14:20:17 <ohiojoe> sandbergja++
14:20:22 <sandbergja> I think, at this point, it's time for the "Where do we go from here?" question
14:20:34 <kmlussier> I think we should switch it over.
14:20:48 <dluch> Agreed
14:20:51 <jihpringle> agreed
14:20:54 <ohiojoe> sounds good to me
14:21:06 <ohiojoe> let's see, there's a command here for this..
14:21:52 <sandbergja> Should we plan for 3.0, then?  I think it would be messy, and some things would be in the wrong books.
14:22:09 <sandbergja> But it could still provide some usability benefits?
14:22:34 <sandbergja> Also, new major release = new presentation of documentation sounds fun!
14:22:37 <kmlussier> Yes, I think that makes sense. So the organization for the other releases would remain the same?
14:22:37 <jihpringle> I think 3.0 makes the most sense, since most of the docs are having to be touched anyways with new screenshots for the webclient
14:22:42 <dluch> Yes!
14:23:22 <ohiojoe> yeah, even if there's some messiness, a major release is a good time to introduce such a change in the docs..
14:23:36 <sandbergja> kmlussier: I think just doing 3.0 docs sounds safer
14:23:50 <kmlussier> +1
14:24:38 <ohiojoe> so, are we agreeing to change the structure starting with the 3.0 docs?
14:24:53 <jihpringle> +1
14:25:09 <kmlussier> I don't think the 3.0 docs are added until the major release day, which is October 3. Maybe we could look at updating master now so that we have time to troubleshoot any issues that arise?
14:25:54 <sandbergja> That makes sense.  Switching it over would be a 3-step process:
14:26:42 <sandbergja> 1) Getting the new root_*.adoc files into master (these determine which content is in which books)
14:27:28 <sandbergja> 2) Updating the script on the production docs server to generate the new, reorganized manuals based on the root_*.adoc files
14:27:37 <sandbergja> 3) Lots and lots of cleanup :-)
14:28:39 <kmlussier> sandbergja: I assume Robert hast to take care of #2?
14:29:43 <sandbergja> kmlussier: I think so.  There's a reorganized-documentation-generator script on the docs testing server that would just need a few modifications.
14:31:11 <kmlussier> OK, so I guess we need to coordinate a bit to make sure he can update the script right after the new root file is added.
14:32:18 <sandbergja> I believe that the current script would just ignore the new files, so it wouldn't be terrible if there were a lag between 1 and 2.
14:32:30 <sandbergja> But doing 2 before 1 would cause problems. :-)
14:32:55 <sandbergja> I'm wondering if 1) and 2) should be action items for me?
14:33:07 <ohiojoe> that sounds good to me
14:33:13 <kmlussier> And 3 should be an action item for the rest of us. :)
14:33:37 <ohiojoe> I was thinking it sounds like an action item, and like something that only a few of y'all know what to do/how to do it
14:34:08 <sandbergja> Maybe #3 could be coordinated in the wiki?
14:34:18 <ohiojoe> #action sandbergja will coordnate getting the new root_*.adoc files into master
14:34:22 <dluch> That's a good idea
14:34:49 <sandbergja> The cleanup that I mean is stuff like "There is random administrator stuff in the middle of the circ manual; please move it to the admin manual"
14:34:52 <ohiojoe> #action sandbergja will coordnate updating the script on the production doc server to generate the new, reorganized manuals based on the root_*.adoc files
14:35:46 <ohiojoe> #action everyone will work on cleaning up the reorganized documentation
14:36:05 <kmlussier> Should somebody take an action item to get that wiki page started?
14:36:30 <jihpringle> I'll start the wiki page
14:36:47 <sandbergja> jihpringle: thanks!
14:36:53 <kmlussier> jihpringle++ sandbergja++
14:37:11 <ohiojoe> #action jihpringle will start a wiki page to coordinate the cleanup on the reorganized docs
14:37:31 <ohiojoe> jihpringle++ sandbergja++
14:37:52 <dluch> jihpringle++ sandbergja++
14:38:00 <ohiojoe> #agree the reorganized documentation structure will be applied starting with the 3.0 documentation
14:38:21 <abneiman> #info abneiman = Andrea Neiman, EOLI
14:38:29 <abneiman> (apologies, I had another meeting)
14:38:45 <ohiojoe> no worries
14:40:13 <ohiojoe> #topic progress on documentation launchpad bugs
14:41:17 <ohiojoe> #link https://bugs.launchpad.net/evergreen/+bugs?field.tag=documentation
14:41:46 <ohiojoe> does anyone have anything to report here?
14:42:48 <kmlussier> nope
14:43:16 <dluch> No, sorry
14:43:39 <ohiojoe> in that case, moving swiftly along
14:43:40 <ohiojoe> #topic old business
14:43:47 <ohiojoe> #topic progress on Web Client docs
14:44:43 <kmlussier> Yes, I think we covered that above when we talked about the web client documentation days.
14:44:54 <ohiojoe> mm, very true
14:45:02 <sandbergja> I had a quick question about it
14:45:13 <ohiojoe> please
14:45:43 <sandbergja> I saw a Cataloging doc staff client rewrite mentioned in the 2.12 doc needs wiki page
14:45:54 <sandbergja> Does anybody have details to share about this?
14:46:13 <sandbergja> Especially, should others hold off on contributing cataloging-related documentation until this re-write is done?
14:46:28 <sandbergja> akilsdonk: is this a project you are working on?
14:46:47 <kmlussier> sandbergja: Remind me. What's the link for that page?
14:47:04 <sandbergja> #link https://wiki.evergreen-ils.org/doku.php?id=evergreen-docs:2.12_needs#cataloging
14:48:18 <jihpringle> I'm not seeing it on that page, am I completely missing it?
14:48:32 <jihpringle> nm, just saw where it is
14:48:44 <kmlussier> abneiman: Do you know anything about it?
14:49:20 <abneiman> kmlussier: sorry, I don't -- akilsdonk would be the one to ask, but I don't think she's available right now
14:50:06 * kmlussier hopes it means akilsdonk is doing all the cataloging docs for the web client. :D
14:50:40 <sandbergja> abneiman: would you mind checking in with her?
14:51:16 <abneiman> sure, but I do not think she is documenting the entirety of webby cataloging :)
14:51:26 <kmlussier> Darn!
14:51:30 <ohiojoe> shucks
14:51:35 <dluch> Bummer
14:51:37 <dluch> lol
14:51:46 <sandbergja> hahaha hope springs eternal
14:51:58 <ohiojoe> shall we make that an action item?
14:52:03 <abneiman> sure
14:53:28 <ohiojoe> #action abneiman will check on the 2.12 cataloging docs rewrite undertaken by akilsdonk
14:54:14 <ohiojoe> #topic previous action items
14:55:02 <sandbergja> I'm wondering if we could dispense with the missing RDA content action item?
14:55:17 <kmlussier> yes
14:55:19 <kmlussier> please
14:55:23 <ohiojoe> will do
14:55:28 <ohiojoe> excellent
14:55:30 <jihpringle> sandbergja: I searched through my email this morning and could not find anything
14:55:45 <sandbergja> jihpringle: thanks for checking!
14:55:53 <jihpringle> so +1 to dispensing it
14:55:54 <kmlussier> I think that action item started with me about two years ago.
14:56:17 <ohiojoe> looking at them, with Christineb not here, that leaves just 4 and 5..
14:56:24 <kmlussier> nope
14:56:34 <kmlussier> I inadvertently took one of Christineb's action item.
14:56:56 <jihpringle> I'm sure Christineb has no problem with that kmlussier :)
14:57:12 <kmlussier> We now have an Evergreen-specific YouTube channel. I had forgotten it was discussed at the last meeting.
14:57:23 <ohiojoe> excellent
14:57:33 <dluch> Yay!
14:57:38 <kmlussier> But I will take an action item to see if I can get ChristineB linked up to that channel.
14:57:54 <sandbergja> kmlussier: I think that your 3.0 video would be a good fit for Christineb's playlist too!
14:58:03 <sandbergja> In the spirit of action item #4
14:58:19 <ohiojoe> Does that mean that 1 and 2 are complete, or just #2?
14:58:39 <kmlussier> #1 hasn't been done. I think we should probably move the videos to the Evergreen channel before adding the link.
14:58:55 <kmlussier> Also, please subscribe to the channel. We need 100 subscribers to get a custom URL.
14:59:00 <ohiojoe> ok, that makes good sense.  I can leave that in there for now then
14:59:16 <kmlussier> #link https://www.youtube.com/channel/UC83L8WyXoj8Kf9hShdDY61A
14:59:34 <jihpringle> kmlussier: Christineb is on vacation this week, back next week
14:59:39 <dluch> Just subscribed!
15:00:15 <ohiojoe> #action everyone should subscribe to the Evergreen-specific YouTube channel
15:00:41 <dluch> kmlussier++
15:00:44 <ohiojoe> I just did as well..  and with that, any other last minute things before we close the meeting?
15:00:51 <ohiojoe> kmlussier++
15:00:56 <abneiman> one thing from me
15:01:00 <ohiojoe> please
15:01:06 <sandbergja> kmlussier++
15:01:47 <abneiman> I have a pullrequest up on github for Offline Circulation for the web client; I didn't want to straight up replace the XUL Offline
15:02:02 <abneiman> but that's there if someone wants to look at it.  I may have even done it correctly (maybe) :)
15:02:37 <sandbergja> abneiman++
15:02:55 <abneiman> akilsdonk++ (I had lots of help)
15:02:56 <kmlussier> abneiman: We've been replacing XUL documentation for anything in 2.12 or later.
15:03:08 <ohiojoe> abneiman++
15:03:10 <dluch> Cool.  abneiman++
15:03:10 <kmlussier> abneiman++ akilsdonk++
15:03:23 <ohiojoe> and with that..
15:03:25 <ohiojoe> #endmeeting