15:02:06 <gmcharlt> #startmeeting Evergreen development meeting, 4 October 2017
15:02:06 <pinesol_green> Meeting started Wed Oct  4 15:02:06 2017 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:06 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:06 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__4_october_2017'
15:02:11 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-10-04
15:02:15 <gmcharlt> #topic Introductions
15:02:19 <gmcharlt> please introduce yourselves
15:02:28 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox, 3.0 release manager
15:02:30 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:02:31 <DPearl> #info DPearl is Dan Pearl, C/W MARS Inc.
15:02:34 <miker> #info miker == Mike Rylander, EOLI
15:02:47 <phasefx> #info phasefx = Jason Etheridge, EOLI
15:02:58 <abneiman> #info abneiman = Andrea Buntz Neiman, EOLI
15:03:03 <jeff> #info jeff = Jeff Godin, Traverse Area District Library (TADL)
15:03:17 <JBoyer> #info JBoyer = Jason Boyer, IN State Library
15:03:48 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:03:53 <rhamby_> #info rhamby_ = Rogan Hamby, Equinox
15:03:59 <berick> #info berick Bill Erickson, KCLS
15:04:55 <gmcharlt> so
15:05:08 <gmcharlt> #topic Old business
15:05:40 <Dyrcona> #info Dyrcona = Jason Stephenson C/W MARS
15:06:41 <gmcharlt> so, I still need to wrangle the Gooogle wb store account (and now that 3.0.0 is out, will have more time)
15:06:47 <gmcharlt> so I'll just carry forward the action items
15:06:55 <gmcharlt> #action gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:07:01 <gmcharlt> #action berick and gmcharlt will get a shared Google Web Store account started
15:07:09 <gmcharlt> #action kmlussier will wrangle creation of necessary icons/logos for the store and Hatch app
15:07:23 <gmcharlt> any questions before we move on to the next topics?
15:07:53 <kmlussier> nope
15:08:07 <gmcharlt> #topic OpenSRF
15:08:42 <gmcharlt> #info OpenSRF 3.0.0 is available; it's essentially OpenSRF 2.5.x + Stretch support + renaming shared libraries for C services
15:09:38 <gmcharlt> and I'm thinking that, except for bugfixes... that's kinda it for the 3.0.x series?
15:10:02 <gmcharlt> so, if that makes sense to folks as a stance, suggests that 3.1.x would be the next big feature release
15:10:15 <gmcharlt> which then raises the question... what do we want to get in to a 3.1.0?
15:10:21 <miker> seems sane. do you have features in mind? ha
15:11:01 <gmcharlt> SASL auth might be one (e.g., see bug 1703411)
15:11:01 <pinesol_green> Launchpad bug 1703411 in OpenSRF "OpenSRF: XMPP Non-SASL auth is being phased out" [Undecided,New] https://launchpad.net/bugs/1703411
15:11:19 <JBoyer> +1 to sasl
15:11:20 <miker> ah, indeed. I was looking at that a bit last month
15:11:22 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:11:23 <jeff> seems reasonable. are you thinking / have we previously decided to try and have some opensrf<->evergreen version synchronicity?
15:11:39 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:11:43 <miker> jeff: I'm against imposing it, personally
15:11:45 <gmcharlt> jeff: no, at the moment that's just a coincidence
15:12:04 <cesardv> #info cesardv = Cesar Velez, EOLI
15:12:33 <gmcharlt> another potential 3.1.x enhancement - HTTP/2 support for API access
15:12:38 <gmcharlt> (at least as something to investigate)
15:14:00 <gmcharlt> another idea: an nginx module for serving WS more direclty
15:14:23 <gmcharlt> (given the likely trend of nginx becoming a standard frontend for Evergreen)
15:14:37 <gmcharlt> at this point I'm just brainstorming
15:14:55 <gmcharlt> are there other big itches folks want scratched?
15:15:32 <berick> i might get a pullrequest on bug 1706147
15:15:32 <pinesol_green> Launchpad bug 1706147 in OpenSRF "Option to force-recycle drones after long-running sessions" [Wishlist,New] https://launchpad.net/bugs/1706147 - Assigned to Bill Erickson (berick)
15:15:45 <gmcharlt> cool
15:17:18 <gmcharlt> ok, so things to consider
15:17:21 <gmcharlt> next up
15:17:24 <gmcharlt> #topic Evergreen
15:17:39 <gmcharlt> #info Evergreen 3.0.0 was released on 3 October
15:18:01 <gmcharlt> #info Evergreen 3.0.1 will be released along with the other maintenance releases on 18 October
15:18:19 <gmcharlt> so... feel free to fix bugs! ;)
15:18:42 <gmcharlt> rel_3_0 has been branched, and courtesy of bshum, a 3.0 series for translations now exists in Launchpad
15:19:05 <gmcharlt> any questions regarding the Evergreen release?
15:19:46 <kmlussier> gmcharlt++
15:19:48 <jeffdavis> no questions, but maybe a special thanks to gmcharlt for managing an especially big complex release
15:20:02 <miker> gmcharlt++ # manage ALL THE THINGS
15:20:05 <jeff> gmcharlt++
15:20:06 <dbwells> gmcharlt++
15:20:18 <remingtron> gmcharlt++
15:20:27 <rhamby_> gmcharlt++
15:20:38 <berick> gmcharlt++
15:20:40 <berick> huzzah
15:20:41 <cesardv> while(true) gmcharlt++
15:20:44 <phasefx> gmcharlt++
15:20:46 <Bmagic> gmcharlt++
15:20:49 * gmcharlt overflows
15:20:53 <JBoyer> gmcharlt++
15:21:06 <gmcharlt> and thanks, y'all - but it was truly a group and community effort
15:21:09 <gmcharlt> all_yall++
15:21:14 <JBoyer> action item: upgrade gmcharlt karma to 64 bit?
15:21:57 <gmcharlt> so, moving on to new business
15:22:02 <gmcharlt> #topic Selecting next release manager
15:22:14 <gmcharlt> for this, I propose to do what we did the last few times
15:22:36 <gmcharlt> I can send out a formal call on Monday;, and if we keep nominations open a couple weeks, close it on 20 October
15:22:49 <gmcharlt> I then propose we hold an IRC vote on the 25th (before hack-a-way)
15:23:12 <gmcharlt> note that I will definitely _not_ be putting my hat in the ring to 3.1
15:23:26 <gmcharlt> so, thoughts on that plan?
15:23:46 <miker> +1
15:23:52 <miker> that's my though
15:23:52 <JBoyer> +1; //Sounds good to me.
15:23:53 <miker> t
15:23:59 <phasefx> +1
15:24:16 <berick> +1
15:24:40 <kmlussier> +1
15:25:11 <dbwells> +1
15:25:37 <gmcharlt> ok, upon hearing no suggestions to delegate the decision process to a d20...
15:25:56 * JBoyer makes note for suggestion next time
15:26:11 <gmcharlt> #agreed Call for 3.1 release manager nominations will be made on 10/9 and close on 10/20 with IRC vote to be held on 10/25
15:26:23 <cesardv> +1
15:26:43 <gmcharlt> so, continuing on
15:26:50 <gmcharlt> #topic 2.12 and 3.0 rmaints
15:27:20 <gmcharlt> (and well, 2.11, but that'll be moot by end of the year for security updates)
15:27:31 <gmcharlt> and basically a question:
15:27:37 <gmcharlt> well, two
15:27:58 <gmcharlt> one: any objection to my following usual practice and continuing on as rmaint for 3.0.x?
15:28:18 <kmlussier> no objections from me
15:28:25 <JBoyer> no
15:28:38 <gmcharlt> two: kmlussier, are you planning on continuing on as rmaint for 2.12?
15:28:58 <kmlussier> gmcharlt: yes
15:30:25 <gmcharlt> groovy
15:31:08 <gmcharlt> so, not hearing any objections... *holds breath for 60 seconds*
15:31:26 <kmlussier> Will our buildmasters be continuing too?
15:31:46 <gmcharlt> good question - I'll raise that next
15:32:03 * kmlussier hopes gmcharlt has started breathing again by now.
15:32:27 <gmcharlt> let's just say a Google search for "60 second countdown" is a wonderful thing
15:32:42 <gmcharlt> #agreed kmlussier will continue on as 2.12 release maintainer
15:32:53 <gmcharlt> #agreed gmcharlt will serve as 3.0 release maintainer
15:32:59 <gmcharlt> so, regarding buidlmaster
15:33:47 <gmcharlt> dbwells: Bmagic: Dyrcona: any immediate thoughts on whether y'all want to carry on as buildmasters?
15:33:58 <gmcharlt> and shall we also put out a call for more volunteers?
15:34:07 <Bmagic> I don't mind
15:34:22 <Dyrcona> Well, I kind of forgot that I was and hadn't done anything. :)
15:35:08 <dbwells> gmcharlt: I am fine either way, if someone else wants to take any of it on.
15:35:52 <Bmagic> It's amazing how often 30 days comes around. It's like every 30 days
15:36:04 * gmcharlt can't resist
15:36:07 <gmcharlt> @quote add <Bmagic> It's amazing how often 30 days comes around. It's like every 30 days
15:36:07 <pinesol_green> gmcharlt: The operation succeeded.  Quote #179 added.
15:36:12 <dbwells> Bmagic: I know *exactly* how you feel :)
15:36:23 <Bmagic> haha
15:36:36 <gmcharlt> heh
15:37:13 <gmcharlt> but it sounds like it might be a good idea to help supplement your numbers? would one of the existing buildmasters be willing to take an action item to send out a call for additional volunteers?
15:37:26 <kmlussier> Bmagic++
15:37:53 <dbwells> gmcharlt: sure, I can do that
15:37:57 <gmcharlt> great
15:38:09 <gmcharlt> #action dbwells will send out a call for additional buildmasters
15:39:17 <gmcharlt> so, as far as other topics go
15:39:20 <gmcharlt> #topic 2017 hack-a-way
15:39:34 <gmcharlt> #link https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017
15:39:48 <gmcharlt> #info Hack-a-way agenda is https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda
15:40:38 <gmcharlt> so... if you're attending but haven't yet listed yourself, please do so
15:41:01 <gmcharlt> if you won't be able to attend in person, but there's a topic you would like discussed at a set time so that you can participate
15:41:05 <gmcharlt> please speak up
15:41:18 <gmcharlt> ... and anything else? rhamby_? agoben? JBoyer?
15:41:43 <berick> i have a hackaway question..
15:41:44 <rhamby_> Only that I'm looking forward to seeing everyone there.
15:41:57 <kmlussier> Did we get enough people to rent the guest house again?
15:41:57 <JBoyer> I don't think there's much else. There are still a couple rooms at the Harrison House for those interested.
15:42:05 <JBoyer> kmlussier, yes.
15:42:12 <kmlussier> Great!
15:42:40 <berick> i have not booked a flight.  was hoping to plan it so my flight times were close to others for shuttle efficiency.
15:42:40 <Bmagic> sweet!
15:42:57 <berick> any chance we could see the survey responses?  (or maybe that's already possible..)
15:42:57 <JBoyer> I don't think we watch the Cubs win the series again, but what can you do.
15:43:25 <JBoyer> berick, let me check on that. At the very least I can get you a list of times where flights are clustering.
15:43:25 <gmcharlt> JBoyer: NO JINXING ALLOWED!
15:43:35 <berick> JBoyer: that would be great, thanks!
15:43:57 <rhamby_> note: pack bungee in case we need to strap berick on top of shuttle
15:44:11 <berick> bah, I'll roof-surf!
15:44:28 <JBoyer> I'll be sure to rent a van with a luggage rack.
15:44:37 <Dyrcona> JBoyer: Where is the survey/whatever for that, 'cause I've not sent my times.
15:44:38 <gmcharlt> heh
15:45:02 <berick> https://docs.google.com/forms/d/e/1FAIpQLSdepNIDR_hkjozA7TcL2IUAv6r-GTCZ6Rtn4x_5UkdJ_iabKA/viewform
15:45:16 <berick> via https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017
15:45:18 <dbwells> berick: https://docs.google.com/spreadsheets/d/1ofbF8gDdWJyZ0CuUhSahSmHt0Fs7fKFJfvMgAiQZ2Mw/edit?usp=sharing
15:45:28 <Dyrcona> Thanks! I just found it. :)
15:45:32 <berick> dbwells++
15:46:05 <dbwells> and in walk all the random animals :)
15:46:07 <miker> JBoyer: and, for us EOLI folken, we assumed "transportation method" as /desired/, not /demanded/ :)
15:46:14 <JBoyer> I'm not sure I have access to the responses yet, I'll get on that once agoben is back at her desk.
15:46:25 <miker> (re the "shuttle us!"'s)
15:46:43 <JBoyer> miker, it's just as well, we'll need a larger vehicle to move people to and fro in the evening.
15:47:18 <kmlussier> I'm trying to figure out how four EOLI people are on the same flight that is arriving at two different times. Will two of you be dropped off 10 minutes before landing?
15:47:42 <gmcharlt> parachute practice, natch
15:47:45 <berick> that's the vanguard
15:48:25 <gmcharlt> any other topics that folks would like to bring up quickly before we clsoe this meeting?
15:48:28 <agoben> Please do continue to update that sheet (particularly if you need us to drive or have an accommodations we need to make arrangements for).
15:48:53 <miker> kmlussier: ha ... yeah, those need adjustment
15:49:03 <agoben> If you prefer, you can also let me know privately if there are accommodations which you'd rather not post.
15:49:10 <JBoyer> Ah, hadn't saved that to my drive yet.
15:50:29 * berick puts "EL shuttle" as travel method, awaits arrival in Durham
15:51:12 <Dyrcona> he
15:51:17 <gmcharlt> OK, so hearing no additional topics, I will now bestow upon you all 9 additional free minutes
15:51:21 <gmcharlt> #endmeeting