15:00:48 <gmcharlt> #startmeeting Evergreen development meeting, 8 November 2017
15:00:48 <pinesol_green> Meeting started Wed Nov  8 15:00:48 2017 US/Eastern.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <pinesol_green> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <pinesol_green> The meeting name has been set to 'evergreen_development_meeting__8_november_2017'
15:00:54 <gmcharlt> #info Agenda is https://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2017-11-08
15:01:04 <gmcharlt> #topic Introductions
15:01:20 <gmcharlt> #info gmcharlt = Galen Charlton, Equinox
15:01:58 <bshum> #info bshum = Ben Shum, evergreener
15:02:03 <rhamby> #info rhamby = Rogan Hamby, Equinox
15:02:14 <DPearl> #info DPearl = Dan Pearl, C/W MARS
15:02:49 <JBoyer> #info JBoyer = Jason Boyer, IN State Lib
15:03:20 <Dyrcona> #info Dyrcona = Jason Stephenson, C/W MARS
15:04:01 <phasefx> #info phasefx = Jason Etheridge, Equinox
15:04:02 <berick> #info berick Bill Erickson, KCLS
15:04:20 <remingtron> #info remingtron = Remington Steed, Hekman Library (Calvin College)
15:04:53 <Bmagic> #info Bmagic = Blake GH, MOBIUS
15:04:55 <gmcharlt> #topic Action items from previous meeting
15:04:55 <dbwells> #info dbwells = Dan Wells, Hekman Library (Calvin College)
15:05:10 <gmcharlt> #action gmcharlt will open and work on bugs for documentation changes for better ejabberd configuration during installation of OpenSRF
15:05:10 <kmlussier> #info kmlussier is Kathy Lussier, MassLNC
15:05:14 <csharp> #info csharp = Chris Sharp, GPLS, but you knew that
15:05:22 <gmcharlt> ^^ that one is just being carried over
15:05:23 <cesardv> #info cesardv = Cesar Velez, EOLI
15:05:28 <abneiman> #info abneiman is Andrea Neiman, EOLI
15:05:42 <miker> #info miker = Mike Rylander, EOLI
15:05:58 <gmcharlt> #info There is now a Chrome Web Store account onto which we can upload the Hatch extension
15:06:10 <gmcharlt> berick: thoughts on when you expect to be able do the upload?
15:06:10 <Dyrcona> And, there was much rejoicing!
15:06:17 <kmlussier> gmcharlt++
15:06:46 <berick> gmcharlt: thought this week, but realize that's not likely.  more likely w/in next 2 weeks.
15:06:57 <gmcharlt> ok
15:07:12 <gmcharlt> #action berick will upload Hatch to the Chrome Store in the next couple weeks or so
15:07:25 <kmlussier> berick++
15:07:32 <JBoyer> berick++ # I finally allowed Java on my laptop today.
15:07:37 <gmcharlt> #info maryj has created an icon and promotional image for the Hatch extension
15:07:39 <gmcharlt> maryj++
15:07:42 <kmlussier> maryj++
15:07:44 <JBoyer> maryj++
15:08:02 <Dyrcona> maryj++
15:08:05 <csharp> maryj++
15:08:06 <bshum> maryj++
15:08:08 <Bmagic> maryj++
15:08:15 <remingtron> maryj++
15:08:17 <cesardv> maryj++
15:08:22 <csharp> @karma maryj
15:08:22 <pinesol_green> csharp: Karma for "maryj" has been increased 9 times and decreased 0 times for a total karma of 9.
15:08:46 <berick> maryj++
15:09:16 <kmlussier> @karma
15:09:16 <pinesol_green> kmlussier: Highest karma: "gmcharlt" (210), "kmlussier" (100), "berick" (95), "Dyrcona" (80), and "dbs" (63).  Lowest karma: "comcast" (-19), "systemd" (-10), "oracle" (-7), "ie" (-6), and "^" (-6).  You (kmlussier) are ranked 2 out of 177.
15:09:21 <gmcharlt> #info dbwells has sent out a call for additional buildmasters
15:09:24 <gmcharlt> dbwells++
15:09:50 <gmcharlt> oh, by the way, Cartago delenda est^W^W^W
15:09:50 <kmlussier> dbwells: Have you heard back from anyone?
15:09:52 <gmcharlt> comcast--
15:10:03 <csharp> comcast--
15:10:18 <dbwells> kmlussier: yes, a few.  Still haven't rallied the troops yet, though
15:10:18 <kmlussier> comcast--
15:10:39 * csharp volunteered to be a buildmaster, but hasn't done it yet
15:10:45 <gmcharlt> csharp++
15:10:50 <kmlussier> csharp++
15:11:14 <gmcharlt> #topic OpenSRF release
15:11:50 <gmcharlt> #info Another release expected in the next couple weeks, given additional bundling/chunking bugs
15:12:14 <Dyrcona> Is there a fix for the gateway(s) pending?
15:12:24 <gmcharlt> Dyrcona: there will be :)
15:12:25 <Dyrcona> If so, I'll be happy to test.
15:12:40 <gmcharlt> great!
15:12:59 <gmcharlt> #topic Evergreen release
15:13:03 <gmcharlt> dbwells: any words of wisdom?
15:13:20 <miker> gmcharlt: also, message queuing
15:13:24 <miker> doh... nm
15:13:27 <gmcharlt> miker: ah yes, message queuing
15:13:40 <gmcharlt> lining up the bugfixes </dadjoke>
15:13:47 <dbwells> Nothing for 3.1 beyond the email sent a few days back, so please check it out if you haven't yet.
15:14:41 <gmcharlt> #link http://libmail.georgialibraries.org/pipermail/open-ils-general/2017-November/014381.html
15:14:54 <dbwells> gmcharlt++ # thanks
15:15:22 <gmcharlt> #topic Hack-a-way update
15:15:46 <gmcharlt> #info As of the moment, patches for ~15 bugs have been pushed since the hack-a-way started
15:15:55 <Dyrcona> yay!
15:15:58 <JBoyer> Woo!
15:16:02 <gmcharlt> (general call for folks to chime in with #info updates)
15:16:10 <kmlussier> Hackaway2017++
15:16:26 <gmcharlt> #info We discussed plans for starting project of upgrading Angular; berick has offerred to do some initial prototyping
15:16:58 <gmcharlt> #info Test instances of GitLab and Phabricator are being set up
15:17:06 <cesardv> awesome
15:17:44 <bshum> #info Using pofilter to test our current PO translations; finding useful tidbits to eventually be shared back with the translator teams and greater group.
15:17:45 <gmcharlt> #info Some updates are being tracked on the agenda page: https://wiki.evergreen-ils.org/doku.php?id=hack-a-way-2017-agenda
15:18:10 <gmcharlt> #info There's also a shared Google doc: https://docs.google.com/document/d/19EctprR1cybery-zbaNBntRmyASMYcRwt4-6S1-YNts/edit
15:19:01 <gmcharlt> in other news, bug 1724915 is ready for a final pair of commiter eyes
15:19:02 <pinesol_green> Launchpad bug 1724915 in Evergreen 2.12 "Webstaff fails to auto-logout in some scenarios" [Medium,Confirmed] https://launchpad.net/bugs/1724915
15:19:56 <pinesol_green> [evergreen|Kyle Huckins] LP#1646210 Add CN Affixes to Grids WIP - <http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=19cf716>
15:20:22 <gmcharlt> #info We perfomed a successful denial of service attack on the omelet line this morning
15:20:36 <Dyrcona> :)
15:20:41 <rhamby> gmcharlt++
15:20:58 <gmcharlt> any updates or questions from folks NOT in Indianapolis?
15:21:00 <berick> gmcharlt++
15:21:31 <csharp> gmcharlt++
15:21:35 <Dyrcona> Lp 1243841 is ready for another pair of eyes.
15:21:36 <pinesol_green> Launchpad bug 1243841 in OpenSRF "compilation warnings on Ubuntu 12.04.3 LTS" [Undecided,Confirmed] https://launchpad.net/bugs/1243841
15:21:36 <JBoyer> gmcharlt++
15:21:45 <csharp> Dyrcona++
15:22:12 <rhamby> @quote add <gmcharlt> #info We perfomed a successful denial of service attack on the omelet line this morning
15:22:12 <pinesol_green> rhamby: Error: You must be registered to use this command. If you are already registered, you must either identify (using the identify command) or add a hostmask matching your current hostmask (using the "hostmask add" command).
15:23:26 <gmcharlt> OK, sounds like we've come to a pause
15:23:39 <gmcharlt> so us folks in Indy will leave this meeting... to return to our meeting ;)
15:23:42 <gmcharlt> #endmeeting